18:00:11 <colindixon> #startmeeting tsc
18:00:11 <odl_meetbot> Meeting started Thu Mar 2 18:00:11 2017 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:11 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:16 <colindixon> #topic roll call and agenda bashing
18:00:21 <colindixon> TSC members please #info in
18:00:30 <skitt> #info skitt
18:00:37 <anipbu> #info anipbu
18:00:43 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53150#Agenda today's agenda
18:00:57 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-02-24-04.34.html last week's meeting minutes (thanks vishnoianil!)
18:01:03 <hideyuki> #info Hideyuki
18:01:03 <colindixon> #info colindixon
18:01:15 <zxiiro> #info Thanh
18:01:25 <colindixon> #chair anipbu zxiiro phrobb CaseyODL
18:01:25 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon phrobb zxiiro
18:01:31 <edwarnicke_> #info edwarnicke_
18:01:59 <colindixon> #action vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer list and raise the vote for Ravi for committer to the project
18:02:00 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
18:02:01 <colindixon> #action colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
18:02:01 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
18:02:11 <vishnoianil> #info Anil Vishnoi
18:02:33 <anipbu> https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1293046707
18:02:33 <abhijitkumbhare> #info abhijitkumbhare
18:02:42 <jamoluhrsen> #info jamoluhrsen
18:02:47 <anipbu> #link https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1293046707 <--- Categorizing autorelease failures
18:03:21 <rovarga> #info rovarga
18:03:45 <LuisGomez> #info LuisGomez
18:04:02 <skitt> #link Current progress on Karaf 4: https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1
18:05:21 <abhijitkumbhare> Having audio issues - trying to reconnect
18:06:39 <colindixon> #info it seems like we're planning to get readouts about Karaf 4 from M5 milestones per katie and anipbu, phrobb asks if we could do it earlier, skitt says that the above linked bug dependency tree is a good list of what's left
18:07:21 <colindixon> #Info rovarga and skitt say that skitt has done the bulk of the work here
18:08:17 <colindixon> #info rovarga says that cross-project stuff doesn't seem to be work and that worries him from an SR and planning perspective
18:09:57 <colindixon> #info skitt says it's worrying to see so little engagment from so many projects, e.g., this work and mockito from vorburger
18:10:46 <colindixon> #info colindixon says in general, his approach has been you can't make projects stay engaged, you can make it as easy as possible to stay engaged and you can make it so disengaged projects hurt the rest as little as possible
18:11:57 <colindixon> #info vishnoianil says that his take is that things like this (cross-project) need to be scoped and fully anounced by M3 to get things done easily, and we have to make it clear we'll drop people if they don't do it, edwarnicke_ agrees that's sort of our one hammer, not shipping projects
18:13:51 <colindixon> #Info it's pretty clear that this has been a huge burden on a very small number of people, e.g., skitt, rovarga and vorburger, which isn't sustainable, healthy or good for the OpenDaylight community
18:14:43 <skitt> vorburger does a lot, but he hasn't done much (yet) on the Karaf 4 migration ;-)
18:14:50 <colindixon> skitt: noted
18:14:55 <colindixon> I meant that generally
18:15:02 <colindixon> not jut for Karaf 4
18:15:08 <colindixon> sorry if that wasn't clear
18:15:08 <skitt> right, cross-project work yes
18:15:12 <colindixon> exactly
18:19:31 <colindixon> #info vishnoianil and rovarga go back and forth about how that might be resolve and why projects don't respond and if we should change things to encourage projects to be more attentive
18:20:28 <colindixon> #info rovarga says that we should consider shifting our stance to kick people out of the release if they do things like miss multiple milestones
18:21:58 <colindixon> #info edwarnicke_ says he's open with that, as long as we make it clear when people will be dropped and how they can remediate it and when
18:23:42 <colindixon> #info an example might be if you milestone readout is late (how late?) then you will be removed for some period of time until you get the new ones, that might get more compliance
18:25:46 <colindixon> #action colindixon to start a thead talking about what we migth do to address unresponsive projects and have something to actually act on in the next meeting or so
18:26:24 <colindixon> #Info abhijitkumbhare says that in line with that, there's too many projects and too many unusable projects
18:26:51 <colindixon> #info skitt says that he gets the impression that many projects use OpenDaylight for infra and release, basically you get code-dump at M4 or M5 with no open development
18:27:09 <colindixon> #info skitt says we need to figure out carrots in addition to sticks
18:28:59 <colindixon> #info colindixon notes that docuemnting how to ship apps and projects that work with an SR but aren't part of the SR might alleviate some pressure, edwarnicke_ notes that will intereact potentailly badly with offline installation and running of ODL
18:30:25 <colindixon> #action vrpolak is creating a karaf 4 distribtion and its running into some issues with netconf that he's resolving, will keep working there
18:30:32 <colindixon> #action colindixon to set up some kind of meeting (or at least thread) about semantic-versioning-ish things for nitrogen
18:31:10 <colindixon> #topic carbon
18:31:25 <colindixon> #Info all M4 offset 0 and offset 1 are in but aa
18:31:27 <colindixon> #Undo
18:31:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a2ded0>
18:31:29 <colindixon> #Info all M4 offset 0 and offset 1 are in but aaa
18:31:35 <colindixon> #undo
18:31:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a2ded0>
18:31:45 <colindixon> #Info all M4 offset 0 and offset 1 are in but aaa and snmp
18:31:58 <katiezhang> weather item link is here : https://wiki.opendaylight.org/view/Weather#OpenFlowPlugin_-_Turn_Single_Layer_Serialization_on_by_default
18:32:11 <colindixon> #link https://wiki.opendaylight.org/view/Weather#OpenFlowPlugin_-_Turn_Single_Layer_Serialization_on_by_default weather item
18:32:40 <katiezhang> Description: Single Layer Serialization will be turned on by default. For those who will want to revert back to Multi Layer Serialization, please follow the following guide: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:OF13%2B_Single_Layer_Serialization#Disabled After you will do above, recompile project and you can use Multi Layer Serialization again
18:32:51 <colindixon> #Info if you want to go back to the old way of OpenFlow serialization, you can follow instructions here: https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:OF13%2B_Single_Layer_Serialization#Disabled
18:33:10 <colindixon> #Info M4 offset 2 is due today
18:33:23 <colindixon> #info katiezhang says that there are not many missed M3 offset 2 reports
18:33:24 <abhijitkumbhare> katiezhang: the instructions will be updated - as we will have a config knob rather than recompile
18:33:35 <abhijitkumbhare> for the weather report I mean
18:33:53 <colindixon> #Info M5 offset 0 is today
18:34:39 <katiezhang> https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1544647361
18:35:01 <colindixon> #link https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1544647361 milestone readouts so far here
18:36:03 <hideyuki> #link https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=355465003 <= M2 status
18:36:05 <colindixon> #Info hideyuki note that many offset 2 projects don't have M3 milestones, rovarga adds that we're missing M2 status too
18:38:15 <colindixon> #info rovarga says that his take is that we have many projects now which are now 3 milestones behind
18:42:17 <colindixon> #action katiezhang will let projects know that the TSC will likely drop projects from the release unless they submit correct, acceptable M4 and M5
18:43:50 <colindixon> #info anipbu notes that you also need to review M4 and M5 readouts carefully to make sure they're correct
18:44:21 <katiezhang> here are list of projects missing M3
18:44:24 <katiezhang> M3 offset 1 snmp offset 1 M3 offset 2 "atrium capwap cardinal centinel didm eman integration/distribution iotdm lacp natapp next of-config opflex sdninterfaceapp snbi usecplugin vpnservice yang-push yangide"
18:44:54 <colindixon> #info from katie: M3 offset 1 snmp offset 1 M3 offset 2 "atrium capwap cardinal centinel didm eman integration/distribution iotdm lacp natapp next of-config opflex sdninterfaceapp snbi usecplugin vpnservice yang-push yangide"
18:45:31 <colindixon> #topic boron
18:45:43 <colindixon> #info nothing this week
18:45:49 <colindixon> #Undo
18:45:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a00810>
18:46:35 <colindixon> #info boron SR3 release on 3/23, cutoff on 3/19, so that's 3 weesk to releas, 2.5 weeks to cutoff
18:46:53 <colindixon> #Info boron autorelease is currently failing (caused by security update of bouncycastle) rovarga will look at it
18:47:07 <colindixon> #action rovarga will be looking at boron autorelease failures with USC and bouncycastle having issues
18:47:22 <colindixon> #topic events
18:48:00 <colindixon> #info ONS is coming up the first week of April, we're having a docfest Sunday and Monday, there will be space on Monday, there may be space on Sunday too, but we'll have hotel rooms if nothing else
18:48:40 <colindixon> #Info LuisGomez asks if you can come to the docfest w/o registering, if that's an issue let us know
18:48:58 <jamoluhrsen> i need a smuggling
18:49:08 <jamoluhrsen> undo
18:49:33 <colindixon> #topic system integration and test
18:49:36 <colindixon> #info nothing this week
18:49:44 <colindixon> #Undo
18:49:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a00ed0>
18:49:45 <colindixon> #Undo
18:49:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1a00450>
18:50:23 <colindixon> #info skitt asking about having a summit later this year, phrobb says it's up in the air, his take is less than 50/50, the board needs to decide by 3/15
18:51:18 <colindixon> #info phrobb says that the goal of the LF right now is to have an end user and business and general interest networking event in the spring and have that be ONS
18:52:00 <colindixon> #Info phrobb says that there is a goal to have a fall conference that's more techincally oriented (closer to how the ODL summit was), but do it with more than just ODL, e.g., ODL + OPNFV + FD.io + …
18:52:21 <colindixon> #Info phrobb says that the question is if we have the runway to do the fall one in 2017 or punt to 2018
18:52:49 <colindixon> #info phrobb says that we may end up doing more, smaller events in more areas instead of a big bang summit
18:53:21 <colindixon> #topic system integration and test
18:53:23 <colindixon> #Info nothing this week
18:56:23 <colindixon> #topic events cont'd
18:57:41 <colindixon> #info we need be sure to keep cirtical mass, people just flying in for 2 days is harder to get funds for, gets lower attendance, and is incentives less people to come, e.g., DDFs w/o an attached summit
18:58:05 <colindixon> #action phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
18:58:59 <colindixon> #info abhijitkumbhare asks if we should move it to some other time, phrobb says that in general we've tried to line up DDFs coincident with the gap between releases
18:59:18 <colindixon> #Info this is to the extent that we haven't done them all with summits in the past some of the time
18:59:51 <colindixon> #info if those constraints are changing, phrobb would love to note
19:00:23 <colindixon> #Info rovarga suggests that maybe just making it a DDF + hackfest that is longer without necessarily having a major colocated event might actually work well too
19:00:41 <colindixon> #info skitt agrees with that point
19:01:47 <colindixon> #Info skitt also note that cross-community DDFs (which which might be easier if we synced releases)
19:02:30 <colindixon> #topic cookies
19:03:02 <colindixon> #endmeeting