17:59:43 <anipbu> #startmeeting tsc
17:59:43 <odl_meetbot> Meeting started Thu Mar  9 17:59:43 2017 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:59:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:43 <odl_meetbot> The meeting name has been set to 'tsc'
17:59:52 <anipbu> #topic Roll Call and Agenda Bashing
18:01:22 <LuisGomez> #info LuisGomez
18:01:22 <skitt> #info skitt
18:01:24 <hideyuki> #info Hideyuki
18:01:25 <vishnoianil> #info Anil Vishnoi
18:02:25 <abhijitkumbhare> #info abhijitkumbhare (Abhijit Kumbhare)
18:02:41 <anipbu> #chair zxiiro phrobb CaseyODL
18:02:41 <odl_meetbot> Current chairs: CaseyODL anipbu phrobb zxiiro
18:02:47 <anipbu> #info anipbu
18:02:56 <anipbu> #link https://wiki.opendaylight.org/index.php?title=TSC:Main#Agenda   <--- Today's Agenda
18:03:04 <jamoluhrsen> #info jamoluhrsen
18:03:05 <anipbu> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-02-18.00.html   <--- Last Week's Meeting Minutes
18:03:20 <anipbu> #action vishnoianil, anipbu will follow-up wtih LACP project to clean -up the committer
18:03:26 <edwarnicke_> #info edwarnicke_
18:03:30 <afredette> #info Andre Fredette (Proxy for Sam Hague)
18:03:31 <anipbu> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
18:04:01 <anipbu> #link https://lists.opendaylight.org/pipermail/dev/2017-March/003381.html   <--- colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
18:04:14 <anipbu> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
18:04:31 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006695.html   <--- colindixon to start a thead talking about what we migth do to address unresponsive projects and have something to actually act on in the next meeting or so
18:05:07 <anipbu> #action vrpolak is creating a karaf 4 distribtion and its running into some issues with netconf that he's resolving, will keep working there
18:05:21 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006696.html   <--- colindixon to set up some kind of meeting (or at least thread) about semantic-versioning-ish things for nitrogen
18:05:37 <anipbu> #info katiezhang will let projects know that the TSC will likely drop projects from the release unless they submit correct, acceptable M4 and M5 (See notification to respective mailing lists)
18:05:51 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/52295/   <--- rovarga will be looking at boron autorelease failures with USC and bouncycastle having issues
18:06:09 <anipbu> #action phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
18:06:31 <zxiiro> #info Thanh
18:06:51 <anipbu> #topic TSC Mailing List Conversations and Votes
18:07:00 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html   <--- Nitrogen planning
18:07:05 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006581.html   <--- Namespace management
18:07:10 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006578.html   <--- projects with few/no active committers
18:07:15 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-January/009034.html   <--- flagship features in Carbon
18:07:20 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006695.html   <--- stricter enforcement of release requirements
18:07:27 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006696.html   <--- semantic versioning (or something like it) in Nitrogen
18:08:25 <anipbu> #topic Events
18:08:32 <anipbu> #link https://www.opendaylight.org/global-events   <--- Global Events Page
18:08:39 <anipbu> #link https://wiki.opendaylight.org/view/Events:Main   <-- Events Wiki
18:09:05 <anipbu> #link https://www.opendaylight.org/events/2017-04-03-000000-2017-04-06-000000/open-networking-summit   <--- OPEN NETWORKING SUMMIT Monday, April 3, 2017 to Thursday, April 6, 2017
18:09:25 <anipbu> #info ONS has tutorials, docfest, ODL state of the union
18:10:03 <anipbu> #info phrobb asks did we want any meetings if we have critical mass
18:10:47 <anipbu> #info phrobb asks if we want to have TSC meeting in person
18:11:25 <vishnoianil> #vote +1
18:11:29 <dfarrell07> +1, will be at ONS
18:11:31 <vishnoianil> #vote +1 on colin'
18:11:39 <vishnoianil> #vote +1 on colin's behalf
18:11:47 <zxiiro> #vote +1
18:11:48 <abhijitkumbhare> vishnoianil: there is no vote going on
18:11:50 <jamoluhrsen> #vote 0 (I *can* be there whenever needed, will be there for sure Sun/Mon)
18:12:06 <hideyuki> I will not be at ONS
18:12:06 <abhijitkumbhare> not registered
18:13:03 <afredette> #vote -1 (on shague's behalf)
18:13:06 <anipbu> #action CaseyODL to send email regarding topics or meetings for ONS
18:13:14 <afredette> #vote 0 I'll be there.
18:13:14 <vishnoianil> abhijitkumbhare, i know, just saying that i will be there and good to have face to face meeting :)
18:13:49 <anipbu> #topic Boron
18:15:40 <anipbu> #info Boron SR3 Release on 3/23/2017 with Cutoff on 3/19/2017 at 23:59 UTC
18:15:46 <anipbu> #topic Carbon
18:16:54 <anipbu> #info Missing M3:Status, capwap, cardinal, centinel, eman, next, of-config, opflex
18:17:01 <anipbu> #info Missing M4 Status: aaa, snmp, alto, capwap, cardinal, docs, eman, int/dist, next, of-config, opflex, packetcable, ttp
18:18:01 <anipbu> #info Missing M5 Status: odlparent, netconf, infrautils, aaa
18:18:14 <anipbu> #undo
18:18:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a22ed0>
18:18:21 <anipbu> #info Missing M5 Status:  netconf, infrautils, aaa
18:19:21 <anipbu> #link https://wiki.opendaylight.org/view/Weather#OpenFlowPlugin_-_Turn_Single_Layer_Serialization_on_by_default  <--- OpenFlowPlugin - Turn Single Layer Serialization on by default
18:19:27 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-March/009499.html   <--- SFC MAC Chaining
18:19:34 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-March/009409.html   <--- MD-SAL Binding Generator API Change Waiver
18:19:57 <anipbu> #action katiezhang to complete validation of M4 Status per project
18:20:14 <katie> M3 missing status snmp    offset 1
18:20:23 <anipbu> #topic System Integration and Test
18:20:31 <katie> offset 2:"atrium capwap cardinal centinel eman next of-config opflex yang-push"
18:20:51 <anipbu> #info jenkins queue is rather large
18:20:56 <katie> M4 status missing : offset 0 aaa, offset 1 : snmp
18:21:09 <katie> offset 2: "alto atrium capwap cardinal centinel docs eman integration/distribution next of-config opflex packetcable ttp yang-push"
18:21:09 <anipbu> #info we do not have system test report, kindly request projects to add their link to the page
18:21:23 <jamoluhrsen> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report  landing page for projects to add their test reports
18:21:25 <LuisGomez> all, i have to pick sick daughter from school, vrpolak_ will stand-by for me
18:21:48 <anipbu> #topic Infrastructure
18:22:05 <abhijitkumbhare> take care LuisGomez
18:22:30 <LuisGomez> nothing bad but you know US schools…
18:22:49 <zxiiro> #link https://git.opendaylight.org/gerrit/#/q/topic:improve-linting linting patches
18:22:57 <anipbu> #info merged patches for linting
18:23:24 <anipbu> #topic TSC Membership
18:23:38 <anipbu> #link https://www.opendaylight.org/membership   <--- ZTE has joined OpenDaylight as a Platinum Member
18:23:52 <anipbu> #link https://www.opendaylight.org/governance   <--- Welcome Huan Linying as new Platinum Member Designated TSC Member
18:24:17 <abhijitkumbhare> #info Welcome Huan Linying & ZTE :)
18:24:39 <anipbu> #info Welcome Huan Linying!
18:24:52 <vishnoianil> #info Welcome Huan Linying
18:25:34 <anipbu> #topic MD-SAL Binding Generator
18:25:49 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-March/009409.html   <--- MD-SAL Binding Generator API Change Waiver
18:25:56 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=6859   <--- Bug Tracking
18:26:05 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:binding-gen-v1-refactoring-package-naming   <--- Impacted Projects
18:26:19 <anipbu> #info May remove projects that are unresponsive: snmp, snbi, tsdr, capwap
18:27:10 <anipbu> #topic Karaf 4
18:27:18 <anipbu> #link https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1   <--- Tracking
18:28:35 <anipbu> #info skitt says he has generated patches for leaf projects.  Since then, openflowplugin has been merged.  Bug one we are waiting on is neutron, genius.
18:30:10 <anipbu> #info skitt says there are issues with SingleFeatureTest.  May affect us (block us) for karaf 4 in Carbon
18:30:47 <anipbu> #topic Nitrogen Planning: Stricter Enforcement
18:30:52 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006695.html   <--- stricter enforcement of release requirements
18:31:08 <anipbu> #info having an official timeline of when we'll remove you from the release for a late milestone
18:31:21 <anipbu> #info having an official timeline of when we'll remove you from the release for failing to merge patches that block others
18:31:42 <anipbu> #info more aggressively maybe removing all (or many) true leaves from the release and having them be "add-ons" by doing their own independent releases and then having users do a repo:add before feature:install for those projects' features
18:32:24 <anipbu> #info edwarnicke_ says we need to set crisp deadline and process for remediation
18:35:54 <anipbu> #info abhijitkumbhare asks what about nonleaf projects?  how do we remove controller, mdsal
18:38:15 <anipbu> #info abhijitkumbhare asks would it make sense to drop projects one week after the deadline
18:38:58 <anipbu> #info hideyuki says one week is reasonable
18:40:05 <anipbu> #info edwarnicke_  suggest we rephrase to be less draconian such as "if you do not do X, then they will be dropped from autorelease"
18:42:59 <anipbu> #info TSC will continue this discussion on the mailing list
18:43:25 <anipbu> #topic Nitrogen Planning: Semantic Versioning
18:43:31 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006698.html   <--- semantic versioning (or something like it) in	Nitrogen
18:44:52 <anipbu> #info dependent projects switch to version ranges (as per Colin's proposal)
18:44:59 <anipbu> #info per-project releases are at the hands of the project (perhaps via a helpdesk ticket, this isn't about the process, it's about its existence)
18:45:04 <anipbu> #info projects are free to release on multiple branches (so we can have an "in-development" series of releases which isn't part of the current release, but planned for use in a future release)
18:45:09 <anipbu> #info we enforce the semantic constraints somehow (API breaks are reverted or cause a bump, at least if there hasn't been one in the release cycle)
18:45:13 <anipbu> #info we set up processes to ensure version convergence at release time
18:48:04 <anipbu> #info edwarnicke_ asks have to done any trial and tests?
18:48:41 <anipbu> #info edwarnicke_ says maven may get lowest permissible version, so we may not pick up the latest
18:51:44 <anipbu> #info skitt says we can start with some of the kernal projects like odlparent and yangtools, and then slowly trickle down
18:53:08 <anipbu> #topic Nitrogen Planning: Faster Release
18:53:21 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2017-February/006577.html
18:53:30 <anipbu> #info Moving to a twice a year release process. This would help planning by not having our release dates shift randomly around each year, fall more in line with other open source projects, get us cycling a bit faster, and maybe also have some more discipline.
18:54:01 <anipbu> #info jamoluhrsen asks if we are making a small group to come up with a plan
18:55:09 <anipbu> #info abhijitkumbhare suggests we form a working group to discuss
18:55:38 <abhijitkumbhare> actually anipbu - it was colin who suggested that
18:56:08 <anipbu> #info edwarnicke_ suggests we need to figure out what is a process based plan.
18:56:21 <anipbu> #undo
18:56:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a1b3d0>
18:56:24 <anipbu> #undo
18:56:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a1ba10>
18:56:38 <anipbu> #info abhijitkumbhare reminds us that colin had suggested we form a working group to discuss
18:56:46 <anipbu> #info edwarnicke_ suggests we need to figure out what is a process based plan.
18:56:57 <anipbu> abhijitkumbhare: thanks, I updated the meeting notes to reflect that
18:59:22 <anipbu> #info edwarnicke_ suggest 1) we decide if we want to fit in a timeframe, 2) write a release plan that can happen within that timeframe
19:00:40 <anipbu> #link https://lists.opendaylight.org/pipermail/tsc/2016-July/005665.html   <--- previous analysis from colindixon
19:04:08 <zxiiro> +1 for me too
19:04:53 <anipbu> #action jamoluhrsen, abhijitkumbhare, edwarnicke_, vishnoianil, colindixon, anipbu, zxiiro to look into investigating a 6 month timeframe for our release and present something next week.
19:05:42 <jamoluhrsen> great job anipbu!
19:05:43 <anipbu> #topic cookies
19:05:53 <anipbu> #endmeeting