03:30:45 <colindixon> #startmeeting tsc
03:30:45 <odl_meetbot> Meeting started Fri Mar 24 03:30:45 2017 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
03:30:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:30:45 <odl_meetbot> The meeting name has been set to 'tsc'
03:30:50 <colindixon> #topic agenda bashing and roll call
03:30:53 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53341#Agenda
03:31:05 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-16-17.00.html last week's meeting minutes
03:31:17 <colindixon> #info colindixon
03:31:21 <colindixon> TSC members please #info in
03:31:38 <hideyuki> #info Hideyuki
03:31:54 <zxiiro> #info Thanh Ha
03:31:55 <dfarrell07> #info Daniel Farrell
03:33:08 <jamoluhrsen> #info jamoluhrsen
03:33:33 <abelur> o/
03:33:47 <LuisGomez> #info LuisGomez
03:33:50 <vishnoianil> #info Anil Vishnoi
03:33:57 <colindixon> we have quorum
03:34:31 <jamoluhrsen> dist-test timetrend: https://jenkins.opendaylight.org/releng/view/distribution/job/integration-distribution-test-boron/buildTimeTrend
03:34:35 <anipbu> #info anipbu
03:35:12 <colindixon> #action colindixon to try to find a time for an infromal meeting of ODL folks at ONS
03:35:59 <colindixon> lori: hopefully you're sleeping, but join if you can
03:36:05 <lori> #info lori
03:36:11 <lori> trying to joing webex
03:36:15 <dfarrell07> welcome lori :)
03:36:21 <abhijitkumbhare> #info abhijitkumbhare
03:36:24 <lori> thanks dfarrell07
03:36:49 <colindixon> lori: there's a different one for today
03:37:06 <lori> colindixon: yeap, that
03:37:07 <colindixon> it's the second one here: https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53341#Meeting_Schedule_and_Logistics
03:37:13 <anipbu> https://lists.opendaylight.org/pipermail/sdninterfaceapp-dev/2017-March/000230.html <--- SDNINTERFACEAPP responding to concerns
03:37:13 <CaseyODL> https://meetings.webex.com/collabs/meetings/join?uuid=M8U23SHB6WH2X6FIJ6CR6G8G8N-9VIB
03:37:13 <lori> that's what I'm trying to use
03:37:41 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
03:37:46 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
03:37:56 <colindixon> #action phrobb to start a thread on how to have the best DDF-like developer event that works for everyone, e.g., colocated with OPNFV summit in Beijing?
03:38:46 <zxiiro> Yes i'm on audio
03:38:46 <CaseyODL> lori: Still having trouble with WebEx? Are you getting an error?
03:38:48 <vrpolak> This meeting was not found and may have been removed. <--- https://meetings.webex.com/collabs/meetings/join?uuid=M8U23SHB6WH2X6FIJ6CR6G8G8N-9VIB
03:38:59 <abhijitkumbhare> Yes - I am having trouble too
03:39:11 <colindixon> huh, I was able to join here: https://meetings.webex.com/collabs/meetings/join?uuid=M8U23SHB6WH2X6FIJ6CR6G8G8N-9VIB
03:39:39 <abhijitkumbhare> Now able to join
03:39:50 <dfarrell07> I'm called-in with 1-844-740-1264 and 194 267 215
03:40:05 <colindixon> try 844.740.1264, then 194 267 214
03:40:54 <lori> CaseyODL: no error, just a timeout after a whi;e
03:41:05 <CaseyODL> :(
03:41:20 <CaseyODL> Try from an Incognito window maybe?
03:41:22 <colindixon> #action katiezhang to follow up with validation of M4 Status per project
03:41:24 <dfarrell07> CaseyODL: are there international call-in numbers?
03:41:32 <colindixon> 1-240-454-0879 Call-in toll number (US/Canada)
03:41:32 <colindixon> Access code: 194 548 370
03:41:35 <colindixon> try that maybe lori
03:41:42 <colindixon> #action rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
03:41:57 <CaseyODL> phrobb: Can you look? I don't want to log you out on accident.
03:42:19 <lori> CaseyODL: We've hit a glitch in processing your request. Try again later.
03:42:19 <lori> Error Code : 17983
03:42:19 <lori> ID : NA_55ff4829f2c27d1982ed.64dcb0c51eb54d12
03:42:23 <jamoluhrsen> LuisGomez, all these projects removed still have csit running
03:42:40 <lori> trying phone
03:42:57 <colindixon> #topic TSC mailing list votes and discussions
03:43:07 <colindixon> #info see the agenda, but most of this stuff is either old, or come to conclusion
03:43:11 <colindixon> #topic events
03:43:20 <colindixon> #link https://www.opendaylight.org/global-events
03:43:25 <LuisGomez> jamoluhrsen, we need to check if these are still required
03:43:31 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
03:43:51 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006756.html possible get together for ODL folks at ONS
03:44:51 <colindixon> #link https://www.surveymonkey.com/r/PGXT5PX open source community reception on Monday @ 6p RSVP
03:45:01 <lori> I got in on the phone
03:45:54 <colindixon> #Info jamoluhrsen asks about trying cross-project relaase syncing, colindixon says ChrisPriceAB is trying to set something up, if you want to participate, let him know
03:46:40 <colindixon> #info OpenStack Boston is 2nd week of May
03:46:50 <jamoluhrsen> hey lori :)
03:46:53 <colindixon> #info we will have a booth there, looking for demos
03:46:55 <lori> hello
03:47:20 <colindixon> welcome lori, sorry it was a pain, hopefully you're not personally paying by the minute
03:47:30 <dfarrell07> #link http://events.linuxfoundation.org/events/opnfv-summit/program/cfp CFP OPNFV
03:47:49 <lori> colindixon: no, I have a plan with many international minutes
03:48:44 <colindixon> #topic boron
03:48:56 <colindixon> #info Boron-SR3 is supposed to go out today, that's not going to happen
03:49:06 <colindixon> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1776065453 tracking spreadsheet
03:49:23 <jamoluhrsen> 174
03:49:46 <colindixon> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/219/ this is the respin which literally just finished
03:50:41 <colindixon> #info distribution test job should start now-ish and take 8-9 hours, we should have better data tomorrow morning
03:51:47 <colindixon> #info it's worht noting that since we've moved a lot more tests into distribution test jobs, resulting in 113 failures vs. 11 for SR2
03:52:59 <colindixon> #info shague notes that we really want to keep anipbu's basic release strategy of tracking test failures, votes on go-nogo (traditionally for major release only, SRs is only test failures), tracking blocking bugs, respins, etc.
03:54:52 <dfarrell07> #info shague wants to make sure we continue to get dist test results on the spreadsheet, actually track down projects and get them to sign-off/fix
03:55:23 <colindixon> #info jamoluhrsen says that all system tests are run as part of distribution test now vs. only opt-in before
03:56:08 <dfarrell07> #info shague wants to make sure we track bockers that will require respin, trigger re-spins quickly when needed
03:57:01 <colindixon> #action jamoluhrsen to add a new status type for jobs that integration opted-in without project effort, so we know which ones might have no response because of that
03:57:42 <jamoluhrsen> slightly bsc
03:58:29 <colindixon> #info colindixon hopes we'll have something we could release for Boron-SR3 by monday sometime, people should be ready to vote over e-mail on Monday
03:58:33 <anipbu> for folks, I updated the links to Boron SR3 (links to tracking spreadsheet, autorelease job, distribution test job): https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Boron_SR3_Download
03:58:41 <colindixon> anipbu: thanks!
03:58:48 <colindixon> #topic carbon
04:00:12 <colindixon> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896 Karaf 4 progress
04:00:50 <colindixon> #Info 28 projects have finished karaf 4, 7 projects have pending patches, and 16 projeects with no patches
04:01:00 <colindixon> #Info that's a bit over half or projects done
04:01:12 <colindixon> #Info anipbu notes that this puts karaf 4 migration in an unhealthy state
04:02:18 <colindixon> #info colindixon notes that, in his mind and others, this means we're either likely to kick a large number offset 2 projects out of carbon, or have people volunteer to help
04:02:44 <colindixon> #Info jamoluhrsen notes that doing patches for people, might further enable bad behavior
04:03:15 <jamoluhrsen> anipbu, all 16 projects are offset 2?
04:03:57 <colindixon> #action colindixon or katie to send out nastygrams about being removed from the release
04:06:07 <colindixon> #info jamoluhrsen and dfarrell07 say that one idea is to have true leaves participate in the release as a privilege, not a right, basically then show them how to do releases, repo:add, feature:install
04:11:18 <colindixon> #action colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
04:13:23 <colindixon> #info phrobb asks if we'll host these artifacts and instructions, colindixon says for things hosted in ODL infra we should host them, for others, it's a good question, phrobb notes that if it's a wiki page there's nothing to stop others from also adding it
04:14:07 <colindixon> #Info LuisGomez notes that some things change with testing too, and offers to help some
04:15:36 <colindixon> #Info vishnoianil notes that he worries a bit that this may result in nobody participating in the simultaneous release
04:17:28 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/53664/2 carbon autorelease is failing because of sal-netconf-connector, colindixon isn't sure why
04:17:42 <colindixon> #topic system integration and test
04:18:09 <colindixon> #Info vrpolak noteed that Karaf 4 for distribiton now has restconf, so he's working on the distribution test for that
04:18:38 <colindixon> #info there was a recent controller regression as far as clustering goes, there's a new patch merged which seems to have gotten things back to normal
04:19:18 <colindixon> #Info jamoluhrsen notes that it took 2 days to get a response and it hurt our jenkins queue
04:19:34 <colindixon> #action colindixon to create postmortem topics for Carbon and add the clustering breakage to it
04:19:53 <colindixon> #topic infrastructure
04:20:02 <colindixon> #info nothing this week
04:20:19 <jamoluhrsen> oh hey abelur
04:20:34 <colindixon> #Info abelur is on the call because this call is at a time that works for him
04:20:38 <colindixon> wecome abelur
04:20:48 <dfarrell07> hello abelur :)
04:21:41 <colindixon> #topic TSC membership
04:21:54 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006813.html language for filling vacancies
04:22:03 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006822.html 8 +1s or more
04:22:20 <colindixon> #Info phrobb and/or colindixon will take this to the board either over e-mail or at the next meeting
04:22:37 <colindixon> #info the next board meeting is 3/12
04:22:48 <colindixon> #undo
04:22:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a043d0>
04:22:51 <colindixon> #info the next board meeting is 4/12
04:22:53 <colindixon> #topic Nitrogen planning
04:23:08 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006779.html Preliminary notes on 6-month release cadence
04:23:20 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-March/006849.html proposal for month-based release schedule
04:27:23 <jamoluhrsen> openstack is now bsc
04:27:33 <colindixon> #info jamoluhrsen says he likes this, he wants to stress lining up, jamoluhrsen also asks about lining up with all or (almost all) other LF networking projects
04:28:53 <colindixon> #info dfarrell07 notes that OPNFV tries to line up with OpenStack, colindixon notes OpenStack has moved away from April and October (for the last 5 years), to releasing in Feb this last time and planning on Setpebmer
04:29:02 <colindixon> #info colindixon worries if that means they're nota good reliable clock
04:29:23 <colindixon> #info phrobb says lining up inside the LF seems like good goal
04:30:02 <jamoluhrsen> good point, we can maybe set the trend.
04:30:04 <colindixon> #info colindixon says the best way forward is probably to produce a clump and try to get others to join
04:30:33 <colindixon> #info maybe start FD.io, ODL, and OPNFV, then hope ONAP choose to align, that would be a big center of mass
04:30:53 <colindixon> #topic cookies
04:31:02 <colindixon> #endmeeting