17:03:22 <colindixon> #startmeeting tsc
17:03:22 <odl_meetbot> Meeting started Thu Mar 30 17:03:22 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:22 <odl_meetbot> The meeting name has been set to 'tsc'
17:03:27 <colindixon> #topic agenda bashing and roll call
17:03:29 <colindixon> #Info colindixon
17:03:32 <skitt> #info skitt
17:03:34 <colindixon> #Info rovarga (on voice)
17:03:36 <abhijitkumbhare> #info abhijitkumbhare
17:03:38 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53466#Agenda
17:03:45 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-24-03.30.html last week's meeting minutes
17:03:55 <hideyuki> #info Hideyuki
17:04:03 <jamoluhrsen> #info jamoluhrsen
17:04:08 <katiez> #info katie
17:04:22 <zxiiro> #info Thanh Ha
17:04:24 <colindixon> #action colindixon to e-mail about an informal ODL gathering at ONS (abeit a bit late)
17:04:40 <colindixon> #agreed there will be no TSC call next week (decided a few weeks ago)
17:04:48 <zxiiro> katiez: only TSC members need to #info in
17:04:58 <colindixon> #actoin colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:04:59 <colindixon> #actoin phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:05:29 <colindixon> #link next DDF planning thread https://lists.opendaylight.org/pipermail/tsc/2017-March/006851.html
17:05:33 <LuisGomez> #info LuisGomez
17:06:07 <CaseyODL> #link https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum Submit topics to the Nitrogen DDF here.
17:06:14 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:06:15 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:06:16 <colindixon> #action rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
17:06:17 <katiez> got it , thanks
17:06:24 <CaseyODL> ... I'm not chair so that didn't go though.
17:06:35 <colindixon> #chair CaseyODL
17:06:35 <odl_meetbot> Current chairs: CaseyODL colindixon
17:06:51 <CaseyODL> #link https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum Submit topics to the Nitrogen DDF here.
17:06:55 <colindixon> #action colindixon or katie to send out nastygrams about being removed from the release
17:07:07 <colindixon> #action colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
17:07:11 <colindixon> #action colindixon to create postmortem topics for Carbon and add the clustering breakage to it
17:07:58 <colindixon> #topic TSC mailing list
17:08:15 <colindixon> #info see agenda, mostly it's future DDF planning (above) and nitrogen planning (below)
17:08:20 <colindixon> #topic Events
17:08:26 <colindixon> #link https://www.opendaylight.org/global-events
17:08:31 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:08:41 <colindixon> #Info ONS is next week Sunday to Thursday
17:09:47 <colindixon> #info the DDF will have a wiki page up soon to start populating topics for the one end of May and start of June
17:09:59 <shague> #info shague
17:10:17 <colindixon> #info CaseyODL thinks that the booth demos are closed for the ONS booth
17:10:23 <colindixon> #topic boron
17:10:39 <colindixon> #info still churning on Boron-SR3
17:10:54 <colindixon> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1776065453 spreadsheet
17:11:30 <colindixon> #info zxiiro says we're waiting on 14 projects to OK it for now, colindixon asks if we know what fraction of them are the exact same failures that were OKed in the previous spin
17:11:39 <colindixon> #info jamoluhrsen and zxiiro say they'll look at it after this call
17:12:50 <colindixon> #action colindixon to work with jamoluhrsen and zxiiro on automating "real vs. fake" failures for future releasing
17:14:41 <CaseyODL> #info ONS has the following Demo times available: Tues, 3 and 4PM.  Wed: 2, 3 and 4PM. Thrus: 11AM, 12 and 1:30PM.  If you want to showcase a demo in the main LF booth at ONS, please contact me.
17:14:58 <jamoluhrsen> +100 to what edwarnicke just said
17:15:04 <zxiiro> +1
17:15:45 <colindixon> #info jamoluhrsen, edwarnicke, zxiiro and colindixon say that the right solution to this is really to try very hard to get projects to fix their tests, most of them aren't very hard to fix
17:17:21 <colindixon> #topic carbon
17:18:34 <colindixon> #info katiez reminds all projects to please respond about karaf 4 (don't ignore it)
17:18:50 <katiez> atrium capwap cardinal centinel  integration/distribution next of-config ttp yang-push
17:18:58 <katiez> missing M2 offset 2
17:19:06 <colindixon> #info the following projects are missing M4: atrium capwap cardinal centinel  integration/distribution next of-config ttp yang-push
17:19:25 <katiez> netconf	0 infrautils	0 genius	1
17:19:33 <katiez> M5 missing
17:19:36 <colindixon> #info the following (offset 0/1) projecs are missing M5: netconf, infrautils and genius
17:20:21 <colindixon> #action anipbu to work with katiez to validate the M4 status reports (use colindixon if need be)
17:20:49 <anipbu> #info anipbu
17:21:23 <katiez> https://bugs.opendaylight.org/show_bug.cgi?id=7976
17:21:38 <katiez> https://bugs.opendaylight.org/show_bug.cgi?id=8021
17:21:53 <colindixon> #link two API change waivers: https://bugs.opendaylight.org/show_bug.cgi?id=7976
17:21:58 <colindixon> #link two API change waivers: https://bugs.opendaylight.org/show_bug.cgi?id=8021
17:22:28 <colindixon> #Info rovarga says that they should affect nobody in OpenDaylight, but might affect downstream, one is a typo fix another is a race condition fix which requires a small API change
17:23:23 <colindixon> #info rovarga asks if we're still planning to cut the carbon branch today or hold off
17:24:33 <colindixon> #info jamoluhrsen notes that adding a new branch will increase CSIT from boron + carbon running daily to boron + carbon + nitrogen running daily?
17:27:23 <colindixon> #info colindixon asks how we're doing with Karaf 4? jamoluhrsen says that during the integration call the problem is that RESTCONF doesn't work in Karaf 4 and everything is blocked on that.
17:27:49 <shague> zxiiro: barring the discussion going on right now, would the branch pull happen at the 11:59 utc? netvirt and genius have patches in gates right now so we were expecting to at least get to that time today
17:28:12 <colindixon> #info vrpolak notes that many jobs to a RESTCONF check to get a 200 OK, and they never get it
17:28:22 <colindixon> #info skitt says that RESTCONF never comes up in the traces that vrpolak sees
17:29:39 <colindixon> #action rovarga will take a look at the isuse with RESTCONF as soon as vrpolak files a bug for it
17:31:20 <colindixon> #agreed we will cut stable/carbon branches on Monday, April 10th unless otherwise decided
17:31:24 <colindixon> #Undo
17:31:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x17b4c90>
17:32:37 <colindixon> #agreed we will cut stable/carbon branches on Monday, April 10th at 10pm UTC unless otherwise decided
17:32:51 <colindixon> #action colindixon to statt a thread as to when branch makes sense for stable/carbon
17:33:38 <vrpolak> # link https://bugs.opendaylight.org/show_bug.cgi?id=8117  <-- the karaf4 restconf bug
17:34:03 <vrpolak> #link https://bugs.opendaylight.org/show_bug.cgi?id=8117  <-- the karaf4 restconf bug
17:34:10 <colindixon> #info skitt says that the bug tracker has 24 issues open, but that may be more like 20
17:35:26 <colindixon> #info skitt says that skitt has had lots of requests for help with Karaf 4 migrations recently, he thinks that many of the 20 projects are just starting or have yet to start
17:35:47 <skitt> #link https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1
17:36:28 <colindixon> #info rovarga says that the issue in GBP is actually caludio helping and discovering projects which don't follow best practices upstream of GBP
17:36:43 <colindixon> #info rovarga says that claudio says that things get worse as they move to offset 2
17:36:58 <colindixon> #info skitt notes that some offset 2 projects don't have the SingleFeatureTest enabled, which means it's usually broken
17:37:40 <colindixon> #action colindixon to work with katiez to let projects that don't have karaf 4 done that they will be dropped from the release without it
17:38:13 <colindixon> #info skitt notes that almost everyone has moved to features-parent, but need to do pacakging jar to get the SingleFeatureTest to run
17:39:48 <colindixon> #info skitt says it would be really good if people could test their karaf4 code now
17:40:28 <skitt> #info to test with Karaf 4, switch from karaf-parent to karaf4-parent and use the features4 repository instead of features
17:40:39 <colindixon> #undo
17:40:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x196afd0>
17:40:59 <colindixon> #info to test with Karaf 4, switch from you're local karaf disgtributions use of karaf-parent to karaf4-parent and use the features4 repository instead of features
17:41:31 <colindixon> #info colindixon asks about Karaf 5, skitt says Karaf 4.1 is easy, Karaf 4.2 or 5.0 will use Java 9 which is a wildcard
17:41:41 <colindixon> #info skitt says that the next fun upgrade after Karaf 4 will be guava
17:41:49 <skitt> #info skitt qualifies "easy" as "not too hard"
17:41:58 <colindixon> #topic system integration and test
17:42:29 <colindixon> #info we have reduced the numbers of times we need to run our CSIT jobs, yay!
17:42:49 <colindixon> #topic infrastructure
17:42:52 <colindixon> #info none this week
17:43:02 <colindixon> #topic gaps in release management
17:44:17 <colindixon> #info colindixon notes that you may have been hearing more from him, jamoluhrsen and zxiiro during the last few weeks with Boron-SR3 and carbon as we transition from different people in release management roles
17:44:52 <colindixon> #info colindixon notes that we would love help
17:46:13 <colindixon> #info CaseyODL notes that one major thing people are commenting about is the test failures being reported for builds and then easier to update things frequently
17:47:00 <colindixon> #info CaseyODL also notes that keeping blocking bugs up-to-date is key
17:47:51 <zxiiro> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=75953&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- blocking bugs list
17:48:02 <colindixon> https://wiki.opendaylight.org/view/Weather#Blocker_Bugs
17:50:00 <colindixon> #Info katiez asks where blocking bugs come from, colindixon says the authoritative place where people track bugs is in the tracking spreadsheet here: https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1293046707 (for carbon)
17:50:27 <colindixon> #Info periodically, people queriy the buzilla for blocking bugs to find them and move them to the speadsheet
17:51:07 <colindixon> #action zxiiro and katiez to work together to describe how to to generate the build failure reports from distribution jobs
17:51:25 <colindixon> https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1703426731
17:51:51 <colindixon> #Link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1703426731 columns D and E are semi-automatically generated on distribution jobs
17:53:23 <colindixon> #topic conference call platform platforms
17:53:49 <colindixon> #info CaseyODL and phrobb say that the LF uses Zoom effectively for cross-OS conference calling with large numbers of participants
17:55:09 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8091 related to release engineering, this but is asking for notifications on merge failiures for active releases, which should signify a major problem
17:55:46 <colindixon> #info CaseyODL notes that Zoom has nearly universal support for OSes (Linux, Mac, Windows)
17:56:15 <colindixon> #info it allows for local and cloud recording to mp4 files as well as anyone to record (or not) which means you don't need to have the host code to record and easliy get recordings out
17:56:44 <colindixon> #info license only comes with 1 GB of cloud storage, but can be upraded to $10/GB/mo, but local recording allows for that
17:57:46 <colindixon> #info each license $14.99/mo for 50 people, can go up to 100 people for $40/mo, can allow some licenses to be community administered to let phrobb and CaseyODL get out of the way from people scheduling meetings
17:57:57 <colindixon> #info can get suage reports, if people want to use them
17:58:59 <jamoluhrsen> +1 to demo on TWS
17:59:10 <anipbu> +1 to TWS
17:59:13 <jamoluhrsen> what is the downside to webex?
17:59:28 <jamoluhrsen> because from what I can see it's a no brainer if it works.
17:59:28 <colindixon> #info starting at $100/mo, we can get international dial-ins, credit for dial ins to numbers
17:59:37 <colindixon> jamoluhrsen: skitt and vorburger among others can't make it work
17:59:47 <shague> linux users can't use webex without substantial hoops
17:59:47 <colindixon> under Linux
17:59:51 <jamoluhrsen> colindixon, ah, well then I hate it.
17:59:52 <skitt> colindixon, I've got it working,
17:59:54 <jamoluhrsen> :)
17:59:55 <anipbu> does zoom work in China?
18:00:01 <skitt> colindixon, but it's going to die with Firefox 52
18:00:01 <colindixon> anipbu: it says
18:00:24 <colindixon> #info edwarnicke asks if does who's talking notifcation + can mute people for them + recording indication
18:01:02 <colindixon> #info colindixon says that he has motivated humans at the Kernel projects + TWS when we have one
18:01:39 <colindixon> #info edwarnicke asks if multilple concurrent meetings to go on at the same time, need a separate license for each meeting, we could have multiple licenses
18:03:06 <colindixon> #info CaseyODL said that having ~6 licenses which would more than take care of our needs a lower cost than what we do now
18:04:02 <colindixon> #info abhijitkumbhare says given that we usually ask people before recording, how will that work with local recording, CaseyODL say that by default only admins can record, can be done per-call to allow only certain people to record if we want to make sure to notify people
18:04:28 <shague> CaseyODL: are they a pull of licenses or are they assigned to a specific number? Thinking of cases where meetings are back to back and if a number is shared their could be a conflict
18:04:54 <colindixon> #action CaseyODL to send mail about Zoom to relevant lists
18:05:00 <colindixon> #topic security mailng list
18:05:27 <colindixon> #info the mailing list is defunct, rovarga says that there are only 2 people reading it and neither seem to have time respond
18:05:42 <colindixon> #topic cookies
18:05:48 <CaseyODL> shague: They would be a specific number.  So they would be broken up in Meeting Group 1, 2 etc..  We can have 6 running a time.  We would just need to coordinate to ensure that the groups don't overlap.
18:06:15 <colindixon> #action colindixon to add security community population to the TSC next time
18:06:16 <colindixon> #topic cookies
18:06:17 <colindixon> #endmeeting