#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:14 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:22)
    1. colindixon (colindixon, 17:00:24)
    2. skitt (skitt, 17:00:44)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-24-03.30.html last meeting's minutes (2 weeks ago) (colindixon, 17:00:56)
    4. anipbu (anipbu, 17:01:06)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53881#Agenda today's agenda (colindixon, 17:01:09)
    6. abhijitkumbhare (abhijitkumbhare, 17:01:26)
    7. Hideyuki (hideyuki, 17:01:29)
    8. LuisGomez (LuisGomez, 17:01:38)
    9. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:01:39)
    10. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:01:39)
    11. https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum <-- ddf (jamoluhrsen, 17:02:23)
    12. DDF discussion: https://lists.opendaylight.org/pipermail/tsc/2017-March/006851.html (skitt, 17:02:42)
    13. lori (lori, 17:02:46)
    14. rovarga (rovarga, 17:02:51)
    15. Thanh (zxiiro, 17:02:53)
    16. jamoluhrsen (jamoluhrsen, 17:02:57)
    17. ACTION: katiezhang to follow up with validation of M4 and M5 Status per project (colindixon, 17:03:24)
    18. ACTION: colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release (colindixon, 17:04:15)
    19. ACTION: colindixon to create postmortem topics for Carbon and add the clustering breakage to it (colindixon, 17:04:16)
    20. Anil VIshnoi (vishnoianil, 17:05:06)
    21. https://www.irccloud.com/pastebin/7GlaYAWH/ (CaseyODL, 17:05:31)
    22. CaseyODL would like the TSC to discussion choosing between BlueJeans and Zoom today (colindixon, 17:05:31)
    23. ACTION: colindixon to add the security mailing list to today's meeting or next meeting if we dont' have time (colindixon, 17:06:16)
    24. ACTION: colindixon to add BlueJeans vs. Zoom today or next week if no time (colindixon, 17:06:28)
    25. ACTION: beryllium security release (colindixon, 17:06:43)

  2. mailing list votes and discussions (colindixon, 17:06:52)
    1. shague (shague, 17:06:58)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-April/006980.html Michael Vorburger and Stephen Kitt as committers on controller (colindixon, 17:07:02)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-April/006981.html Tomas Slusny as a committer on OpenFlow plugin (colindixon, 17:07:15)

  3. events (colindixon, 17:07:56)
    1. https://www.opendaylight.org/global-events (colindixon, 17:08:02)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:08:07)
    3. OPNFV summit in Beijgin in first week in June, Our DDF end of may/beginning of june in Santa Clara (colindixon, 17:08:55)

  4. boron (colindixon, 17:09:29)
    1. Boron-SR3 was released last week (colindixon, 17:09:40)

  5. Carbon (colindixon, 17:09:47)
    1. chasing projects that haven't gotten their milestones in (colindixon, 17:10:07)
    2. the following projects are still absent: atrium capwap cardinal centinel next yang-push (colindixon, 17:10:47)
    3. colindixon notes that he's pretty sure atrium, capwap, centinel, and yang-push have already left the Carbon release (colindixon, 17:11:42)
    4. ACTION: colindixon to work with zxiiro and katie_ to figure out if we should drop next and cardinal (colindixon, 17:12:03)
    5. the following projects are still missing M5: dlux faas genius lacp natapp next nic opflex ovsdb snbi snmp4sdn tsdr usecplugin yang-push (colindixon, 17:12:34)
    6. projects having issues with karaf 4: federation alto BIER netconf (colindixon, 17:15:06)

  6. Karaf 4 migration risk and status (colindixon, 17:15:24)
    1. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896 (colindixon, 17:15:30)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-April/006957.html Mailing list thread on Karaf 4 risks and options (colindixon, 17:15:40)
    3. during the kernel call on Tuesday, it seems as though very few projects have done very little testing of their Karaf 4 distributions, the result is that other than green verify +1s, we have very little testing of Karaf 4 itself (colindixon, 17:17:04)
    4. it appears as though there's still less manpower than needed to drive this forward (colindixon, 17:17:37)
    5. restconf was broken in Karaf 4, but then was fixed, after that the upgrade to Karaf 4.0.9, but it seems to be a feature resolution issue in Karaf (colindixon, 17:18:59)
    6. anipbu says that this is our current status for Karaf 4 migration patches is: 11 Projects pending. 8 with pending patches. 3 without any patches. 3 nonleaf project cannot be dropped (colindixon, 17:19:54)
    7. skitt asks if we could roll back to 4.0.7, rovarga says that might work (colindixon, 17:20:37)
    8. colindixon asks if we get restconf fixed (which seems plausible), we could then have a reasonable Karaf 4 distribution which we could test (colindixon, 17:21:38)
    9. ACTION: jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez (colindixon, 17:22:10)
    10. https://bugs.opendaylight.org/show_bug.cgi?id=8208 (jamoluhrsen, 17:22:57)
    11. https://git.opendaylight.org/gerrit/53797 (vrpolak, 17:24:39)
    12. ETA to merge: 1 week. (vrpolak, 17:24:53)
    13. jamoluhrsen and LuisGomez note that RC0 is supposed to be today and even if we were to unblock Karaf 4 distributions today, there's no way we could get all the jobs in place to meaningfully get carbon out the door (colindixon, 17:25:03)
    14. based on this assessment, we are 2-3 weeks behind where we would really like to be, but that's with zero system testing (colindixon, 17:27:13)
    15. if system testing is mostly clean, that woiuld mean that was it, otherwise, that might be off by another 1-2 weeks as we figure things out (colindixon, 17:27:38)
    16. rovarga says his hope is that we should have much fewer issues once we get out toward leaf projects (colindixon, 17:28:16)
    17. lori has been testing Karaf 4, the distribution seems to build locally and come up fine, but the integration tests don't work locally, but do work in jenkins (colindixon, 17:31:07)
    18. skitt and rovarga note that pax-exam issues when moving to Karaf 4 weren't trivial (colindixon, 17:31:48)
    19. colindixon notes that there is no way that we can have an RC0 today, next week would be as early as possible (colindixon, 17:34:57)
    20. we haven't started putting features into the Karaf 4 distribution yet, in part becuase we don't have a distribution check for our Karaf 4 distribution (colindixon, 17:35:54)
    21. from anipbu: Leaf projects with Karaf 4 Pending: cardinal, didm, iotdm, lacp, nic, snmp4sdn, unimgr. Nonleaf projects with Karaf 4 Pending: snmp, tsdr (colindixon, 17:36:18)
    22. vishnoianil asks if we could ship Karaf 3 in Carbon and switch to Karaf 4 in Carbon SR1 (colindixon, 17:39:16)
    23. colindixon notes that given how much trouble we've had migrating from Karaf 3 to Karaf 4 internally, it seems like downstream users would find that super jarring (colindixon, 17:42:30)
    24. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/ (jamoluhrsen, 17:44:52)
    25. colindixon asks if we have a Karaf 3 RC0 today if we wanted to do that, anipbu notes that we haven't had a succsessful carbon autorelease build since February (colindixon, 17:45:41)
    26. skitt notes that his feeling from the projects he touches is that Carbon is in generally better shape than Boron was going into RC0 failing builds or not (colindixon, 17:46:51)
    27. colindixon asks if we can get autorelease building without leaf projects to see if we can cut out some noise (colindixon, 17:49:41)
    28. AGREED: colindixon says that as far as he understands we have repeatedly communicated to projects that Karaf 4 is required for Carbon participation, also we have given the integration and autorelease projects permission to remove projects which are interfering with the release to make progress knowing that projects which are truly participating can quickly fix issues and re-add themselves (colindixon, 17:52:17)
    29. ACTION: colindixon will look up the agreement that karaf4 is required for Simultaneous Release participation (rovarga, 17:53:44)

  7. zoom vs. bluejeans (colindixon, 17:54:20)
    1. edwarnicke says he's had trouble using bluejeans internationally, zoom doesn't seem to have those problems (colindixon, 17:54:36)
    2. edwarnicke says echos, latency, etc. (colindixon, 17:54:52)
    3. skitt notes Red Hat has had no such issues despite using internationally (colindixon, 17:55:17)
    4. to be clear this is informational, not decisive in my mind (colindixon, 17:58:49)
    5. VOTE: Voted on "(anyone, not just TSC members please also chime in) do people prefer bluejeans, zoom, or don't care?" Results are, bluejeans: 5, either: 4, zoom: 1 (colindixon, 17:59:36)
    6. ACTION: CaseyODL to send mail to disucss@ tsc@ saying what the time-frame (colindixon, 18:02:23)

  8. cookies (anipbu, 18:04:21)


Meeting ended at 18:04:31 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. katiezhang to follow up with validation of M4 and M5 Status per project
  4. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
  5. colindixon to create postmortem topics for Carbon and add the clustering breakage to it
  6. colindixon to add the security mailing list to today's meeting or next meeting if we dont' have time
  7. colindixon to add BlueJeans vs. Zoom today or next week if no time
  8. beryllium security release
  9. colindixon to work with zxiiro and katie_ to figure out if we should drop next and cardinal
  10. jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez
  11. colindixon will look up the agreement that karaf4 is required for Simultaneous Release participation
  12. CaseyODL to send mail to disucss@ tsc@ saying what the time-frame


Action items, by person

  1. CaseyODL
    1. CaseyODL to send mail to disucss@ tsc@ saying what the time-frame
  2. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
    3. colindixon to create postmortem topics for Carbon and add the clustering breakage to it
    4. colindixon to add the security mailing list to today's meeting or next meeting if we dont' have time
    5. colindixon to add BlueJeans vs. Zoom today or next week if no time
    6. colindixon to work with zxiiro and katie_ to figure out if we should drop next and cardinal
    7. colindixon will look up the agreement that karaf4 is required for Simultaneous Release participation
  3. jamoluhrsen
    1. jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez
  4. katie_
    1. colindixon to work with zxiiro and katie_ to figure out if we should drop next and cardinal
  5. LuisGomez
    1. jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez
  6. vrpolak
    1. jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez
  7. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to work with zxiiro and katie_ to figure out if we should drop next and cardinal
  8. UNASSIGNED
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    2. katiezhang to follow up with validation of M4 and M5 Status per project
    3. beryllium security release


People present (lines said)

  1. colindixon (80)
  2. skitt (28)
  3. anipbu (16)
  4. odl_meetbot (12)
  5. jamoluhrsen (9)
  6. rovarga (5)
  7. zxiiro (5)
  8. afredette (4)
  9. dfarrell07 (4)
  10. abhijitkumbhare (3)
  11. katie_ (3)
  12. vrpolak (2)
  13. shague (2)
  14. hideyuki (2)
  15. vishnoianil (2)
  16. LuisGomez (1)
  17. edwarnicke (1)
  18. lori (1)
  19. CaseyODL (1)


Generated by MeetBot 0.1.4.