17:01:35 <colindixon> #startmeeting tsc
17:01:35 <odl_meetbot> Meeting started Thu Apr 20 17:01:35 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:35 <odl_meetbot> The meeting name has been set to 'tsc'
17:01:40 <colindixon> #topic roll call and agenda bashing
17:01:50 <colindixon> TSC members please #info in
17:01:55 <colindixon> we're using Zoom this week: https://zoom.us/j/896670700
17:01:58 <colindixon> #info colindixon
17:02:00 <anipbu> #info anipbu
17:02:07 <abhijitkumbhare> #info abhijitkumbhare
17:02:09 <colindixon> #Link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-04-13-17.00.html last week's meeting minutes
17:02:17 <hideyuki> #info Hideyuki
17:02:26 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=54053#Agenda agenda
17:02:29 <vishnoianil> #info Anil Vishnoi
17:02:37 <skitt> #info skitt
17:02:57 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:02:58 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:02:59 <colindixon> #action katiezhang to follow up with validation of M4 and M5 Status per project
17:03:00 <colindixon> #action colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
17:03:01 <colindixon> #action colindixon to create postmortem topics for Carbon and add the clustering breakage to it
17:03:08 <dfarrell07> #info Daniel Farrell for Jamo
17:03:10 <CaseyODL> Recording has started.
17:03:28 <colindixon> #action colindixon to add beryllium security release if needed to the agenda for next week if we don't get to it
17:03:46 <LuisGomez> #info LuisGomez
17:04:18 <colindixon> #action jamoluhrsen to talk to vrpolak about how to get Karaf 4 distribution testing going along with perhaps LuisGomez
17:04:19 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/53797/
17:04:32 <dfarrell07> ^^that's the one
17:04:43 <colindixon> #info the idea is to merge that patch today
17:04:55 <colindixon> #action colindixon will look up the agreement that karaf4 is required for Simultaneous Release participation
17:05:28 <edwarnicke> #info edwarnicke
17:05:43 <shague> #info shague
17:06:16 <lori> #info lori
17:06:29 <rovarga> #info rovarga
17:06:32 <colindixon> #action colindixon to add back should we do Karaf 4 in Carbon or Nitrogetn (especially if Ntirogen is a mini-release)
17:06:59 <colindixon> #topic events
17:07:09 <colindixon> #link https://www.opendaylight.org/global-events
17:07:13 <CaseyODL> lori: Did you fix your audio issues?
17:07:19 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:07:45 <colindixon> #info DDF on 5/31 and 6/1 is coming up
17:08:13 <colindixon> #link https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum topics page for the DDF, please get them in so we can start planning things
17:08:35 <colindixon> #topic Boron
17:08:51 <colindixon> #info nothing this week
17:08:56 <colindixon> #topic Carbon
17:09:25 <colindixon> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/ we have had a few successful builds of autorelease carbon
17:09:42 <colindixon> #info as we're adding projects back in with Karaf 4 support, we're seeing some instability
17:10:05 <colindixon> #info currently, TSDR and Cardinal aren't really ready and needs to be taken out
17:10:21 <colindixon> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896 Karaf 4 tracking sheet
17:10:26 <lori> CaseyODL: yes
17:10:55 <colindixon> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 Karaf 4 blocking bugs sheet
17:11:58 <dfarrell07> #info Vratko's patch to make jobs karaf-version specific was just merged
17:12:52 <colindixon> #Info we're just getting CSIT that runs against Karaf 4 now
17:13:54 <colindixon> #Info vorburger noticed issues with Karaf 4 and pax exam that we will need to fix to get tests working right
17:15:18 <dfarrell07> #info The Carbon autorelease jobs that recently "worked" didn't actually push artifacts to Nexus (so they are gone), zxiiro will add logic to check if size is problem, we don't have the RC0 mentioned on TSC mail thread
17:16:09 <zxiiro> we should discuss ^
17:16:14 <dfarrell07> +1
17:16:24 * zxiiro is working on opening a bug now
17:17:57 <colindixon> #Info colindixon says that his feel is that we're 1.5-2 weeks behind right now, because we have had sucessful builds of autorelease carbon and we're likley to have all the projects we need in by the end of this week and/or beginning of next week
17:18:06 <colindixon> #info skitt says that's his take too
17:18:39 <colindixon> #info colindixon notes that this is assuming that nothing unexpected _really_ blows up as we start to be able to test and bang on our Karaf 4 distribution, vishnoianil also confirms that
17:21:05 <colindixon> #action zxiiro to look into how to ensure that we actually will actually have a version of the distribution on successful runs, even storing it in Jenkins
17:21:35 <vishnoianil> I have a feeling it's going to spill over 2 weeks, because we still didn't started with the big beast.. testing karaf4
17:25:26 <colindixon> #info colindixon asks if we have a karaf 3 distribution? vrpolak and rovarga say yes and it's looking mostly like it's working.
17:25:59 <colindixon> #info that means that we do have the option of going back to karaf 3 if we chose to do so, so that's at least the option
17:27:36 <colindixon> #info at this point we have a karaf 4 distribution, but the only thing that's in it is RESTCONF
17:28:39 <colindixon> #info anipbu asks if the plan is for projects to add themselves to the karaf 4 distribution, vrpolak says that maybe the better appraoch now is to start with offset 0 and move forward adding features from karaf 3 and make sure distribution checks work
17:30:22 <colindixon> #info anipbu asks what the ETA would be? vrpolak doesn't know? probably in 1 week if he has to do it himself.
17:31:55 <colindixon> #action colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features
17:36:24 <colindixon> #info colindixon aks if the genera idea of waiting until next week to figure out how long a delay we think we need to ship Karaf 4
17:38:33 <anipbu> +1 to ed
17:39:14 <colindixon> #info colindixon asks the TSC what we feel like we should do, wait another week for more information, decide to abandon Karaf 4 in Carbon, or charge ahead on Karaf 4
17:39:26 <colindixon> #undo
17:39:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x190f210>
17:39:37 <colindixon> #info colindixon asks the TSC what we feel like we should do, wait another week for more information, decide to abandon Karaf 4 in Carbon, or charge ahead on Karaf 4 no matter the delay
17:40:55 <colindixon> #startvote should we (1) abandon karaf 4 in Carbon, focus on Karaf 3 with a quick (with 3ish months or shorter) follow-on release to target karaf 4, (2) wait a week and see where we are, (3) push on Karaf 4 unless the delay egregious, e.g., 6+ weeks? 1, 2, 3
17:40:55 <odl_meetbot> Begin voting on: should we (1) abandon karaf 4 in Carbon, focus on Karaf 3 with a quick (with 3ish months or shorter) follow-on release to target karaf 4, (2) wait a week and see where we are, (3) push on Karaf 4 unless the delay egregious, e.g., 6+ weeks? Valid vote options are 1, 2, 3.
17:40:55 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:40:58 <colindixon> #vote 2
17:41:01 <anipbu> #vote 2
17:41:05 <rovarga> #vote 3
17:41:08 <hideyuki> #vote 2
17:41:14 <shague> #vote 2
17:41:15 <skitt> #vote 3
17:41:16 <lori> #vote 2
17:41:16 <zxiiro> #vote 2
17:41:19 <dfarrell07> #vote 3
17:41:23 <edwarnicke> #vote 2
17:41:24 <abhijitkumbhare> #vote 1
17:41:24 <vishnoianil> #vote 2
17:41:38 <colindixon> #endvote
17:41:38 <odl_meetbot> Voted on "should we (1) abandon karaf 4 in Carbon, focus on Karaf 3 with a quick (with 3ish months or shorter) follow-on release to target karaf 4, (2) wait a week and see where we are, (3) push on Karaf 4 unless the delay egregious, e.g., 6+ weeks?" Results are
17:41:38 <odl_meetbot> 1 (1): abhijitkumbhare
17:41:38 <odl_meetbot> 3 (3): skitt, rovarga, dfarrell07
17:41:38 <odl_meetbot> 2 (8): anipbu, edwarnicke, shague, hideyuki, colindixon, lori, zxiiro, vishnoianil
17:43:00 <colindixon> #topic system integration and test
17:43:27 <colindixon> #info anipbu says he's considering a blacklist of integration test failures because there are currently 214 and that's too many to follow up on each one
17:43:41 <colindixon> #Info if you have test failures and want us to care about them, look now :-)
17:44:09 <abhijitkumbhare> My option 1 was actually: focus on getting some release out in time - whether karaf 3 or karaf 4 - to maintain ODL credibility
17:44:19 <colindixon> abhijitkumbhare: noted
17:45:22 <colindixon> #info LuisGomez says that the patch for doing test of Karaf 4 was merged, the default for CSIT is now Karaf 4, so it's going to start failing a lot
17:46:11 <colindixon> #info our current plan is to only use CSIT on either Karaf 4 or Karaf 3
17:46:44 <colindixon> abhijitkumbhare: there's the trade-off of shipping something that is significantly out of date and will blow up on us in a way that requires unplanned an painful upgrades to Karaf 4 when we have issues for security
17:46:57 <rovarga> colindixon: +1
17:47:15 <dfarrell07> +1
17:47:31 <dfarrell07> Releasing clearly-insecure distro is also major hit to cred
17:48:28 <hideyuki> dfarrell07: That makes sense to me.
17:48:40 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-April/010130.html there's an ongoing meeting, currently at 8a pacific every day for (hopefully) 15 minutes
17:50:52 <katie> I am muted
17:50:59 <colindixon> #info skitt asks what happened with release reviews, colindixon says we're not really yet ready yet, among other things, we really want to know from projects that they've tried their karaf 4 distribution
17:51:00 <katie> I already sent out those emails
17:51:05 <katie> it is ok
17:51:10 <katie> I will talk here
17:51:33 <katie> I will resend another copy
17:51:43 <katie> I sent it to release list
17:51:45 <colindixon> #action colindixon to make sure people have been told that their release reviews will start likely sometime next week
17:51:45 <katie> yesterday
17:51:48 <katie> resending it
17:51:49 <colindixon> katie: thanks
17:52:07 <colindixon> #topic infrastructure
17:52:19 <katie> sorry
17:52:24 <katie> one more thing for carbon
17:52:39 <colindixon> #info nothing other than the missed artifacts being published in from autorelease for carbon
17:52:42 <katie> does TSC already give permission to frank to help snmp?
17:52:59 <colindixon> katie: has Frank asked to be a committer?
17:53:06 <colindixon> I didn't see that mail if it happened
17:53:18 <katie> I think frank asked to help??
17:53:25 <katie> just Sent another copy?
17:53:30 <katie> let me find the link
17:53:32 <colindixon> yeah, but then didn't respond to my e-mail calling for volunteers last I saw
17:53:36 <skitt> he didn't ask to be a committer
17:53:55 <edwarnicke> zxiiro: I do recall you mentioning that Karaf 4 was doing some build time inclusion stuff from maven files?  If so, that might be the source of our size woes...
17:54:29 <zxiiro> edwarnicke: That wouldn't be from me.
17:54:36 <zxiiro> edwarnicke: i'm not aware of such a thing
17:54:40 <edwarnicke> zxiiro: I am hoping I simply confused
17:55:09 <colindixon> #action colindixon to bring up SNMP committers and/or dropping it in Nitrogen
17:55:26 <rovarga> edwarnicke: actually our K4 distro should be smaller
17:55:32 <rovarga> than K3
17:55:35 <edwarnicke> rovarga: That is good news :)
17:55:51 <abhijitkumbhare> About earlier point: agree about the tradeoff colindixon & dfarrell07 - I am not suggesting shipping clearly-insecure distro (whatever option we take we should have a secure distro). but we also need to consider our release schedules & consider the tradeoffs if the delay is really significant.
17:55:57 <rovarga> just because we package less crap into opendaylight-karaf4-empty :)
17:55:57 <anipbu> https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/251/artifact/dependencies.log
17:56:54 <katie> I resend the email of postpone the release interview, also CCed conlin, it is strange, I do not see it in the release mailing list
17:57:56 <colindixon> #topic TSC conference platform
17:58:01 <hideyuki> katie: this one? https://lists.opendaylight.org/pipermail/release/2017-April/010201.html
17:58:44 <colindixon> #info CaseyODL says he hopes people have gotten some time with Zoom and BlueJeans, and seen what things are like
17:59:24 <colindixon> #info CaseyODL says at this point since many other LF projects use Zoom and it's much lower cost, the plan is to move to Zoom unless there is a critical complaint that means we shouldn't
17:59:32 <katie> no, not that one, there is another one for everybody. :(
17:59:34 <tykeal> I can attest to their response time
17:59:54 <tykeal> I had an issue with the app when I updated my workstation and they had a fix in less than 6 hours for me
17:59:58 <abhijitkumbhare> Zoom experience is fine so far
18:00:25 <colindixon> #info CaseyODL further says that Zoom has been responsive to fixing issues and adding features, tykeal says he's been impressed with Zoom responses too
18:00:45 <hideyuki> Zoom is also fine to me so far.
18:00:55 <colindixon> #info CaseyODL plans to cancel all WebEx meetings this week and migrating meetings to Zoom
18:03:25 <tykeal> hehe, that's a complain I've got for several of our tools ;)
18:03:39 <tykeal> s/complain/complaint/
18:03:55 <colindixon> #info nobody objects
18:03:57 <colindixon> #topic cookies
18:04:00 <colindixon> #endmeeting