03:30:54 <dfarrell07> #startmeeting tsc
03:30:54 <odl_meetbot> Meeting started Fri Apr 28 03:30:54 2017 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
03:30:54 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:30:54 <odl_meetbot> The meeting name has been set to 'tsc'
03:30:59 <dfarrell07> #chair colindixon
03:30:59 <odl_meetbot> Current chairs: colindixon dfarrell07
03:31:33 <dfarrell07> #chair phrobb anipbu CaseyODL jamoluhrsen LuisGomez
03:31:33 <odl_meetbot> Current chairs: CaseyODL LuisGomez anipbu colindixon dfarrell07 jamoluhrsen phrobb
03:31:43 <colindixon> hey
03:31:44 <jamoluhrsen> #info jamoluhrsen
03:31:45 <colindixon> #topic agenda bashing and roll call
03:31:46 <colindixon> TSC members please #info in
03:31:46 <colindixon> #info colindixon
03:31:48 <tykeal> #info Andrew Grimberg proxy for Thanh Ha
03:31:57 <dfarrell07> #info Daniel Farrell for Sam Hague
03:32:38 <lori> #info lori
03:32:48 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-01-05-18.04.html last week's meetin minutes
03:32:59 <LuisGomez> #info LuisGomez
03:33:05 <colindixon> #Link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=54302#Agenda agnda for this week
03:33:18 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
03:33:19 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
03:33:20 <colindixon> #action colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
03:33:21 <colindixon> #action colindixon to work with zxiiro, anipbu, and others to try to help work with projects to generate the patches to populate karaf 4 features
03:33:29 <colindixon> #link colindixon created postmortem topics for Carbon and added the clustering breakage to it https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Lessons_learned_during_the_Carbon_release
03:33:30 <colindixon> #info we will remember to question SNMP when/if it seeks to participate in Nitrogen
03:33:31 <colindixon> #info colindixon has made sure people have been told that their release reviews will start once we have some RCs to have tested
03:33:32 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8265 it appears as though autorelease-carbon failing to create staging repositories was due to either (1) something very strange about tsdr or cardinal or (2) something about our current tests
03:33:33 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-01-05-18.04.html see 5.p for where the TSC agreed to make Karaf 4 a requirement for Carbon on 1/5/17
03:35:01 <jamoluhrsen> so colindixon's voice sounds much different in zoom. not sure if I like it better or worse
03:35:11 <LuisGomez> :)
03:35:29 <tykeal> colindixon: you're going to need to start the recording...
03:35:38 <abelur> o/
03:35:48 <colindixon> katiezhang to follow up with validation of M4 and M5 Status per project
03:36:23 <katie> https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165
03:37:58 <abhijitkumbhare> #info abhijitkumbhare
03:37:58 <colindixon> #action katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165
03:38:12 <colindixon> #info we do have the security team on the agend for today
03:39:42 <colindixon> #info jamoluhrsen ran one AAA CSIT against the artifacts that came out of the sandbox job, and that worked 2 of 3 times
03:40:27 <tykeal> do we have quorum?
03:40:41 <vishnoianil> #info Anil Vishnoi
03:40:43 <dfarrell07> 7
03:40:44 <dfarrell07> 8
03:41:05 <colindixon> #topic events
03:41:08 <colindixon> #Link https://www.opendaylight.org/global-events
03:41:08 <colindixon> #Link https://wiki.opendaylight.org/view/Events:Main
03:41:15 <colindixon> #info hopefully we'll be done releasing carbon by the DDF on 5/31
03:41:26 <jamoluhrsen> glass half empty ?
03:41:36 <abhijitkumbhare> fully empty :)
03:41:41 <jamoluhrsen> lol
03:42:05 <colindixon> #topic boron
03:42:12 <colindixon> #info nothing this week
03:42:30 <colindixon> #topic infrastructure
03:43:09 <colindixon> #link we will have a maintainance window on Saturday https://lists.opendaylight.org/pipermail/release/2017-April/010435.html critical security fixes
03:43:23 <colindixon> #Info tykeal says that he hopes it should be fast, but it's 3-hours
03:43:42 <colindixon> #topic Carbon
03:44:02 <colindixon> #Link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 this is the blocking bugs part of the one big spreadsheet
03:44:16 <colindixon> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896 karaf 4 progress in the same spreadsheet
03:44:44 <colindixon> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/ last succsessful autoreleas was last week (7d7h ago)
03:45:33 <colindixon> #link https://jenkins.opendaylight.org/sandbox/job/autorelease-release-notests-carbon/ we have a skiptest autorelease job in the sandbox, that hopefully abelur will move to regular autorelese, that does produce artifacts
03:46:08 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8322 this bug is tracking our woes with autorelease
03:47:06 <tykeal> jamoluhrsen: that hand raised in the participants window is funny
03:47:27 <jamoluhrsen> tykeal, i dont see it
03:47:54 <tykeal> jamoluhrsen: probably because you raised your hand? I see the icon just went away
03:51:43 <colindixon> #info colindixon goes on a long tirade about how to progress from here, which boils down to BUGs 8322 to 8325
03:51:55 <jamoluhrsen> that is something we don't know.
03:52:03 <jamoluhrsen> are projects ignoring their own UT failures?
03:52:20 <tykeal> jamoluhrsen: we've had a few projects that were doing manual Verify +1
03:52:23 <tykeal> not many
03:54:01 <colindixon> #info colindixon and LuisGomez say that ignoring unit tests failures in autorelease, is probably relatively safe since most (hopefully all) projecst will be checking for their own unit test failures
03:54:32 <abelur> https://jenkins.opendaylight.org/releng/view/Merge-Carbon/
03:54:39 <colindixon> #Link https://jenkins.opendaylight.org/releng/view/Merge-Carbon/ this is a good link to see if unit tests are failing in projects
03:55:36 <jamoluhrsen> well that means autorelease alone is where this stuff is failing :(
03:55:52 <colindixon> #Info we can see there that merge jobs are not failing, so it's special about autorelease that things are failing
03:58:24 <colindixon> #Info abelur says he's noticed high memory usage, now including sar files in artifacts so we can look at it
03:58:44 <colindixon> #info colindixon notes that expeting projects to look there won't happen, we will need to find particular culprits
03:59:30 <colindixon> #topic (really a subtopic of carbon) karaf distributino testing and CSIT stuff
04:00:04 <colindixon> #info we removed all features from the karaf4 distribution because the distribution-check job was taking way too long
04:00:32 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=7900 bug 7900 fixed that, so we should be able to add features back
04:01:03 <colindixon> #info vrpolak notes that for most projects that now means we can make progress, but some projects being added will break things again
04:01:20 <colindixon> #action vrpolak can you please mark the bugs against projects as blockers
04:02:10 <vrpolak> #link https://bugs.opendaylight.org/show_bug.cgi?id=7891  <-- Things to fix in Netconf.
04:03:26 <colindixon> #Info the lifecycle management in karaf 4 is different from karaf 3 and that is causing us issues
04:03:55 <vrpolak> #link https://git.opendaylight.org/gerrit/56147  <-- An example of Karaf 4 feature fix.
04:03:57 <colindixon> #info LuisGomez, vrpolak, and jamoluhrsen note that we might need to have some pretty wide-ranging changes across projects to fix things related to that
04:04:40 <jamoluhrsen> lol
04:04:45 <colindixon> #info colindixon would like to note that vrpolak actually knows what he's talking about here, unlike jamoluhrsen and colindixon
04:07:06 <colindixon> #info abhijitkumbhare asks if there's light at the end of the tunnel, colindixon says it's basically that things seem to actually work once you get a distribution, so things are likely much better than it appears and most things are false positives
04:08:51 <vrpolak> #link https://git.opendaylight.org/gerrit/56100  <-- Opt-in way to test Carbon Karaf 4 once a feature repo is in distribution (before abandoning Carbon Karaf 3 test).
04:10:04 <colindixon> #info colindixon notes that if things were really all on fire all over the place, we wouldn't see projects able to test with local distributions and we'd see merge failures and CSIT was also broken
04:10:41 <colindixon> #info abelur notes that he's already on BUG-8323 (with -DskipTests) and BUG-8324 (with -fn)
04:12:12 <abhijitkumbhare> jamoluhrsen: I see your raised hand again - and as tykeal noted it does look funny :)
04:14:17 <colindixon> #info abelur notes that -fn might not be as useful as we hope, colindixon agrees, but maybe hopes it will flush out some of our failures
04:15:04 <colindixon> #topic (really a sub-topic of carbon) karaf 4 features into int/dist
04:15:27 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2017-April/010444.html
04:16:05 <colindixon> #info it seems as though the integration team, e.g., jamoluhrsen, vrpolak, LuisGomez and others are going to be adding karaf 4 features to integration/distribution rather than relying on projects
04:16:14 <vrpolak_> The next big thing we need to make work in Karaf 4 is netconf-connector. Many projects use that to reconfigure ODL in CSIT.
04:16:32 <colindixon> #info this will start tomorrow, probably hopefully
04:16:40 <colindixon> #info vrpolak_ notes that The next big thing we need to make work in Karaf 4 is netconf-connector. Many projects use that to reconfigure ODL in CSIT
04:17:23 <colindixon> #Link https://git.opendaylight.org/gerrit/#/c/56036/ colindixon thinks we can merge this now
04:17:58 <abelur> abhijitkumbhare, dint realize we need to raise hands before interrupting :)
04:18:20 <colindixon> #topic security team
04:18:27 <abhijitkumbhare> Yes - other teacher colindixon will be mad :)
04:18:40 <abhijitkumbhare> s/other/otherwise
04:19:36 <colindixon> #info we'll cover this again next week because rovarga is the biggest person who wants this covered
04:20:21 <abhijitkumbhare> do a “lower hand” jamoluhrsen
04:21:04 <colindixon> #info basically, we don't have enough spare cycles from people on the security team, which is basically edwarnicke, cdub, rovarga, rgoulding, and a few people who only basically file CVEs now (David Jorm, Kurt Seifreid, and Summer Long)
04:22:19 <colindixon> #info if there are people who would like to help, we are currently deeply in need of extra cycles handing security-related things and vulnerability reports
04:22:39 <colindixon> #info we are handling things, but help would be good
04:24:13 <colindixon> #topic cookies
04:24:19 <jamoluhrsen> thanks colindixon !
04:24:25 <colindixon> #endmeeting