#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:07 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 17:00:15)
    1. colindixon (colindixon, 17:00:25)
    2. Anil Vishnoi (vishnoianil, 17:00:27)
    3. skitt (skitt, 17:00:28)
    4. jamoluhrsen (jamoluhrsen, 17:00:28)
    5. Hideyuki (hideyuki, 17:00:35)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=54416#Agenda (colindixon, 17:00:35)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-04-28-03.30.html last week's meeting minutes (colindixon, 17:00:48)
    8. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:01:09)
    9. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:01:09)
    10. ACTION: colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release (colindixon, 17:01:10)
    11. ACTION: katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165 (colindixon, 17:01:11)
    12. abhijitkumbhare (abhijitkumbhare, 17:01:14)
    13. rovarga (rovarga, 17:01:37)
    14. LuisGomez (LuisGomez, 17:03:02)
    15. LuisGomez and vrpolak are working on enabling features in the karaf 4 distribution and filing blocking bugs against projects that aren't loading properly (colindixon, 17:03:19)
    16. anipbu (anipbu, 17:04:18)
    17. lori (lori, 17:04:30)

  2. events (colindixon, 17:05:06)
    1. https://www.opendaylight.org/global-events (colindixon, 17:05:18)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:05:24)
    3. there's an ONAP event happening now in NJ (colindixon, 17:05:33)
    4. openstack boson is next week (colindixon, 17:05:56)
    5. our DDF is at the end of the month (hopefully) after our release (colindixon, 17:06:10)
    6. ONAP is working on getting a release plan and timelines for project proposals, tentative release date of 11/2 (not approved yet) (colindixon, 17:06:48)
    7. colindixon notes that ONAP is using ODL Beryllium for both App-C and SDN-C (colindixon, 17:07:21)
    8. vishnoianil says that they are trying to move to ODL boron in ONAP (colindixon, 17:09:17)
    9. ACTION: if you are attending OpenStack Boston, reach out to casey since there might be a community event (colindixon, 17:10:12)

  3. boron (colindixon, 17:10:24)
    1. nothing this week (colindixon, 17:10:26)

  4. carbon (colindixon, 17:10:32)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2017/carbon_release_sync/opendaylight-meeting-carbon_release_sync.2017-05-04-15.01.html from the release sync this morning (colindixon, 17:11:08)
    2. https://lists.opendaylight.org/pipermail/release/2017-May/010691.html (colindixon, 17:11:36)
    3. https://git.opendaylight.org/gerrit/#/c/56541/ skitt has a patch which makes dependency=true default (colindixon, 17:14:11)
    4. rovarga asks if this is true also for bulk feature installation, incremental feature installation, or both (colindixon, 17:16:09)
    5. LuisGomez says he's seen both fail in this way, LuisGomez also thinks just adding a feature repo (colindixon, 17:16:52)
    6. colindixon wonders if adding repos is really just ascribing blame to specific things for random/sporadic failures, LuisGomez says he doesn't think so (colindixon, 17:19:35)
    7. rovarga asks if we have these behaviors with reproduction instructions documented, LuisGomez says not really yet (colindixon, 17:20:05)
    8. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=259245455 bugs LuisGomez has opened so far are here (colindixon, 17:20:37)
    9. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 blocking bugs tracker (colindixon, 17:23:11)
    10. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/ autorelease job (colindixon, 17:23:32)
    11. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-notests-carbon/ jenkins -DskipTest job (colindixon, 17:23:44)
    12. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-failnever-carbon/ jenkins -fn and skip SFT job (colindixon, 17:24:01)
    13. https://git.opendaylight.org/gerrit/56545 (skitt, 17:25:06)
    14. we will merge skitt's odlparent dependency=true patch and see if it fixe things over the course of the next day (colindixon, 17:25:29)
    15. colindixon asks rovarga if he thinks that featuresBoot features is different, rovarga says he thinks so, but it's not clear if dpendency=true will help or not (colindixon, 17:26:26)

  5. keep going on karaf 4? (colindixon, 17:26:57)
    1. we are 1 week from our original planned release date (colindixon, 17:27:11)
    2. we are 3.5 weeks from the DDF, so if at all possible we'd really like to release in 3 weeks or less (colindixon, 17:27:28)
    3. what does that mean we should do with respect to Karaf 4 (colindixon, 17:27:42)
    4. skitt says that Karaf 3 still has security support from apache, but that doesn't totally save us as it could be that karaf 3 stops us from pulling in a dependency that would be critical for us, but doesn't matter to Karaf (colindixon, 17:28:05)
    5. rovarga asks what about apache commons on the classpath that is vulnerable and we need to upgrade (colindixon, 17:29:32)
    6. vrpolak asks if karaf 3 will have security support through Carbon-SR4 (and actually it really needs to be Oxygen release) (colindixon, 17:30:35)
    7. abhijitkumbhare is noting that he suspects some downstreams will not pick up Karaf 4 (colindixon, 17:33:59)
    8. LuisGomez asks if we have an idea of what delay would be reasonable and/or tolerable (colindixon, 17:36:08)
    9. ACTION: colindixon to reach out to the advisory group and board about how long a delay would be OK (colindixon, 17:37:17)
    10. jamoluhrsen asks if we can EoL Carbon sooner than would normally happen, colindixon says maybe, phrobb says that would probably be an even bigger exception than a 5-week delay (colindixon, 17:38:34)
    11. phrobb says the biggest thing here is our reputation, we haven't slipped this far in a long time (colindixon, 17:39:30)
    12. everyone basically says unless karaf 3.0.x will be supported for security updates for another year+, we really don't have a choice but to move to Karaf 4 and keep our word about security updates (colindixon, 17:40:33)
    13. abhijitkumbhare says that if we see carbon slip long enough, then we will not need an interim release to re-align (colindixon, 17:43:16)
    14. VOTE: Voted on "assuming (as we expect) that karaf 3.0.x will not have security updates for the next year+, should we make karaf 4 migration a mandatory part of Carbon?" Results are, yes: 10 (colindixon, 17:49:37)
    15. AGREED: assuming Karaf 3 security support for the next year is an issue for them, we will keep karaf 4 as mandatory for Carbon (colindixon, 17:50:07)

  6. security mailing list (colindixon, 17:50:40)
    1. rovarga notes (and colindixon confirms) we simply don't have enough people with enough free cycles on the security team and security mailing list to address the issues that come in in the manner we would like to (colindixon, 17:51:26)
    2. skitt asks about the process for handling CVEs in OpenDaylight that we know about, colindixon says there is a process and we should have private bugs for them, this hasn't happened flawlessly lately for the previous reason (colindixon, 17:52:03)
    3. https://wiki.opendaylight.org/view/Security:Main (rovarga, 17:53:59)
    4. https://wiki.opendaylight.org/view/TSC:Vulnerability_Management (rovarga, 17:54:17)
    5. ACTION: colindixon to post current CVEs to the security advisories page (colindixon, 17:55:07)
    6. ACTION: colindixon will also make sure security-announce is notified (colindixon, 17:55:39)
    7. Happy birthday colindixon ! (abhijitkumbhare, 17:56:25)
    8. rovarga notes that we really need people that have this security issue handling as a top-of-their-stack responsibility, they also likely need at least some familiarity with OpenDaylight or a willingness to get it to hunt and track issues (colindixon, 18:00:25)
    9. rovarga asks if there is another place to lean for at least the administrative parts of the security issues and track, hound OpenDaylight internal people (colindixon, 18:00:56)
    10. dfarrell07 asks if we could try to find a security manager the way we've found release managers in the past (colindixon, 18:01:48)
    11. skitt also notes that he'd expect us to handle our own CVEs instead of RedHat doing it for us (colindixon, 18:03:46)
    12. we also need to clean up the current people on the security mailing list (colindixon, 18:03:55)
    13. ACTION: colindixon to work on maybe schedule a Beryllium-4.1 release to handle the fixes (colindixon, 18:04:50)
    14. ACTION: phrobb to bring the need for a security manager to the board (colindixon, 18:05:07)
    15. we have not had a successful https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-beryllium/ in 2 months (rovarga, 18:05:22)

  7. cookies (colindixon, 18:05:29)


Meeting ended at 18:05:43 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
  4. katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165
  5. if you are attending OpenStack Boston, reach out to casey since there might be a community event
  6. colindixon to reach out to the advisory group and board about how long a delay would be OK
  7. colindixon to post current CVEs to the security advisories page
  8. colindixon will also make sure security-announce is notified
  9. colindixon to work on maybe schedule a Beryllium-4.1 release to handle the fixes
  10. phrobb to bring the need for a security manager to the board


Action items, by person

  1. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
    3. colindixon to reach out to the advisory group and board about how long a delay would be OK
    4. colindixon to post current CVEs to the security advisories page
    5. colindixon will also make sure security-announce is notified
    6. colindixon to work on maybe schedule a Beryllium-4.1 release to handle the fixes
  2. UNASSIGNED
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    2. katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165
    3. if you are attending OpenStack Boston, reach out to casey since there might be a community event
    4. phrobb to bring the need for a security manager to the board


People present (lines said)

  1. colindixon (76)
  2. skitt (15)
  3. rovarga (11)
  4. odl_meetbot (11)
  5. jamoluhrsen (6)
  6. abhijitkumbhare (5)
  7. dfarrell07 (3)
  8. hideyuki (3)
  9. lori (3)
  10. anipbu (3)
  11. vishnoianil (3)
  12. LuisGomez (2)
  13. CaseyODL (2)
  14. vrpolak (1)
  15. gzhao (1)
  16. vina_ermagan (1)


Generated by MeetBot 0.1.4.