#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:08 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:13)
    1. colindixon (colindixon, 17:00:15)
    2. skitt (skitt, 17:00:16)
    3. jamoluhrsen (jamoluhrsen, 17:00:29)
    4. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=55295#Agenda agenda (colindixon, 17:00:38)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-05-11-17.00.html last week's meeting minutes (colindixon, 17:00:49)
    6. rovarga (rovarga, 17:00:57)
    7. anipbu (anipbu, 17:01:06)
    8. lori (lori, 17:01:21)
    9. edwarnicke (edwarnicke, 17:01:29)
    10. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:01:34)
    11. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:01:35)
    12. ACTION: colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release (colindixon, 17:01:37)
    13. ACTION: phrobb to bring the need for a security manager to the board (colindixon, 17:01:38)
    14. ACTION: phrobb to bring the TSC replacment language to the board (colindixon, 17:01:39)
    15. ACTION: colindixon to update the Carbon-SR dates once we release Carbon (colindixon, 17:01:40)
    16. https://wiki.opendaylight.org/view/Events:Main#ODL_Nitrogen_Developer_Design_Forum CaseyODL put the link (and how to register) is on the wiki events page (colindixon, 17:01:49)
    17. https://lists.opendaylight.org/pipermail/release/2017-May/010850.html colindixon notified release that projects must be in the release in git by 23:59 UTC on Monday, May 15th to participate (colindixon, 17:01:50)
    18. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#RC0_Download anipbu got pointers to RC0 and notified people appropriately (colindixon, 17:01:51)
    19. ACTION: colindixon to send o#ut a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules (colindixon, 17:02:13)
    20. abhijitkumbhare (abhijitkumbhare, 17:02:30)
    21. ACTION: jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3) (colindixon, 17:03:31)
    22. Anil Vishnoi (vishnoianil, 17:03:39)
    23. Thanh (zxiiro, 17:03:48)

  2. TSC mailing list votes and discussions (colindixon, 17:04:29)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-May/007208.html Need for a Beryllium-SR4.1? (colindixon, 17:04:41)

  3. events (colindixon, 17:05:59)
    1. https://www.opendaylight.org/global-events (colindixon, 17:06:04)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:06:23)
    3. https://wiki.opendaylight.org/view/Events:Main#ODL_Nitrogen_Developer_Design_Forum the DDF is coming up on 5/31 and 6/1 (colindixon, 17:06:43)
    4. shague (shague, 17:06:49)
    5. https://wiki.opendaylight.org/view/Events:Main#Eurasia_Network_Operators_Group_ENOG13 new even in st petersburg on 5/23-24 with some major ODL content (colindixon, 17:07:21)
    6. agenda for DDF should be finalized soon and published (colindixon, 17:07:32)
    7. we only have 35 registrants for the DDF, please register if you plan to attend, the cost for the event is $225,000, we should talk about how to either make these cheaper and/or not have them if the attendance is this low (colindixon, 17:08:31)

  4. boron (colindixon, 17:09:20)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule <--- Boron SR4 currently scheduled for 6/15/2017 (anipbu, 17:09:30)
    2. zxiiro note that the boron build has been consistently passing (colindixon, 17:10:15)
    3. colindixon notes that unless Carbon shifts out past the DDF, things should be fine with that date (colindixon, 17:10:28)

  5. carbon (colindixon, 17:10:39)
    1. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1746681968 <--- Release Review is ongoing right now: waiting on 6 projects to sign up: dlux, docs, next, sdninterfaceapp, cardinal, snmp (anipbu, 17:10:53)
    2. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1178576345 (anipbu, 17:11:10)
    3. goo.gl/OaCOAG <--- 19 Blocker Bugs in bgpcep, controller, genius, netvirt, sfc (anipbu, 17:11:55)
    4. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 <--- Tracking Carbon Blocker Bugs (anipbu, 17:12:08)
    5. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948 <--- RC1 (anipbu, 17:12:28)
    6. for what it's worth, we have patches in the pipe for all blocking bugs but 2 assuming the spreadsheet is up-to-date (colindixon, 17:12:56)
    7. remaining two are BUG-7451 and BUG-8446 (colindixon, 17:14:13)
    8. rovarga says they're trying to get enough logs to debug BUG-8446, the claim is is that it may have been fixed (masked?) by some other fix, we should know by tomorrow morning (colindixon, 17:14:56)
    9. it seems like a patch was added for BUG-7451 (colindixon, 17:15:16)
    10. anipbu says that we will need to push back on blocker bugs harder as we get closer to the release we will have to raise the bar of what a blocker is (colindixon, 17:18:36)
    11. colindixon notes that bugs fall into 3 bins: 1.) functionality that is critical for users and was there in prior releases that is broken with no workarounds, 2.) the same thing as 1, but for functionality that is new to Carbon, 3.) things that have workarounds, are very uncommon, or otherwise aren't really blcoking (colindixon, 17:22:10)
    12. I think the question is what we're going to do around bin 2 (colindixon, 17:22:19)
    13. anipbu notes that we're hoping to build RC2 today, but it looks like it might be tomorrow (colindixon, 17:23:37)
    14. anipbu further notes that RC3 (which should be the last one) is scheduled for Sunday and ideally we'd then go through the bureaucratic motions of final CSIT testing, and final go/nogo sign offs (colindixon, 17:24:16)

  6. infrastructure (colindixon, 17:25:39)
    1. there are still a couple outstanding WebEx meetings out there, at the end of next week all WebEx meetings and WebEx account will be canceled (colindixon, 17:26:23)
    2. all recordings will be exported and uploaded to the wiki (colindixon, 17:26:30)
    3. ALL WEBEX ARE BELONG TO NOT US BY END OF NEXT WEEK (colindixon, 17:26:45)

  7. security response team (colindixon, 17:27:50)
    1. lori is interested in being part of the security response team (colindixon, 17:28:05)
    2. VOTE: Voted on "shall the TSC add lori as a member of the security response team?" Results are, 0: 1, +1: 8 (colindixon, 17:29:02)
    3. AGREED: lori is a member of the security release team unanimously (colindixon, 17:29:25)
    4. ACTION: colindixon to look to see if any current security response team members would like to voluntarily step down for any reason (colindixon, 17:30:32)

  8. beryllium-SR4.1/SR5 (colindixon, 17:32:26)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-May/007208.html (colindixon, 17:32:42)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-May/007209.html (colindixon, 17:32:52)
    3. https://wiki.opendaylight.org/view/Security_Advisories description of CVEs here (colindixon, 17:33:17)
    4. https://git.opendaylight.org/gerrit/#/q/topic:die-xsql-die-stable/beryllium+status:open xsql patches still needed for stable/beryllium (colindixon, 17:35:17)
    5. vishnoianil notes that if we do this after Carbon, technically we will no longer be supporting even security updates for that (colindixon, 17:37:47)
    6. VOTE: Voted on "given that we've been told about these vulnerabilities while beryllium was still open for security updates, but have workarounds, do we 1.) just provide release notes with workarounds given that it won't be supported for security updates, 2.) fix the issues and ship the ones for which we have patches, or 3.) do nothing?" Results are, 1: 7, 2: 5 (colindixon, 17:47:18)
    7. ACTION: given the precedent this might set, colindixon to ping the last two TSC members for votes (colindixon, 17:48:54)

  9. cookies (colindixon, 17:52:39)


Meeting ended at 17:52:42 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
  4. phrobb to bring the need for a security manager to the board
  5. phrobb to bring the TSC replacment language to the board
  6. colindixon to update the Carbon-SR dates once we release Carbon
  7. colindixon to send o#ut a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules
  8. jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
  9. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
  10. given the precedent this might set, colindixon to ping the last two TSC members for votes


Action items, by person

  1. anipbu
    1. jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
  2. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
    3. colindixon to update the Carbon-SR dates once we release Carbon
    4. colindixon to send o#ut a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules
    5. jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
    6. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
    7. given the precedent this might set, colindixon to ping the last two TSC members for votes
  3. jamoluhrsen
    1. jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
  4. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  5. UNASSIGNED
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    2. phrobb to bring the need for a security manager to the board
    3. phrobb to bring the TSC replacment language to the board


People present (lines said)

  1. colindixon (69)
  2. odl_meetbot (16)
  3. anipbu (9)
  4. rovarga (5)
  5. jamoluhrsen (5)
  6. abhijitkumbhare (5)
  7. skitt (4)
  8. shague (3)
  9. zxiiro (3)
  10. edwarnicke (3)
  11. lori (3)
  12. LuisGomez (2)
  13. vishnoianil (2)
  14. CaseyODL (1)


Generated by MeetBot 0.1.4.