17:00:47 <colindixon> #startmeeting tsc
17:00:47 <odl_meetbot> Meeting started Thu Jun 15 17:00:47 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:47 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:52 <colindixon> #topic roll call and agenda bashing
17:01:17 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=57619#Agenda agenda
17:01:38 <rovarga> #info rovarga
17:01:39 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-06-08-17.00.html last week's meeting minutes
17:01:41 <anipbu> #info anipbu
17:01:43 <colindixon> #info colindixon
17:01:47 <colindixon> TSC members please #info in
17:02:07 <colindixon> #action phrobb to bring the need for a security manager to the board
17:02:08 <colindixon> #action phrobb to float the idea of hiring a Karaf consultant to the board
17:02:09 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:02:10 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:02:11 <colindixon> #action colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
17:02:27 <hideyuki> #info Hideyuki
17:02:29 <lori> #info lori
17:02:48 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description from anipbu and colindixon
17:02:50 <edwarnicke> #info edwarnicke
17:02:57 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=8698 is a bug to track off-cycle release tools and docs
17:03:12 <colindixon> #info it seems like the TSC meeting invites are correct now
17:03:32 <colindixon> #info the board has asked for us to bering the TSC replacement language to the board again after some of the harmonization efforts have progressed
17:04:55 <shague> #info shague
17:05:28 <LuisGomez> #info LuisGomez
17:06:05 <colindixon> #info we will add a TCP-MD5 termination review
17:06:16 <jamoluhrsen> #info jamoluhrsen
17:06:20 <colindixon> #topic TSC mailing list votes and discussions
17:06:23 <zxiiro> #info Thanh
17:06:34 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007485.html Dhruv Bhardwaj and Cedric Ollivier are now commiters on transport PCE
17:06:50 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007487.html Michal Rehak is now an ODL SXP commiter
17:07:02 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description
17:07:20 <colindixon> #info for the above, we need volunteers to take that on, so please chim in if you're interested
17:07:55 <anipbu> and it's fun! =)
17:08:15 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007507.html meetings at constant UTC offset vs. shifting with DST?
17:09:18 <colindixon> https://lists.opendaylight.org/pipermail/tsc/2017-June/007509.html
17:11:14 <rovarga> #link https://en.wikipedia.org/wiki/Daylight_saving_time_by_country a surprising number of countries do not care about DST
17:11:24 <edwarnicke> rovarga: I believe you :)
17:11:30 <colindixon> #starvote shall we make the APAC-time zone TSC call on the Fourth Thursday of each month at 0330 UTC time (7:30p or 8:30p pacfic) instead fo varying with US DST because it appears India, China and Japan don't have DST? -1,0,+1
17:11:35 <edwarnicke> rovarga: I personally don't like DST
17:11:35 <colindixon> #startvote shall we make the APAC-time zone TSC call on the Fourth Thursday of each month at 0330 UTC time (7:30p or 8:30p pacfic) instead fo varying with US DST because it appears India, China and Japan don't have DST? -1,0,+1
17:11:35 <odl_meetbot> Begin voting on: shall we make the APAC-time zone TSC call on the Fourth Thursday of each month at 0330 UTC time (7:30p or 8:30p pacfic) instead fo varying with US DST because it appears India, China and Japan don't have DST? Valid vote options are -1, 0, +1.
17:11:35 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:11:39 <jamoluhrsen> #vote +1
17:11:40 <colindixon> #vote +1
17:11:43 <shague> #vote +1
17:11:44 <edwarnicke> #vote +1
17:11:45 <anipbu> #vote +1
17:11:46 <zxiiro> #vote +1
17:11:46 <rovarga> #vote +1
17:11:47 <hideyuki> #vote +1
17:11:51 <lori> #vote +1
17:12:12 <colindixon> #endvote
17:12:12 <odl_meetbot> Voted on "shall we make the APAC-time zone TSC call on the Fourth Thursday of each month at 0330 UTC time (7:30p or 8:30p pacfic) instead fo varying with US DST because it appears India, China and Japan don't have DST?" Results are
17:12:12 <odl_meetbot> +1 (9): rovarga, zxiiro, edwarnicke, shague, hideyuki, colindixon, lori, jamoluhrsen, anipbu
17:12:21 <rovarga> edwarnicke: yeah, I can't wait for an EU directive terminating this anachronism in this neck of the woods :)
17:12:33 <edwarnicke> rovarga: :)
17:12:40 <colindixon> #agreed the APAC-time zone TSC call wiill be on the Fourth Thursday of each month at 0330 UTC time (7:30p or 8:30p pacfic) instead fo varying with US DST because it appears India, China and Japan don't have DST
17:12:46 <lori> rovarga: +1
17:13:29 <colindixon> #topic events
17:13:50 <colindixon> #link https://www.opendaylight.org/global-events
17:13:51 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:14:09 <colindixon> #Info OPFNV summit is going on as we speak in Beijing (or just closing down as it's 1a on Friday morning)
17:14:28 <colindixon> #info linuxcon china is next week also there
17:14:52 <colindixon> #topic boron
17:15:10 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/SR4/Status   <--- We initially targeted Boron SR4 Release on 6/15, but our latest build has blocker bugs in NETVIRT and we are waiting to finish respinning Boron SR4.
17:15:24 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=8696   <--- NETVIRT Blocker Bug
17:15:30 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/59002/   <--- Patch Fixing NETVIRT Blocker Bug
17:15:37 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/306/  <--- We are respinning Boron SR4.
17:17:41 <colindixon> #topic carbon
17:17:46 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- We are three weeks away from Carbon SR1 on July 6.
17:18:01 <jamoluhrsen> it's better to say 2 weeks
17:18:05 <jamoluhrsen> for carbon sr1
17:18:09 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011238.html   <--- Autorelease carbon failed to build sal-distributed-datastore from controller
17:18:31 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1746681968    <--- We are waiting on 3 projects to revise or submit Carbon Release Notes: packetable, next, dlux.
17:18:58 <anipbu> #info We kindly inform projects we are not running SFT in Carbon build.  We plan to disable the Karaf 4 SFT in Carbon ODLPARENT.
17:22:39 <colindixon> #topic nitrogen
17:22:44 <colindixon> #chair CaseyODL phrobb anipbu
17:22:44 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon phrobb
17:22:49 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:odlparent-1.9.0   <--- We are bumping all Nitrogen projects to ODLPARENT version 1.9.0.  Pending: sdninterfaceapp, bier, snmp4sdn, nic, bgpcep, netv
17:23:12 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011237.html   <--- We are removing Karaf 3 from the Nitrogen Integration Distribution.
17:23:24 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/58820/   <--- We have removed all nonoffset0 projects from the Nitrogen Integration Distribution.
17:23:39 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/58992/   <--- We have added infrautils back into autorelease.
17:23:46 <anipbu> #info We plan on adding Nitrogen Integration Distribution back into autorelease this week to generate a test build.
17:23:58 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf   <--- Nitrogen Karaf 4 Status
17:24:03 <anipbu> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933   <--- Nitrogen Karaf 4 Tracking
17:24:10 <anipbu> #link https://wiki.opendaylight.org/view/File:TWS-2017-06-12.mp4   <--- TWS Session on Monday 6/12/2017 to discuss Nitrogen Karaf 4 Project Action Items
17:24:27 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011221.html   <--- Karaf 4 Schedule
17:24:36 <anipbu> #info Plan of Action This Week: all projects build and test local karaf 4 distribution and identify blocker bugs
17:25:01 <anipbu> #info Plan of Action Next Week: release odlparent version 2.0.0, all projects migrate to odlparent version 2.0.0, all projects add karat 4 features to integration distribution
17:25:34 <vishnoianil> #info Anil Vishnoi
17:25:58 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf#Nitrogen_Project_Requirements   <--- 3 Nitrogen Project Requirements for Karaf 4
17:26:29 <anipbu> #info NOTICE: Expected breakages expected in the next two weeks
17:26:50 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=8638   <--- Karaf 4 Related Blocker Bugs (NETVIRT): Karaf4 specific problems seen on boot and during manual & CSIT testing of netvirt distribution
17:27:05 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=8694   <--- Karaf 4 Related Blocker Bugs (OPENFLOWPLUGIN): Karaf 4 openflowplugin "not working" (title to be refined as more is found out)
17:27:14 <anipbu> #link https://bugs.opendaylight.org/show_bug.cgi?id=8571   <--- Karaf 4 Related Blocker Bugs (ODLPARENT): karaf4-parent does not include files from src/main/assembly.  This is critical for 3 nodes system test.
17:27:32 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-June/011222.html   <--- Need to make a decision on featuresBoot or not featuresBoot
17:35:33 <colindixon> #info there is a long disussion about whether we can use feature:install or featuresBoot only and not both
17:35:49 <colindixon> #Info they use different code paths in Karaf to load them
17:36:51 <colindixon> #Info thus they may expose different sharp corners and possibly different bugs between ODL and Karaf
17:37:54 <colindixon> #info if we that to choose one to eliminate in the meantime to try to reduce testing overhead, it would be feautresBoot today
17:38:06 <colindixon> #info in the long run, we would really like both to work
17:39:55 <colindixon> #info edwarnicke says that it might make sense to take a confd-style appaoch in Karaf that would help us, maybe we should consider putting a direcotry with files that say what feautres to load as a plug-in to Karaf
17:40:16 <colindixon> #Info then if we did this since it would be new, we could then have it use the same code path as feaure:install at the CLI
17:41:08 <jamoluhrsen> stephen is pto
17:41:49 <colindixon> #action colindixon to file an upstream bug with Karaf around featureBoot install not working if we don't have one yet
17:43:59 <colindixon> #topic system integration and test
17:44:03 <colindixon> #info nothing this week other than than what's above
17:44:07 <colindixon> #topic infrastructure
17:44:32 <colindixon> #info this past weekend we had jenkins outage because of a batter issue, it came back up
17:45:07 <colindixon> #info we had an SSL cert expiring on monday, but we have a temporary fix, we're are enabling auto-renewal for let's encrypt so it won't happen in the future
17:47:11 <colindixon> #topic TCP-MD4 termination review
17:47:30 <rovarga> #link https://lists.opendaylight.org/pipermail/tsc/2016-August/005894.html
17:47:36 <zxiiro> 8/4/2016
17:47:49 <colindixon> #info a million years ago, we had a termination review for TCP-MD5 in which we put it off until Carbon was released and Beryllium was thus truly EoLed becuase TCP-MD5 was in Beryllium
17:47:53 <colindixon> #Info we're now there
17:48:41 <rovarga> #link https://wiki.opendaylight.org/view/TCPMD5:Termination_Proposal the proposal itself
17:49:50 <colindixon> https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-09-08-17.00.html
17:50:02 <colindixon> #startvote shall the TSC archive TCP-MD5 project? -1,0,+1
17:50:02 <odl_meetbot> Begin voting on: shall the TSC archive TCP-MD5 project? Valid vote options are -1, 0, +1.
17:50:02 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:50:04 <colindixon> #vote +1
17:50:05 <rovarga> #vote +1
17:50:07 <vishnoianil> #vote +1
17:50:08 <anipbu> #vote +1
17:50:09 <hideyuki> #vote +1
17:50:11 <jamoluhrsen> #vote +1
17:50:14 <LuisGomez> #vote +1
17:50:23 <edwarnicke> #vote +1
17:50:25 <shague> #vote +1
17:50:27 <lori> #vote +12
17:50:27 <odl_meetbot> lori: +12 is not a valid option. Valid options are -1, 0, +1.
17:50:30 <lori> #vote +1
17:50:34 <colindixon> #endvote
17:50:34 <odl_meetbot> Voted on "shall the TSC archive TCP-MD5 project?" Results are
17:50:34 <odl_meetbot> +1 (10): rovarga, LuisGomez, edwarnicke, shague, hideyuki, colindixon, lori, jamoluhrsen, anipbu, vishnoianil
17:50:44 <colindixon> #agreed the TCP-MD5 project has been archived
17:50:44 <zxiiro> #vote +1
17:50:53 <colindixon> #topic other project archives
17:51:21 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007493.html we should follow up with these archivals as well
17:52:01 <colindixon> #action colindixon should reach out to projects and see if we can't archive some of them
17:52:28 <colindixon> #topic liblldp
17:52:51 <colindixon> #Info this is currently housed in the controller, but something like 4 other projects are using the jar directly
17:53:19 <colindixon> #Info rovarga woudl like to take it out of the controller and put it into another project and/or make it it's own project
17:53:40 <colindixon> #info currently used by openflowplugin, genius, l2switch and something else
17:53:41 <rovarga> #info genius, netvirt and ofp each spell it out in their features.
17:54:24 <colindixon> #Link https://lists.opendaylight.org/pipermail/netconf-dev/2017-June/001179.html
17:55:00 <colindixon> #action rovarga to reach out to the project that use it and ask
17:56:02 <colindixon> #topic merging patches on inactive proejcts
17:56:12 <colindixon> #info shague asking if we can auto-merge patches for things like federation
17:56:40 <colindixon> #action colindixon to reach out to gidi to try to get them merged and maybe mint new committers
17:58:57 <colindixon> #topic cookies
17:59:02 <colindixon> #endmeeting