#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:22 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:32)
    1. anipbu (anipbu, 17:00:40)
    2. colindixon (colindixon, 17:01:38)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=58423#Agenda (colindixon, 17:01:58)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-06-22-03.30.html last week's meeitng minutes (colindixon, 17:02:13)
    5. Hideyuki (hideyuki, 17:02:17)
    6. ACTION: phrobb to bring the need for a security manager to the board (colindixon, 17:02:39)
    7. ACTION: phrobb to float the idea of hiring a Karaf consultant to the board (colindixon, 17:02:39)
    8. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:02:40)
    9. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:02:41)
    10. ACTION: colindixon to look to see if any current security response team members would like to voluntarily step down for any reason (colindixon, 17:02:42)
    11. colindixon says it sounds like might not actually need a Karaf consultant because karaf 4 seems to be going reasonably well (colindixon, 17:03:09)
    12. abhijitkumbhare (abhijitkumbhare, 17:03:20)
    13. LuisGomez (LuisGomez, 17:03:45)
    14. Anil Vishnoi (vishnoianil, 17:03:53)
    15. rovarga (rovarga, 17:04:16)
    16. Daniel Farrell for Sam Hague (dfarrell07, 17:04:16)
    17. Thanh Ha (zxiiro, 17:04:21)
    18. colindixon reached out to gidi to try to get federation patches merged and maybe mint new committers, but it seems like it will be inactive in nitrogen (colindixon, 17:04:57)
    19. Daniel Farrell for Sam Hague and jamoluhrsen (dfarrell07, 17:04:58)
    20. ACTION: rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller (colindixon, 17:05:23)
    21. ACTION: CaseyODL to follow up on this discussion about what we would do to poll people about what would encourage attendance at future DDFs (colindixon, 17:05:32)
    22. if you have anythign you'd like to see in the poll and care about, please ping CaseyODL by the end of the day (colindixon, 17:06:01)
    23. ACTION: colindixon or CaseyODL to send the poll to the tsc list (colindixon, 17:06:44)

  2. mailing list votes and discussions (colindixon, 17:07:19)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description (colindixon, 17:08:05)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-June/007506.html future dveloper design forums (colindixon, 17:08:20)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-June/007592.html openflowjava merging into openflowplugin (colindixon, 17:08:36)
    4. colindixon asks if it's doing this in nitrogen only, or also carbon and boron, rovarga says nitrogen-only (colindixon, 17:09:54)
    5. https://lists.opendaylight.org/pipermail/tsc/2017-June/007578.html Support for carbon vote (colindixon, 17:10:22)
    6. http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_b61348bdd2b0c06d results from the support for carvon vote (colindixon, 17:10:32)
    7. the vote is tied, we still need votes from Huan, An, Sam and Stephen (colindixon, 17:12:36)
    8. ACTION: colindixon will reach out to those who didn't vote in the carbon support poll to see if we can resolve it (colindixon, 17:13:03)
    9. https://lists.opendaylight.org/pipermail/tsc/2017-June/007572.html Boron-SR4 released (colindixon, 17:13:28)
    10. rovarga notes that ending suppport for Karaf 3 sooner rahter than later might be good (colindixon, 17:14:15)
    11. colindixon notes that one tie-breaking mecahnism fo the 5 provided (minimax) gives a result (colindixon, 17:15:53)
    12. that supports doing date-based releases for 6-months, and 12-months of bug fixes and security fixes, respectively (colindixon, 17:16:57)
    13. https://www.opendaylight.org/tsc-charter (colindixon, 17:17:50)
    14. https://lists.opendaylight.org/pipermail/tsc/2017-June/007566.html Subodh Roy is now a committer on Cardinal (colindixon, 17:19:37)
    15. https://lists.opendaylight.org/pipermail/tsc/2017-June/007517.html APAC TSC meeting will be tied to non-DST time; Normal TSC meeting will still be tied to US DST time (colindixon, 17:19:49)
    16. https://lists.opendaylight.org/pipermail/tsc/2017-June/007613.html Archiving Discovery (colindixon, 17:20:35)
    17. https://lists.opendaylight.org/pipermail/tsc/2017-June/007614.html Archiving Armoury (colindixon, 17:20:44)

  3. events (colindixon, 17:21:17)
    1. https://www.opendaylight.org/global-events (colindixon, 17:21:22)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:21:30)
    3. nothing major is coming up now, open source summit NA would be the next thing on 9/11/2017 (colindixon, 17:22:13)

  4. boron (colindixon, 17:22:27)
    1. we are removing boron from the normal discussion here because it only receiving security updates, so it will be popped up as needed (colindixon, 17:22:54)

  5. carbon (colindixon, 17:22:55)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- Carbon SR1 Cutoff this Sunday 7/2/2017 at 23:59 UTC Time. stable/carbon branches will be locked. (anipbu, 17:23:04)
    2. https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/carbon <--- 81 open patches in gerri for stable/carbon branch (anipbu, 17:23:16)
    3. https://goo.gl/DZVjKq <--- 2 blocker bugs in SFC and NETVIRT (anipbu, 17:23:24)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=8501 <--- Problem with the installation of sfc, groupbasedpolicy, vbd related to vpp features (anipbu, 17:23:32)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=8398 <--- summary: communication between two tenant network failed while using default SG (stateful mode) (anipbu, 17:23:37)
    6. ACTION: colindixon or anipbu to ping SFC and NETVIRT after this meeting to see if those projects actually have blocking bugs (colindixon, 17:24:16)
    7. https://lists.opendaylight.org/pipermail/release/2017-June/011443.html <--- Red Flag: autorelease carbon failing on odl-sfclisp from sfc (anipbu, 17:24:54)
    8. dfarrell07 gets the impression that these might be real bugs and thus might delay Carbon (colindixon, 17:24:55)
    9. zxiiro says the autorelease-carbon build is fixed as of this morning (colindixon, 17:25:30)

  6. nitrogen (colindixon, 17:25:38)
    1. https://lists.opendaylight.org/pipermail/release/2017-June/011421.html <--- OpenFlowJava being merged into OpenFlowPlugin in Nitrogen (anipbu, 17:25:54)
    2. https://lists.opendaylight.org/pipermail/release/2017-June/011448.html <--- Remove mechanism for mounting netconf devices via the config system in Nitrogen (anipbu, 17:26:10)
    3. https://lists.opendaylight.org/pipermail/release/2017-June/011420.html <--- Pending changes to BGPCEP -Interface PCEPSession API as described in https://bugs.opendaylight.org/show_bug.cgi?id=8156 (anipbu, 17:27:01)
    4. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956 <--- We are tracking Nitrogen Karaf 4 Migration (anipbu, 17:27:19)
    5. https://git.opendaylight.org/gerrit/#/q/topic:odlparent200 <--- As of Tuesday, we are waiting on patches from the following projects for odlparent2.0.0: bier, cardinal, didm, mean, fans, federation, iotdm, lace, lack, memo, next, of-config, pocketable, sdni, snmp4sdn, tsar, unimgr (anipbu, 17:27:37)
    6. https://git.opendaylight.org/gerrit/#/c/59303/ <--- We have merged patch to add kernel projects into Nitrogen Integration Distribution (anipbu, 17:27:51)

  7. system integration and testing (colindixon, 17:31:54)
    1. LuisGomez says nothing really, there's a discussion around karaf 4 and the karaf 4 distribution to start doing CSIT (colindixon, 17:32:16)
    2. LuisGomez says that as we upgrade to odlparent 2.0.1, we will in parallel work with getting the distribution working to not lose time, at the risk of breaking things more often (colindixon, 17:34:09)
    3. LuisGomez and vrpolak would like to enoucrage projects to get their gerrit patches for int/dist up ASAP so they can help (colindixon, 17:37:14)

  8. infrastructure (colindixon, 17:38:39)
    1. this past Sunday, Rackspace replaced the raid battery, that's what caused our servers to go down a few weeks ago (colindixon, 17:39:17)
    2. there will be some downtime Friday evening pacific time from API maintaince at Rackspace, tykeal plans to use that gap to fix our letsencrypt cert renewal stuff (colindixon, 17:39:47)

  9. cookies (colindixon, 17:40:52)


Meeting ended at 17:40:55 UTC (full logs).

Action items

  1. phrobb to bring the need for a security manager to the board
  2. phrobb to float the idea of hiring a Karaf consultant to the board
  3. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  5. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
  6. rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
  7. CaseyODL to follow up on this discussion about what we would do to poll people about what would encourage attendance at future DDFs
  8. colindixon or CaseyODL to send the poll to the tsc list
  9. colindixon will reach out to those who didn't vote in the carbon support poll to see if we can resolve it
  10. colindixon or anipbu to ping SFC and NETVIRT after this meeting to see if those projects actually have blocking bugs


Action items, by person

  1. anipbu
    1. colindixon or anipbu to ping SFC and NETVIRT after this meeting to see if those projects actually have blocking bugs
  2. CaseyODL
    1. CaseyODL to follow up on this discussion about what we would do to poll people about what would encourage attendance at future DDFs
    2. colindixon or CaseyODL to send the poll to the tsc list
  3. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
    3. colindixon or CaseyODL to send the poll to the tsc list
    4. colindixon will reach out to those who didn't vote in the carbon support poll to see if we can resolve it
    5. colindixon or anipbu to ping SFC and NETVIRT after this meeting to see if those projects actually have blocking bugs
  4. rovarga
    1. rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
  5. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  6. UNASSIGNED
    1. phrobb to bring the need for a security manager to the board
    2. phrobb to float the idea of hiring a Karaf consultant to the board
    3. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials


People present (lines said)

  1. colindixon (67)
  2. anipbu (13)
  3. dfarrell07 (6)
  4. odl_meetbot (6)
  5. vrpolak (4)
  6. abhijitkumbhare (4)
  7. zxiiro (2)
  8. rovarga (1)
  9. LuisGomez (1)
  10. hideyuki (1)
  11. vishnoianil (1)
  12. CaseyODL (0)


Generated by MeetBot 0.1.4.