17:00:30 <colindixon> #startmeeting tsc
17:00:30 <odl_meetbot> Meeting started Thu Jul 13 17:00:30 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:30 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:35 <colindixon> #topic agenda bashing and roll call
17:00:38 <skitt> #info skitt
17:00:39 <colindixon> TSC members please #info in
17:00:41 <colindixon> #Info colindixon
17:00:47 <vrpolak> #info Vratko Polak proxying for Luis Gomez
17:00:47 <dfarrell07> #info Daniel Farrell for Jamo
17:00:55 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-06-17.04.html last week's meeting minutes
17:01:09 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=58746#Agenda the agenda
17:01:24 <hideyuki> #info Hideyuki
17:01:28 <rovarga> #info rovarga
17:01:29 <anipbu> #info anipbu
17:01:30 <vishnoianil> #info Anil Vishnoi
17:01:30 <colindixon> #action colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
17:01:30 <colindixon> #action phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
17:01:32 <colindixon> #action colindixon to look to see if any current security response team members would like to voluntarily step down for any reason
17:01:33 <colindixon> #action rovarga to reach out to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller
17:01:33 <colindixon> #action CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them
17:02:43 <colindixon> #action CaseyODL to send mail to controller-dev about the DDF poll too
17:03:21 <shague> #info shague
17:03:21 <colindixon> #info the issue of carbon support lifetime was resovled last TSC call
17:03:38 <colindixon> #info I don't think we are in depserate need of a Karaf 4 expert/consultant anymore
17:04:00 <colindixon> #action CaseyODL to add this release manager position be made a priority for the next board meeting
17:04:16 <colindixon> skitt: did you update the security wiki?
17:04:23 <skitt> colindixon, urgh no
17:04:45 <colindixon> #info CaseyODL says that there is a member company entertaining providing a release manager, but it hasn't gone to the board yet
17:05:35 <colindixon> #action phrobb to bring the need for a security manager to the board and figure out if we can get a response
17:06:01 <skitt> #info the security wiki page has been updated
17:07:05 <colindixon> #topic security response team
17:08:44 <edwarnicke> #info edwarnicke
17:09:40 <CaseyODL> The events page has been updated with the CableLabs event.
17:09:41 <CaseyODL> https://wiki.opendaylight.org/view/Events#Upcoming_Events
17:10:13 <colindixon> #info skitt asks how changes in the security team are things that are done by current members or the TSC, colindixon says basically the TSC has all the power there, but in practice the team's opinions (and votes) are taken seriously
17:10:59 <colindixon> #topic mailing list discussions and votes
17:11:18 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007505.html release manager job description
17:11:30 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007506.html future dveloper design forums
17:11:43 <colindixon> #Link https://lists.opendaylight.org/pipermail/tsc/2017-July/007626.html survey
17:11:50 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-July/007628.html survey accessilble in China
17:12:18 <colindixon> #topic event
17:12:20 <colindixon> #undo
17:12:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2e47250>
17:12:24 <colindixon> #topic events
17:12:28 <colindixon> #link https://www.opendaylight.org/global-events
17:12:32 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:13:13 <colindixon> #info CableLabs Summer Conference in Keystone, CO on August 6-9th
17:13:41 <colindixon> #info Open Source Summit North America is 9/11 in Los Angeles
17:14:16 <colindixon> #info SDN/NFV World Congress in Europe will have ODL presence will be followed by an ODL road tour
17:14:29 <colindixon> #topic carbon
17:14:34 <colindixon> anipbu: take it away
17:14:39 <colindixon> #chair anipbu CaseyODL phrobb
17:14:39 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon phrobb
17:14:48 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Carbon/SR1/Status   <--- We would like to present the final build for Carbon SR1. There are no pending blocking bugs. All test issues found have been signed off as "OKAY" to release.
17:15:58 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#SR1_Download   <--- Carbon SR1 Build 20170712
17:16:15 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- Carbon SR2 is scheduled for 8/17/2017.  The stable/carbon branches will be unlocked for only 3 weeks for development.
17:16:40 <anipbu> #undo
17:16:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2c00a50>
17:16:47 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- Carbon SR2 is scheduled for 8/17/2017.  The stable/carbon branches will be unlocked for only 4 weeks for development.
17:16:48 <colindixon> #startvote shall the TSC approve the release of Carbon SR1 as summarized by anipbu above? -1,0,+1
17:16:48 <odl_meetbot> Begin voting on: shall the TSC approve the release of Carbon SR1 as summarized by anipbu above? Valid vote options are -1, 0, +1.
17:16:48 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:16:56 <rovarga> #vote +1
17:16:58 <vishnoianil> #vote +1
17:16:59 <colindixon> #vote +1
17:17:00 <anipbu> #vote +1
17:17:12 <skitt> #vote +1
17:17:14 <dfarrell07> #vote +1
17:17:15 <hideyuki> #vote +1
17:17:37 <colindixon> vrpolak:
17:17:48 <edwarnicke> #vote +1
17:17:50 <shague> #vote +1
17:17:58 <vrpolak> #vote +1
17:17:58 <colindixon> #endvote
17:17:58 <odl_meetbot> Voted on "shall the TSC approve the release of Carbon SR1 as summarized by anipbu above?" Results are
17:17:58 <odl_meetbot> +1 (10): vrpolak, rovarga, skitt, dfarrell07, edwarnicke, shague, hideyuki, colindixon, anipbu, vishnoianil
17:18:11 <CaseyODL> Yay!
17:18:13 <CaseyODL> :)
17:18:16 <colindixon> #agreed Carbon-SR1 is released
17:18:35 <rovarga> woo-hoo... now to get that branch unlocked... :)
17:18:36 <dfarrell07> w00t, now bump-and-tag quickly so I can downstream ;)
17:18:41 <anipbu> Did i lose my audio?
17:18:51 <skitt> anipbu, we can't hear you
17:18:57 <colindixon> anipbu: we can't hear you if you're talking
17:20:37 <dfarrell07> abelur: I guess you'll ping the lists as soon as bump-tag is done? /me has tight timeline to consume this downstream
17:20:57 <colindixon> #info given that Nitrogen ships on 9/7 (planned), it seems like 8/17 or 9/21 are the two valid dates to target for Carbon-SR2 that don't directly conflict with Nitrogen
17:21:02 <rovarga> abelur: same here, I have a slew of patches that need to land in carbon asap
17:21:42 <zxiiro> sorry I missed the vote
17:21:44 <zxiiro> #vote +1
17:21:44 <zxiiro> :)
17:22:07 <colindixon> #startvote shall week keep the target of 8/17 given that it's only 4 weeks for SR2 or move it to 9/21 to be 2 weeks after the planned nitrogen release? 8/17, 9/21, 0
17:22:07 <odl_meetbot> Begin voting on: shall week keep the target of 8/17 given that it's only 4 weeks for SR2 or move it to 9/21 to be 2 weeks after the planned nitrogen release? Valid vote options are 8, 17, 9, 21, 0.
17:22:07 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:22:11 <skitt> zxiiro, no reaction from odl_meetbot, that's surprising
17:22:14 <colindixon> #endvote
17:22:14 <odl_meetbot> Voted on "shall week keep the target of 8/17 given that it's only 4 weeks for SR2 or move it to 9/21 to be 2 weeks after the planned nitrogen release?" Results are
17:22:24 <colindixon> #startvote shall week keep the target of 8/17 given that it's only 4 weeks for SR2 or move it to 9/21 to be 2 weeks after the planned nitrogen release? Aug17, Sep21, 0
17:22:24 <odl_meetbot> Begin voting on: shall week keep the target of 8/17 given that it's only 4 weeks for SR2 or move it to 9/21 to be 2 weeks after the planned nitrogen release? Valid vote options are Aug17, Sep21, 0.
17:22:24 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:22:33 <skitt> #vote Aug17
17:22:34 <anipbu> #vote Aug17
17:22:35 <colindixon> #vote Aug17
17:22:38 <edwarnicke> #vote Aug17
17:22:45 <shague> #vote Aug17
17:22:48 <vrpolak> #vote Aug17
17:22:53 <vishnoianil> #vote Aug17
17:22:53 <hideyuki> #vote Aug17
17:22:55 <zxiiro> #vote Aug17
17:23:06 <colindixon> #endvote
17:23:06 <odl_meetbot> Voted on "shall week keep the target of 8/17 given that it's only 4 weeks for SR2 or move it to 9/21 to be 2 weeks after the planned nitrogen release?" Results are
17:23:06 <odl_meetbot> Aug17 (9): vrpolak, zxiiro, edwarnicke, vishnoianil, shague, hideyuki, colindixon, anipbu, skitt
17:23:18 <colindixon> #agreed we will keep Carbon-SR2 at 2017-08-17
17:23:26 <colindixon> #topic Nitrogen
17:23:38 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-July/011587.html   <--- SFT was hanging for over 3 hrs in Clustered Netconf Topology :: Netconf Connector
17:23:42 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-July/011590.html    <--- SFT was hanging for over 3 hrs in neutron :: integration-test
17:23:52 <CaseyODL> https://xkcd.com/1179/
17:23:58 <CaseyODL> :)
17:24:19 <edwarnicke> CaseyODL: I'm a big ISO 8601 proponent
17:24:19 <rovarga> CaseyODL: +1 :)
17:25:27 <colindixon> #info colindixon asks skitt and rovarga what's going on, rovarga says he's responded on the thread that it seems to be something to do with AAA
17:26:00 <colindixon> #Info there's also an issue ith threadpool in controller, that we need to go mess with
17:26:18 <colindixon> #info rovarga says that a thread-dump would still be useful, if zxiiro could produce it, that would help a lot
17:27:21 <colindixon> #action colindixon, CaseyODL, and/or anipbu to find somebody to look at the controller threadpool issue, maybe ping TomP
17:27:44 <colindixon> #topic system integration and testing
17:28:05 <colindixon> #info the SFT hangs we already talked about, otherwise nothing
17:28:18 <colindixon> #topic infra
17:28:22 <colindixon> #info no updates this week
17:28:39 <colindixon> #topic Amoury archive review
17:28:47 <colindixon> #Link https://wiki.opendaylight.org/view/Archive_Proposals/Armoury
17:29:35 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007621.html process started 2 weesk ago on 2017-06-29
17:30:23 <colindixon> #info colindixon notes that the above thread has Alexis who is the PTL saying we should archive it
17:31:09 <colindixon> #info rovarga asks is there something similar in ODL, edwarnicke says no, but APPC in ONAP does a very similar thing and is based on ODL
17:31:16 <colindixon> #startvote shall the TSC archive Amoury? -1,0,+1
17:31:16 <odl_meetbot> Begin voting on: shall the TSC archive Amoury? Valid vote options are -1, 0, +1.
17:31:16 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:31:19 <skitt> #vote +1
17:31:21 <dfarrell07> #vote +1
17:31:21 <rovarga> #vote +1
17:31:22 <colindixon> #vote +1
17:31:29 <vrpolak> #vote +1
17:31:31 <vishnoianil> #vote +1
17:31:32 <zxiiro> #vote +1
17:31:34 <hideyuki> #vote +1
17:31:36 <anipbu> #vote +1
17:31:36 <edwarnicke> #vote +1
17:31:40 <shague> #vote +1
17:31:44 <colindixon> #endvote
17:31:44 <odl_meetbot> Voted on "shall the TSC archive Amoury?" Results are
17:31:44 <odl_meetbot> +1 (11): rovarga, skitt, zxiiro, dfarrell07, edwarnicke, shague, hideyuki, colindixon, anipbu, vrpolak, vishnoianil
17:31:47 * dfarrell07 loves archiving projects:)
17:31:51 <colindixon> #agreed Amoury has been archived
17:32:09 <colindixon> #action colindixon to add the note about APPC in ONAP doing similar things to the Armoury Archive Proposal
17:32:16 <vishnoianil> dfarrell07, yeah because the wait time is around 18 months ;)
17:32:34 <colindixon> #topic Discovery Project Archive Review
17:32:37 <colindixon> #link https://wiki.opendaylight.org/view/Archive_Proposals/Discovery
17:32:58 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-June/007613.html archival proposed on 2017-06-29
17:33:58 <colindixon> #startvote shall the TSC archive the Discovery project? -1,0,+1
17:33:58 <odl_meetbot> Begin voting on: shall the TSC archive the Discovery project? Valid vote options are -1, 0, +1.
17:33:58 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:34:00 <rovarga> #vote +1
17:34:01 <hideyuki> #vote +1
17:34:02 <colindixon> #vote +1
17:34:04 <anipbu> #vote +1
17:34:05 <vishnoianil> #vote +1
17:34:06 <dfarrell07> #vote +1
17:34:07 <vrpolak> #vote +1
17:34:14 <skitt> #vote +1
17:34:15 <shague> #vote +1
17:34:27 <colindixon> #endvote
17:34:27 <odl_meetbot> Voted on "shall the TSC archive the Discovery project?" Results are
17:34:27 <odl_meetbot> +1 (9): rovarga, vrpolak, skitt, dfarrell07, shague, hideyuki, colindixon, anipbu, vishnoianil
17:34:36 <colindixon> #agreed the Discovery project has been archived
17:35:27 <CaseyODL> What!? Two TSC calls in a row that end early?!
17:35:40 <colindixon> #topic cookies
17:35:43 <colindixon> #endmeeting