17:00:33 <colindixon> #startmeeting tsc
17:00:33 <odl_meetbot> Meeting started Thu Jul 20 17:00:33 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:33 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:39 <colindixon> #topic roll call and agenda bashing
17:00:44 <colindixon> TSC members please #info in
17:00:51 <colindixon> I'm joining Zoom as we speak
17:00:52 <zxiiro> #info Thanh
17:01:15 <Huan> #info Huan
17:01:50 <Huan> I have no audio device and  will follow the minutes
17:02:44 <skitt> #info skitt
17:02:55 <vishnoianil> #info Anil VIshnoi
17:03:11 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=58746#Agenda agenda
17:03:30 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-06-17.04.html last week's minutes
17:03:44 <rovarga> #info rovarga
17:04:05 <LuisGomez> #info LuisGomez
17:04:28 <lori> #info lori
17:05:00 <abhijitkumbhare> #info abhijitkumbhare
17:05:00 <Huan> https://www.opendaylight.org/global-events returns 404?
17:05:09 <shague> #info shague
17:05:47 <shague> let me find the button
17:06:20 <shague> colin is host again
17:06:45 <rovarga> a Dalek Colin? :-)
17:06:49 <colindixon> OK
17:06:54 <colindixon> let me know when I should dial back in
17:07:21 <skitt> colindixon, you’re still in the list of participants
17:07:29 <skitt> colindixon, ah you’ve just disappeared
17:07:46 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-13-17.00.html note that these are the real last-weeks' minutes
17:07:56 <skitt> colindixon, you can join again
17:07:59 <CaseyODL> colindixon: Come back :)
17:08:13 <colindixon> #info moving "colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way" out of being weekly tracked
17:10:02 <colindixon> #info moving "phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials" out weekly tracked
17:10:29 <colindixon> #info colindixon has requested that edwarnicke and cdub be removed from the security response team based on their requests
17:10:31 <jamoluhrsen> #info jamoluhrsen
17:10:44 <colindixon> #action colindixon to update the wiki with the changes to the security response team
17:11:05 <colindixon> #action colindixon is still trying to hunt down one more unresponsive security response team member
17:12:07 <CaseyODL> colindixon: I think I figured out why the co-host isn't working on the TSC meeting.   On the Zoom page, go to "My  Account" > "Meeting Settings" > Check the box "Co-host".
17:12:21 <colindixon> #info rovarga reach edout to the projects that use liblldp and ask if they can take it over or stop using it to get it out of controller, the two options are (i) move it to openflowplugin or (ii) it's own project
17:13:04 <colindixon> #info rovarga says he thinks making it it's own project might make it's own sense, it's only 40 lines of code, if we just released it might be easier to make it just frozen
17:13:42 <rovarga> correction: it is 4KLOC
17:14:13 <colindixon> #undo
17:14:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2e38d10>
17:14:20 <colindixon> #info rovarga says he thinks making it it's own project might make it's own sense, it's only 4k lines of code, if we just released it might be easier to make it just frozen
17:14:42 <phrobb> #info phrobb has removed cdub from the Security@lists.opendaylight.org mailing list.  phrobb notes that edwarnicke is not on this mailing list.
17:15:28 <colindixon> #action rovarga to start a thread on the TSC about creating a project for liblldp and how we can do it in an efficient way (shague and colindixon note that a full project might be an issue)
17:15:42 <colindixon> phone overheated (because I'm in the sun) hold on
17:15:51 <skitt> phrobb, could you send an email to the security mailing list with the people who *are* on the list?
17:16:34 <colindixon> skitt: it might be good to make it so that people on it can see who else is on it
17:16:50 <colindixon> skitt: I think you can open a helpdesk ticket for that
17:16:52 <phrobb> #action phrobb to send a test-email to security mailing list with the list of people who are on the list.
17:16:58 <edwarnicke> #info edwarnicke
17:17:03 <colindixon> #action CaseyODL and/or colindixon to work on getting more DDF poll responses and starting to summarize them
17:17:09 <skitt> colindixon, I‘ll do that (I’ll check the mailman interface too)
17:17:20 <colindixon> CaseyODL: did you send the DDF mail to controller-dev?
17:17:22 <colindixon> I assume so
17:17:27 <skitt> #action skitt to open a helpdesk ticket so security team members can see who’s on the mailing list
17:17:29 <CaseyODL> I did.
17:17:33 <colindixon> (still waiting for phone to cool offf, will run things from here)
17:17:49 <colindixon> #Info CaseyODL did send the DDF poll to controller-dev, I think the plan is to close it before next week's TSC meeting
17:18:02 <colindixon> #action CaseyODL to add this release manager position be made a priority for the next board meeting
17:18:09 <colindixon> #action phrobb to bring the need for a security manager to the board and figure out if we can get a response
17:18:33 <colindixon> #info colindixon has lost the link, but TomP submitted a patch to fix the threadpool issue in the controller that was causing SFT hangs, fix was in AAA
17:18:49 <colindixon> #info colindixon added the note about APPC in ONAP doing similar things to the Armoury Archive Proposal
17:19:15 <colindixon> anything else in terms of action items?
17:19:23 * colindixon is dialing back in
17:19:46 <rovarga> well, the threadpool thing is a bandaid, we need to find someone to drive migration to Jersey 2
17:20:28 <zxiiro> Kit Kou (klou) is the volunteer Release Manager
17:20:39 <zxiiro> Lou* sorry
17:21:04 <colindixon> #Info CaseyODL says that there is a release manager volunteer from Brocade (Kit Lou) who is working with anipbu and others to try to get spun up
17:22:06 <colindixon> #info targeting the first week in october in the bay area for a Oxygen DDF, looking for member orgs to host it
17:22:39 <colindixon> #info CaseyODL says that there were only 13 responses to the mandarin poll and even then there were very few fields filled out
17:23:30 <colindixon> #info the dominant info from the mandarin poll was a bunch of cities in Asia as a place host it
17:24:11 <colindixon> #info dfarrell07 says that there's an OPNFV plugfest in portland in september sometime, dfarrell07 asks if we've considered co-located
17:24:26 <colindixon> #Info CaseyODL says that very few people say co-location mattered in the poll
17:25:17 <dfarrell07> #info that OPNFV plugfest is in December according to CaseyODL
17:25:47 <colindixon> #topic mailing list votes and discussions
17:25:55 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-July/007668.html e-mail creation review for OVIL
17:26:10 <colindixon> #info please go look at that thread and where it points
17:28:11 <colindixon> #info colindixon notes that there's already been _a lot_ of discussion in the threads pointed to from ther
17:28:19 <colindixon> #topic events
17:28:29 <colindixon> #link https://www.opendaylight.org/global-events
17:28:35 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:28:52 <colindixon> #info see information about the Oxygen DDF above in these minutes
17:28:59 <colindixon> #Info we have the cablelabs even happening in august
17:30:03 <colindixon> #topic nitrogen
17:30:17 <colindixon> #chair anipbu CaseyODL
17:30:17 <odl_meetbot> Current chairs: CaseyODL anipbu colindixon
17:30:35 <jamoluhrsen> nitro m5 offset 0 is in 8 days
17:30:44 <colindixon> #info zxiiro as of this morning, we've added all of the projects that have submitted patches to autorelease and int/dist
17:30:59 <colindixon> #Info zxiiro has a build going that will test things, but as of yesterday, we had a passing autorelease build
17:31:08 <colindixon> #info jamoluhrsen notes that m5 offset 0 is in 8 days
17:31:15 * jamoluhrsen has to stay on mute
17:31:24 <phrobb> skitt, colindixon: The email has been sent to the security team.
17:31:29 <skitt> phrobb, thanks!
17:31:45 <colindixon> #Info abhijitkumbhare asks how we're doing on Karaf 4 migration, zxiiro says looking at the autorelease pom, we're still missing a lot of projects
17:31:47 <jamoluhrsen> our line in the sand for getting in to nitro (k4 migration) is m5
17:32:11 <skitt> jamoluhrsen, shouldn’t that be a line in granite or something? ;-)
17:32:14 <colindixon> #info zxiiro says that we have 26 in autorelease right now
17:32:27 <jamoluhrsen> netvirt is in
17:32:56 <CaseyODL> https://www.opendaylight.org/global-events is fixed.
17:32:56 <jamoluhrsen> skitt, yeah, line in the granite is better
17:33:31 <colindixon> #info colindixon says at this point not migrating to karaf 4 seems like it's laziness
17:33:39 <colindixon> #undo
17:33:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2d0fed0>
17:33:47 <colindixon> #info colindixon says at this point, projects not migrating to karaf 4 seems like it's laziness
17:34:39 <colindixon> #action colindixon, zxiiro, and/or anipbu to look into if netconf (not just restconf) is enabled in karaf 4 in int/dist
17:35:05 <edwarnicke> #info it could also be summer vacations delaying migration
17:35:14 <colindixon> edwarnicke: :-)
17:36:39 <colindixon> #info colindixon notes that laziness is (intentionally overstated) includes summer vacation, abandoned projects, etc.
17:38:01 <colindixon> #action colindixon to work with anipbu to get some intuition about if we have responsive projects that haven't migrated
17:38:10 <colindixon> #topic carbon
17:38:26 <zxiiro> #info Carbon-SR2 code freeze is 2017-08-10 with release expected 2017-08-17
17:39:16 <colindixon> #info autorelease carbon has been failing for 7 days, currently on GBP renderer, so reaching out after the call
17:39:31 <colindixon> #topic system integration and test
17:39:32 <jamoluhrsen> nothing to report
17:39:33 <colindixon> jamoluhrsen: anything
17:39:39 <colindixon> #info nothing this week
17:39:40 <jamoluhrsen> #info nothing to report for sys int test
17:39:43 <colindixon> #topic infra
17:40:32 <colindixon> #undo
17:40:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2e92850>
17:40:36 <colindixon> #topic back to carbon
17:41:14 <colindixon> #info kevin wang says he has a patch he needs merged in carbon for bgpcep, colindixon and/or anipbu will help find a committer
17:41:46 <rovarga> which patch?
17:41:46 <dfarrell07> isn't rovarga a BGP committer?
17:42:03 <colindixon> #action colindixon and/or anipbu to try to find a bgpcep committer today if at all possible?
17:43:04 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/60401/ is the patch
17:43:36 <colindixon> #topic infra
17:43:41 <colindixon> #info no updates this week
17:46:05 <colindixon> #topic cookies
17:46:24 <colindixon> #endmeeting