#opendaylight-meeting: tsc

Meeting started by skitt at 17:00:51 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (skitt, 17:01:16)
    1. TSC members please info in (skitt, 17:01:21)
    2. skitt (skitt, 17:01:24)
    3. lori (lori, 17:01:25)
    4. anipbu (anipbu, 17:01:27)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=63242#Agenda (skitt, 17:01:32)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-03-16.59.html (skitt, 17:01:37)
    7. huan (huan, 17:01:38)
    8. jamoluhrsen (jamoluhrsen, 17:01:42)
    9. klou (klou__, 17:01:46)
    10. gilesheron (proxy for edwarnicke) (gilesheron, 17:01:49)
    11. Anil Vishnoi (vishnoianil, 17:01:54)
    12. Thanh (zxiiro, 17:02:31)
    13. https://lists.opendaylight.org/pipermail/tsc/2017-August/007764.html (skitt, 17:03:11)
    14. release engineering to look at the yangtools branching proposal (skitt, 17:03:26)
    15. ACTION: release engineering to look at the yangtools branching proposal (skitt, 17:03:58)
    16. ACTION: colindixon to allow co-hosts for the TSC meeting (skitt, 17:04:53)
    17. abhijitkumbhare (abhijitkumbhare, 17:05:01)
    18. ACTION: colindixon to follow up about one last non-responsive security response team member (skitt, 17:05:11)
    19. shague (shague_, 17:05:58)
    20. the request for a security manager is on the agenda for the next board meeting (skitt, 17:06:31)

  2. TSC mailing list votes and discussions (skitt, 17:06:41)
  3. Events (skitt, 17:07:38)
    1. cablelabs event was a success (skitt, 17:07:55)
    2. lots of interest in ODL (skitt, 17:08:04)
    3. next big event: DDF (skitt, 17:08:09)
    4. please add topics to the topics page (skitt, 17:08:17)
    5. https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum (skitt, 17:08:31)
    6. https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum Add DDF topics here (dfarrell07, 17:09:00)
    7. encourage cross-project discussions at our DDF (ONAP etc.) (skitt, 17:09:41)
    8. Oxygen DDF on Oct. 9th and 10th (phrobb, 17:11:02)
    9. https://wiki.opendaylight.org/view/Events:Main (CaseyODL, 17:11:26)
    10. rovarga (rovarga, 17:11:42)
    11. rovarga_ (rovarga_, 17:12:18)
    12. OPNFV and ONAP events in December (skitt, 17:15:17)
    13. having aligned project releases will simplify the organisation of collaborative events (skitt, 17:16:15)
    14. mid-December is Oxygen M3 which is ideal for integrating with upstreams and downstreams (skitt, 17:17:04)
    15. opportunity to prepare Fluorine as well (skitt, 17:18:31)
    16. ACTION: CaseyODL to start a thread to discuss a December meet-up (skitt, 17:20:44)
    17. multiple logistical questions to address (skitt, 17:25:51)
    18. ACTION: phrobb to pursue the opportunity and keep the TSC up to speed (skitt, 17:27:12)

  4. Carbon (skitt, 17:27:20)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- Carbon SR2 on 8/17/2017 with cutoff this Sunday (branches will be locked). (anipbu, 17:27:39)
    2. Carbon release next week (skitt, 17:27:40)
    3. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/buildTimeTrend <--- We have not had a successful build of Carbon since July 27 (anipbu, 17:27:49)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=8941 <--- Pending One Blocker Bug for Carbon SR2 (anipbu, 17:28:08)

  5. Nitrogen (skitt, 17:29:48)
    1. 43 projects in Nitrogen (skitt, 17:30:10)
    2. 5 not in the distribution yet: gbp, snmp, faas, + 2 leaf projects (skitt, 17:30:32)
    3. M5 is August 14, which is also RC0 (skitt, 17:30:49)
    4. https://jenkins.opendaylight.org/releng/view/CLM/ (anipbu, 17:31:01)
    5. if gbp removes its dependency on faas then faas becomes a leaf and can be dropped (gilesheron, 17:33:10)
    6. gbp no longer depends on faas (skitt, 17:35:16)
    7. ACTION: gzhao to reach out to the faas team (skitt, 17:36:30)
    8. no successful autorelease for quite a while (skitt, 17:36:53)
    9. odlparent needs to settle on a final Nitrogen version (skitt, 17:41:14)
    10. all projects need to upgrade and we need to track this (skitt, 17:41:23)
    11. odlparent 2.0.4 can be used as the final version for Nitrogen, barring bugs (skitt, 17:44:53)
    12. if any SFT-related change is necessary, its impact can be limited to integration/distribution (skitt, 17:45:17)
    13. patches for projects to migrate to 2.0.4: https://git.opendaylight.org/gerrit/#/q/topic:odlparent-2.0.4 (skitt, 17:46:18)
    14. ultimately, micro-version bumps should happen automatically (once we have appropriate sanity tests) (skitt, 17:50:33)
    15. distribution-check is obsolete on every patch in odlparent-style projects, it's only needed on releases (skitt, 17:52:39)

  6. System Integration and Testing (skitt, 17:52:48)
    1. lack of committers on int/dist (skitt, 17:53:07)
    2. suggestion to grant zxiiro rights to merge patches in int/dist (skitt, 17:55:58)
    3. but that goes against project sovereignty (skitt, 17:56:05)
    4. projects are governed by their committers (skitt, 17:57:26)
    5. the TSC can only step in when solicited by projects (skitt, 17:57:43)
    6. ACTION: jamoluhrsen to ask edwarnicke to vote to grant zxiiro committer rights (temporarily) (skitt, 18:01:13)
    7. reminder about the resource thread (skitt, 18:01:33)
    8. Ed is offline until Monday I think? (gilesheron, 18:02:07)
    9. we might need to delay the release (skitt, 18:05:00)
    10. same issue with the docs project (skitt, 18:05:40)
    11. ACTION: skitt to start committer votes (skitt, 18:06:24)

  7. Cookies (skitt, 18:06:27)


Meeting ended at 18:06:40 UTC (full logs).

Action items

  1. release engineering to look at the yangtools branching proposal
  2. colindixon to allow co-hosts for the TSC meeting
  3. colindixon to follow up about one last non-responsive security response team member
  4. CaseyODL to start a thread to discuss a December meet-up
  5. phrobb to pursue the opportunity and keep the TSC up to speed
  6. gzhao to reach out to the faas team
  7. jamoluhrsen to ask edwarnicke to vote to grant zxiiro committer rights (temporarily)
  8. skitt to start committer votes


Action items, by person

  1. CaseyODL
    1. CaseyODL to start a thread to discuss a December meet-up
  2. gzhao
    1. gzhao to reach out to the faas team
  3. jamoluhrsen
    1. jamoluhrsen to ask edwarnicke to vote to grant zxiiro committer rights (temporarily)
  4. phrobb
    1. phrobb to pursue the opportunity and keep the TSC up to speed
  5. skitt
    1. skitt to start committer votes
  6. zxiiro
    1. jamoluhrsen to ask edwarnicke to vote to grant zxiiro committer rights (temporarily)
  7. UNASSIGNED
    1. release engineering to look at the yangtools branching proposal
    2. colindixon to allow co-hosts for the TSC meeting
    3. colindixon to follow up about one last non-responsive security response team member


People present (lines said)

  1. skitt (62)
  2. rovarga_ (9)
  3. dfarrell07 (9)
  4. abhijitkumbhare (6)
  5. anipbu (5)
  6. odl_meetbot (4)
  7. jamoluhrsen (4)
  8. vishnoianil (4)
  9. gilesheron (3)
  10. zxiiro (3)
  11. huan (2)
  12. gzhao (1)
  13. rovarga (1)
  14. klou__ (1)
  15. phrobb (1)
  16. lori (1)
  17. CaseyODL (1)
  18. shague_ (1)


Generated by MeetBot 0.1.4.