17:03:35 <colindixon> #startmeeting tsc
17:03:35 <odl_meetbot> Meeting started Thu Aug 31 17:03:35 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:35 <odl_meetbot> The meeting name has been set to 'tsc'
17:03:36 <colindixon> #topic agenda bashing and roll call
17:03:39 <jamoluhrsen> #info jamoluhrsen
17:03:43 <colindixon> TSC members please #info in
17:03:44 <rovarga> #info rovarga
17:03:44 <dfarrell07> #info Daniel Farrell for Stephen Kitt
17:03:45 <colindixon> #info colindixon
17:03:51 <vishnoianil> #info Anil Vishnoi
17:03:51 <abhijitkumbhare> #info abhijitkumbhare
17:04:25 <edwarnicke> #info edwarnicke
17:04:32 <zxiiro> #info Thanh
17:05:40 <colindixon> #Link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=64051
17:05:48 <colindixon> #undo
17:05:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x140c490>
17:05:53 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=64051#Agenda
17:06:05 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-24-03.28.html last meetings' minutes
17:06:14 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-17-17.02.html two weeks ago meeting's minutes
17:06:27 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-17-17.48.html two weeks ago meeting's minutes II
17:07:34 <colindixon> #info jamoluhrsen wants to add "how to not be late in releases?" to the agenda
17:08:03 <colindixon> #action colindixon and/or CaseyODL to look int why recording isn't working in Zoom
17:08:06 <colindixon> #topic updates
17:08:13 <shague> #info shague
17:08:34 <colindixon> #info nothing new this week
17:08:44 <colindixon> #topic events
17:08:53 <colindixon> #link https://www.opendaylight.org/global-events
17:09:03 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:09:08 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-July/007684.html
17:09:13 <colindixon> #undo
17:09:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x14a7810>
17:09:21 <colindixon> #Link https://lists.opendaylight.org/pipermail/tsc/2017-July/007684.html DDF coming up
17:09:49 <colindixon> #info phrobb is looking for how we can participate in the ONAP DDF in December (currently 2nd week fo December in the bay area at Intel Santa clara)
17:11:36 <colindixon> #info dfarrell07 asks about hotels near the DDF, CaseyODL says he might be able to get a block discount, but if it goes past today, just book something
17:12:08 <colindixon> #info colindixon says probably just booking will make sense (CaseyODL seems to mostly agree)
17:12:15 <colindixon> #topic carbon
17:12:57 <colindixon> #info we have 6 blocker bugs for SR2 as of this morning
17:12:58 <klou> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 - carbon tracking sheet
17:14:40 <colindixon> #info jamoluhrsen says that there a two bugs filed recently that he's checking if they're blocking (likely not), 1 but had a merged patch this morning and is hopefully fixed (BUG-9060), can't comment on the other three bugs
17:15:51 <colindixon> #info 9063 and 9064 are likely not blocking (according to jamo)
17:18:50 <colindixon> #inf 9061 jamoluhrsen says is a maybe non-blocker, but bad
17:18:54 <colindixon> #info 9061 jamoluhrsen says is a maybe non-blocker, but bad
17:19:25 <colindixon> #info 9034 rovarga says is a umbrella bug for things the tooling exposed about not closing transaction chains (we need to look at it, figure out if it's a regression)
17:19:51 <colindixon> #info 9054 has a patch, which is waiting for review
17:21:43 <colindixon> #info it sounds like the next steps are: investigate everything but 9054 with a critical eye for if they're blockers or just bad (blocker is a regression with no reasonable workaround), then merge the patch for 9054
17:23:08 <colindixon> #info rovarga asks how long we should delay carbon, do we want to set a line in the sand?
17:23:09 * dfarrell07 is just happy that carbon is becoming reliable through this process, SR1 was :(
17:23:18 <colindixon> yeah…
17:23:56 <colindixon> #startvote should we focus on cabon-sr2 first, nitrogen first, or both at the same time? C, N, both
17:23:56 <odl_meetbot> Begin voting on: should we focus on cabon-sr2 first, nitrogen first, or both at the same time? Valid vote options are C, N, both.
17:23:56 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:24:27 <rovarga> #vote C
17:24:27 <zxiiro> #vote N
17:24:27 <colindixon> #vote C
17:24:27 <vishnoianil> #vote both
17:24:38 <dfarrell07> #vote N
17:24:39 <jamoluhrsen> #vote C
17:24:42 <shague> #vote C
17:25:08 <colindixon> going once
17:25:10 <abhijitkumbhare> #vote both
17:25:24 <colindixon> going twice
17:25:37 <gzhao> both is an option?
17:25:46 <zxiiro> yes
17:26:00 <colindixon> gzhao: do both at the same time? focus on one? or focus on the other?
17:26:10 <colindixon> going three times
17:26:13 <edwarnicke> #vote +1
17:26:13 <odl_meetbot> edwarnicke: +1 is not a valid option. Valid options are C, N, both.
17:26:28 <edwarnicke> #vote N
17:26:41 <colindixon> #endvote
17:26:41 <odl_meetbot> Voted on "should we focus on cabon-sr2 first, nitrogen first, or both at the same time?" Results are
17:26:41 <odl_meetbot> both (2): vishnoianil, abhijitkumbhare
17:26:41 <odl_meetbot> C (4): shague, rovarga, colindixon, jamoluhrsen
17:26:41 <odl_meetbot> N (3): edwarnicke, dfarrell07, zxiiro
17:27:00 <vishnoianil> colindixon if we won't focus on Nitrogen, there is a risk on executing the 6 month release plan, focussing on carbon is fine, if we don't care about the 6 month plan
17:27:13 * dfarrell07 voted for N because it has 6 month cadence we need to keep
17:27:31 <abhijitkumbhare> agree with dfarrell07
17:27:43 <vishnoianil> dfarrell07 abhijitkumbhare +1
17:28:02 <gzhao> zxiiro: colindixon: understood, if we can do both, we don't need a vote. -:)
17:28:03 <colindixon> #info it sounds like we shoudl focus on carbon first, probalby true if we can get it done in the next ~24 hours, maybe less so if it drifts
17:28:09 <dfarrell07> SRs can be delayed for long time without major schedule impact
17:28:19 <abhijitkumbhare> just don’t know if N needs to be prioritized over C in order to do N faster
17:28:20 <edwarnicke> dfarrell07: Agreed
17:28:47 <rovarga> dfarrell07: yes, and we discussed this some ... 4-6 weeks ago and chose not to
17:29:02 <vishnoianil> somehow i started feeling that 6 month release is not really a realistic solution
17:30:38 <colindixon> #info vishnoianil and dfarrell07 say that SRs are less important to keep on-time vs. releasing Nitrogen on-time to keep the 6-month release cycle
17:30:45 <colindixon> rovarga: you're next
17:31:25 <colindixon> #Info vishnoianil asks if we slip the nitrogen release by two weeks, what will happen and will it be OK, can we start the Oxygen release on the same schedule as planned
17:32:14 <colindixon> #info rovarga says getting something that is currently active used downstream faster may matter more than getting them a shiny new object
17:34:59 <dfarrell07> for our downstream, I think we care more about having Carbon SR2 stable than having it on time
17:35:52 <rovarga> colindixon: not to mention the fact that yangtools kinda needs to start doing oxygen stuff in order to leave enough time to get reintegration done in oxygen ;-)
17:37:04 <dfarrell07> shague: +1, that is very not okay
17:38:27 <colindixon> #info shague says that it takes a 32 GB box and that only buys you ~24 hours, telling a customer you have to reboot ODL every 24 hours in production is a bad idea, might actually be "not a reasonable workaround"
17:38:54 <dfarrell07> I think in practice we'll "focus" on both, but we should try to push Nitrogen out the door (maybe with bugs) to keep cadence and should get SR2 stable b/c schedule doesn't matter, stability does
17:39:14 <colindixon> #info it sounds ike the issues in carbon are also issues in nitrogen, so there's no value to focusing on eone or th eother
17:40:42 <dfarrell07> vishnoianil: +1, I think it's expected that first release is not super stable
17:40:57 <colindixon> #info also in general, we prefer quality over timeliness, so… fixing the issues we understand before shipping is better
17:41:15 <colindixon> #Info vishnoianil says that people will forgvie a mildly broken Nitrogen mroe than a mildly broken Carbon-SR2
17:42:10 <dfarrell07> colindixon: +1
17:43:22 <colindixon> #info rovarga says he thinks SR2 is better than SR1, especially without clustering, so it might be worth shipping SR2 as is, but I think others think the key metric is still missing
17:43:52 <colindixon> #topic nitrogen
17:44:04 <klou> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=592032762 - nitrogen tracking sheet
17:44:09 <colindixon> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-nitrogen/ we have working builds!
17:44:35 <colindixon> #info klou says that we're officially only 2 days late, but that may be misleading
17:45:36 <colindixon> #info 8858 is waiting on a +2 from TomP
17:45:49 <colindixon> #undo
17:45:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x144b110>
17:46:30 <colindixon> #info 8858 is waiting on a +2 from TomP in Carbon, and then go into nitrogen and master (rovarga says that it's not critical enough to block SR2)
17:46:59 <colindixon> #info 8741 the startup archetype is broken for Karaf 4, this is likely a blocker
17:48:49 <colindixon> #info 9044 after hard reset, Robot fails to establish SSH connection to karaf: jamoluhrsen says he's looking into it to figure out if it's a real issue or just affecting tests
17:49:30 <colindixon> #Info 9044 is using kill -9, it would be nice to know if a more graceful reboot would work
17:50:03 <colindixon> #info 8987 example-bgp-rib does not exist when updating peer configuration, nobody seems to know what this is
17:50:46 <colindixon> #info 9057 IncompatibleClassChangeError in RPC test: rovarga says that this is seeming to point to an inconsistent distribution, it's the first time we're seeing it, so may take some time to understand
17:51:18 <colindixon> #info 9054 Singleton leader chasing exhausts heap space in few hours (manifestation of stabiltiy issues in carbon on this list)
17:52:00 <colindixon> #info we still have 3-4 projects that haven't reviewed the test results, jamoluhrsen says to just get them to review RC2
17:52:57 <colindixon> #info aaa, bier, snmp, sfc, unimgr are the ones, of those sfc and aaa are the only ones I'd worry about
17:54:27 <jamoluhrsen> since nobody is speaking up for carbon sr2 now, let's make sam happy
17:55:42 <dfarrell07> the thing I don't like about waiting on SR2 is that some smaller bugs aren't getting backported to stable/carbon
17:56:15 <rovarga> dfarrell07: yup
17:56:59 <rovarga> dfarrell07: I do believe an open branch would be very useful
17:58:11 <colindixon> #Info colindixon asks if anyone disagrees with the idea of getting the patch for 9054 merged in Carbon, then ship SR2, then work the remaining bugs in both Nitrogen and Carbon
17:58:45 <colindixon> #Info rovarga notes that TomP beign somewhat off the grid is hurting our debugging now because clustering issues basically fall to Robert or TomP
17:59:38 * dfarrell07 kinda likes this "just open the branch" solution
18:00:30 * zxiiro likes that idea
18:00:42 <colindixon> #startvote what to do with Carbon-SR2: ship it and open the branch, just open the branch, leave the branch closed? ship, open, leave
18:00:42 <odl_meetbot> Begin voting on: what to do with Carbon-SR2: ship it and open the branch, just open the branch, leave the branch closed? Valid vote options are ship, open, leave.
18:00:42 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:00:42 * dfarrell07 likes this idea more and more
18:00:50 <colindixon> #vote open
18:01:37 <abhijitkumbhare> #vote ship
18:01:54 * dfarrell07 sees almost no benefit in shipping now
18:01:58 <dfarrell07> #vote open
18:02:50 <abhijitkumbhare> ship and make all Carbon blockers also blockers on Nitrogen
18:03:02 <zxiiro> #vote open
18:03:08 <dfarrell07> abhijitkumbhare: what good is SR2 though?
18:03:14 <rovarga> #vote ship
18:03:27 <abhijitkumbhare> dfarrell07: its better than sr1
18:03:37 <dfarrell07> abhijitkumbhare: both are unusable
18:03:57 <abhijitkumbhare> but probably all releases we have so far dfarrell07
18:04:10 <abhijitkumbhare> unusable i mean
18:04:29 <dfarrell07> abhijitkumbhare: we had some good Boron SRs;)
18:04:29 <abhijitkumbhare> in shague deployment
18:04:41 <colindixon> #Info rovarga points out that punting on SR2 doesn't necessariy help, it will just make it fall on top of nitrogen SR1 and oxygen spinup
18:04:43 <abhijitkumbhare> i mean with shague tests
18:05:19 <lori> #vote open
18:05:22 * rovarga can vote for open... because it leaves the SR2 date open-ended
18:05:35 <edwarnicke> #open
18:05:39 <edwarnicke> #vote open
18:05:55 <rovarga> #vote open
18:06:05 <vishnoianil> #vote open
18:06:05 <dfarrell07> rovarga: latest date would be SR3 date;)
18:06:05 <colindixon> #endvote
18:06:05 <odl_meetbot> Voted on "what to do with Carbon-SR2: ship it and open the branch, just open the branch, leave the branch closed?" Results are
18:06:05 <odl_meetbot> ship (1): abhijitkumbhare
18:06:05 <odl_meetbot> open (7): rovarga, edwarnicke, dfarrell07, colindixon, lori, zxiiro, vishnoianil
18:06:35 <colindixon> #action colindixon to (immediately) send mail to TSC about SR2
18:06:38 <dfarrell07> shague: open gives us some small bugfixes on top of the blockers
18:07:25 <colindixon> #topic cookies
18:07:31 <colindixon> #endmeeting