17:00:15 <colindixon> #startmeeting TSC
17:00:15 <odl_meetbot> Meeting started Thu Sep  7 17:00:15 2017 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:15 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:15 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:20 <colindixon> #topic roll call and agenda bashing
17:00:50 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=64435#Agenda
17:01:01 <colindixon> #info linking in minutes from the past 3 meetings (including split notes for one meeting) to catch action items
17:01:02 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-17-17.02.html
17:01:03 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-17-17.48.html
17:01:03 <LuisGomez> #info LuisGomez
17:01:04 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-24-03.28.html
17:01:05 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-31-17.03.html
17:01:07 <edwarnicke> #info edwarnicke
17:01:08 <anipbu> #info anipbu
17:01:09 <colindixon> #info colindixon
17:01:17 <zxiiro> #info Thanh
17:01:28 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-September/007890.html colindixon sent mail to TSC about Carbon-SR2
17:01:28 <colindixon> #info CaseyODL should have fixed Zoom recording
17:01:30 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Committer-At-Large_Election_Process says "Normally…the term is 1 year…During the Boron Release, the elected Committers-At-Large (CALs) will only serve on the TSC until the end of the Boron development cycle."
17:01:31 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-November/006328.html the TSC election results were posted 11/22/2016, so technically we should do the new election then, not after Nitrogen
17:01:32 <vrpolak> #info Vratko Polak proxying for Robert Varga
17:01:33 <colindixon> #link Oxygen DFF registration page https://www.regonline.com/ODLDesignForumOctober2017
17:01:34 <colindixon> #link Oxygen DDF registration page linked to from here https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum#October_9-10th_in_Santa_Clara.2C_CA.
17:01:34 <colindixon> #link Oxygen DDF registration page also linked to from here https://wiki.opendaylight.org/view/Events:Main#ODL_Oxygen_Developer_Design_Forum
17:02:06 <shague> #info shague
17:02:49 <colindixon> #action colindixon to provide results of vote to remove non-responsive security response team member
17:02:50 <colindixon> #action colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
17:02:51 <colindixon> #action CaseyODL to send mail about elections and/or make sure it's on next week's TSC agenda
17:02:52 <colindixon> #action CaseyODL to add Registration link for DDF to the webpage here: https://www.opendaylight.org/events
17:03:06 <skitt> #info skitt
17:03:16 <LuisGomez> #info LuisGomez stands also for vishnoianil
17:03:30 <jamoluhrsen> #info jamoluhrsen
17:03:38 <abhijitkumbhare> #info abhijitkumbhare
17:04:23 <colindixon> #action phrobb and/or CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up
17:04:55 <colindixon> #action phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
17:05:04 <lori> #info lori
17:05:20 <colindixon> #info there is not a hotel discount for for the Oxygen DDF
17:06:10 <colindixon> #action projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them)
17:07:05 <colindixon> #info klou asks to add the oxygen release plan as well
17:07:46 <colindixon> #topic events
17:07:54 <colindixon> #link https://www.opendaylight.org/global-events
17:08:02 <colindixon> #undo
17:08:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x14b4dd0>
17:08:05 <colindixon> #link https://www.opendaylight.org/events
17:08:12 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main
17:08:40 <colindixon> #link https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum on October 9-10th in Santa Clara
17:09:12 <colindixon> #info thre will be an OPNFV plugfest in portland in december
17:09:24 <colindixon> #action CaseyODL to add the December OPNFV plugfest to the agenda
17:09:41 <colindixon> #topic Carbon
17:09:58 <colindixon> #info no updates this week, we are postponing Carbon-SR2 to after Nitrogen
17:10:22 <colindixon> #topic Oxygen release plan
17:11:07 <colindixon> #action colindixon to look up the 6-month release cadence docs and draw up a draft Oxygen release plan and send it out to the TSC mailing list
17:11:18 <zxiiro> #link http://docs.opendaylight.org/en/latest/release-process/release-schedule.html A release schedule but for Nitrogen
17:11:33 <zxiiro> actually it has "future release" listed too
17:11:46 <colindixon> #link http://docs.opendaylight.org/en/latest/release-process/release-schedule.html#future-odd-releases
17:12:31 <colindixon> thanks zxiiro
17:13:01 <colindixon> #action klou to start asking for M0 particpation from projects in Oxygen
17:13:32 <colindixon> #topic Nitrogen
17:13:48 <klou> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=592032762 - nitrogen tracking sheet
17:15:15 <colindixon> #info By my count we have 11 currently tracked blocking bugs:
17:15:16 <colindixon> #info * 1 of which has a merged patch and should probably be verified and closed.
17:15:17 <colindixon> #info * 2-4 of which are waiting for review (I'm not sure 9034 and 8988)
17:15:18 <colindixon> #info * 3 of which are in progress
17:15:19 <colindixon> #info * 3 of which have no patches
17:15:46 <colindixon> #action jamoluhrsen to look into 9063 9064, it's possible that the fix for 9034 helped
17:16:31 <colindixon> #info 8741	startup archetype upgrade to karaf 4, skitt says vorburger is going to get to in in a day or two
17:16:41 <colindixon> #Undo
17:16:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x156f5d0>
17:16:58 <colindixon> #info 8741 startup archetype upgrade to karaf 4, skitt says vorburger is going to get to in in a day or two, it needs to be moved from master to nitrogen
17:18:19 <colindixon> #9044 After hard reset, Robot fails to establish SSH connection to karaf, looks like vrpolak is looking into it, but he says not this second, currently it's after kill -9, it might work better if we did something more graceful like bin/karaf/stop
17:19:04 <colindixon> #info 9044 After hard reset, Robot fails to establish SSH connection to karaf, looks like vrpolak is looking into it, but he says not this second, currently it's after kill -9, it might work better if we did something more graceful like bin/karaf/stop
17:19:23 <colindixon> #info 9057 IncompatibleClassChangeError in RPC test, vrpolak has a workaround which is ugly, looking for cleaner one, should be fixed soon
17:20:15 <colindixon> https://git.opendaylight.org/gerrit/#/q/message:9034
17:21:37 <colindixon> #info 9034 OOM due to huge Map in ShardDataTree: MANY MORE!, jamoluhrsen says that there is a candidate patch and it seems to work (really bug 9038 is the one that is a blocker)
17:23:12 <colindixon> #Undo
17:23:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x156fcd0>
17:23:38 <colindixon> #Info 9034 is a collection of bugs to try to fix OOM issues, with the biggest manifestation of that being 9038
17:23:59 <colindixon> #info the fixes for 9038 and 9034 so far, have helped iwth OOM issues, but haven't resolved the underlying problem with 9038
17:24:36 <colindixon> #info 9038 IllegalStateException: Attempted to close chain with outstanding transaction PingPongTransaction at org.opendaylight.openflowplugin.impl.device.TransactionChainManager.createTxChain
17:25:22 <colindixon> #info as above jamoluhrsen will look into 9063/9064
17:25:49 <colindixon> #info 9006 Sporadic cluster failure when member is restarted in OF cluster test, not being worked as far as we know
17:27:45 <colindixon> #info 8988 NPE when adding routes to app-peer, Jakub Morvay is working on it locally
17:28:41 <colindixon> #info 9092 Exception in ListenerAdapter: java.lang.UnsupportedOperationException: Cannot create XMLStreamReader or XMLEventReader from a org.codehaus.stax2.io.Stax2ByteArr, quick fix is waiting for review, longer fix is a work in progress by skitt, ready by tomorrow
17:29:25 <colindixon> #info 9093 With logical SFF and OF based tunnels, chain does not work with SFs on different nodes, waiting for review
17:30:01 <colindixon> #action colindixon to ping brady on twitter about 9093
17:30:07 <CaseyODL> lol
17:30:50 <colindixon> #info based on the above, assuming jamoluhrsen has luck 9063/9064, we have two bugs that aren't really being worked: 9044 and 9006
17:31:15 <jamoluhrsen> brady has been tweeted!
17:31:29 <colindixon> #action klou anipbu colindixon and zxiiro to try to find owners for 9063 9064 9044 9006
17:33:03 <colindixon> #info it sounds like we might have a bunch of these fixed on Monday
17:33:26 <colindixon> #action colindixon to set up a nitrogen sync on Monday (and maybe Wednesday)
17:33:31 <colindixon> #undo
17:33:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1554690>
17:33:35 <colindixon> #action colindixon to set up a nitrogen sync on Monday (and maybe Wednesday and Friday)
17:35:02 <colindixon> #action klou to set up release review meetings, ask anipbu for advice on how to set them up
17:36:30 <kkershaw> whois anipbu
17:37:01 <colindixon> kkershaw: anipbu is An Ho
17:38:19 <colindixon> #info CaseyODL points out that our tutorials are wildly out of date and we need to update them (or mark them as broken)
17:39:55 <colindixon> #info LuisGomez asks what we actually want, CaseyODL says that ideally it woudl be simple instructions with a video showing it that we could post to our youtube channel
17:40:14 <colindixon> #info LuisGomez asks if we have any events where we're giving tutorials that we could leverage now?
17:40:19 <colindixon> #info CaseyODL says not realy
17:40:23 <colindixon> #undo
17:40:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1554b10>
17:40:25 <colindixon> #undo
17:40:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1554a90>
17:40:25 <colindixon> #undo
17:40:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1554190>
17:40:26 <colindixon> #undo
17:40:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1554610>
17:40:32 <colindixon> #topic tutorials
17:40:37 <colindixon> #info CaseyODL points out that our tutorials are wildly out of date and we need to update them (or mark them as broken)
17:40:41 <colindixon> #info LuisGomez asks what we actually want, CaseyODL says that ideally it woudl be simple instructions with a video showing it that we could post to our youtube channel
17:40:47 <colindixon> #info LuisGomez asks if we have any events where we're giving tutorials that we could leverage now?
17:40:52 <colindixon> #info CaseyODL says not realy
17:42:39 <colindixon> #info colindixon points out that this is pretty easy to do with QuickTime on a Mac if you have one, it's not perfect, but pretty easy
17:44:19 <colindixon> #info LuisGomez says information about what's needed (what topics) and insturctions on how to do it (woudl help)
17:44:23 <colindixon> #topic oxygen DDF
17:44:29 <colindixon> #Info we still need topcis
17:44:56 <colindixon> #link https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum add topics here
17:45:29 <colindixon> #link https://www.regonline.com/ODLDesignForumOctober2017 also register, it's free, but there's a $50 no show fee if you register and don't go
17:45:34 <colindixon> #topic back to tutorials
17:46:12 <colindixon> #info abhijitkumbhare asks what tutorials we have and where are they
17:46:32 <colindixon> #link CaseyODL says mostly in the youtube channel here: https://www.youtube.com/user/opendaylightproject
17:47:01 <colindixon> #link https://www.youtube.com/user/opendaylightproject/search?query=tutorial that's a search for tutorial there
17:48:10 <colindixon> #action colindixon to record a video about how to record videos and post
17:49:03 <colindixon> #undo
17:49:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x14a4510>
17:49:19 <colindixon> #action colindixon to post instructions for record videos for tutorials
17:49:51 <colindixon> #topic elections
17:50:16 <vina_ermagan> #info screen recording with quicktime instructions - http://etc.usf.edu/techease/4all/getting-started/creating-screen-recordings-with-quicktime-player/
17:50:34 <colindixon> #undo
17:50:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x14a4c90>
17:50:35 <colindixon> #Undo
17:50:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x14a4ad0>
17:50:47 <colindixon> #link screen recording with quicktime instructions - http://etc.usf.edu/techease/4all/getting-started/creating-screen-recordings-with-quicktime-player/ (from vina_ermagan)
17:50:51 <colindixon> #topic elections
17:50:55 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Committer-At-Large_Election_Process says "Normally…the term is 1 year…During the Boron Release, the elected Committers-At-Large (CALs) will only serve on the TSC until the end of the Boron development cycle."
17:50:56 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2016-November/006328.html the TSC election results were posted 11/22/2016, so technically we should do the new election then, not after Nitrogen
17:51:15 <vina_ermagan> colindixon: thanks
17:51:19 <colindixon> #info CaseyODL points out that we normally do TSC elections for a term, but given that elections and release are both calendar-aligned
17:51:23 <colindixon> #Undo
17:51:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x14a4f90>
17:51:32 <colindixon> #info CaseyODL points out that we normally do TSC elections for a term, but given that elections and release are both calendar-aligned, it might make sense to shift them earlier
17:52:07 <vina_ermagan> #link video tutorial for quicktime desktop screen recording: https://www.youtube.com/watch?v=m4s7YF7OEBY
17:54:09 <jamoluhrsen> colindixon, zxiiro anipbu klou , brady just +2'd his SFC blocker patch. needs someone to merge it
17:54:52 <jamoluhrsen> colindixon, zxiiro anipbu klou patch is https://git.opendaylight.org/gerrit/#/c/62550/
17:54:58 <colindixon> #Info abhijitkumbhare asks if being release-aligned matters that much, colindixon and CaseyODL note that engagement in OpenDaylight tends to fall along release lines, and many of the things that the TSC does are release oriented
17:55:04 <zxiiro> jamoluhrsen: merged
17:55:10 <colindixon> jamoluhrsen: twitter FTW, see shague :-)
17:59:18 <colindixon> #action colindixon to send mail about TSC election timing this time
17:59:57 <colindixon> #info abhijitkumbhare points out it seems like it's mid october vs. end of november, so not a big deal either way in his mind
18:00:01 <colindixon> #topic cookies
18:00:04 <colindixon> #endmeeting