#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:59 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:01:05)
    1. colindixon (colindixon, 17:01:18)
    2. anipbu (anipbu, 17:01:30)
    3. rovarga_ (rovarga_, 17:01:34)
    4. skitt (skitt, 17:01:45)
    5. jamoluhrsen (jamoluhrsen, 17:01:52)
    6. https://wiki.opendaylight.org/view/TSC:Main#Agenda still last week's agenda (colindixon, 17:02:09)
    7. lori (lori, 17:02:28)
    8. rovarga_ asks if we can do the creation review for TrieMap (colindixon, 17:02:43)
    9. Thanh (zxiiro, 17:02:47)
    10. CaseyODL would like to bring up the idea of a smaller release (colindixon, 17:03:02)
    11. shague (shague, 17:03:14)
    12. CaseyODL notes that ask.opendaylight.org is now in read-only mode (colindixon, 17:03:22)
    13. gilesheron (for edwarnicke) (gilesheron, 17:03:34)
    14. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-10-05-17.00.html last week's meeting minutes (colindixon, 17:03:53)
    15. https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan klou took the disclaimer off the top of the oxygen release plan (colindixon, 17:04:08)
    16. https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan klou updated Nitrogen SR1 to have a 10/26 release date and move the dates for branch locking and things as well (colindixon, 17:05:09)
    17. https://git.opendaylight.org/gerrit/#/c/64205/ colindixon did the basic migration of the Oxygen release plan to rst (colindixon, 17:05:15)
    18. ACTION: CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go (colindixon, 17:05:49)
    19. ACTION: phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL (via the board) (colindixon, 17:05:50)
    20. ACTION: CaseyODL to coordinate rovarga to add a session to the TWS page about the lessons learned from nitrogen (colindixon, 17:06:05)
    21. ACTION: klou to get rovarga to say mdsal is participating in oxygen (colindixon, 17:06:25)
    22. ACTION: zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs (colindixon, 17:06:45)
    23. ACTION: dfarrell07 to ask OPNFV when they would need an SR1 and is there anything that would actually be helpful that we could get in that, if not we'll leave it at 10/26 (colindixon, 17:07:31)
    24. abhijitkumbhare (abhijitkumbhare, 17:07:59)

  2. mailing list (colindixon, 17:08:33)
    1. no significant changes from last week (colindixon, 17:08:34)

  3. events (colindixon, 17:08:35)
    1. https://www.opendaylight.org/global-events (colindixon, 17:08:39)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:08:45)
    3. the Oxygen DDF was this week (Monday and Tuesday) (colindixon, 17:09:00)
    4. phrobb said he thougth it went quite well, was happen with the attendance, venue, topics, and outcomes (colindixon, 17:09:15)
    5. Anil Vishnoi (vishnoianil, 17:09:38)
    6. CaseyODL notes that there's OPNFV plug-fest in portland in December, the next major event would be ONS in March (colindixon, 17:11:18)
    7. phrobb notes that there is some planning about an India road show as well, but not specific details yet (colindixon, 17:11:56)
    8. the CFP for ONAP developer forum is coming out now, the forum itself will be the week of December 12th (colindixon, 17:12:25)
    9. ACTION: CaseyODL to make sure we get whatever details we can for the india road show, ONS and ONAP forum are at least on the wiki events page (colindixon, 17:13:37)

  4. Oxygen (colindixon, 17:13:45)
    1. we're witing for M0 from md-sal (colindixon, 17:14:08)
    2. we are going to remove cardinal and ttp (colindixon, 17:14:24)
    3. jsonrpc is joining late (colindixon, 17:14:32)
    4. M1 status for offset 0 projects was 10/7, so far we only have 1-2 projects have submitted gerrit patches for their M1 status (colindixon, 17:15:05)
    5. M1 status for offset 1 and 2 projects are 10/14 (two days from now) and 10/21, respectively (colindixon, 17:15:47)
    6. genius broke the oxygen build, but it looks like we have a patch and the last one (15-hours ago was successful) (colindixon, 17:16:39)

  5. nitrogen (colindixon, 17:17:01)
    1. klou says we're still having some problems getting a good build since we've released (colindixon, 17:17:19)
    2. klou says that there have been a lot of problems, the most recent one is in netvirt, shague is looking at it (colindixon, 17:17:53)
    3. shague says he can't repoduce it locally w/o sleeps, but zxiiro will spin off another one (colindixon, 17:18:32)

  6. carbon (colindixon, 17:18:43)
    1. we have an RC for Carbon-SR2 that was built on Monday (colindixon, 17:18:58)
    2. klou says the only thing blocking us is checking off on the CSIT problems (colindixon, 17:19:31)
    3. anipbu says that this is all new failures, jamoluhrsen says he should be able to hammer a lot of those out this afternoon (colindixon, 17:19:56)
    4. anipbu notes that we really need to look at all the blocker bugs from nitrogen are fixed in carbon (as well as blocker bugs in carbon) (colindixon, 17:20:34)
    5. ACTION: klou to make sure the blocker bugs from both carbon and nitrogen are fixed in Carbon-SR2 and update the spreadsheet (colindixon, 17:20:54)
    6. it sounds like LuisGomez is the person who needs to sign off on those (colindixon, 17:21:11)

  7. system integration and test (colindixon, 17:22:17)
    1. rovarga_ is working about -all jobs and -only jobs, it turns out that we have tool from infrautils that lets us know when all the projects are loaded or not, this might help with the issues rovarga_ was experiencing (according to jamoluhrsen) (colindixon, 17:23:09)

  8. infra (colindixon, 17:23:49)
    1. as of wednesday, the wiki is only taking LFIDs (colindixon, 17:24:04)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-October/008138.html ODLID -> LFID mapping form (zxiiro, 17:24:11)
    3. colindixon asks if we're planning to do anything for people in China who can't get access to google forms (colindixon, 17:25:14)

  9. TrieMap Creation Review (colindixon, 17:26:15)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-September/007932.html proposal sent on 9/18 (colindixon, 17:26:33)
    2. https://wiki.opendaylight.org/view/Project_Proposals:Triemap (colindixon, 17:26:44)
    3. 3 lines of feedback (colindixon, 17:27:40)
    4. 1.) why do we need a new project for 5 classes? (colindixon, 17:27:49)
    5. 2.) why can't it be in infrautils? (colindixon, 17:27:57)
    6. 3.) why can't it live on github? (colindixon, 17:28:02)
    7. w.r.t. 1.) rovarga_ says it won't be part of autorelease or simulatenous releases, it is very, very stable and won't release much and so won't have to deal with version bumps (colindixon, 17:28:59)
    8. w.r.t., 3.) rovarga_ says it's hard to depend on odlparent from github (colindixon, 17:29:13)
    9. w.r.t. 2.) rovarga_ says infrautils is still an incubation project, so having yangtools depending on it is somewhat odd, and the rovarga_ worries about the fact that infrautils scope doesn't (currently include it) (colindixon, 17:30:36)
    10. colindixon asks if it depends on odlparent, will it need to be version bumped every time odlparent is, skitt says no, not unless it's a runtime dependency, which there are few, rovarga_ says guava is the only thing that might be complicated (colindixon, 17:32:01)
    11. rovarga_ says he's considering dropping guava because they don't need a lot of it and it might cause problems (colindixon, 17:32:20)
    12. vishnoianil asks what the bar is for being an opendaylight project, usually "is it related to networking", but in this case it's not, is "an opendaylight project wants to use it" enough (colindixon, 17:34:45)
    13. vrpolak and colindixon point out that infrautils and tcpmd5 probably have the same issue (colindixon, 17:36:28)
    14. colindixon notes that his preference would be to amend the scope of infrautils and work to make it mature, but he won't block it (colindixon, 17:38:04)
    15. vishnoianil asks if we can have a single mature library project where we put things like this (colindixon, 17:38:46)
    16. rovarga_ notes this is a matte of whether we'd do apache commons style, with lots of smaller projects, or the guava style with a single bigger project that revs all the time (colindixon, 17:44:47)
    17. colindixon says the only thing he really sees as bad for having more projects are overhead and organizational survivability (colindixon, 17:45:28)
    18. colindixon is really only worries about the small number of committers on stable projects meaning you might lose all the developers, not notice for a while, and then discover you need to patch it and don't have any committers (colindixon, 17:47:16)
    19. abhijitkumbhare points out that projects also result in changing our electorate, spltiting a project out into many other projects theoretically allows more votes in elections (colindixon, 17:47:59)
    20. rovarga_ notes that this problem is real, but maybe not an issue, the idea that one huge project has the same votes as smaller projects might mean that splitting was good (colindixon, 17:50:24)
    21. rovarga_ also notes that an incentive for big projects to split up, might improve understandability (colindixon, 17:50:41)
    22. colindixon asks if we're ready to vote, abhijitkumbhare asks if we could have an option in voting for this goes into a common library vs. a new project (colindixon, 17:51:47)
    23. rovarga_ says the other option would be to have yangtools have a sub-repo under the same project (colindixon, 17:53:35)
    24. colindixon asks what rovarga_'s thoughts are right now (colindixon, 17:55:01)
    25. rovarga_ says that he things infrautils is the wrong place for it, he's willing to park this issue if people aren't ready to vote yet, the votes issue that abhijitkumbhare brings up is a real one (colindixon, 17:55:41)
    26. rovarga_ notes that it's probably not enough to force all these issuse for splitting out 5k lines (colindixon, 17:56:04)
    27. ACTION: colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are) (colindixon, 17:57:40)
    28. skitt notes that he agrees that infrautils is a bad place (colindixon, 17:58:09)
    29. skitt would like to have the ability to host small projects that are stable and don't really fit anywhere else (colindixon, 17:58:35)

  10. DDF outcomes around consolidated, more stable releases (colindixon, 17:59:26)
    1. CaseyODL asks if we want to have a TWS about it and when (colindixon, 17:59:35)
    2. ACTION: skitt to offer a tl;dr version of this before we have a TWS (colindixon, 18:00:08)
    3. LuisGomez says there were other topics for TSC that came out of the DDF: the above, but also differing requirements for different proejcts (colindixon, 18:00:57)
    4. ACTION: skitt to offer a tl;dr version of the "stable base" offset-0/1 proposal + offset-2 distros (skitt, 18:00:59)
    5. ACTION: colindixon to add different requirements for different kinds of projects in SRs to next week's agenda (colindixon, 18:01:20)

  11. cookies (colindixon, 18:01:37)


Meeting ended at 18:01:53 UTC (full logs).

Action items

  1. CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
  2. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL (via the board)
  3. CaseyODL to coordinate rovarga to add a session to the TWS page about the lessons learned from nitrogen
  4. klou to get rovarga to say mdsal is participating in oxygen
  5. zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
  6. dfarrell07 to ask OPNFV when they would need an SR1 and is there anything that would actually be helpful that we could get in that, if not we'll leave it at 10/26
  7. CaseyODL to make sure we get whatever details we can for the india road show, ONS and ONAP forum are at least on the wiki events page
  8. klou to make sure the blocker bugs from both carbon and nitrogen are fixed in Carbon-SR2 and update the spreadsheet
  9. colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
  10. skitt to offer a tl;dr version of this before we have a TWS
  11. skitt to offer a tl;dr version of the "stable base" offset-0/1 proposal + offset-2 distros
  12. colindixon to add different requirements for different kinds of projects in SRs to next week's agenda


Action items, by person

  1. colindixon
    1. zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
    2. colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
    3. colindixon to add different requirements for different kinds of projects in SRs to next week's agenda
  2. skitt
    1. zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
    2. skitt to offer a tl;dr version of this before we have a TWS
    3. skitt to offer a tl;dr version of the "stable base" offset-0/1 proposal + offset-2 distros
  3. zxiiro
    1. zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
  4. UNASSIGNED
    1. CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
    2. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL (via the board)
    3. CaseyODL to coordinate rovarga to add a session to the TWS page about the lessons learned from nitrogen
    4. klou to get rovarga to say mdsal is participating in oxygen
    5. dfarrell07 to ask OPNFV when they would need an SR1 and is there anything that would actually be helpful that we could get in that, if not we'll leave it at 10/26
    6. CaseyODL to make sure we get whatever details we can for the india road show, ONS and ONAP forum are at least on the wiki events page
    7. klou to make sure the blocker bugs from both carbon and nitrogen are fixed in Carbon-SR2 and update the spreadsheet


People present (lines said)

  1. colindixon (103)
  2. odl_meetbot (7)
  3. vrpolak (4)
  4. rovarga_ (3)
  5. abhijitkumbhare (3)
  6. skitt (2)
  7. zxiiro (2)
  8. shague (1)
  9. gilesheron (1)
  10. lori (1)
  11. jamoluhrsen (1)
  12. anipbu (1)
  13. vishnoianil (1)


Generated by MeetBot 0.1.4.