17:01:30 <skitt> #startmeeting tsc
17:01:30 <odl_meetbot> Meeting started Thu Oct 19 17:01:30 2017 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:30 <odl_meetbot> The meeting name has been set to 'tsc'
17:01:40 <skitt> #topic agenda bashing and roll call
17:01:44 <skitt> TSC members please #info in
17:02:13 <jamoluhrsen> #info jamoluhrsen
17:02:13 <anipbu> #info anipbu
17:02:14 <skitt> #info skitt
17:02:16 <rovarga> #info rovarga
17:02:19 <gilesheron> #info gilesheron (for edwarnicke)
17:02:30 <skitt> #link last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-10-12-17.00.html
17:03:30 <LuisGomez> #info LuisGomez
17:04:01 <zxiiro> #info Thanh
17:05:21 <vishnoianil> #info Anil Vishnoi
17:05:38 <huan> #info huan
17:06:49 <skitt> #action colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
17:08:38 <skitt> #info CaseyODL would like some help with messaging around the TSC election which are due to start on Sunday
17:09:03 <skitt> #info CaseyODL has notes from the AG to discuss today
17:09:08 <jamoluhrsen> what is going to be different about the tsc election messaging from last time?
17:09:17 <jamoluhrsen> yep
17:10:11 <shague> #info shague
17:10:37 <skitt> #info there's still space available at the OPNFV plugfest, see the events section on the wiki
17:10:38 <CaseyODL> #link https://www.regonline.com/registration/Checkin.aspx?EventID=2027715
17:11:02 <skitt> #info it's taking place at the Intel campus in Hillsboro near Portland, Oregon
17:11:46 <skitt> #info we're still waiting on the board for an official response re. the security manager position
17:12:32 <skitt> #info if we don't find anyone, CaseyODL will take the role but that will result in him having to reduce his involvement in other areas
17:13:50 <skitt> #action rovarga to add a session to the TWS page about the lessons learned from nitrogen
17:14:55 <skitt> #info dfarrell07 says there's no pressing concern re OPNFV and Nitrogen SR1
17:15:27 <skitt> #info CaseyODL underlines the importance of attending next Monday's TWS call, re ODL stable distributions
17:16:25 <skitt> #action CaseyODL to make sure we get whatever details we can for the India road show, ONS and ONAP forum are at least on the wiki events page
17:16:46 <zxiiro> skitt: I think we need to keep the action to work on getting releng team permission to merge version bump patches since we hvaen't sent out an official email to the community about the proposal yet
17:16:58 <skitt> zxiiro, good point
17:17:11 <skitt> #action zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
17:17:18 <skitt> #topic mailing list
17:17:56 <skitt> #info JIRA migration: tykeal has sent a few emails about that
17:18:14 <skitt> #info the migration has happened, including some things which shouldn't have been able to happen
17:18:25 <skitt> #info changes made to Bugzilla during the migration are not in JIRA
17:18:50 <skitt> #info some fields have not been carried over, but we had a month to test beforehand so ...
17:19:15 <skitt> #info people asked about mapping old bug ids to new bug ids, there's an "external issue id" field that can be used for that
17:19:34 <skitt> #info user mapping has caused some issues but there is a way to merge accounts so helpdesk can fix those issues
17:20:19 <skitt> #action tykeal to send an email explaining how to map bug ids
17:24:19 <skitt> #info there's no global version to JIRA, all projects need to manage their own lists
17:26:10 <skitt> #info we should be able to have much better bug tracking wrt versions, but we need to be careful so that things stay somewhat consistent across projects
17:27:00 <abhijitkumbhare> #info abhijitkumbhare (had info’ed in on a wrong channel earlier by mistake)
17:28:27 <skitt> #info filters can be set up across projects, and JIRA has very useful dashboards
17:29:29 <skitt> #info labels are global so that could be used for synchronisation
17:29:53 <skitt> #info labels are created on the fly (and are case-sensitive)
17:31:24 <skitt> #info shague asks about links from Gerrit to Bugzilla, and how to transition those to JIRA
17:31:55 <skitt> #info tykeal has a number of actions in progress to address that
17:32:06 <skitt> #topic events
17:32:46 <skitt> #topic Oxygen
17:33:10 <tykeal> lol
17:33:23 <skitt> #info we're trying to collect M1 readouts
17:33:49 <skitt> #info offset 0 and 1 is past due, offset 2 is this Saturday
17:33:59 <skitt> #info the readouts should be in .rst files checked in to the docs project
17:34:18 <skitt> #info we have a good autorelease build for Oxygen
17:35:42 <skitt> #info abhijitkumbhare asks why we're asking projects to use .rst format now for readouts
17:35:44 <zxiiro> it's easier to search
17:36:06 <skitt> #info klou says it's easier to maintain, easier to compile etc.; zxiiro says it's easier to search
17:37:45 <skitt> #info open question whether to use the wiki or .rst for release plans
17:38:49 <skitt> #topic Nitrogen
17:39:01 <skitt> #info good builds the past two days
17:39:14 <skitt> #info SR1 has two blocker bugs, 9163 in controller and 9007 in openflowplugin
17:39:47 <skitt> #info if those are resolved soon we can meet the target date of October 26
17:40:18 <jamoluhrsen> I already wrote in jira to ask for a link to the patch
17:40:21 <skitt> #info 9163 apparently has a patch already
17:40:33 <jamoluhrsen> and vishnoianil will fix 9007 by EOD
17:40:43 <jamoluhrsen> :-)
17:40:45 <skitt> #info 9007 will be fixed today
17:40:54 <jamoluhrsen> undo that skitt. that was a joke
17:40:59 <skitt> #undo
17:40:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1518750>
17:41:08 <skitt> bad jamoluhrsen :-P
17:41:48 <skitt> #action klou to send the controller team an email about 9163
17:42:16 <skitt> #topic Carbon
17:42:25 <skitt> #info SR2 released last week, not much to discuss
17:42:52 <zxiiro> skitt: nothing for infra either
17:43:23 <zxiiro> yep
17:43:39 <skitt> #topic Committer promotions
17:43:54 <skitt> #info klou is now a committer on releng/autorelease
17:44:26 <skitt> #topic Notes to AG
17:44:30 <skitt> #undo
17:44:30 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1528c90>
17:44:37 <skitt> #topic Notes from the AG
17:44:58 <skitt> #info the AG would like to talk about clustering in more detail
17:45:06 <skitt> #info in particular active/active failover
17:45:12 <skitt> #info CaseyODL directed the AG to the kernel call
17:45:44 <skitt> #info they brought up the need to upgrade Swagger
17:45:56 <skitt> #info and requested a tl;dr version of the DDF
17:46:24 <skitt> #action CaseyODL and a few others to write up a summary of the DDF
17:46:49 <skitt> #topic TSC elections
17:47:07 <skitt> #info emails going out next Sunday
17:47:15 <skitt> #info CaseyODL needs help with the messaging
17:47:42 <skitt> #info the messaging should be similar to the last elections
17:47:51 <zxiiro> skitt: I want to bring up the Verify /w dependencies job and for folks to test it and report back any issues / feedback. https://lists.opendaylight.org/pipermail/dev/2017-October/004164.html
17:48:04 <skitt> zxiiro, OK, noted
17:48:39 <skitt> #info two weeks of nominations and two weeks of voting, as usual
17:48:58 <skitt> #topic Verify w/ dependencies
17:49:08 <skitt> #link https://lists.opendaylight.org/pipermail/dev/2017-October/004164.html
17:49:48 <skitt> #info the job takes a list of patches, in the order they need to build (odlparent patches first, etc.)
17:50:35 <skitt> #info the job will apply the patches and run verify on the Gerrit patch that's driving the recheck
17:51:33 <skitt> #topic cookies
17:51:40 <zxiiro> thanks
17:51:41 <skitt> #endmeeting