17:04:43 <CaseyODL> #startmeeting tsc
17:04:43 <odl_meetbot> Meeting started Thu Nov  2 17:04:43 2017 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:43 <odl_meetbot> The meeting name has been set to 'tsc'
17:05:02 <CaseyODL> #chair zxiiro skitt
17:05:02 <odl_meetbot> Current chairs: CaseyODL skitt zxiiro
17:05:04 <abhijitkumbhare> #info abhijitkumbhare
17:05:22 <zxiiro> #info Thanh
17:05:27 <skitt> #info TSC members please #info in
17:05:30 <skitt> #info skitt
17:05:31 <rovarga_> #info rovarga_
17:05:40 <skitt> #link Last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-10-26-03.32.html
17:06:47 <skitt> #info Lessons learned from Nitrogen scheduled for Monday 13's TWS
17:07:08 <skitt> #action colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
17:07:28 <skitt> #action rovarga to add a session to the TWS page about the lessons learned from nitrogen
17:08:09 <lhinds> forgot to info..
17:08:14 <lhinds> #info lhinds
17:08:32 <skitt> lhinds, only TSC members are asked to info in ;-)
17:08:43 <lhinds> ah ok, thanks skitt
17:08:46 <jamoluhrsen> #info jamoluhrsen
17:08:46 <skitt> #chair dfarrell07
17:08:46 <odl_meetbot> Current chairs: CaseyODL dfarrell07 skitt zxiiro
17:08:51 <vishnoianil> #info Anil Vishnoi
17:09:04 <skitt> #topic JIRA migration
17:09:19 <skitt> #info a few hiccups, mostly for people who hadn't provided their initial account info
17:09:41 <skitt> #info issues with watches, they're working for tykeal but not for shague and various others
17:10:19 <skitt> #info could be an issue with the mail path between the LF and users, the SMTP servers aren't the same
17:10:51 <skitt> #info rovarga_ gets email from JIRA, so it could just be Red Hat
17:12:38 <dfarrell07> sorry, my laptop battery died as I started talking
17:12:45 <dfarrell07> I did update the agenda
17:12:46 <dfarrell07> https://wiki.opendaylight.org/view/TSC:Main#Agenda
17:14:05 <skitt> #info question about adding the ability for anyone to add watchers
17:14:17 <skitt> #info enough voting on the mailing list, this will be enabled
17:15:58 <zxiiro> I'd also like to raise an issue that Jira is not publicly viewable by an anonymous user.
17:16:03 <abhijitkumbhare> My internet seems to be flaky today - voices breaking
17:16:14 <skitt> #link JIRA workflow email discussion: https://lists.opendaylight.org/pipermail/tsc/2017-October/008193.html
17:16:53 <skitt> #info the current workflow is in bad shape, we need to either agree on a common workflow for every one or tell projects to choose
17:17:38 <skitt> #info rovarga_ suggests porting over the Bugzilla workflow, tykeal says that's not trivial
17:18:46 <skitt> #info zxiiro raises the issue that JIRA isn't publicly viewable for anonymous users (not logged in)
17:19:09 <skitt> #action tykeal to allow non-logged-in users to view JIRA
17:19:13 <zxiiro> #link Proposal to allow releng team to merge all version bump patches https://lists.opendaylight.org/pipermail/tsc/2017-October/008218.html
17:19:32 <skitt> #topic RelEng Team to perform all version bumping activities
17:19:39 <skitt> #info decided on the mailing list
17:19:46 <skitt> #topic GNT creation review
17:20:27 <skitt> #action anipbu to revive the GNT creation discussion
17:20:33 <skitt> #topic TrieMap creation review
17:20:41 <skitt> #action rovarga_ to revive the TrieMap creation review
17:20:58 <skitt> #topic liblldp project proposal
17:21:19 <skitt> #action shague to revive the liblldp project discussion if appropriate
17:21:29 <skitt> #topic RelEng Team to perform all version bumping activities, take two
17:21:55 <shague> #info I believe openflowplugin took lldp so no need to revive the discussion
17:22:00 <dfarrell07> "The Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first."
17:22:08 <skitt> shague, yeah that's why I added the "if appropriate" ;-)
17:22:29 <abhijitkumbhare> Yes - openflowplugin will add lldp
17:22:59 <dfarrell07> #startvote Shall the Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first -1,0,+1
17:22:59 <odl_meetbot> Unable to parse vote topic and options.
17:23:22 <CaseyODL> #startvote The Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first. +1,0,-1
17:23:22 <odl_meetbot> Unable to parse vote topic and options.
17:23:31 <edwarnicke> You need a question mark
17:23:35 <skitt> #startvote The Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first? -1, 0, +1
17:23:35 <odl_meetbot> Begin voting on: The Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first? Valid vote options are -1, 0, +1.
17:23:35 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:23:49 <jamoluhrsen> #vote +1
17:23:50 <anipbu> #vote +1
17:23:51 <skitt> #vote +1
17:23:51 <zxiiro> #vote +1
17:23:52 <edwarnicke> #vote +1
17:23:54 <abhijitkumbhare> #vote +1
17:23:55 <LuisGomez> #vote +1
17:23:55 <rovarga_> #vote +1
17:23:59 <shague> #vote +1
17:24:02 <vishnoianil> #vote +1
17:24:14 <skitt> that carries
17:24:20 <CaseyODL> #endvote
17:24:20 <odl_meetbot> Voted on "The Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first?" Results are
17:24:20 <odl_meetbot> +1 (10): skitt, anipbu, LuisGomez, edwarnicke, shague, abhijitkumbhare, zxiiro, rovarga_, vishnoianil, jamoluhrsen
17:24:32 <skitt> #agreed The Releng Team will merge trivial version bump changes for projects participating in autorelease. More complex version bumps that require code changes can also be merged IF the project +2s the patches first.
17:25:17 <skitt> #topic Inter-project dependencies
17:25:24 <skitt> #action skitt or rovarga_ to revive the discussion
17:26:01 <CaseyODL> #link https://lists.opendaylight.org/pipermail/tsc/2017-September/007937.html Disscussion on Inter-project dependencies.
17:26:04 <skitt> #info Vratko has been working on a verification tool
17:26:29 <skitt> #info some of rovarga_'s patches have been merged so the situation has improved
17:26:55 <skitt> #topic Events
17:27:08 <skitt> #topic Releases/distributions refactoring discussions
17:27:13 <dfarrell07> #link https://docs.google.com/presentation/d/18BF5I4WIGgYXr1-oPAyxgtPKFtkKnDz77c05cYLBllY/ Sam
17:27:16 <dfarrell07> #undo
17:27:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x14de350>
17:27:24 <dfarrell07> #link https://docs.google.com/presentation/d/18BF5I4WIGgYXr1-oPAyxgtPKFtkKnDz77c05cYLBllY/ Sam's slide summery
17:28:06 <skitt> #info TWS on the topic next Monday
17:28:31 <skitt> #info the poll has been sent out, no responses yet
17:29:03 <skitt> #topic Events
17:29:30 <skitt> #info OPNFV plug-fest in December, register soon
17:29:41 <skitt> #info Open Source Leadership Summit in March
17:29:48 <skitt> #info ONS in March with co-located ODL DDF
17:30:43 <anipbu> https://lists.opendaylight.org/pipermail/tsc/2017-November/008240.html
17:31:11 <skitt> #link LF networking projects informational update: https://lists.opendaylight.org/pipermail/tsc/2017-November/008240.html
17:31:19 <skitt> #info webinar next Monday, 6pm PT
17:31:33 <skitt> #info same again next Tuesday, 7am PT
17:32:00 <skitt> #info topic is the umbrella discussion in progress for all the networking projects in the LF
17:32:38 <skitt> #topic Oxygen
17:32:48 <skitt> #info M2 milestone coming up, Nov 7/14/21
17:33:01 <skitt> #info still missing M1 milestones for ~20 projects
17:33:10 <skitt> #info new project P4Plugin wishing to join the release
17:33:44 <skitt> #info this is an existing project wishing to join
17:34:07 <skitt> #info no need for a TSC vote to approve their joining
17:35:08 <skitt> #action klou to continue pinging projects for M1 milestones
17:35:22 <skitt> #topic Nitrogen
17:35:40 <skitt> #info SR1 candidate ready, waiting for teams to check off CSIT issues
17:36:36 <skitt> #info big issues with ODL getting killed, so no urgency for teams to look into CSIT issues
17:36:44 <skitt> #info blocker bugs will be opened as necessary
17:36:52 <skitt> #info SR2 planned for December 7
17:37:11 <skitt> #info given that SR1 will only go out next week at the earliest, klou asks if we should move SR2 back
17:38:24 <skitt> #info LuisGomez suggests waiting until we get closer to the release
17:38:50 <skitt> #info we'll wait until late November/early December to see if we have something worth releasing before the end-of-year holidays
17:38:52 <skitt> #topic Carbon
17:39:12 <skitt> #info SR3 was planned for November 9
17:39:32 <skitt> #info klou sent out an email regarding SR3 and has had no reaction so far
17:39:52 <skitt> #info given the recent release of SR2, no point in releasing SR3 now
17:40:01 <skitt> #info SR3 was planned for February 15
17:40:04 <skitt> #undo
17:40:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x152efd0>
17:40:11 <skitt> #info SR4 was planned for February 15
17:40:21 <skitt> #info rovarga_ suggests moving SR3 to half-way between now and SR4
17:42:16 <skitt> #info the release plan doesn't reflect the longer release plan we approved a while ago
17:42:30 <skitt> #info the February 15 release won't be the last Carbon release
17:42:44 <skitt> #info we'd need one last release three months later
17:44:03 <skitt> #info Carbon is supposed to be supported as long as Nitrogen which has one last release on May 7
17:44:57 <skitt> #info rovarga_ suggests taking this to the mailing list so we can dig up the relevant meeting minutes
17:45:20 <skitt> #info he also suggests avoiding back-to-back Carbon/Nitrogen releases given how much trouble we had with the Nitrogen GA
17:46:00 <skitt> we need a search function for https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/ ;-)
17:46:18 <vishnoianil> yeah
17:46:50 <skitt> #topic Committer promotion for SXP (Martin Dindoffer)
17:46:56 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2017-October/008114.html nomination
17:47:30 <skitt> #startvote Does the TSC approve Martin Dindoffer as SXP Committer? -1, 0, +1
17:47:30 <odl_meetbot> Begin voting on: Does the TSC approve Martin Dindoffer as SXP Committer? Valid vote options are -1, 0, +1.
17:47:30 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:47:36 <rovarga_> #vote +1
17:47:37 <skitt> #vote +1
17:47:40 <anipbu> #vote +1
17:47:42 <edwarnicke> #vote +1
17:47:42 <zxiiro> #vote +1
17:47:42 <jamoluhrsen> #vote +1
17:47:47 <abhijitkumbhare> #vote +1
17:47:49 <LuisGomez> #vote +1
17:48:05 <shague> #vote +1
17:48:12 <dfarrell07> #endvote
17:48:12 <odl_meetbot> Voted on "Does the TSC approve Martin Dindoffer as SXP Committer?" Results are
17:48:12 <odl_meetbot> +1 (9): skitt, anipbu, LuisGomez, edwarnicke, shague, jamoluhrsen, zxiiro, rovarga_, abhijitkumbhare
17:48:14 <rovarga_> klou: skitt: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-06-17.04.html are the meeting minutes for Carbon extension (see point 5)
17:48:27 <skitt> #agreed Martin Dindoffer is an SXP Committer
17:48:36 <skitt> #action skitt to inform the various parties
17:48:44 <klou> thank you rovarga_!
17:48:53 <skitt> #action skitt to inform the various parties that Martin Dindoffer is approved as SXP Committer
17:49:14 <rovarga_> skitt: or we need to at least extract votes to a single page :)
17:49:23 <skitt> rovarga_, indeed
17:49:37 <skitt> #topic Infrastructure
17:49:52 <dfarrell07> lol, /me jumped off too soon? ;)
17:50:15 <skitt> #info at the end of December we need to migrate off our cloud provider
17:50:29 <skitt> #info we'll be migrating over the next two months
17:50:35 <rovarga_> skitt: or, actually, it would best to aggregate the logs into a mailing list
17:51:00 <skitt> rovarga_, that too, perhaps the summary emails should attach the logs
17:51:15 <skitt> #info the migration has already started and explains some of the recent disruption
17:51:25 <skitt> #info next up is Gerrit which will also involve a switch to LFID
17:51:37 <skitt> #info then Nexus and Jenkins and the build CI
17:51:56 <skitt> dfarrell07, probably best to do the SXP vote early ;-)
17:52:42 <skitt> rovarga_, and summarise the votes explicitly
17:53:04 <skitt> #info the new provider has different OpenStack flavours
17:53:12 <skitt> #info the Heat templates need to be updated
17:53:26 <skitt> #info the new provider has no quota for us
17:53:28 <skitt> :-D
17:53:50 <skitt> #info but we do run the risk of over-spending
17:58:32 <skitt> #info rovarga_ asks if we can automate emailing the TSC meeting IRC logs to a mailing list
17:58:54 <CaseyODL> Sorry it took so long to find the link to the questionnaire.  https://goo.gl/forms/Jsz7HheQz9nN910Q2
17:59:03 <skitt> #info tykeal asks that we open a ticket but it will be very low priority
17:59:14 <skitt> patches welcome ;-)
17:59:38 <skitt> #action rovarga_ to open a ticket asking for IRC meeting log search or emailing to the mailing list
18:00:11 <skitt> #topic Security coordinator
18:00:24 <skitt> #info lhinds is Red Hat's nomination for the security coordinator role
18:00:32 * tykeal waves. I gotta drop for another meeting
18:00:36 <skitt> #info his bio went to the TSC mailing list
18:02:26 <skitt> #info first task would be to set up a proper embargo process (as done in OPNFV etc.)
18:02:37 <skitt> #info other topics could include threat analysis, secure coding etc.
18:03:15 <dfarrell07> #startvote Shall the TSC approve Luke Hines as Security Manager? -1,0,+1
18:03:15 <odl_meetbot> Begin voting on: Shall the TSC approve Luke Hines as Security Manager? Valid vote options are -1, 0, +1.
18:03:15 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:03:25 <zxiiro> #vote +1
18:03:26 <jamoluhrsen> #vote +1
18:03:27 <skitt> #vote +1
18:03:27 <anipbu> #vote +1
18:03:27 <shague> #vote +1
18:03:28 <rovarga_> #vote 0
18:03:36 <abhijitkumbhare> #vote +1
18:03:37 <rovarga_> (didn't have time to review credentials :-))
18:03:38 <skitt> it's Luke Hinds BTW ;-)
18:03:44 <skitt> rovarga_, yeah that's what I was going to ask
18:03:50 <dfarrell07> skitt: oh no lol
18:03:51 <LuisGomez> #vote +1
18:05:18 <skitt> #endvote
18:05:18 <odl_meetbot> Voted on "Shall the TSC approve Luke Hines as Security Manager?" Results are
18:05:18 <odl_meetbot> 0 (1): rovarga_
18:05:18 <odl_meetbot> +1 (7): skitt, zxiiro, LuisGomez, shague, jamoluhrsen, anipbu, abhijitkumbhare
18:05:21 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2017-November/008236.html Luke's bio
18:05:49 <skitt> #agreed the TSC approves Luke Hinds as Security coordinator
18:05:55 <skitt> congrats lhinds
18:06:08 <skitt> #topic Cookies
18:06:14 <lhinds> thx! good to be part of efforts
18:06:15 <abhijitkumbhare> congrats lhinds
18:06:19 <skitt> #endmeeting