18:04:40 <skitt> #startmeeting tsc
18:04:40 <odl_meetbot> Meeting started Thu Nov 16 18:04:40 2017 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:04:40 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:04:40 <odl_meetbot> The meeting name has been set to 'tsc'
18:04:40 <odl_meetbot> CaseyODL: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
18:04:48 <skitt> #chairs CaseyODL
18:04:53 <skitt> #info TSC members please info in
18:04:55 <CaseyODL> #chair skitt
18:04:58 <skitt> #info skitt
18:05:01 <vishnoianil> #info Anil Vishnoi
18:05:06 <skitt> #chair CaseyODL
18:05:06 <odl_meetbot> Current chairs: CaseyODL skitt
18:05:10 <skitt> #topic Rollcall
18:05:10 <jamoluhrsen> #info jamoluhrsen
18:05:13 <tykeal> #info tykeal - Andrew Grimberg (Proxy for zxiiro / Thanh Ha)
18:05:16 <anipbu> #info anipbu
18:05:16 <jamoluhrsen> #info jamoluhrsen
18:05:17 <abhijitkumbhare> #info abhijitkumbhare
18:05:21 <jamoluhrsen> #info jamoluhrsen for shague
18:05:27 <LuisGomez> #info LuisGomez
18:05:38 <lori> #info lori
18:05:45 <skitt> #link Last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-11-09-18.01.html
18:05:45 <jamoluhrsen> i get 3 votes today
18:10:16 <abhijitkumbhare> I better watch my back or jamoluhrsen may steal my vote as well :)
18:10:55 <skitt> #topic Events
18:12:43 <skitt> #topic Oxygen
18:13:06 <skitt> #info klou sent the final M1 reminder last week
18:13:18 <skitt> #info ocpplugin and tsdr didn’t respond and will be dropped
18:13:42 <skitt> #info yangtools asked to be tracked separately
18:15:39 <skitt> #info non-autorelease projects should feel free to respond N/A to non-applicable questions in the readouts
18:16:55 <skitt> #action rovarga_ to fill in the yangtools milestone readouts until an alternative is in place
18:17:26 <skitt> #info we want to ensure the project in general is aware of odlparent and yangtools’ status
18:17:38 <skitt> #topic Nitrogen
18:17:54 <skitt> #info still waiting for SR1 sign-off on CSIT issues
18:18:05 <skitt> #info jamoluhrsen and LuisGomez will be looking at the remaining problems
18:18:15 <skitt> #info as soon as we get sign-off we can formally release SR1
18:18:24 <skitt> #info (hopefully before Thanksgiving)
18:18:43 <skitt> #info SR2 date is December 7, we won’t hit that date
18:18:58 <skitt> #info SR1 likely early next week, starting November 21
18:19:30 <skitt> #info one fall-out from the TWS session on lessons from Nitrogen was reducing the number of SRs
18:20:24 <skitt> #info so we could perhaps drop the December 7 release
18:21:11 <skitt> #info releases take ~6 weeks
18:23:57 <jamoluhrsen> we used to release every 8-9 months and we would cram 4 SRs over two of those releases. so 4 per 16-18 months
18:24:06 <jamoluhrsen> no we are trying to cram 4 SRs over 12m
18:24:57 <skitt> #info too much overlap now with six month releases, zxiiro and abelur are always in release mode
18:26:06 <skitt> #info we never hit our release targets
18:26:18 <dfarrell07> did any other committers not-get the CAL election email? I think at least jamoluhrsen and I didn't
18:26:23 <anipbu> Beryllium and Boron was on target =)
18:26:41 <jamoluhrsen> dfarrell07, I did not get the CAL election email
18:26:44 <jamoluhrsen> CaseyODL, ^^
18:26:46 <abhijitkumbhare> dfarrell07: I have not got any election email
18:26:59 <tykeal> CAL email??? was supposed to go to all comitters or just PTLs?
18:26:59 <dfarrell07> abhijitkumbhare: ack
18:27:06 <abhijitkumbhare> including CAL
18:27:12 <jamoluhrsen> tykeal, i'm both
18:27:16 <dfarrell07> tykeal: CAL elections for for all committers
18:27:23 <abhijitkumbhare> CAL email to all committers
18:27:33 <tykeal> jamoluhrsen: I'm only a committer at this point since I handed my only PTL role to zxiiro last year sometime
18:27:39 <skitt> #info specific proposal is to reduce SRs from 4 to 3
18:27:50 <dfarrell07> tykeal: did you get an CAL election email?
18:27:53 <skitt> #info or even doing as-needed SRs, but that would be too hard (no consensus)
18:27:54 <jamoluhrsen> tykeal, yeah. my point was that I didn't get an email and I cover both conditions
18:28:03 <tykeal> I'm searching my mail ;)
18:28:22 <skitt> jamoluhrsen, reinforcing the feeling int/ doesn’t count :-P
18:28:38 <dfarrell07> tykeal: it should be from civs
18:29:02 <abhijitkumbhare> i have not got protocol projects email as well
18:29:11 <tykeal> in that case, no. the last CIVS mail I have is from May
18:29:18 <skitt> abhijitkumbhare, no protocol elections
18:29:21 <abhijitkumbhare> has the election actually started?
18:29:24 <abhijitkumbhare> aah
18:29:37 <tykeal> ah... and now I just got it
18:29:42 <CaseyODL> I re-sent the CAL election email just now.
18:29:47 <skitt> abhijitkumbhare, only elections were apps and CAL
18:29:48 <tykeal> CaseyODL: thanks
18:29:53 <abhijitkumbhare> I just got CAL email
18:29:58 <CaseyODL> If you still don't have it by this afternoon, please let me know.
18:30:00 <dfarrell07> got it
18:32:01 <gzhao> CaseyODL:  We no longer have the restriction that no 3 people can be from the same company for CAL, right?
18:32:18 <skitt> #info our downstreams don’t track our releases very closely
18:32:33 <skitt> #info we do still need SR1 not too long after GA because that release has lots of fixes
18:32:39 <lori> dfarrell07: sorry, I wasn't watching IRC, I didn't get the CAL election email either
18:32:51 <CaseyODL> gzhao: the "cap" is 33% of the TSC.
18:33:00 <dfarrell07> lori: you may have just gotten it, CaseyODL just sent/resent
18:33:25 <skitt> #info which indicates that our initial releases are hurried and not properly engineered
18:33:43 <dfarrell07> gzhao: only cap is <=4 people from same company on TSC
18:33:53 <dfarrell07> gzhao: no cap per RG
18:34:01 <lori> dfarrell07: ok, yes, I just received it now (sorry, was still going through the chat log)
18:34:02 <gzhao> dfarrell07: got it.
18:34:17 <dfarrell07> cool @ both:)
18:38:56 <skitt> #info we need to avoid having too many SRs from different streams close together
18:39:40 <skitt> #info we need to conclude the distribution discussions before we plan Fluorine, which makes them quite urgent (January)
18:40:09 <skitt> #info the key problem with Oxygen is that we have Oxygen GA, Carbon SR and Oxygen SR in quick succession
18:40:42 <skitt> #info resulting in over two full months spent in full release mode (ramp-down Oxygen, then Carbon, then Oxygen again)
18:42:03 <klou> #link https://wiki.opendaylight.org/view/Release_Dashboard  <- view of all active releases
18:42:19 <skitt> #info one solution would be to release Oxygen GA, Oxygen SR1 and only then Carbon SR
18:42:29 <skitt> #info which would extend our Carbon support time by two months
18:43:51 <skitt> #info and also give time to back-port issues fixed in Oxygen SR1 to Carbon before its last SR
18:47:21 <skitt> #info we need to ask projects whether they need a Carbon release
18:47:26 <skitt> #info likewise for our downstreams
18:47:34 <skitt> #info some of this goes back to our decision to support Carbon longer
18:50:04 <skitt> #info we’ve tried asking before, without getting any feedback
18:50:36 <skitt> #info we’ll revisit this issue later
18:51:41 <skitt> #topic Carbon
18:51:53 <skitt> #info SR3 planned for December 14
18:52:38 <skitt> #topic Infrastructure
18:52:58 <skitt> #info Gerrit migration coming up next week on Friday (black Friday)
18:53:11 <skitt> #info this will switch ids to LF ids
18:53:32 <skitt> #info known mappings will be applied
18:53:41 <skitt> #info unknown accounts will be disabled in Gerrit
18:54:05 <skitt> #info so if you don’t have a wiki account or JIRA account yet, pay close attention to tykeal’s email which went out yesterday
18:54:23 <skitt> #info upgrading to the latest version of Gerrit too
18:54:34 <skitt> #info (the issues with Jenkins have been fixed)
18:54:43 <skitt> #info also upgrading to the latest version of JIRA
18:55:01 <skitt> #info should fix a couple of issues and provide a couple of features people have been asking for
18:55:11 <skitt> #info expecting some fallout from Gerrit accounts being locked
18:55:20 <skitt> #info final migration out of Rackspace planned for early December
18:55:53 <skitt> #info as mentioned previously, we’ll be uncapped, however overage will cost us (but less than with Rackspace)
18:58:52 <skitt> #info things should be much better after the migration: better relations with the provider, no more hybrid setup...
18:59:21 <skitt> #topic LF news
18:59:39 <skitt> #info the LF has asked that we display the antitrust policy notice at the start of every TSC call
19:00:26 <skitt> #info many people didn’t get the voting emails from Condorcet for the CAL election, ping CaseyODL if you haven’t got it
19:00:35 <skitt> #info (he resent them today)
19:01:13 <skitt> #info the LF is considering moving all their mailing lists etc. to groups.io
19:03:45 <skitt> #info CaseyODL can talk about this at some future TWS
19:04:06 <skitt> #topic Cookies
19:04:12 <skitt> #endmeeting