#opendaylight-meeting: tsc

Meeting started by CaseyODL at 18:02:15 UTC (full logs).

Meeting summary

    1. Anil Vishnoi (vishnoianil, 18:03:00)
    2. Thanh Ha (zxiiro, 18:03:05)
    3. Brady Johnson (bjohnson, 18:03:06)
    4. anipbu (anipbu, 18:03:08)
    5. abhijitkumbhare (abhijitkumbhare, 18:03:08)
    6. skitt (skitt, 18:03:09)
    7. rovarga (rovarga, 18:03:18)
    8. shague (shague, 18:03:23)
    9. gzhao (gzhao, 18:04:35)
    10. TSC chair nomination period open until Dec 13 (abhijitkumbhare, 18:08:12)
    11. LuisGomez (LuisGomez, 18:08:21)
    12. yuling asks to talk about TSDR joining Oxygen (skitt, 18:08:40)
    13. rovarga asks where the project lifecycle page has gone (skitt, 18:08:48)
    14. Nitrogen project lifecycle: http://docs.opendaylight.org/en/stable-nitrogen/release-process/project-lifecycle.html (skitt, 18:09:26)
    15. but that’s not the one, rovarga is thinking about the page which described stable feature requirements etc. (skitt, 18:09:39)
    16. ACTION: rovarga to send CaseyODL his email again (skitt, 18:10:05)

  1. Events (skitt, 18:10:39)
    1. OPNFV plugfest next week in Hillsboro (skitt, 18:10:57)
    2. CaseyODL and abhijitkumbhare are attending (skitt, 18:11:10)
    3. next big event is ONS (skitt, 18:11:23)
    4. no other upcoming events on the immediate horizon (skitt, 18:11:39)
    5. http://events.linuxfoundation.org/events/open-networking-summit-north-america Link to ONS (CaseyODL, 18:12:28)
    6. ONS summit March 26-29 in downtown Las Angeles (bjohnson, 18:13:02)
    7. Open Source Leadership summit, invite only, March 6-8, 2018 (bjohnson, 18:14:11)
    8. Open Source leadership summit March 6-8 in the Sonoma Valley (skitt, 18:14:11)

  2. Oxygen (skitt, 18:16:12)
    1. https://wiki.opendaylight.org/view/Release_Dashboard (klou, 18:16:16)
    2. the TSDR team have been catching up with Oxygen (skitt, 18:17:18)
    3. their goal is modest for Oxygen: catch up with whatever was left out in Nitrogen and meet the requirements for Oxygen (skitt, 18:17:41)
    4. TSDR is quite big so some work still needs to be done, but many features already working fine (skitt, 18:17:57)
    5. next steps: CSIT and feature completeness (skitt, 18:18:06)
    6. the TSDR project has migrated to Karaf 4 (skitt, 18:18:18)
    7. rovarga suspects TSDR will encounter issues migrating to odlparent 3 (skitt, 18:19:14)
    8. dfarrell07 thinks TSDR’s status is fine for Oxygen, but hopes futures releases of ODL will find a place for TSDR which doesn’t put such onerous requirements on the team (skitt, 18:21:42)
    9. More info on TSDR request- https://lists.opendaylight.org/pipermail/tsc/2017-November/008375.html (klou, 18:21:56)
    10. https://wiki.opendaylight.org/view/TSDR:Main TSDR ODL Wiki (bjohnson, 18:23:01)
    11. TSDR declared their intent to participate (skitt, 18:27:08)
    12. anipbu wonders if this is a precedent, or if TSDR is being singled out: fall behind, get kicked out, then have to come back to the TSC to ask to get back in (skitt, 18:27:56)
    13. rovarga hopes this sets a precedent: the milestones are important (skitt, 18:28:12)
    14. from a release engineering perspective the important thing isn’t the readout, it’s the date (skitt, 18:28:34)
    15. several agree we need to make this consistent, we encourage projects to be on time (skitt, 18:28:52)
    16. perhaps we need to formalise this before singling out TSDR (skitt, 18:29:12)
    17. we’d have to add something to the TSC charter describing how projects are removed and re-instated (skitt, 18:30:19)
    18. e.g. time limits etc. (skitt, 18:30:40)
    19. typically we drop projects after RC0 when they’re not effectively in the project (skitt, 18:30:56)
    20. https://github.com/opendaylight/docs/tree/master/docs/release-process/milestone-readouts/m1 (anipbu, 18:32:57)
    21. rovarga reminds us that some releases were made on time, thanks to careful planning (skitt, 18:33:06)
    22. ACTION: the new TSC chair to start drafting language to update the charter (skitt, 18:35:13)
    23. the governance documents need to be rewritten anyway (skitt, 18:35:22)
    24. we might want to refactor our milestones too (as discussed in the recent TWS sessions) (skitt, 18:36:04)
    25. fewer checkpoints with automatic metrics so we’re data-driven and objective (skitt, 18:36:44)
    26. without setting a precedent yet (skitt, 18:37:45)
    27. VOTE: Voted on "Shall the TSC approve TSDR’s return to Oxygen?" Results are, 0: 4, +1: 6 (skitt, 18:39:18)
    28. AGREED: TSDR rejoins Oxygen (skitt, 18:40:29)
    29. M2 still ongoing, half the projects have submitted (skitt, 18:42:10)
    30. ACTION: klou to send another reminder next week (skitt, 18:44:12)

  3. Nitrogen (skitt, 18:44:21)
    1. SR1 released on Monday (skitt, 18:44:42)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan Nitrogen Release Plan (bjohnson, 18:44:57)
    3. SR2 needs a revised date otherwise it will come out too close to SR1 (skitt, 18:45:03)
    4. https://wiki.opendaylight.org/view/Release_Dashboard ODL Release Dashboard (bjohnson, 18:45:24)
    5. perhaps combine SR2 and SR3? (skitt, 18:45:43)
    6. either combine, or push back (skitt, 18:47:19)
    7. not much overlap with Oxygen yet (skitt, 18:47:25)
    8. raises the question of always pushing release back (skitt, 18:49:16)
    9. need to build a combined calendar with all releases (skitt, 18:50:51)
    10. so we can see how SRs fit in around the Oxygen release (skitt, 18:51:00)
    11. ACTION: klou to combine all release dates in a single document, on a calendar of some sort (skitt, 18:55:49)
    12. four SRs may be too many (skitt, 18:57:05)
    13. bjohnson says we need SRs too avoid waiting too long (skitt, 18:57:58)
    14. there’s a resource problem, or a process problem (skitt, 18:58:09)
    15. exceptional situation because we’re supporting Carbon *and* Nitrogen as well as developing Oxygen (skitt, 18:59:58)
    16. it also takes us too long to release (skitt, 19:00:14)

  4. Carbon (skitt, 19:01:44)
  5. Nitrogen (skitt, 19:01:50)
    1. AGREED: we won’t have SR2 next week (skitt, 19:01:58)

  6. Carbon (skitt, 19:02:02)
    1. SR3 is December 14 (skitt, 19:02:09)
    2. security issue being fixed, build ready to go (skitt, 19:02:20)
    3. so should we release SR3 early? (skitt, 19:02:28)
    4. OPNFV are seeing regressions on Carbon (skitt, 19:03:48)
    5. AGREED: we’re not releasing SR3 early (skitt, 19:04:34)

  7. Infrastructure (skitt, 19:04:50)
    1. the Gerrit update last week failed and we're looking into scheduling another attempt soon once more testing is completed (skitt, 19:05:04)

  8. Cookies (skitt, 19:05:14)
    1. and congrats to all the winners, and welcome to the new TSC members (skitt, 19:05:36)
    2. ACTION: someone to update the TSC page and update the agenda (skitt, 19:05:53)


Meeting ended at 19:06:00 UTC (full logs).

Action items

  1. rovarga to send CaseyODL his email again
  2. the new TSC chair to start drafting language to update the charter
  3. klou to send another reminder next week
  4. klou to combine all release dates in a single document, on a calendar of some sort
  5. someone to update the TSC page and update the agenda


Action items, by person

  1. CaseyODL
    1. rovarga to send CaseyODL his email again
  2. klou
    1. klou to send another reminder next week
    2. klou to combine all release dates in a single document, on a calendar of some sort
  3. rovarga
    1. rovarga to send CaseyODL his email again
  4. UNASSIGNED
    1. the new TSC chair to start drafting language to update the charter
    2. someone to update the TSC page and update the agenda


People present (lines said)

  1. skitt (88)
  2. rovarga (15)
  3. odl_meetbot (11)
  4. abhijitkumbhare (10)
  5. bjohnson (8)
  6. CaseyODL (8)
  7. gzhao (5)
  8. anipbu (4)
  9. zxiiro (4)
  10. dfarrell07 (3)
  11. shague (2)
  12. klou (2)
  13. LuisGomez (2)
  14. vishnoianil (2)


Generated by MeetBot 0.1.4.