18:00:24 <skitt> #startmeeting tsc
18:00:24 <odl_meetbot> Meeting started Thu Dec 14 18:00:24 2017 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:24 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:24 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:33 <skitt> #chair CaseyODL abhijitkumbhare
18:00:33 <odl_meetbot> Current chairs: CaseyODL abhijitkumbhare skitt
18:00:48 <skitt> #topic Agenda bashing and roll-call
18:01:37 <abhijitkumbhare> #info abhijitkumbhare
18:01:50 <anipbu> #info anipbu
18:01:57 <gzhao> #info gzhao (IRC only)
18:02:07 <skitt> #info skitt
18:02:13 <skitt> #info TSC members please info in
18:02:25 <rovarga> #info rovarga
18:03:40 <zxiiro> #info Thanh Ha
18:03:59 <jamoluhrsen> #info jamoluhrsen
18:04:05 <shague> #info shague
18:04:08 <lori> #info lori
18:04:21 <bjohnson> #info Brady Johnson
18:04:27 <zxiiro> skitt: I think we should talk about infra first this week.
18:04:35 <skitt> zxiiro, works for me
18:04:38 <bjohnson> I dont see anyone connected to the Zoom meeting
18:04:42 <vishnoianil_> #info Anil Vishnoi
18:05:00 <bjohnson> Ohh, Im on the APAC meeting sorry
18:06:10 <skitt> #topic Groups.io
18:06:17 <skitt> #info CaseyODL will send an email out later
18:06:30 <skitt> #info there is a setting to limit notifications using hashtag filters
18:06:40 <skitt> #info hashtags can be muted, and can have a limited lifetime
18:06:51 <skitt> #info it’s also possible to require hashtags in a post
18:07:21 <skitt> #info it might be possible to set up mail-to-groups.io forwarding with automated tagging
18:07:48 <LuisGomez> #info LuisGomez
18:09:23 <skitt> #topic TSC chair elections
18:09:31 <skitt> #info emails went out very recently to TSC members
18:09:41 <skitt> #info two candidates: abhijitkumbhare and bjohnson
18:10:29 <skitt> #info if members don’t get their email soon they should contact CaseyODL
18:11:46 <skitt> #topic Infrastructure
18:12:01 <bjohnson> CaseyODL: I did indeed receive the ODL TSC chair election email
18:12:42 <skitt> #info two major changes this week
18:12:50 <skitt> #info Gerrit happened last Saturday
18:13:04 <skitt> #info IT working through the queue of emails from people without LFid mappings
18:13:17 <skitt> #info some groups without committers because the committers didn’t accept their invites
18:13:41 <skitt> #info please open a helpdesk ticket with any issues encountered
18:13:52 <skitt> #info we now have the latest version of Gerrit
18:14:01 <skitt> #info there’s an option for a new UI at the bottom of the screen
18:14:08 <skitt> #info the UI is now mobile-compliant
18:14:25 <skitt> #info Jenkins also got upgraded yesterday, in a slightly unplanned move
18:14:39 <skitt> #info Rackspace’s environment dropped offline so it seemed like the ideal time to move
18:14:50 <skitt> #info there are still infra problems in the new provider
18:14:57 <skitt> #info we’re hitting them too hard
18:17:37 <skitt> rovarga, https://git.opendaylight.org/gerrit/#/c/64196/
18:18:36 <skitt> #topic NETCONF
18:18:55 <skitt> #info concerns on the mailing list about the status of the project
18:19:06 <skitt> #info currently no PTL, little committer activity
18:19:14 <rovarga> skitt: fixed
18:19:19 <skitt> rovarga, thanks
18:19:36 <skitt> #info Jakub Morvay stepped forward as PTL and got approved by the committers
18:19:48 <skitt> #info he has cycles for bug fixing, milestones and community activity
18:20:48 <skitt> #info still important to increase the number of committers
18:22:40 <skitt> #info we want to make sure we get quality committers, who won’t just do basic code clean-up
18:23:20 <skitt> #info it remains the project’s prerogative to choose the committers it wishes to promote
18:24:42 <skitt> #info but it’s also important to give contributors a chance
18:27:41 <skitt> #info it’s also necessary to try to keep the docs and test contacts positions filled
18:29:51 <skitt> #info reviewing isn’t only up to committers, we need peer reviews too
18:33:11 <skitt> #action Jakub Morvay to get the project revived
18:33:18 <skitt> #undo
18:33:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2942390>
18:33:33 <skitt> #action Jakub Morvay to get the NETCONF project revived (reviews going etc.)
18:33:46 <skitt> #action the TSC to review the NETCONF situation in early January
18:34:11 <skitt> #topic odlparent 3 / yangtools 2
18:34:42 <skitt> #link migration tracker: https://wiki.opendaylight.org/view/ODL_Root_Parent:BigBumpOfJan2018#To_Do_prio._critical
18:36:20 <skitt> #info migration in progress for offset 0
18:37:51 <skitt> #info the migration was planned at the DDF, with feedback from downstreams who were present then
18:37:58 <skitt> #info it was also communicated on the mailing lists
18:41:57 <skitt> #info the reasons for the upgrade are:
18:42:21 <skitt> #info * upgrading to the latest Karaf, 4.1.3 (with a sane version of SSH, which is important for security and NETCONF, and upgraded Jetty which helps websockets)
18:42:57 <skitt> #info * upgrading to Scala (2.12.4), which is a breaking upgrade but brings higher performance, smaller size (mostly dealt with in controller)
18:43:13 <skitt> #info * upgrading to Akka 2.5 which is the currently-supported version
18:43:26 <skitt> #info * early support for Java 9
18:43:43 <skitt> #info * in yangtools 2, a pile of API changes which were waiting for a semantic versioning breaking change
18:44:21 <skitt> #info with YANG 1.1 properly integrated in the meta-model, lots of clean-up, future support for forthcoming Guava changes, use of java.util.Optional
18:45:52 <skitt> #info as we peel out projects from autorelease, we can expect more changes where we need to kick everyone out of autorelease and int/dist
18:49:31 <skitt> #info we do need to make sure that upstream changes aren’t forced down project’s throats
18:50:21 <skitt> #info we’ll soon be in a position to do a platform release
18:50:53 <skitt> #info once we get there the whole process will be much more predictable
18:50:54 <kkershaw> #info Oxygen code freeze for offset 2 projects is 21 Jan. 2018, correct?  RC0 is 7 Feb. 2018?  So integration w/ ODLParent 3/Yangtools 2 must be done by then, correct?
18:51:21 <anipbu> kkershaw: correct.
18:51:42 <abhijitkumbhare> #undo
18:51:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2808d90>
18:51:47 <rovarga> kkershaw: or we slip the release :)
18:52:41 <abhijitkumbhare> #info kkershaw notes Oxygen code freeze for offset 2 projects is 21 Jan. 2018,   RC0 is 7 Feb. 2018. So integration w/ ODLParent 3/Yangtools 2 must be done by then
18:55:19 <skitt> #info we need some way of tracking progress on projects out of autorelease (odlparent, yangtools)
18:55:30 <skitt> #info such projects need to document in advance clear integration windows
18:57:05 <kkershaw> Can you tell me when integration window will open for the downstream projects?
18:57:38 <skitt> kkershaw, that’s what we need to discuss now
18:59:23 <skitt> #startvote will offset 0 projects start merging patches now for the odlparent 3 / yangtools 2 migration? -1, 0, +1
18:59:23 <odl_meetbot> Begin voting on: will offset 0 projects start merging patches now for the odlparent 3 / yangtools 2 migration? Valid vote options are -1, 0, +1.
18:59:23 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:01:05 <skitt> #endvote
19:01:05 <odl_meetbot> Voted on "will offset 0 projects start merging patches now for the odlparent 3 / yangtools 2 migration?" Results are
19:06:20 <gzhao> .
19:06:45 <skitt> #info gating requirements are:
19:06:49 <skitt> #info 1. CSIT back online
19:06:55 <bjohnson> I have to leave and join another meeting, I'll stay on IRC
19:06:58 <skitt> #info 2. all the critical patch projects ready and tested
19:07:04 <skitt> #info (manual validation)
19:07:28 <skitt> #info 3. clean out autorelease and int/dist
19:07:38 <skitt> #info then we start merging patches, ignoring int/dist
19:07:54 <skitt> #info then rebuild autorelease and int/dist, which should give us valid CSIT for all critical migrated projects
19:08:07 <skitt> #info this gives us a stable autorelease build containing all the critical projects
19:08:35 <skitt> #info vote on the mailing list
19:09:16 <skitt> #action skitt to write the plan up and start the vote on the mailing list
19:09:20 <skitt> #topic Cookies
19:09:33 * rovarga omnomnom
19:09:43 <tykeal> #info extra cookies for skitt
19:09:46 <skitt> #endmeeting