18:01:30 <skitt> #startmeeting tsc
18:01:30 <odl_meetbot> Meeting started Thu Dec 21 18:01:30 2017 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:01:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:30 <odl_meetbot> The meeting name has been set to 'tsc'
18:01:32 <skitt> #chair CaseyODL
18:01:32 <odl_meetbot> Current chairs: CaseyODL skitt
18:01:41 <skitt> #chair abhijitkumbhare bjohnson
18:01:41 <odl_meetbot> Current chairs: CaseyODL abhijitkumbhare bjohnson skitt
18:01:48 <skitt> #topic Agenda bashing
18:01:53 <skitt> #info TSC members please info in
18:01:57 <skitt> #info skitt
18:01:57 <bjohnson> #info Brady Johnson
18:02:00 <gzhao> #info gzhao
18:02:29 <abhijitkumbhare> #info abhijitkumbhare
18:02:33 <anipbu> #info anipbu
18:04:44 <anipbu> Original vote pinned to PST time zone: https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-12-15-18.01.html
18:06:59 <dfarrell07> has the TSC chair vote concluded?
18:07:07 <skitt> dfarrell07, I don’t think so
18:07:14 <dfarrell07> you folks are slow af
18:07:15 <dfarrell07> vote!
18:08:11 * skitt voted last week
18:08:20 * dfarrell07 thanks skitt
18:08:52 <skitt> CaseyODL, you’re not displaying the usual pre-meeting notice
18:09:11 <CaseyODL> I already did.
18:09:15 <skitt> oh sorry
18:09:19 <CaseyODL> :)
18:09:22 <skitt> oh yes we’re recording
18:09:34 <jamoluhrsen> #info jamoluhrsen
18:10:00 <dfarrell07> lori shague
18:10:12 <skitt> LuisGomez too
18:10:32 <skitt> lori and shague aren’t on the call
18:12:40 <LuisGomez> #info LuisGomez
18:12:59 <vishnoianil> #info Anil Vishnoi
18:13:21 <skitt> #startvote Who will be present for next week's TSC call (APAC)? -1, +1
18:13:21 <odl_meetbot> Begin voting on: Who will be present for next week's TSC call (APAC)? Valid vote options are -1, +1.
18:13:21 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:13:27 <skitt> #vote -1
18:13:31 <anipbu> #vote +1
18:13:33 <LuisGomez> #vote -1
18:13:36 <bjohnson> #vote -1
18:13:41 <vishnoianil> #vote -1
18:13:45 <jamoluhrsen> #vote -1
18:13:49 <gzhao> +1
18:13:49 <abhijitkumbhare> #vote +1
18:13:58 <gzhao> #vote +1
18:14:28 <skitt> #endvote
18:14:28 <odl_meetbot> Voted on "Who will be present for next week's TSC call (APAC)?" Results are
18:14:28 <odl_meetbot> +1 (3): gzhao, abhijitkumbhare, anipbu
18:14:28 <odl_meetbot> -1 (5): skitt, LuisGomez, vishnoianil, jamoluhrsen, bjohnson
18:14:56 <skitt> #info Very little participation in APAC meetings anyway, including from APAC members
18:15:12 <skitt> #info Perhaps we should only hold APAC meetings when requested
18:15:46 <skitt> #action bjohnson to reach out to APAC members to ask them if they would like an APAC meeting in the first week of January
18:16:35 <skitt> #undo
18:16:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x29aa6d0>
18:17:16 <skitt> #action bjohnson to reach out to APAC members to see whether they want to continue the APAC meetings and in what form
18:18:36 <skitt> #info Last meeting only had six people join
18:18:46 <skitt> #info (last APAC meeting)
18:18:58 <skitt> #info We hardly ever meet quorum for APAC calls
18:19:33 <skitt> #info We could just cancel next week’s meeting outright anyway
18:20:49 <skitt> #agreed Next week’s TSC meeting is cancelled (December 28)
18:21:10 <skitt> #action CaseyODL to remove the calendar entry for next week’s meeting
18:22:09 <skitt> #info The next TSC meeting will be on January 4 at the usual time
18:22:23 <skitt> #info The next APAC call will be at the end of January as usual (for the time being)
18:23:14 <skitt> #topic Events
18:25:26 <skitt> #info Nothing new, next big event is at ONS, with an ODL DDF
18:25:56 <dfarrell07> #info CaseyODL confirms ODL DDF at ONS will be at start of event, not end, so doesn't conflict with passover on Friday
18:26:27 <dfarrell07> #action CaseyODL to pressure LF leadership folks to get invites to LF Leadership Summit out ASAP so folks can plan budget
18:26:57 <skitt> #info unclear yet whether the ODL DDF will take place before ONS (the previous Friday or over the weekend) or concurrently with the start of ONS
18:28:03 <skitt> #info There will also be a cross-project CI/CD mini-summit
18:28:11 <skitt> #topic Oxygen
18:28:17 <klou> #link https://wiki.opendaylight.org/view/Release_Dashboard
18:28:51 <abhijitkumbhare> That’s neat dashboard klou :)
18:29:26 <dfarrell07> shague: we're about to talk about Netvirt bugs in Carbon and if they are blockers, what to do about release
18:33:28 <dfarrell07> #action New TSC Chair to follow up with new NetConf PTL about situation, adding new committers, it has been the week they requested
18:34:27 <bjohnson> dfarrell07: Im going to reach out to Jakub Morvay today
18:35:05 <dfarrell07> #info vishnoianil points out that if Netconf can't get back to TSC in timely manner it seems very likely they can't follow up with community
18:35:27 <dfarrell07> #info if new NetConf PTL doesn't reply with plans to get project healthy by TSC meeting 1/4 <something bad will happen>
18:37:46 <skitt> #info the lack of updates from yangtools, mdsal etc. raises the question of what to do with projects with a bus factor of 1
18:38:27 <skitt> #info the wiki suggests there are quite a few committers, which seems to be inaccurate
18:38:31 <dfarrell07> #info LuisGomez points out that there are lots of committers on yangtools wiki, that it's not okay to have this disconnect between wiki and reality
18:39:02 * tykeal notes that of the the yangtools committers only robert actually accepted the invite into the new ACL group
18:39:21 <dfarrell07> #info vishnoianil wants projects to update committer list so TSC can accurately judge health of project
18:39:45 <skitt> #info we need to ask projects who is active, and provide a definition of active
18:39:52 <dfarrell07> #info skitt points out that they are therefore not correctly reporting "wiki up to date"
18:40:07 <skitt> #info we need to compare the official list of committers on the wiki with real levels of activity
18:40:42 <dfarrell07> #info dfarrell07 thinks as a part of new release model we will have chance to put better requirements about what "active" means, what to do if project is unhealthy
18:40:43 <skitt> #info a big list of inactive committers on the wiki also discourages new contributors
18:40:48 <skitt> dfarrell07++
18:44:15 <dfarrell07> #topic Nitrogen
18:44:19 <anipbu> maybe we should schedule a special TWS session to specifically discuss this topic?
18:44:24 <dfarrell07> klou: just start talking when you get a chance ;_
18:44:34 <klou> :)
18:45:01 <skitt> #info We did not release SR2 on December 7
18:45:02 <abhijitkumbhare> agree anipbu
18:45:22 <skitt> #info recommendation is just to merge SR2 and SR3, and release on February 7
18:45:37 <dfarrell07> #action CaseyODL to add "healthy project/committer" discussion to TWS agenda
18:45:46 <anipbu> we should vote
18:45:48 <skitt> #startvote Shall we release SR2 on February 7, 2018, merging SR2 and SR3? -1, 0, +1
18:45:48 <odl_meetbot> Begin voting on: Shall we release SR2 on February 7, 2018, merging SR2 and SR3? Valid vote options are -1, 0, +1.
18:45:48 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:45:54 <jamoluhrsen> #vote +1
18:45:55 <anipbu> #vote +1
18:45:56 <skitt> #vote +1
18:46:03 <abhijitkumbhare> #vote +1
18:46:06 <LuisGomez> #vote +1
18:46:06 <gzhao> #vote +1
18:46:11 <vishnoianil> #vote +1
18:46:14 <bjohnson> #vote +1
18:46:17 <jamoluhrsen> see, i do vote
18:46:19 <skitt> #endvote
18:46:19 <odl_meetbot> Voted on "Shall we release SR2 on February 7, 2018, merging SR2 and SR3?" Results are
18:46:19 <odl_meetbot> +1 (8): gzhao, bjohnson, skitt, LuisGomez, jamoluhrsen, anipbu, vishnoianil, abhijitkumbhare
18:46:22 <dfarrell07> jamoluhrsen: ;)
18:46:33 <skitt> #agreed We will release Nitrogen SR2 on February 7, 2018, merging SR2 and SR3
18:46:40 <abhijitkumbhare> jamoluhrsen :)
18:46:48 <skitt> #info SR3 will be planned for May 7
18:47:57 <skitt> #info No planned SR4 now
18:48:05 <dfarrell07> #topic Carbon
18:48:18 <skitt> #info SR3 planned to be released last week
18:48:27 <skitt> #info we have a RC, had to re-run CSIT a couple of times
18:48:39 <skitt> #info there are 45 failures, all of which have been reviewed
18:48:44 <skitt> #info thanks to jamoluhrsen and LuisGomez
18:48:55 <skitt> #info 9 remain to deal with, 3 of which appear to be regressions in NetVirt
18:49:13 <skitt> #info those bugs will be moved to blocker state, and NetVirt will have to decide what to do
18:49:45 <dfarrell07> #action shague to decide if three Carbon SR3 regressions are blockers, and if so find someone to fix, else move out of bokcer state
18:50:02 <skitt> #info Carbon SR3 is liable to be released only in January
18:54:19 <dfarrell07> #action vishnoianil to push netvirt bugs, either confirm blockers or help find/push folks to fix
18:55:34 <dfarrell07> #undo
18:55:40 <dfarrell07> skitt: can you undo
18:55:43 * dfarrell07 isn't chair
18:55:46 <abhijitkumbhare> #undo
18:55:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x28ae5d0>
18:55:47 <skitt> #undo
18:55:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x28ae050>
18:56:01 <abhijitkumbhare> Sorry - race condition dfarrell07 :)
18:56:02 <skitt> #info Carbon SR3 is liable to be released only in January
18:56:06 <skitt> #topic Infrastructure
18:57:16 <skitt> #info We will soon be completely switched over to the new Nexus system, which should resolve download speed issues
18:57:25 <dfarrell07> #info logs are being rsync'd over, sorry impossible to get to old logs for now
18:58:03 <skitt> #info The quick clone issue should be resolved soon, except for projects using submodules
18:58:17 <dfarrell07> #info there is a git mirror in our new cloud that mirrors main git in AWS, that makes clones work but some types of interactions with Gerrit are still very slow/don't work at all
18:58:38 <dfarrell07> #info dfarrell07 has seen curls of small files from old gerrit just fail, TSC timeout
18:58:44 <dfarrell07> #undo
18:58:52 <dfarrell07> #info dfarrell07 has seen curls of small files from old gerrit just fail, TCP timeout
18:59:44 <skitt> #info The vendor also have various tweaks in the wings to help fix speed issues
19:00:25 <skitt> #topic Cookies
19:00:30 <skitt> #endmeeting