#opendaylight-meeting: tws
Meeting started by CaseyODL at 18:06:21 UTC
(full logs).
Meeting summary
- Groups.io (CaseyODL, 18:07:16)
  - Brady Johnson (bjohnson,
    18:07:19)
- Groups.io has many of the features of Mailman,
    but a modern interface, better security and extra features
    (lori,
    18:09:20)
- extra features include muting threads,
    integrations with many popular services (lori,
    18:10:06)
- Groups.io was tested with ODPi, tested with
    email in China, with Exchange and Apple clients, with email from
    different geographical regions (lori,
    18:11:48)
- it would be interesting to have less mailing
    lists, using the features of Groups.io (lori,
    18:12:30)
- one such list would be a general support
    mailing list (lori,
    18:12:52)
- vorburger suggests to have two support lists:
    one user support and one dev support list (lori,
    18:13:39)
- CaseyODL ask how do we direct unexperienced
    users to the right list (lori,
    18:14:42)
- CaseyODL also suggests to obsolete project
    specific mailing lists in favor of topics/hashtags on a general
    list (lori,
    18:15:37)
- dfarrell07 says that in OPNFV they use tagging
    in the subject line, and that has issues, people don't get it right,
    and they're not too happy with that (lori,
    18:16:33)
- vishnoianil says that it is easy to have typos,
    which makes this error prone (lori,
    18:17:08)
- bjohnson asks who benefits by switching to one
    list (lori,
    18:18:18)
- CaseyODL says that it would help users who
    don't know which lists to ask (lori,
    18:18:41)
- there is still a feeling that complexity is not
    going to be reduced by this move (lori,
    18:19:08)
- the Groups.io interface allows easy searching
    through all groups (lori,
    18:19:43)
- CaseyODL suggests to use tags, but have groups
    based on category (kernel, support, protocol, etc.) (lori,
    18:20:35)
- vorburger and vishnoianil say they don't want
    to receive email for all app projects for example, and have to setup
    filtering (lori,
    18:21:59)
- filtering can be set up in the group config
    too, not just in the email client (like mailman topics) (lori,
    18:22:26)
- one option to make it possible to use the old
    email aliases is to set up forwarding rules for the old lists
    (lori,
    18:23:45)
- ACTION: CaseyODL to
    check if the above is possible (forwarding an email alias to a
    hashtag in a new group) (lori,
    18:24:45)
- it seems like the same people usualy subscribe
    to the project specific lists of a cluster of projects, which are
    not the same as the kernel, apps, and other categories (lori,
    18:30:25)
- ACTION: CaseyODL will
    look into options for mailing list consolidation (lori,
    18:32:42)
 
 
- Release streamlining (CaseyODL, 18:35:02)
  - ACTION: CaseyODL to
    send out email to the community to continue the discussion about the
    email list consolidation (lori,
    18:35:02)
- the current release process has several issues
    slowing things down (lori,
    18:36:40)
- people ignoring CSIT requirements (lori,
    18:36:52)
- release engineering (RE) is unable to unblock
    the release due to unresponsive projects (lori,
    18:37:29)
- the all-in-one distribution is forcing
    arbitrary linking of unrelated projects (lori,
    18:38:02)
- unresposinsive projects are more-or-less
    freeloaders for maintenance (lori,
    18:38:25)
- one solution is focus on core projects, which
    have to be there for ODL to actually work (lori,
    18:39:00)
- and then on active/responsive projects, which
    are consumed a lot downstream (lori,
    18:39:24)
- make sure these projects are stable
    (lori,
    18:39:38)
- make sure core projects have a healthy
    committer team and it's easy to onboard committers (lori,
    18:40:14)
- RE has a bit more control now to make things go
    faster by merging e.g. version bumping related patches and so
    on (lori,
    18:41:20)
- we need to define requirements for projects to
    be "admitted" into this list of "core" projects (lori,
    18:41:45)
- e.g., dependencies of core projects need to be
    in the core (lori,
    18:42:20)
- the proposal is to have three buckets: 1. core
    projects which need to work all the time; 2. projects meeting the
    requirements for distribution, like passing jenkins jobs; which are
    part of the Karaf distro ZIP file; and 3. unresposnsive projects not
    included in the ZIP file, but which can still be loaded manually
    from the Karaf console (lori,
    18:49:28)
- https://docs.google.com/presentation/d/1wAG_zQ0IkFdh9kZgjKtMbTP-x7jJOvnOgFO5iehebpE/edit#slide=id.g2bfeb64f3c_0_7
    <-- new distro model slide deck (jamoluhrsen,
    19:06:56)
- the plan is to have this hashed out in Oxygen
    timeframe so it can be applied to the Fluorine release (lori,
    19:08:05)
 
Meeting ended at 19:09:26 UTC
(full logs).
Action items
  - CaseyODL to check if the above is possible (forwarding an email alias to a hashtag in a new group)
- CaseyODL will look into options for mailing list consolidation
- CaseyODL to send out email to the community to continue the discussion about the email list consolidation
Action items, by person
  -  CaseyODL 
    - CaseyODL to check if the above is possible (forwarding an email alias to a hashtag in a new group)
- CaseyODL will look into options for mailing list consolidation
- CaseyODL to send out email to the community to continue the discussion about the email list consolidation
 
People present (lines said)
  - lori (38)
- odl_meetbot (3)
- abhijitkumbhare (3)
- CaseyODL (3)
- zxiiro (2)
- jamoluhrsen (2)
- bjohnson (1)
Generated by MeetBot 0.1.4.