17:04:32 <vorburger> #startmeeting kernel
17:04:32 <odl_meetbot> Meeting started Tue Nov 13 17:04:32 2018 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:32 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:32 <odl_meetbot> The meeting name has been set to 'kernel'
17:04:38 <vorburger> #topic Agenda?
17:04:58 <vorburger> #info Fluorine SR1, Oxygen SR4
17:05:35 <vorburger> #info skitt mentions there are pending problems in autorelease
17:05:42 <vorburger> #undo
17:05:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2bb5410>
17:06:09 <vorburger> #info skitt mentions that the requirement is a passing autorelease for Fluorine SR1
17:06:44 <vorburger> skitt: rovarga: feel free to minute yourself
17:07:34 <rovarga> #info Oxygen SR4 needs to bee updated to carry yangtools-2.0.6.5
17:07:59 <skitt> #info the projects affected are bgpcep, controller, mdsal, netconf, sxp, and int/dist
17:12:50 <skitt> #action skitt to file a bug in int/dist to determine whether to complete or remove feature-repos
17:13:00 <skitt> #action skitt to file a bug in int/dist to migrate to artifact POMs
17:14:56 <vorburger> #topic new PingPongDataBroker interface for simpler annotation instead of XML based dependency injection?
17:15:50 <vorburger> #link https://lists.opendaylight.org/pipermail/controller-dev/2018-November/014678.html
17:19:15 <vorburger> #info @Named ?
17:19:40 <vorburger> #info @Qualifier in CDI and Spring
17:19:50 <vorburger> #info @Filter for Blueprint annotation
17:22:09 <vorburger> #info grep for "filter" in https://osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd
17:22:56 <vorburger> #link http://aries.apache.org/modules/blueprint.html "Example showing use of filter" - empty ;-)
17:23:07 <vorburger> #topic Any other business?
17:23:59 <vorburger> #topic Annotations, other, in general?
17:25:30 <vorburger> #info both JSR 305 javax.annotation, e.g. @NonNull, and CDI e.g. @PostDestroy are in javax.annotation, which is a problem in OSGi
17:26:37 <vorburger> #info SpotBugs has their own, see link
17:26:38 <vorburger> #link https://github.com/spotbugs/spotbugs/tree/release-3.1/spotbugs-annotations/src/main/java/edu/umd/cs/findbugs/annotations
17:28:11 <vorburger> #info SpotBugs struggles with other annotations, specifically TYPE_USE type annotations
17:30:42 <rovarga> #link https://github.com/google/error-prone/issues/1158
17:34:19 <vorburger> #info so we should just drop null analysis with SpotBugs
17:34:36 <vorburger> #info we could instead of NullAway or vorburger's http://www.lastnpe.org (TBD TBC)
17:35:00 <vorburger> #info skitt and rovarga mention that NullAway is an Error-Prone plugin, but that EP is NOK on Java 11 :-(
17:35:18 <vorburger> #info but we could just skip EP while we build on Java 11 until that's supported
17:38:55 <skitt> #action skitt to check that the null features in SpotBugs are disabled
17:39:39 <skitt> #action skitt to send an email to discuss@ to start the discussion on what features we want from EP
17:39:54 <vorburger> #action vorburger pick up https://git.opendaylight.org/gerrit/#/c/63838/ some day when time (not immediate future), and compare it to NullAway
17:44:03 <vorburger> #topic exists() support in mdsal
17:44:18 <vorburger> #info available in DOM API but not exposed in the Binding DataBroker
17:44:33 <vorburger> #action rovarga is filing and issue to add that
17:46:49 <vorburger> #topic Web components move from AAA to infrautils?
17:57:55 <vorburger> #info rovarga objects to Web components move from AAA to infrautils, and aaa and netconf for restconf thus becoming dependant on infrautils for the web components, because it would prevent moving aaa and netconf to move to MRI
17:58:23 <vorburger> #info vorburger is not a fan of more projects becoming MRI (but that wasn't the question here)
17:58:43 <vorburger> #info ergo Web components shall not move from AAA to infrautils in the short term
17:59:35 <vorburger> #info if aaa and netconf move to MRI in Neon then we could revisit this discussion (seeing if infrautils becomes MRI as well)
17:59:48 <vorburger> #endmeeting