17:04:29 <rgoulding> #startmeeting kernel projects
17:04:29 <odl_meetbot> Meeting started Tue Jan 23 17:04:29 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:29 <odl_meetbot> The meeting name has been set to 'kernel_projects'
17:05:42 <rgoulding> #topic agenda bashing
17:05:58 <rgoulding> #info odlparent 3.0.3
17:06:06 <rgoulding> #info MessageBodyWriter Exception in AAA Master
17:08:12 <bjohnson> Just curious, will there be another version bump to odlparent 3.0.3 in Oxygen?
17:08:22 <bjohnson> Im not on the audio part of the meeting, IRC only
17:08:31 <LuisGomez> rgoulding, is this the bug you were looking for https://jira.opendaylight.org/browse/NEUTRON-154?
17:09:22 <rgoulding> #action rgoulding send out Jersey Bump Patches
17:10:00 <rgoulding> #topic odlparent 3.0.3
17:10:35 <rgoulding> #info Jersey with jersey-client?
17:10:59 <rgoulding> #info SXP has issues with SXP CSIT
17:11:10 <rgoulding> #info SXP pulls in robot deps that rely on jetty feature
17:11:36 <rgoulding> #info In karaf 4.1.3 pulls in jetty 9.3.15 and odl-karaf-feat-jetty (depend on war feature) pull in jetty 9.3.14
17:11:48 <rgoulding> #info our DM relies upon jetty 8.something
17:12:29 <rgoulding> #info odlparent 3.0.3 upgrades to karaf 4.1.4 (fixes jetty dependencies issues resolves to 9.3.21)
17:12:42 <rgoulding> #info also resolves more bundle refresh issues
17:13:04 <rgoulding> #info odl-jersey-1 added to odlparent 3.0.3
17:14:15 <rgoulding> #info war brings in more stuff around jetty
17:15:53 <rgoulding> #info do we want to try a 3.0.3 in the intial offering
17:16:14 <rgoulding> #info i.e., do we hack something together for oxygen GA for SXP/AAA
17:18:00 <rgoulding> #info given the timeline maybe we should stick with 3.0.2
17:20:52 <rgoulding> #info is there a workaround for SXP?
17:21:03 <rgoulding> #info skitt thinks that if you manually load jetty feature first that everythign should work
17:21:43 <rgoulding> #info 3.0.3 put off until first SR of oxygen
17:23:02 <rgoulding> #info skitt does anyone have any thoughts on using managed blueprint feature that karaf provides instead of building our own
17:23:28 <skitt> #link https://git.opendaylight.org/gerrit/51455
17:23:53 <rgoulding> #info rovarga points out that we are utilizng an extender which may require some more elegant loading
17:23:59 <rgoulding> #info there is investigation needed for htis
17:25:28 <rgoulding> #topic cohorts
17:25:30 <rgoulding> #link https://jira.opendaylight.org/browse/CONTROLLER-1641
17:25:36 <rgoulding> #info tpantelis asking about status of this
17:25:39 <rgoulding> #topic archetype
17:25:59 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/67511/
17:30:30 <rgoulding> #info archetype probably should live somewhere else
17:30:39 <rgoulding> #info the -rest feature depends on NETCONF
17:30:55 <rgoulding> #info the day we add tests to make sure archetype isn’t broken, it will cause circular dependency issue
17:31:14 <rgoulding> #info or we peel controller out of autorelease and controller/NETCONF have separate release cycles
17:34:23 <rgoulding> #topic netvirt CSIT
17:34:28 <rgoulding> #info restart issue has been worked around
17:34:36 <rgoulding> #info tpantelis still thinks there is still something weird going on
17:35:06 <rgoulding> #info tpantelis can’t reproduce in toaster example with CFG files
17:37:06 <rgoulding> #topic odlparent release plans
17:37:10 <rgoulding> #info what is the plan?
17:37:24 <rgoulding> #info there are a bunch of patches against master which have been kicking around a while
17:37:35 <rgoulding> #info patches go into 3.0.X if they are bug fixes
17:37:47 <rgoulding> #info 3.1.X is for new features that don’t break stuff
17:37:57 <rgoulding> #ifno and 4.0.X is for things that break stuff
17:38:05 <rgoulding> #info that way we should at least be able to start merging things again
17:38:33 <rgoulding> #info is guava upgrade 3.0 or 3.1 stuff
17:38:37 <rgoulding> #info since it changes behavior
17:38:41 <rgoulding> #info and what about the akka stuff?
17:39:03 <rgoulding> #info 3.0.X is for intial release and 3.1.Y may be the SR target
17:39:14 <rgoulding> #info so perhaps 3.0.X may not actually be used in another distribution
17:40:29 <rgoulding> #topic feature restarts in SFC
17:40:42 <rgoulding> #info bjohnson seeing strange restarts for SFC
17:40:49 <rgoulding> #info what would be the best project to create the bug for?
17:41:14 <rgoulding> #info rovarga says probably odlparent, but it may require downstream fixes
17:43:03 <rgoulding> #info try etc/org.ops4j.pax.url.cfg and adjust featuresBoot property
17:43:11 <rgoulding> #info we would need to see the karaf log to see what is going on
17:44:18 <rgoulding> #endmeeting