#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 17:02:08 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 17:02:18)
    1. Infra issues (rgoulding, 17:02:36)
    2. re-enable archetype self testing (rgoulding, 17:05:27)

  2. infra issues (rgoulding, 17:05:39)
    1. three updates (rgoulding, 17:06:17)
    2. 1) last night there was severe disk i/o and network slowdowns (rgoulding, 17:06:32)
    3. vexhost trying to give new hardware, and they did this last night (rgoulding, 17:06:41)
    4. when they did this, the upgrade slowed everything down due to sync costs (rgoulding, 17:07:01)
    5. hopefully will not see the very slow transfers that were happening last night (rgoulding, 17:07:18)
    6. 2) filesystem ran out of disk inodes (rgoulding, 17:07:25)
    7. the ext4 partition ran out of inodes for nexus (rgoulding, 17:07:39)
    8. ran out of the ability to index the disk (rgoulding, 17:07:54)
    9. xfs partitioned disk has been created (rgoulding, 17:08:04)
    10. which can support this (rgoulding, 17:08:08)
    11. the sync will take a very long time to sync (rgoulding, 17:08:15)
    12. some things have been deleted to helpf accelerate the transition (rgoulding, 17:08:26)
    13. includes a lot of logs that are tiny, which take up a ton of inodes (rgoulding, 17:08:39)
    14. should hold us over for the week or so until we have the XFS system in place (rgoulding, 17:08:50)
    15. 3) issues with maven merge jobs (rgoulding, 17:09:01)
    16. globaljjb maven merge jobs is different than what we used in ODL originally (freestyle) (rgoulding, 17:09:26)
    17. CLI tool is producing invalid timestamp for files it is producing locally (rgoulding, 17:09:53)
    18. a bug has been discovered in maven 3.5.0 which is similar to this issue, even though we aren’t using it (we use 3.3.9) (rgoulding, 17:10:15)
    19. reverted to ODL - specific merge jobs (rgoulding, 17:10:23)
    20. these jobs were around for a month, which is why it is confusing that we suddenly see this issue (rgoulding, 17:10:41)
    21. rovarga has a theory that it was probably due to the fact that we had a limited number of patches actually getting merged during the odlparent/yangtools migration (rgoulding, 17:11:31)
    22. now we have a huge backlog of patches, so we are more likely to run into this issue (rgoulding, 17:11:53)
    23. in the meantime we can possibly detect and correct the maven metadata (rgoulding, 17:13:31)
    24. we are going to wait on switching this until the release is out the door (rgoulding, 17:13:59)
    25. if merge jobs continue to fail, please contact zxiiro and he will look into it (rgoulding, 17:14:29)
    26. vorburger brings up a 4th possible error; there are memory issues with validate-autorelease (rgoulding, 17:14:51)
    27. the VM template was changed, which could cause this (rgoulding, 17:16:05)
    28. reverting validate-autorelease to use 2 core / 8 gig RAM templates will result in slower jobs, but they won’t crash due to OOM at least (rgoulding, 17:21:41)
    29. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/mdsal-validate-autorelease-oxygen/181/console.log.gz (rovarga_, 17:23:16)
    30. the above link was provided to show cpu/memory analysis for validate-autorelease process (rgoulding, 17:24:13)
    31. it would appear that validate-autorelease is very memory sensitive, but less CPU sensitive (rgoulding, 17:24:29)
    32. zxiiro will revert the template for validate-autorelease, but not touch the others since they don’t require the same resources (rgoulding, 17:24:55)
    33. further analysis of this and broader messaging could help in the future (rgoulding, 17:26:36)

  3. archetype self-testing (rgoulding, 17:28:12)
    1. https://git.opendaylight.org/gerrit/#/c/67833/ (rgoulding, 17:28:15)
    2. 14:49:16 networkx.exception.NetworkXUnfeasible: Graph contains a cycle or graph changed during iteration (rgoulding, 17:31:08)
    3. it appears there is a cycle (rgoulding, 17:31:20)
    4. https://github.com/opendaylight/controller/blob/master/opendaylight/archetypes/opendaylight-startup/src/main/resources/archetype-resources/features/odl-__artifactId__-rest/pom.xml#L35-L38 (rgoulding, 17:32:35)
    5. this causes the cyclic dependency loop (rgoulding, 17:32:42)
    6. so this can’t actually work (with self-testing) in controller (rgoulding, 17:34:20)
    7. since then controller depends on netconf, which is not correct (rgoulding, 17:34:31)
    8. this self-test helps detect errors before releasing (rgoulding, 17:35:31)
    9. and it is used a bunch more than what we had imagined (rgoulding, 17:35:41)
    10. coretutorials may be a good landing spot for this, since it is outside of autorelease (rgoulding, 17:36:35)
    11. i.e., this is how you generate the code etc. (rgoulding, 17:36:50)
    12. coretutorials is currently broken (behind nitrogen and oxygen currently) but Robert has some patches to fix this (rgoulding, 17:37:14)
    13. tpantelis is a committer / PTL for it (rgoulding, 17:37:58)
    14. rovarga is suggesting to move the archetype to coretutorials (rgoulding, 17:39:27)
    15. with the tests and everything (rgoulding, 17:39:32)
    16. you can then evolve the archetype outside the normal release process since you can release the artifacts outside of autorelease (rgoulding, 17:39:51)
    17. would it make sense to keep in autorelease? that would allow us to see it breaking live (rgoulding, 17:40:26)
    18. skitt brings up the fact that we could do it in other ways (rgoulding, 17:41:06)
    19. https://git.opendaylight.org/gerrit/#/q/status:open+project:coretutorials+branch:stable/nitrogen (rovarga_, 17:41:46)
    20. if it lives in autorelease, you cannot provide bugfixes etc. outside of autorelease (rgoulding, 17:44:17)
    21. there are benefits and drawbacks associated with all of this (rgoulding, 17:44:39)
    22. ACTION: vorburger to move archetype to coretutorials (rgoulding, 17:45:54)
    23. propose a separate project for just the archetype (rgoulding, 17:47:48)
    24. why don’t we just delete it? (rgoulding, 17:48:24)
    25. https://wiki.opendaylight.org/view/Project_Proposals:Main (rovarga_, 17:51:47)
    26. wiki page describing what needs to do to propose a new project (rovarga_, 17:52:04)
    27. this page will likely need to be reverted as someone screwed the template (rgoulding, 17:56:21)
    28. tpantelis to look at https://git.opendaylight.org/gerrit/#/c/67662/ (rgoulding, 18:00:03)


Meeting ended at 18:02:17 UTC (full logs).

Action items

  1. vorburger to move archetype to coretutorials


Action items, by person

  1. vorburger
    1. vorburger to move archetype to coretutorials


People present (lines said)

  1. rgoulding (64)
  2. rovarga_ (4)
  3. odl_meetbot (3)
  4. vorburger (1)


Generated by MeetBot 0.1.4.