#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 17:01:02 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 17:01:05)
    1. release blockers (rgoulding, 17:01:12)
    2. https://jira.opendaylight.org/browse/NETCONF-516 (rgoulding, 17:01:26)
    3. https://jira.opendaylight.org/browse/CONTROLLER-1802 (rgoulding, 17:01:31)
    4. https://lists.opendaylight.org/pipermail/neutron-dev/2018-February/001607.html (rgoulding, 17:01:38)
    5. https://lists.opendaylight.org/pipermail/controller-dev/2018-February/014245.html (rgoulding, 17:01:45)
    6. https://jira.opendaylight.org/browse/ODLPARENT-142 (rgoulding, 17:01:50)
    7. https://git.opendaylight.org/gerrit/#/c/61718/ (rgoulding, 17:01:57)

  2. agenda bashing (rgoulding, 17:03:16)
    1. ODLPARENT-139 (rgoulding, 17:03:24)
    2. https://jira.opendaylight.org/browse/ODLPARENT-139 (rgoulding, 17:03:35)
    3. NETCONF-512 (rgoulding, 17:05:45)
    4. https://git.opendaylight.org/gerrit/#/c/68651/ (rgoulding, 17:05:49)
    5. is there a committer paying attention to this? (rgoulding, 17:05:55)
    6. NETCONF-510 (rgoulding, 17:08:42)
    7. https://jira.opendaylight.org/browse/NETCONF-510 (rgoulding, 17:08:59)
    8. also just waiting for review (rgoulding, 17:09:04)
    9. NETCONF-504 (rgoulding, 17:09:22)
    10. nobody is currently looking at this (rgoulding, 17:09:29)
    11. is this actually a blocker? (rgoulding, 17:09:35)
    12. vorburger points out sfc downloads an older version for this (rgoulding, 17:12:03)
    13. can we use an older version? (rgoulding, 17:12:07)
    14. ACTION: luis to take a further look to use an older version that may not suffer same bug (rgoulding, 17:12:44)
    15. given that SFC is using an older one then maybe this is a stopgap (rgoulding, 17:12:55)
    16. ODLPARENT-142 (rgoulding, 17:15:33)
    17. can we strip it in int/dist instead? avoids bumping odlparent and re-releasing (rgoulding, 17:15:45)
    18. can we only bump karaf4-parent modules? (rgoulding, 17:15:56)
    19. ACTION: rgoulding to look at whether we can achieve something similar in int/dist (rgoulding, 17:17:16)

  3. NETCONF-516 (rgoulding, 17:18:59)
    1. https://jira.opendaylight.org/browse/NETCONF-516 (rgoulding, 17:19:08)
    2. tpantelis claims this was seen on stack overflow, so may be a problem in Nitrogen too? (rgoulding, 17:19:21)
    3. this is seen by a number of people in the community (rgoulding, 17:19:38)
    4. is this a blocker? (rgoulding, 17:19:42)
    5. reproducible 100% of the time with tsdr feature (rgoulding, 17:20:17)
    6. we can squash the two patches if necessary (rgoulding, 17:22:53)
    7. ACTION: tpantelis to attempt a squash of the two patches to see if this fixes things on non-local setup (rgoulding, 17:24:36)
    8. those who are encountering this issue are encouraged to add the failed jobs to the jira to ensuyre that a proposed fix actually addresses the issue (rgoulding, 17:25:29)
    9. lets make this a blocker (rgoulding, 17:25:35)

  4. CONTROLLER-1802 (rgoulding, 17:30:24)
    1. https://jira.opendaylight.org/browse/CONTROLLER-1802 (rgoulding, 17:30:32)
    2. this was discussed a lot earlier, and deemed too intrusive for oxygen (rgoulding, 17:30:46)
    3. we need to discuss next steps on how this could get into fluorine (rgoulding, 17:31:00)
    4. are we okay to include this in fluorine in the beginning? (rgoulding, 17:31:38)
    5. rovarga doesn’t know what the state of autorelease is in fluorine right now. if it is stable we should be okay, but if not we need fix that first (rgoulding, 17:32:01)
    6. vorburger is asking just if its okay to put it “soon”-ish in fluroine (rgoulding, 17:32:14)
    7. ACTION: vorburger to rebase this patch (rgoulding, 17:32:49)
    8. we are not talking about validate-autorelease, we are talking about autorelease (rgoulding, 17:33:23)
    9. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-fluorine/ (rgoulding, 17:34:11)
    10. this is currently not building (rgoulding, 17:34:16)
    11. we also need a weather event for this (rgoulding, 17:34:24)
    12. otherwise projects willb e broken and not necessarily know why this is happening (rgoulding, 17:34:38)
    13. after this is merged, then we will promptly file and fix issues against them (rgoulding, 17:35:10)
    14. we need a green autorelease build first though (rgoulding, 17:35:16)
    15. skitt suggest ASAP after we get the autorelease green we should do this, since it often doesnt stay green long (rgoulding, 17:35:46)
    16. ACTION: vorburger to set up weather item relating to this (rgoulding, 17:36:06)

  5. kernel projects fitting into the new release process (rgoulding, 17:38:44)
    1. non-SR managed projects (yangtools and odlparent currently only)— ask these projects in this new release model to deliver whatever release they want consumed at the very beginning of the release cycle (2 weeks max into the release) (rgoulding, 17:39:34)
    2. then dependent projects can adapt to the changes then use the rest of the time to actually do project-specific priorities (rgoulding, 17:40:05)
    3. we need to verbalize that we don’t need to take a release of these non-SR projects if things don’t apear to be working (rgoulding, 17:40:34)
    4. ask SR-managed projects to bump whatever is needed ASAP to adapt to non-SR managed dependency changes (rgoulding, 17:41:01)
    5. rovarga has two concerns 1) non-SR should be called “integrated” 2) going forward we want to peel more and more projects out of autorelease (rgoulding, 17:43:13)
    6. vorburger disagrees with #2 (rgoulding, 17:43:21)
    7. point #2 is relevant since it affects the scale of integration (rgoulding, 17:45:28)
    8. time check: 10 minutes passed (rgoulding, 17:48:34)
    9. this seems like a reasonable timeframe for both odlparent and yangtools at this point (rgoulding, 17:49:31)
    10. two issues are: one is the integration window, the other one is the resource split (rgoulding, 17:50:47)

  6. elimination of web.xml (rgoulding, 17:51:13)
    1. https://lists.opendaylight.org/pipermail/neutron-dev/2018-February/001607.html (rgoulding, 17:51:27)
    2. rovarga draws parallels to CSS vs BP and protocol-framework vs netty (rgoulding, 17:53:27)
    3. rovarga raises point about using something else like CXF (rgoulding, 17:56:18)
    4. which is already bundled in Karaf (rgoulding, 17:56:25)
    5. vorburger isn’t necessarily talking about replacing jax-rs, but rather just using this API as a plausible alternative to existing pax-web infrastructure included in karaf (rgoulding, 17:59:04)
    6. ACTION: TSC members on this call to bring to the TSC about our project governance Re: “project maturity (rgoulding, 18:05:25)
    7. ACTION: vorburger to propose an impl in a separate gerrit (rgoulding, 18:09:02)
    8. api vs impl and where this is going to actually be located (rgoulding, 18:09:20)
    9. ACTION: vorburger to put together a AAA gerrit to show how it would use this implementation natively. then vorburger will push the api and impl in infrautils, then switch AAA to use that. (rgoulding, 18:20:47)

  7. isolation issue (rgoulding, 18:26:04)
    1. https://lists.opendaylight.org/pipermail/controller-dev/2018-February/014245.html (rgoulding, 18:26:06)
    2. first issue is akka code, not ODL (rgoulding, 18:26:52)
    3. second issue, if you isolate shard leader, akka sees it is unreachable, the followers don’t see heartbeat, should re-elect leader (rgoulding, 18:27:16)
    4. tpantelis suggest enabling debug logging on akka specific classes (rgoulding, 18:28:10)
    5. read through the logs to determine the specific issue (rgoulding, 18:28:27)
    6. geo-clustering isn’t tested in public really at all (rgoulding, 18:29:01)
    7. we would need full logs to be able to determine whether this is a bug or expected behavior given the circumstance (rgoulding, 18:29:21)
    8. this is essentially a 3-node cluster as far as voting goes since the redundant cluster nodes are not elegible to be elected leader (rgoulding, 18:29:59)
    9. ACTION: Chethana to open a bug with enhanced logs in public (rgoulding, 18:33:24)
    10. and enhanced details about the config (rgoulding, 18:33:46)
    11. this was not tried with a 3 node cluster (rgoulding, 18:36:08)
    12. ACTION: Chethana to test a 3 node cluster too (rgoulding, 18:36:19)
    13. cookies (rgoulding, 18:41:12)


Meeting ended at 18:41:15 UTC (full logs).

Action items

  1. luis to take a further look to use an older version that may not suffer same bug
  2. rgoulding to look at whether we can achieve something similar in int/dist
  3. tpantelis to attempt a squash of the two patches to see if this fixes things on non-local setup
  4. vorburger to rebase this patch
  5. vorburger to set up weather item relating to this
  6. TSC members on this call to bring to the TSC about our project governance Re: “project maturity
  7. vorburger to propose an impl in a separate gerrit
  8. vorburger to put together a AAA gerrit to show how it would use this implementation natively. then vorburger will push the api and impl in infrautils, then switch AAA to use that.
  9. Chethana to open a bug with enhanced logs in public
  10. Chethana to test a 3 node cluster too


Action items, by person

  1. rgoulding
    1. rgoulding to look at whether we can achieve something similar in int/dist
  2. UNASSIGNED
    1. luis to take a further look to use an older version that may not suffer same bug
    2. tpantelis to attempt a squash of the two patches to see if this fixes things on non-local setup
    3. vorburger to rebase this patch
    4. vorburger to set up weather item relating to this
    5. TSC members on this call to bring to the TSC about our project governance Re: “project maturity
    6. vorburger to propose an impl in a separate gerrit
    7. vorburger to put together a AAA gerrit to show how it would use this implementation natively. then vorburger will push the api and impl in infrautils, then switch AAA to use that.
    8. Chethana to open a bug with enhanced logs in public
    9. Chethana to test a 3 node cluster too


People present (lines said)

  1. rgoulding (98)
  2. odl_meetbot (6)
  3. dfarrell07 (4)
  4. skitt (2)
  5. jamoluhrsen (2)
  6. rovarga_ (2)


Generated by MeetBot 0.1.4.