16:01:31 <rgoulding> #startmeeting kernel projects
16:01:31 <odl_meetbot> Meeting started Tue Mar 20 16:01:31 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:31 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:01:36 <rgoulding> #topic agenda bashing
16:01:42 <rgoulding> #info review existing action items
16:01:48 <rgoulding> #info cancel next week’s meeting
16:04:11 <rgoulding> #topic existing action items
16:04:24 <rgoulding> #info tpantelis to investigate the TCCL issues in 68840
16:04:33 <rgoulding> #info vorburger to create a Jira utilizing older patchset to illustrate the issue
16:04:38 <rgoulding> #info both DONE
16:06:01 <rgoulding> #topic Cancel next weeks call; many kernel contributors will be at ONS
16:07:48 <rgoulding> #topic web service api in AAA
16:08:45 <rgoulding> #info a single API might be easier since they seem to go together logically
16:17:17 <vorburger> rgoulding: something totally different, not related to the authentication discussion going on, will you review and test https://git.opendaylight.org/gerrit/#/c/69411/ some time?
16:17:45 <rgoulding> sure, I had before but I will after the rest of the recent changes again to ensure it doesn’t break anything!
16:17:59 <rgoulding> #action rgoulding to test https://git.opendaylight.org/gerrit/#/c/69411/ locally
16:20:30 <rgoulding> #action tpantelis to take another look and follow up on API patches
16:26:52 <rgoulding> #topic NETCONF committers
16:27:05 <rgoulding> #info make sure to add “JakubToth” with no space instead of “Jakub Toth"
16:35:09 <rgoulding> #link https://lists.opendaylight.org/pipermail/infrastructure/
16:35:21 <rgoulding> #info this list is used for infrastructure related issues
16:36:59 <rgoulding> #topic removal of DCL
16:37:37 <rgoulding> #info tpantelis put in Oxygen release notes that it will be removed in Fluorine
16:38:56 <rgoulding> #info one user in ovsdb but not as DCL, just using it as a DTO
16:39:30 <rgoulding> #info put in milestone, pick a date, enter a weather item, and pull the trigger
16:40:10 <rgoulding> #topic removal of EOS API in controller
16:40:18 <rgoulding> #info just ovsdb as a remaining user
16:41:45 <rgoulding> #topic config subsystem removal
16:42:02 <rgoulding> #info tpantelis had said in release notes that it was deprecated in Nitrogen and would be removed in Fluorine
16:42:42 <rgoulding> #info the issue with partial removal is that we will have to keep some APIs and config yang around
16:42:48 <rgoulding> #info we can discuss this at DDF
16:43:54 <rgoulding> #topic sal-dom-api removal
16:44:03 <rgoulding> #info everything in sal-dom-api hs a counterpart in mdsal now
16:44:19 <rgoulding> #info deprecate all apis in the controller to start the ticking clock
16:47:20 <rgoulding> #info this is why DCL removal is first on the list
16:47:28 <rgoulding> #info since there is not a counterpart for that
16:53:14 <rgoulding> #topic which parent to use
16:53:31 <rgoulding> #info use binding-parent, which derives from odlparent’s bundle-parent
16:53:38 <rgoulding> #link https://github.com/opendaylight/mdsal/blob/master/binding/binding-parent/pom.xml#L14
16:54:41 <rgoulding> #endmeeting