16:01:55 <rgoulding> #startmeeting kernel projects
16:01:55 <odl_meetbot> Meeting started Tue Apr  3 16:01:55 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:55 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:01:59 <rgoulding> #topic agenda bashing
16:07:16 <rgoulding> #info yangtools json patch request
16:07:27 <rgoulding> #topic yangtools json patch request
16:08:06 <rgoulding> #link https://lists.opendaylight.org/pipermail/yangtools-dev/2018-April/002218.html
16:08:50 <rgoulding> #info patch that was reverted
16:08:52 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/68436/
16:09:02 <rgoulding> #info Atul is asking how to do this correctly?
16:09:16 <rgoulding> #info the patch is correct but downstreams need to adopt to the changes
16:09:56 <rgoulding> #info revert patch here
16:09:58 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/70056/
16:11:31 <rgoulding> #info bug link
16:11:33 <rgoulding> #link https://jira.opendaylight.org/browse/NETCONF-486
16:15:48 <rgoulding> #topic NETCONF-526
16:15:53 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/69482/
16:16:01 <rgoulding> #link https://jira.opendaylight.org/browse/NETCONF-526
16:19:10 <rgoulding> #info the issue is that this fixes this just for RESTCONF API and not for other APIS
16:19:56 <rgoulding> #info Bala claims that this will only come into effect if there is not operation specified
16:26:02 <rgoulding> #action jmorvay to look at the patch again and see if this will break someone not using RESTCONF (i.e., using NETCONF transaction APIs), and if it doesn’t appear to break others then it is acceptable.  But this is basically cahnging the “edit-config” operation we are sending to a device
16:33:22 <rgoulding> #info tpantelis says this may be the lesser of two evils
16:35:23 <rgoulding> #info we should emulate the same behaviour in RFC8040 impl
16:36:39 <rgoulding> #info advice given to push to master then cherry-pick down to past stable branches
16:39:07 <rgoulding> #info use topic branches!
16:39:20 <rgoulding> #info git review -t <topic-branch>
16:44:51 <rgoulding> #endmeeting