15:58:47 <rgoulding> #startmeeting kernel projects
15:58:47 <odl_meetbot> Meeting started Tue Apr 10 15:58:47 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:58:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:58:47 <odl_meetbot> The meeting name has been set to 'kernel_projects'
15:58:51 <rgoulding> #topic agenda bashing
15:58:59 <rgoulding> #info vorburger: distribution odl-integration-all SingleFeatureTest Build timed out (after 120 minutes) next steps?
15:59:09 <rgoulding> #info vorburger: Anyone got any memories if in JAXB it's OK to have non-trivial getters, or if any known weird timing concurrency issues? Asking for https://jira.opendaylight.org/browse/NEUTRON-159 where a trival JSON un-marhshalling fails tests arbitrarily every now and then.
16:02:47 <rgoulding> #info configurable NETCONF HELLO message
16:04:51 <rgoulding> #topic distribution odl-integration-all SingleFeatureTest Build timed out (after 120 minutes) next steps?
16:05:14 <rgoulding> #info happening in master
16:05:30 <rgoulding> #info vorburger has seen this multiple times in many changes
16:06:07 <vorburger> #link https://jenkins.opendaylight.org/releng/job/neutron-distribution-check-fluorine/26/console
16:07:29 <rgoulding> #info need the logs from SFT to see what is actually happening
16:07:45 <rgoulding> #info rovarga claims this should have timed out much sooner
16:07:54 <rgoulding> #info since SFT has timeout much less than 120 minutes
16:09:06 <rgoulding> #info logs are not kept by default right now
16:09:10 <rgoulding> #undo
16:09:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2a4f150>
16:09:18 <rgoulding> #info surefire logs aren’t kept by default right now
16:09:30 <rgoulding> #info configure those logs to be output somewhere else might be a solution
16:13:13 <rgoulding> #info integration/distribution could be bumped to utilize a SNAPSHOT for debugging purposes
16:14:25 <rgoulding> #action vorburger to set up some scaffolding to keep logs for SFT for odlparent 3.1.X
16:15:32 <rgoulding> #topic Anyone got any memories if in JAXB it's OK to have non-trivial getters, or if any known weird timing concurrency issues? Asking for https://jira.opendaylight.org/browse/NEUTRON-159 where a trival JSON un-marhshalling fails tests arbitrarily every now and then.
16:16:17 <rgoulding> #link https://jira.opendaylight.org/browse/NEUTRON-159
16:17:35 <rgoulding> #topic Configurable NETCONF HELLO message
16:23:41 <rgoulding> #topic SFT timeout
16:24:14 <rgoulding> #info if the timeout on int/dist cross project feature dependency issue, is this something we can redo?
16:24:44 <rgoulding> #info there is an email to assist figuring out how to recreate this
16:27:40 <rgoulding> #topic javax.annotation issue
16:27:57 <rgoulding> #info yanglib feature from NETCONF should be removed from odl-integration-compatible-with-all
16:28:15 <rovarga_> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/distribution-verify-oxygen/234/console.log.gz
16:30:58 <rgoulding> #action jmorvay to look at imports for the yanglib artifact to resolve the divergent dependency chain issue
16:32:07 <rgoulding> #info similar patch from past: https://git.opendaylight.org/gerrit/#/c/68255/
16:32:09 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/68255/
16:32:26 <rovarga_> <Import-Package>*,
16:32:27 <rovarga_> com.sun.jersey.spi.container.servlet, org.eclipse.jetty.servlets</Import-Package>
16:33:14 <rovarga_> Import-Package: com.google.common.base;version="[23.6,24)",com.google.
16:33:16 <rovarga_> common.collect;version="[23.6,24)",com.google.common.io;version="[23.
16:33:18 <rovarga_> 6,24)",com.google.common.util.concurrent;version="[23.6,24)",javax.an
16:33:19 <rovarga_> notation
16:34:10 <rgoulding> #link https://github.com/opendaylight/netconf/blob/master/netconf/yanglib/pom.xml#L34
16:35:18 <rgoulding> #info So do something like “!javax.annotation,
16:35:19 <rgoulding> javax.ws.rs.*;version=“[1.1.0,2.0.0)”   in the context of yanglib
16:35:44 <rgoulding> #action jmorvay to look into raising patch for this
16:35:52 <rgoulding> #undo
16:35:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2c38850>
16:36:15 <rgoulding> #action jmorvay to look into raising patch for excluding javax.annotation and a particular version for javax.ws.rs
16:41:30 <rgoulding> #action rgoulding to open bug to have WebContextRegistration to extend ObjectRegistration
16:45:24 <rgoulding> #info alternative is to move AAA to jersey2, and see if the other projects are unaffected
16:50:32 <rgoulding> #link https://github.com/opendaylight/aaa/blob/master/aaa-shiro/impl/src/main/java/org/opendaylight/aaa/shiro/web/env/WebInitializer.java#L42
16:50:59 <rgoulding> #info is it useful to not repeat this everywhere and do the import in the pom.xml
16:51:26 <rgoulding> #info can we hide this behind some API?
16:51:36 <JMorvay> Patch for specific javax.ws.rs in yanglib https://git.opendaylight.org/gerrit/#/c/70726/
16:53:59 <rgoulding> #info does the jax-rs api have a way to give you the implementation of the servlet
16:54:09 <jamoluhrsen> skitt: I hear a harp
16:54:22 <skitt> jamoluhrsen, my daughter providing background music as usual ;-)
16:54:30 <jamoluhrsen> cool
16:54:39 <skitt> it's her calming contribution to the kernel calls
16:54:55 <rovarga_> skitt: please do thank her for that :)
16:55:03 <skitt> will do!
17:01:47 <rgoulding> #info rovarga brings up point that we could create a utility bundle which you can pass a jax-rs Application to and register your servlet with the web-api
17:02:56 <rgoulding> #info separate out a bundle
17:05:02 <vorburger> c/70354
17:05:11 <vorburger> https://jira.opendaylight.org/browse/ODLPARENT-148
17:07:19 <skitt> weird, this build sat there doing *nothing* for ~20 min: https://jenkins.opendaylight.org/releng/job/distribution-verify-oxygen/235/console
17:07:30 <skitt> look for 16:44:23 — 17:03:46
17:07:58 <skitt> infra pauses for 20 min would cause issues in CSIT :-/
17:08:01 <skitt> jamoluhrsen, ^^
17:08:26 <jamoluhrsen> skitt: looking
17:09:10 <rgoulding> #endmeeting