16:01:31 <rgoulding> #startmeeting kernel projects
16:01:31 <odl_meetbot> Meeting started Tue Apr 17 16:01:31 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:31 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:01:37 <rgoulding> #topic agenda bashing
16:01:49 <skitt> I’ll be along in a couple of minutes, finishing the NetVirt call
16:01:58 <rgoulding> #info odlparent 3.1.0 and yangtools 2.0.3 upgrade status
16:04:12 <rgoulding> #info increase in frequency in pax-exam timeouts
16:04:28 <rgoulding> #topic increase in frequency in pax-exam timeouts
16:04:50 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/71041/
16:05:44 <rgoulding> #info vorburger:  in the pax-exam tests you can specify the base karaf that you want to deploy into, and asks what the target is
16:06:13 <rgoulding> #info these tests are set to use opendaylight-karaf-empty, which should be already converted to equinox
16:07:49 <rgoulding> #info are we overriding it in the controller poms?
16:12:21 <rgoulding> #info Exception— “  ServiceLookupException: gave up waiting for service org.ops4j.pax.exam.ProbeInvoker"
16:12:34 <rgoulding> #info this used to happen but is happening much more frequently now
16:12:48 <rgoulding> #info rovarga there is probably a race and the race window opened
16:12:56 <rgoulding> #info this doesn’t reproduce locally
16:13:58 <rgoulding> #info either this is reproducible locally or we need to retain the appropriate logs from jenkins to properly investigate
16:14:57 <rgoulding> #info the appropriate information is not put into collected surefire logs
16:15:47 <rgoulding> #info binding ITs are not using surefire, they are using failsafe
16:16:02 <rgoulding> #info the toaster tests are using failsafe not surefire
16:19:27 <rgoulding> #info fire off an email to integration to save off the correct information if test timeout after 2 hours
16:20:58 <rgoulding> #info rovarga was able to reproduce locally
16:22:12 <rgoulding> #info rovarga has logs and can ship over karaf.log
16:22:15 <rgoulding> #link https://lists.opendaylight.org/pipermail/controller-dev/2018-April/014350.html
16:22:21 <rgoulding> #info ^^ mail for this issue
16:22:59 <rgoulding> #info sal-binding-it is pulling in jersey-core, and the same issues are happening that happened with AAA
16:23:43 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/70979/
16:23:48 <rgoulding> #info ^^ fix in AAA
16:26:50 <rgoulding> #info pax-exam is getting messed up if the feature service has trouble getting deployed
16:40:50 <rgoulding> #action tpantelis to try to remove jersey-core dependency (optional) to see if it is actually needed for the tests
16:42:19 <rgoulding> #info this might have been used in formatting controller-config.xml, and may not be needed anymore
16:45:43 <rgoulding> #topic web centralization
16:49:18 <rgoulding> #info we are changing api version so we need to recompile every consumer to make sure this would work.  we would need to create an adaptor of javax.ws.rs-api in order to do this in a “single switch”
16:52:00 <rgoulding> #topic odlparent 3.1.0 and yangtools 2.0.3 upgrade
16:53:24 <rgoulding> #info stable/oxygen was upgraded to odlparent 3.1.0 to get karaf upgrade
16:54:06 <rgoulding> #info upgrade patches have been merged
16:54:35 <rgoulding> #endmeeting