16:01:44 <rgoulding> #startmeeting kernel projects
16:01:44 <odl_meetbot> Meeting started Tue May 29 16:01:44 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:44 <odl_meetbot> The meeting name has been set to 'kernel_projects'
16:02:00 <rgoulding> #topic agenda bashing
16:02:09 <rgoulding> #link https://jira.opendaylight.org/browse/INFRAUTILS-41
16:02:18 <rgoulding> #link https://jira.opendaylight.org/browse/TSC-113
16:02:28 <rgoulding> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2018-May/006878.html
16:02:37 <rgoulding> #link https://lists.opendaylight.org/pipermail/tsc/2018-May/009739.html
16:04:24 <rgoulding> #info Removal of some deprecated APIS in NETCONF
16:05:04 <rgoulding> #info jersey2 update
16:05:43 <rgoulding> #info swagger UI bug
16:06:13 <rgoulding> #topic INFRAUTILS-41
16:06:26 <rgoulding> #link https://jira.opendaylight.org/browse/INFRAUTILS-41
16:06:45 <rgoulding> #info vorburger wants to know plan/next steps
16:07:00 <rgoulding> #info this is for upgrading dropwizard.metrics from 3.2.5 to 4.0.2
16:08:08 <rgoulding> #info rovarga asks if this is provided by other JVMs
16:08:33 <rgoulding> #info vorburger says he has found that it exists in OpenJDK, but hasn’t tested for IBM’s JDK9
16:08:58 <rgoulding> #info definitely good on OpenJDK and Oracle
16:09:06 <rgoulding> #info provides GC stats and other JVM things
16:10:26 <rgoulding> #info skitt brings up the fact that dropwizard should have an optional dependency on this
16:10:35 <rgoulding> #info the manifest should make it optional?
16:11:29 <rgoulding> #info rovarga says that if it isn’t optional then ODL will fail to load if the JVM does not have it
16:11:54 <rgoulding> #info the question becomes whether the metrics are mission critical;  rovarga claims they are not
16:15:53 <rgoulding> #topic TSC-113
16:15:57 <rgoulding> #link https://jira.opendaylight.org/browse/TSC-113
16:16:20 <rgoulding> #info upgrade webapps to use jersey 2
16:16:32 <rgoulding> #info tpantelis is driving this forward
16:16:56 <rgoulding> #info tpantelis is running the multi-patch job to test if this works
16:17:01 <rgoulding> #info neutron patch was already merged
16:17:41 <rgoulding> #info tpantelis ran into same problem with dual dependency chain via javax.annotation in the aaa / netconf patches
16:18:05 <rgoulding> #info the two patches need each other (i.e., this will break temporarily)
16:19:57 <rgoulding> #info we are waiting on a successful multi-patch job
16:20:29 <rgoulding> #info jmorvay to check after the meeting and add +1, then tpantelis can self-merge
16:20:34 <rgoulding> #info for netconf
16:20:45 <rgoulding> #info tpantelis and rgoulding can do it for AAA
16:20:56 <rgoulding> #info passing multi-patch is a gating requirement
16:21:01 <rgoulding> #agreed
16:21:46 <rgoulding> #info should we run netvirt csit?
16:22:00 <rgoulding> #info skitt claims it is in a good state right now, so if failures occur there is probably a problem
16:22:30 <skitt> #info to run netvirt CIST, use test-netvirt-current
16:22:51 <rgoulding> #info to run on a multi-patch job there is a different keyword required
16:23:02 <rgoulding> #info you need to supply the url of your multi-patch-job build and pass it to CSIT
16:24:41 <rgoulding> #topic Autorelease oxygen failed to build odl-netvirt-openstack from netvirt
16:24:48 <rgoulding> #link https://lists.opendaylight.org/pipermail/netvirt-dev/2018-May/006878.html
16:24:54 <rgoulding> #info this has moved on on list discussions
16:25:11 <rgoulding> #topic Request to split genius repo to enhance usability by other projects
16:25:29 <rgoulding> #link https://lists.opendaylight.org/pipermail/tsc/2018-May/009739.html
16:25:38 <rgoulding> #info this one is panning out on mailing lists
16:25:58 <rgoulding> #topic Removal of some deprecated APIS in NETCONF
16:26:46 <rgoulding> #info netconf is using many deprecated yangtools, mdsal and controller APIs
16:26:53 <rgoulding> #info we need to adapt to new counterparts
16:27:44 <rgoulding> #info also, there are many places where NETCONF code exposes deprecated APIs, such as protocol-framework, that we should have a plan to remove such abstractions
16:28:35 <rgoulding> #info removal of the former (usage of deprecated APIs) is blocking upstreams from removing the APIs
16:28:43 <rgoulding> #info we want to garner support to help with removal of such concepts
16:29:07 <rgoulding> #info the question arrises, how do we get people to work on such things?
16:29:43 <rgoulding> #info rovarga suggests making a task list that we can prioritize
16:29:53 <rgoulding> #info one big thing is to get rid of the protocol-framework
16:30:03 <rgoulding> #info and migration to plain netty or mina
16:31:18 <rgoulding> #action jmorvay to create JIRA tasks to showcase some of the places we can clean up
16:36:55 <rgoulding> #topic DCL Removal Discussion
16:37:10 <rgoulding> #info there is one last patch to remove DCL
16:37:47 <rgoulding> #link https://lists.opendaylight.org/pipermail/release/2018-May/015217.html
16:37:53 <rgoulding> #info should we agree to merge this?
16:37:55 <rgoulding> #agreed
16:38:00 <rgoulding> #info rovarga merged.
16:38:24 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/71801/
16:38:34 <rgoulding> #topic config subsystem removal
16:38:44 <rgoulding> #info tpantelis claims no upstream projects have used for a while
16:38:55 <rgoulding> #info downstreams should be migrated by now (we hope)
16:39:07 <rgoulding> #info archetype was changed a while ago to utilize blueprint
16:39:19 <rgoulding> #action tpantelis to send out final removal notice for when it is timed
16:41:18 <rgoulding> #info tpantelis claims that he removed the CSS northbound loopback
16:43:35 <rgoulding> #info NetconfMonitoringActivator shouldn’t be there
16:43:37 <rgoulding> #link https://github.com/opendaylight/netconf/blob/master/netconf/netconf-monitoring/src/main/java/org/opendaylight/netconf/monitoring/osgi/NetconfMonitoringActivator.java
16:43:44 <rgoulding> #info so we should work to remove
16:44:53 <rgoulding> #info tpantelis already migrated XML stuff to NETCONF;  it was only like 3 classes
16:47:16 <rgoulding> #topic SUBMIT removal
16:47:41 <rgoulding> #action AsyncWriteTransaction is only used in controller, so once we switch that we can remove it there
16:47:56 <rgoulding> #undo
16:47:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2b84a50>
16:48:13 <rgoulding> #action AsyncWriteTransaction.submit() is only used in controller, so once we switch that we can remove it there
16:56:42 <rgoulding> #topic removal of controller mdsal apis
16:56:52 <rgoulding> #info tpantelis is looking into a plan for removing these
16:56:58 <rgoulding> #info this could also solve CheckedFuture removal
16:57:45 <rgoulding> #info vorbuger brings up the point that a demo patch of this would help other projects adapt
16:59:35 <rgoulding> #action tpantelis to look at what other API(s) include CheckedFuture in the signature
16:59:52 <rgoulding> #info this is made easier since only Controller is consuming many of these
17:01:22 <rgoulding> #endmeeting