15:58:03 <rgoulding> #startmeeting kernel projects
15:58:03 <odl_meetbot> Meeting started Tue Jul  3 15:58:03 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:58:03 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:58:03 <odl_meetbot> The meeting name has been set to 'kernel_projects'
15:58:08 <rgoulding> #topic agenda bashing
15:58:18 <rgoulding> #info AAA AuthZ/AuthN + RESTCONF
15:58:27 <rgoulding> #link https://jira.opendaylight.org/browse/ODLPARENT-100
15:58:39 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/73672/
16:01:54 <vpickard> #info Clustering CSIT
16:02:18 <shague> #link https://jira.opendaylight.org/browse/NETVIRT-1315 clustering CSIT
16:06:23 <rgoulding> #topic NETVIRT-1315
16:06:26 <rgoulding> #link https://jira.opendaylight.org/browse/NETVIRT-1315
16:07:52 <rgoulding> #info vpickard has created a google doc of the controller CSIT jobas
16:08:13 <rgoulding> #info vpickard is sharing the document, but we don’t have a public link at this point
16:08:45 <rgoulding> #info Oxygen/Ask based is what vpickard has focused on thus far
16:09:25 <rgoulding> #info He looked at several jobs, and most of the jobs pass consistently.  There are some intermittent failures that occur, but they are generally pretty catostrophic failures
16:09:59 <rgoulding> #info tpantelis brought up that we really need to understand what these tests do
16:10:20 <rgoulding> #info tpantelis brings up that some of this has to deal with technology that is not fully baked (i.e., prefix-based sharding, etc.)
16:10:48 <rgoulding> #info jamoluhrsen asks what does “half baked” mean
16:10:55 <rgoulding> #info does that mean we shouldn’t care about the failures?
16:11:18 <rgoulding> #info for example, what does “chasing the leader” do?
16:11:31 <rgoulding> #info rovarga states that there is a test scenario document to go with these test suites
16:13:12 <rovarga> #info int/test/docs/cluster/carbon/scerarios.rst
16:14:04 <rgoulding> #link https://github.com/opendaylight/integration-test/blob/master/docs/cluster/carbon/scenarios.rst
16:17:07 <rgoulding> #action vpickard to review the scenarios file, and figure out if the tests that are failing are ones we actually care about
16:17:23 <rgoulding> #info vpickard brings up he will need help on figuring out what ones we don’t actually care about
16:19:20 <rgoulding> #info rovarga brings up the fact that refactoring the test suite to focus on individual cases and scenarios might be a good idea, but the original design was to keep it all in an “uber test suite”
16:20:17 <rgoulding> #topic CONTROLLER-1845
16:20:23 <rgoulding> #info controller takes 7 minutes to start
16:23:23 <rgoulding> #info vpickard asks how to debug karaf hanging on startup
16:23:56 <rgoulding> #info tpantelis brings up the fact that running jstack and grabbing a thread dump would be helpful
16:25:39 <rgoulding> #info vorburger brings up that before we focus on how to reproduce this first, perhpas locally
16:26:26 <rgoulding> #info tpantelis says “kill -3 <pid>” will dump to the stdout location
16:27:54 <rgoulding> #topic CONTROLLER-1848
16:28:54 <rgoulding> #info leader cannot perform its duties
16:29:18 <rgoulding> #info tpantelis says that this is expected in this scenario
16:30:41 <rgoulding> #topic OPNFLWPLUG-1022
16:30:49 <rgoulding> #info exception during ODL startup in cluster
16:31:29 <rgoulding> #info OptimisticLockFailedException is failure in application code usually
16:31:32 <rgoulding> #info they are taking offline
16:31:40 <rgoulding> #optpic CONTROLLER-1844
16:31:52 <rgoulding> #info incompatibility between restconf-noauth and restconf
16:32:21 <rgoulding> #info the two features are incompatible
16:33:07 <rgoulding> #topic AAA authorization/authentication + RESTCONF
16:34:46 <rgoulding> #info is eventually consistent data fine?
16:34:59 <vorburger> pantelis: background noise may have been me, muted
16:35:37 <rovarga> #link https://git.opendaylight.org/gerrit/73475
16:35:43 <rovarga> #link https://git.opendaylight.org/gerrit/73455
16:40:31 <rgoulding> #action rgoulding to update documentation on eventual consistency
16:41:01 <rgoulding> #info everyone agrees that this tradeoff is fine
16:43:14 <rgoulding> #topic ODLPARENT-100
16:43:30 <rgoulding> #info include error-prone as an opt-in (or opt-out?) feature
16:43:54 <rgoulding> #info rovarga asks how complete the code is for this
16:44:11 <rgoulding> #info vorburger says they are running with this, and it is more than a prototype
16:44:25 <rgoulding> #info vorburger brings up that this might be a good thing to upstream to odlparent
16:46:13 <rgoulding> #link https://github.com/opendaylight/infrautils/blob/master/common/parent/pom.xml#L121
16:48:03 <rgoulding> #info extension of this must be made possible since some projects may not care about some rules
16:49:35 <rgoulding> #topic Bump maven-blueprint-plugin to 1.10.0
16:49:38 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/73672/
16:50:46 <rgoulding> #info this is used extensively in netvirt / genius
16:50:54 <rgoulding> #info it allows annotation based dependency injection
16:51:08 <rgoulding> #action vorburger will comment to bundle that utilizes this
16:51:23 <rgoulding> #info there were issues when we tried to upgrade to 1.5 in the past
16:52:01 <rgoulding> #link https://wiki.opendaylight.org/view/BestPractices/DI_Guidelines#NEW:_.40OsgiService_.26_.40OsgiServiceProvider_.28pax-cdi-api.29
16:52:08 <rgoulding> #info may be dated 1.5 years old
16:53:35 <rovarga> #link https://jira.opendaylight.org/browse/TSC-124
16:53:50 <rgoulding> #topic RFC8345 defines ietf-network(-topology), which we should adopt
16:53:57 <rgoulding> #link https://jira.opendaylight.org/browse/TSC-124
16:54:01 <rgoulding> #link https://jira.opendaylight.org/browse/TSC-125
16:54:11 <rgoulding> #info ^^ companion link
16:54:57 <rgoulding> #info do we ever want to move away from draft models or not?
16:55:08 <rgoulding> #link https://git.opendaylight.org/gerrit/#/c/73661/10/netconf/netconf-console/src/test/resources/schemas/ietf-network%25402018-02-26.yang
16:55:31 <jamoluhrsen> rgoulding: did you guys agree that "AAA authorization/authentication + RESTCONF" patches will be merged?
16:55:52 <rgoulding> jamoluhrsen:  we agreed on the approach, we need to do a final review first
16:55:59 <jamoluhrsen> rgoulding: ack.
16:56:29 <jamoluhrsen> rgoulding: I'm running some tests (rest car perf csit) with those patches.
16:57:59 <rgoulding> #info vishnoianil asks if there is any significant reason to upgrade on the NB side
17:00:56 <rgoulding> #info rovarga says that the upside is getting rid of deprecated models/ warnings
17:01:25 <rgoulding> #info anytime you touch a class marked as deprecated then you will get a deprecation warning
17:10:37 <rgoulding> #endmeeting