15:57:20 <rgoulding> #startmeeting kernel projects
15:57:20 <odl_meetbot> Meeting started Tue Aug  7 15:57:20 2018 UTC.  The chair is rgoulding. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:57:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:57:20 <odl_meetbot> The meeting name has been set to 'kernel_projects'
15:57:24 <rgoulding> #topic agenda bashing
15:57:32 <rgoulding> #info OpenEXI vs EXIficient interoperability issue
15:57:49 <rgoulding> #info MD-SAL near-term future
15:57:56 <rgoulding> #info Neon MRI Integration Window
16:03:50 <vorburger> oups - joining
16:06:18 <rgoulding> #topic OpenEXI vs EXIficient interoperability issue
16:06:47 <rgoulding> #link https://lists.opendaylight.org/pipermail/netconf-dev/2018-August/001912.html
16:06:58 <rgoulding> #info there is an interoperability issue between the two
16:07:11 <rgoulding> #info fluroine ODL won’t work with oxygen TT and vice versa
16:07:23 <rgoulding> #info fluorine ODL with fluorine test tool should work fine
16:07:39 <rgoulding> #info jmorvay has made change in fluroine CSIT to utilize fluroine test tool
16:07:50 <rgoulding> #info jmorvay was able to successfully mount the test tool and two other devices
16:07:55 <rgoulding> #info manually ^^
16:09:04 <rgoulding> #info honeycomb uses ODL netconf northbound based on Oxygen, and this won’t work with Fluorine
16:09:35 <rgoulding> #info OpenEXI hosted at sourceforge
16:10:05 <rgoulding> #info releases not maintained, mailing lists not monitored
16:10:42 <rgoulding> #info Exificient is still maintained
16:12:25 <rgoulding> #info or tern off exi on honeycomb server
16:13:11 <rgoulding> #action jmorvay to release note this limitation
16:16:24 <rgoulding> #topic clustering update
16:16:40 <rgoulding> #info no specific updates
16:17:04 <rgoulding> #topic MD-SAL near-term future
16:17:10 <rgoulding> #info Fluroine branching strategy
16:17:13 <rgoulding> #info neon work items
16:17:37 <rovarga_> #link https://lists.opendaylight.org/pipermail/mdsal-dev/2018-August/001811.html
16:18:36 <rgoulding> #info rovarga pushing for some hard dates for start of Neon
16:18:48 <rgoulding> #info we are 4 weeks away from it as perceived by TSC
16:18:57 <rgoulding> #info but MD-SAL is transitioning to MRI
16:19:31 <rgoulding> #info so MD-SAL to start Neon as soon as Fluorine is branched
16:22:32 <rgoulding> #info the details of this conversation are derived form the above email ^^
16:24:08 <rgoulding> #info shague says the intention is to use the same model as fluorine for release of neon
16:24:24 <rgoulding> #info there are some assumptions but we do need to do proper release planning
16:24:57 <rgoulding> #info the implication is 3/7 and 9/7, but there is question as to whether this is documented
16:25:48 <rgoulding> #info deadlines for participating in certain release tracks needs better documentation
16:26:43 <rgoulding> #info Quote from Jamo: “n an attempt to synchronize with other related open source projects (e.g., OPNFV and OpenStack), OpenDaylight releases twice per year on a 6 month cadence. These releases are scheduled for September 7th and March 7th. These release dates are also used as the beginning for the subsequent release.”
16:26:54 <rgoulding> #link https://docs.opendaylight.org/en/latest/release-process/release-schedule.html?highlight=release%20schedule
16:30:02 <rgoulding> #info MRI integration window is also a question
16:30:38 <rgoulding> #info according to the existing docs, we could deduce 10/7?
16:30:44 <rgoulding> #info this needs to be spelled out better
16:32:01 <rgoulding> #info karaf 4.2 doesnt break yangtools/mdsal, but may break aaa/netconf etc.
16:32:20 <rgoulding> #info powermock upgrade may break some downstreams
16:33:19 <rgoulding> #info integration of yangtools will yield elimination of empty lists from the data store
16:33:33 <rgoulding> #info similar to containers
16:34:21 <rgoulding> #info shague asks if the powermock stuff we won’t know until we drop in, right?
16:35:30 <rgoulding> #info appears to be the case
16:35:52 <rgoulding> #info vorburger asks whether we can just use powermock 1 in certain projects
16:36:01 <rgoulding> yes, you can override
16:36:46 <rgoulding> #info then maintenance is owned by the downstream consumer
16:37:12 <rgoulding> #info it is driven by the project, you can overwrite the version
16:38:00 <rovarga_> #link https://git.opendaylight.org/gerrit/#/q/topic:neon-mri+(status:open+OR+status:merged)
16:38:07 <rovarga_> #info MRI integration multipatch topic
16:38:29 <rovarga_> #info https://jira.opendaylight.org/browse/TSC-132
16:39:57 <rgoulding> #endmeeting