17:03:22 <vorburger> #startmeeting kernel-projects
17:03:22 <odl_meetbot> Meeting started Tue Dec 18 17:03:22 2018 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:22 <odl_meetbot> The meeting name has been set to 'kernel_projects'
17:03:30 <vorburger> #topic Who's here
17:03:50 <vorburger> #info vorburger skitt TomP jmorvay
17:04:00 <vorburger> #topic Gerrits waiting for review
17:04:33 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/78433/
17:05:38 <vorburger> #info skitt says you had actually reviewed it, so we merged it now
17:05:55 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/78507/
17:08:00 <vorburger> #info skitt has +1 this ^^ one, we'll wait for rovarga to review it in January
17:08:03 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/78805/
17:10:38 <vorburger> #info TomP gave an explanation about c/78805 and skitt reviewed it on the fly and merged!
17:11:00 <vorburger> #topic oldparent bump
17:11:23 <vorburger> #info release either this week or in January
17:12:51 <vorburger> #info skitt looking at including something that prints the release name in the console branding and start up logs
17:13:21 <vorburger> #info waiting for Karaf 4.2.2 release which is about to drop
17:14:43 <vorburger> #info enable dependency convergence enforcement in autorelease
17:15:16 <vorburger> #info This will let us more quickly discover patches who have previous ODL versions that got merged after version bumps
17:16:17 <vorburger> #info the actual merge of the bump patches across projects would happen in January (but the odlparent 4.0.3 release could still happen this week)
17:17:28 <vorburger> #info This would be likely be the last odlparent for Neon, and open the door for starting to open odlparent 5.x for breaking changes, targeting Sodium (?)
17:18:42 <vorburger> #topic DataBroker controller vs mdsal API
17:18:54 <vorburger> #info skitt has an open patch to switch all of ovsdb over
17:19:23 <skitt> #link ovsdb patch: https://git.opendaylight.org/gerrit/78432
17:26:45 <vorburger> #info https://github.com/opendaylight/controller/blob/master/opendaylight/md-sal/sal-dom-compat/src/main/java/org/opendaylight/controller/sal/core/compat/DOMDataBrokerAdapter.java
17:27:06 <vorburger> #action vorburger to use this ^^^ to get opendaylight-simple to build again
17:28:21 <vorburger> #info we're discussion @Deprecated of controller API
17:29:05 <vorburger> #info we don't need to @Deprecate every single class, just the entry point Services
17:29:24 <vorburger> #info DataBroker already is, not clear if anything
17:29:43 <vorburger> #action TomP will have a closer look if anything still needs to have a @Deprecated slapped on it for Neon
17:33:49 <vorburger> #topic ODL Container?
17:33:57 <vorburger> #link https://github.com/opendaylight/integration-packaging/tree/master/docker
17:37:02 <vorburger> #endmeeting