18:00:31 <skitt> #startmeeting tsc
18:00:31 <odl_meetbot> Meeting started Thu Jan 11 18:00:31 2018 UTC.  The chair is skitt. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:31 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:37 <skitt> #topic Roll-call and agenda bashing
18:00:42 <skitt> #info TSC members please info in
18:00:55 <skitt> #chair CaseyODL
18:00:55 <odl_meetbot> Current chairs: CaseyODL skitt
18:01:43 <bjohnson> #info Brady Johnson
18:02:38 <skitt> #info skitt
18:02:41 <anipbu> #info anipbu
18:02:42 <jamoluhrsen> #info jamoluhrsen
18:02:43 <zxiiro> #info Thanh Ha
18:02:45 <rovarga_> #info rovarga_
18:02:58 <klou> #info klou (proxy for George Zhao)
18:03:17 <LuisGomez> #info LuisGomez
18:03:24 <LuisGomez> #info LuisGomez proxy for anil vishnoi
18:03:50 <lori> #info lori
18:04:33 <shague> #info shague
18:05:13 <skitt> #action abhijitkumbhare to start an email thread providing a proposal for proxy/delegate & request other TSC members to feedback
18:05:19 <skitt> #action abhijitkumbhare to initiate an email thread regarding the Singularity Principle
18:05:26 <skitt> #action CaseyODL to go write a straw-man/skeleton "How to get help" docs page in docs repo via Gerrit/Rst
18:05:49 <skitt> #action TSC to check the LFN Webinar and bring out a proposal to decide the TAC representative
18:06:37 <skitt> #action CaseyODL to respond to the DDF discussion on the mailing list
18:07:40 <skitt> #action rovarga to revive stalled discussions on TrieMap after he is back from the vacation
18:07:49 <skitt> #link last week’s minutes https://meetings.opendaylight.org/opendaylight-meeting/2018/tsc/opendaylight-meeting-tsc.2018-01-04-18.02.html
18:09:37 <skitt> #topic Mailing list discussions
18:09:47 <skitt> #info re Groups.io, auto-hashing will be added soon
18:10:06 <CaseyODL> https://www.irccloud.com/pastebin/kodDtSg2/
18:10:23 <skitt> #link what rejections look like if tags are enforced: https://www.irccloud.com/pastebin/kodDtSg2/
18:10:58 <skitt> #info the other Groups.io questions are still pending
18:12:01 <skitt> #info re the DDF, if we have the DDF on Monday or Tuesday, there will be scheduling conflicts
18:12:15 <skitt> #info if the DDF is on the Sunday, many people will have to travel on the previous Friday
18:12:45 <dfarrell07> #info One unanswered question from Fd.io I'll ado to CaseyODL's list: "What's their business model? Are we now going to be the product?"
18:12:56 <skitt> dfarrell07, excellent question
18:13:05 <skitt> dfarrell07, presumably the LF would be paying though
18:13:36 * zxiiro will be attending the XCI too
18:14:23 <skitt> #info only event on Sunday is OPNFV XCI
18:14:33 <skitt> #info Monday/Tuesday are dedicated to cross-project collaboration
18:14:41 <skitt> #info the CFP is ongoing so no schedule information yet
18:15:29 <bjohnson> #link https://events.linuxfoundation.org/events/open-networking-summit-north-america-2018/program/cfp/ ONS CFP info and scheduling
18:15:40 <bjohnson> #info CFP Closes: Sunday, January 14, 2018
18:15:51 <bjohnson> #info CFP Notifications: Tuesday, February 6, 2018
18:16:00 <bjohnson> #info Schedule Announcement: Thursday, February 8, 2018
18:17:33 <jamoluhrsen> +1 to bjohnson's idea to book a room each day and release them when we know for sure
18:17:38 <skitt> #info bjohnson suggests putting an option on a room for Sunday through Tuesday and cancelling when we know
18:18:12 <skitt> #info rovarga_ points out we should really discuss what we want from the DDF
18:18:43 <skitt> #info if cross-project collaboration is to be successful the DDF needs to take that into account
18:20:41 <rovarga_> skitt: CaseyODL: the keynotes are always awesome. always. no matter what. ;-)
18:20:55 <skitt> rovarga_, are you giving one this year? :-P
18:21:06 <rovarga_> skitt: I sure hope note :)
18:21:09 <rovarga_> not :)
18:25:51 <dfarrell07> I still like the idea of having a few hours each day for DDF stuff, just not putting other track talks relevant to ODL during that time
18:26:03 <skitt> #topic Oxygen
18:26:24 <skitt> #info still chasing M2/M3 status
18:26:33 <skitt> #info four projects still need to provide M2
18:26:49 <skitt> #info 17 for M2
18:26:51 <skitt> #undo
18:26:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2a20510>
18:26:56 <skitt> #info 17 for M3
18:27:03 <skitt> #info offset 0 is in M4 now
18:27:25 <skitt> #info klou sent reminders for M2 this morning (dlux, dluxapps, p4plugin, faas)
18:29:38 <skitt> #info dlux and dluxapps no longer have a PTL effectively
18:30:12 <skitt> #info TSC might need to step in and ask for contributors from consuming projects
18:30:21 <skitt> #info or investigate removing dlux/dluxapps
18:30:28 <skitt> #info perhaps we should introduce a maintenance mode
18:30:54 <skitt> #info to be defined
18:31:50 <skitt> #info having such projects creates problems for us wrt security etc.
18:33:43 <skitt> #info need to encourage mobility from downstreams to upstreams
18:33:56 <skitt> #info e.g. if a project uses dlux, encourage its contributors to contribute to dlux
18:35:07 <skitt> #info need to communicate upstream situation to downstreams
18:35:51 <skitt> #info downstreams are liable to lose features if their upstreams disappear
18:35:57 <skitt> #info which is a strong incentive to find a solution
18:37:55 <skitt> #info we should reach out to dlux and dluxapps to see what the situation is
18:38:20 <skitt> #info in a similar fashion to netconf recently
18:39:09 <skitt> #action bjohnson to reach out to Maxime re. dlux and dluxapps and his involvement
18:40:23 <skitt> #action lori to reach out to Daniel Malachovsky
18:40:36 <skitt> #undo
18:40:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x26b3090>
18:40:43 <skitt> #action rovarga_ to reach out to Daniel Malachovsky
18:41:54 <skitt> #info dlux and dluxapps are actively looking for contributors, so we should encourage people to step up
18:42:40 <skitt> #link odlparent 3 / yangtools 2 status: https://wiki.opendaylight.org/view/ODL_Root_Parent:BigBumpOfJan2018
18:43:02 <bjohnson> #info depending on the response from Maxime and Daniel, we will reach out to the projects asking someone else to step up and become PTL
18:43:11 <skitt> #link int/dist patch: https://git.opendaylight.org/gerrit/67013
18:50:17 <skitt> #info projects will all be broken, even for plain builds, until their upstreams have merged
18:50:23 <skitt> #info because yangtools 2 is a breaking upgrade
18:55:46 <skitt> #info once we start merging, we can fall back by reverting
18:56:11 <skitt> #info we need to timebox the change to avoid massive disruption in projects trying to meet the code freeze
18:57:36 <skitt> #info few projects are actively racing to meet the code freeze
18:57:42 <skitt> #info genius and netvirt in particular, sfc too
18:58:59 * dfarrell07 votes just do it
18:59:21 * bjohnson agreed
19:01:07 <dfarrell07> +1, bring in the supercommitter rights
19:01:49 <rovarga_> careful....
19:03:15 <dfarrell07> klou: we should write something into the F "joining release" step that gives TSC explicit permissions to use supercommitter rights in this case
19:03:29 <dfarrell07> and I'm okay just doing it now but I guess I'm a dictator at heart;)
19:05:19 <skitt> #startvote Does the TSC approve starting merges for odlparent 3 / yangtools 2 *right now*, and seeing where things stand on Monday? -1, 0, +1
19:05:19 <odl_meetbot> Begin voting on: Does the TSC approve starting merges for odlparent 3 / yangtools 2 *right now*, and seeing where things stand on Monday? Valid vote options are -1, 0, +1.
19:05:19 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:05:20 <dfarrell07> skitt: so start blowing stuff up
19:05:34 <zxiiro> #vote +1
19:05:35 <skitt> #vote +1
19:05:35 <rovarga_> #vote +1
19:05:37 <bjohnson> #vote +1
19:05:41 <lori> #vote +1
19:05:42 <jamoluhrsen> #vote +1
19:05:43 <LuisGomez> #vote +1
19:05:45 <anipbu> #vote +1
19:05:47 <klou> #vote +1 (for gzhao)
19:05:47 <odl_meetbot> klou: +1 (for gzhao) is not a valid option. Valid options are -1, 0, +1.
19:05:53 <shague> #vote +1
19:06:00 <klou> #vote +1
19:06:37 <skitt> #endvote
19:06:37 <odl_meetbot> Voted on "Does the TSC approve starting merges for odlparent 3 / yangtools 2 *right now*, and seeing where things stand on Monday?" Results are
19:06:37 <odl_meetbot> +1 (10): bjohnson, klou, skitt, anipbu, LuisGomez, shague, lori, jamoluhrsen, zxiiro, rovarga_
19:07:35 <skitt> #topic Cookies
19:07:35 <dfarrell07> burning cookies
19:07:40 <skitt> #endmeeting