18:00:40 <CaseyODL> #startmeeting tsc
18:00:40 <odl_meetbot> Meeting started Thu Jan 18 18:00:40 2018 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:40 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:40 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:47 <CaseyODL> #chair abhijitkumbhare skitt
18:00:47 <odl_meetbot> Current chairs: CaseyODL abhijitkumbhare skitt
18:00:59 <skitt> #topic Roll-call and agenda bashing
18:01:00 <bjohnson> #info Brady Johnson
18:01:06 <skitt> #info TSC members please info in
18:01:07 <abhijitkumbhare> #info abhijitkumbhare
18:01:07 <skitt> #info skitt
18:01:16 <gzhao> #info gzhao
18:01:25 <anipbu> #info anipbu
18:01:27 <jamoluhrsen> #info jamoluhrsen
18:04:44 <LuisGomez> #info LuisGomez
18:04:52 <abhijitkumbhare> #info Welcome Quan to the TSC meeting
18:05:12 <zxiiro> #info Thanh
18:05:47 <abhijitkumbhare> #topic Agenda
18:05:49 <abhijitkumbhare> https://wiki.opendaylight.org/view/TSC:Main#Agenda
18:07:03 <abhijitkumbhare> #info bjohnson suggests we discuss the code freeze deadline
18:07:46 <abhijitkumbhare> #action abhijitkumbhare to initiate an email thread regarding the Singularity Principle
18:08:08 <abhijitkumbhare> #action CaseyODL to go write a straw-man/skeleton "How to get help" docs page in docs repo via Gerrit/Rst
18:08:23 <abhijitkumbhare> #action rovarga to revive stalled discussions on TrieMap after he is back from the vacation
18:09:01 <abhijitkumbhare> #action bjohnson to reach out to Maxime re. dlux and dluxapps and his involvement
18:09:36 <abhijitkumbhare> #info bjohnson has already reached out
18:09:50 <abhijitkumbhare> #undo
18:09:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x28aee10>
18:09:53 <abhijitkumbhare> #undo
18:09:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x28aeb50>
18:10:33 <shague> #info shague
18:10:46 <rovarga> #info rovarga
18:11:27 <skitt> #topic TAC representative
18:11:36 <CaseyODL> Feel better!
18:11:55 <klou> +1
18:14:37 <abhijitkumbhare> #info Options:
18:14:47 <abhijitkumbhare> #info Option 1: The TSC Chair by default becomes the TAC representative
18:14:57 <abhijitkumbhare> #info Option 2: Another member of the TSC is elected by the TSC
18:15:10 <abhijitkumbhare> #info Option 3: Any interested committer approved by the TSC and elected by the TSC
18:16:05 <skitt> #info Option 4: further discussion
18:16:09 <lori> [sorry for being late, but I'm here now]
18:16:37 <skitt> #startvote Which option does the TSC prefer? 1, 2, 3, 4
18:16:37 <odl_meetbot> Begin voting on: Which option does the TSC prefer? Valid vote options are 1, 2, 3, 4.
18:16:37 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:16:47 <skitt> #vote 3
18:16:49 <jamoluhrsen> #vote 3
18:16:49 <LuisGomez> #vote 3
18:16:51 <anipbu> #vote 3
18:16:51 <zxiiro> #vote 3
18:17:04 <rovarga> #vote 2
18:17:13 <bjohnson> #vote 2
18:17:35 <shague> #vote 3
18:17:41 <lori> #vote 3
18:17:43 <gzhao> #vote 3
18:17:46 <abhijitkumbhare> #vote 0
18:17:46 <odl_meetbot> abhijitkumbhare: 0 is not a valid option. Valid options are 1, 2, 3, 4.
18:18:07 <skitt> ah sorry I didn’t include an abstain option
18:18:37 <skitt> #endvote
18:18:37 <odl_meetbot> Voted on "Which option does the TSC prefer?" Results are
18:18:37 <odl_meetbot> 3 (8): gzhao, skitt, anipbu, LuisGomez, shague, lori, jamoluhrsen, zxiiro
18:18:37 <odl_meetbot> 2 (2): rovarga, bjohnson
18:19:02 <skitt> #agreed The TAC representative shall be any interested committer approved by the TSC and elected by the TSC
18:19:14 <abhijitkumbhare> #agreed Option 3 wins:  Any interested committer approved by the TSC and elected by the TSC
18:19:19 <abhijitkumbhare> #undo
18:19:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x28ae5d0>
18:21:52 <abhijitkumbhare> #agreed One week self nomination period, followed by one week voting period
18:22:13 <skitt> #topic Proposal for Releng Team to perform all version bumping activities
18:24:15 <dfarrell07> #info Most active projects have bumped to yangtools 2.0.0, LuisGomez has sent out projects that haven't
18:24:30 <dfarrell07> #info There is a fix in 2.0.1 yangtools that has critical fixes
18:24:48 <dfarrell07> #info LuisGomez is proposing LF do a version bump for projects already on 2.0.0 to 2.0.1
18:25:11 <dfarrell07> #info LuisGomez is not proposing LF bump projects to 2.0.0 if they haven't already
18:25:32 <dfarrell07> #info skitt and zxiiro talk about how we have agreed this for minor bumps in the past, and projects can opt out
18:26:15 <dfarrell07> #info there may be complex fixes required for going to 2.0.0, so projects would need to do that themselves LuisGomez  says
18:26:20 <skitt> #info two questions from rovarga
18:26:33 <skitt> #info how can the patches be validated before the releng team merges them
18:27:48 <skitt> #info what are the gating criteria before a patch is merged
18:28:48 <dfarrell07> #info LuisGomez is assuming that minor version bumps will not break projects, so minor version bumps should be okay whereas major version bumps would not be okay
18:29:49 <dfarrell07> #info dfarrell07 clarifies that TSC has authority to do this, it's not the case that the governance docs  say they can't
18:33:17 <dfarrell07> #info LuisGomez and others don't think it's okay to wait on approval for all projects for all version bumps from odlparent and yangtoos to unbreak the world
18:34:46 <dfarrell07> #info shague says the world is broken now, so these patches need to get merged one way or another, project committer or someone else
18:35:39 <dfarrell07> #info all agree that going forward long term, gov docs need to change to make this situation more clear, deal with inactive projects not holding everyone else up
18:36:54 <dfarrell07> #info last time this was voted on it was about projects taking part in the SR bumping versions to release, this is different situation says rovarga
18:38:12 <skitt> #startvote Does the TSC approve that the releng team can merge patches for the merge from yangtools 2.0.0 to yangtools 2.0.1, as long as they pass the verify job? -1, 0, +1
18:38:12 <odl_meetbot> Begin voting on: Does the TSC approve that the releng team can merge patches for the merge from yangtools 2.0.0 to yangtools 2.0.1, as long as they pass the verify job? Valid vote options are -1, 0, +1.
18:38:12 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:38:56 <abhijitkumbhare> #vote +1
18:38:57 <shague> #vote +1
18:38:59 <LuisGomez> #vote +1
18:39:00 <anipbu> #vote +1
18:39:01 <jamoluhrsen> #vote 0
18:39:02 <bjohnson> #vote +1
18:39:03 <skitt> #vote 0
18:39:10 <zxiiro> #vote +1
18:39:32 <abhijitkumbhare> Quan you can vote
18:39:32 <rovarga> #vote 0
18:39:36 <lori> #vote +1
18:39:46 <abhijitkumbhare> Quan the vote is for:
18:39:49 <CaseyODL> https://www.irccloud.com/pastebin/4JfPKsEt/
18:40:03 <abhijitkumbhare> Quan: Does the TSC approve that the releng team can merge patches for the merge from yangtools 2.0.0 to yangtools 2.0.1, as long as they pass the verify job? Valid vote options are -1, 0, +1.
18:40:26 <skitt> #endvote
18:40:26 <odl_meetbot> Voted on "Does the TSC approve that the releng team can merge patches for the merge from yangtools 2.0.0 to yangtools 2.0.1, as long as they pass the verify job?" Results are
18:40:26 <odl_meetbot> 0 (3): skitt, rovarga, jamoluhrsen
18:40:26 <odl_meetbot> +1 (7): bjohnson, anipbu, LuisGomez, shague, lori, abhijitkumbhare, zxiiro
18:40:40 <Quan> +1
18:40:58 <skitt> #info for the record, Quan voted +1
18:41:52 <skitt> the mdsal bump is just finishing its merge job now
18:42:44 <skitt> #topic Groups.io
18:42:57 <skitt> dfarrell07, I’ll send an email about version ranges
18:43:28 <skitt> #topic Oxygen
18:48:01 <dfarrell07> #info bjohnson and others are proposing an extension of code freeze to let offset two projects get changes in, since things have been very broken for quite some time (infra, version bumps)
18:48:02 <skitt> #info pain in this release from the infra changes as well as the odlparent/yangtools bump
18:48:07 <skitt> #undo
18:48:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x283a450>
18:48:41 <rovarga> #info note: we actually held off the integration to get CSIT environment stabilized
18:49:28 <dfarrell07> #info shague thinks we will not be in good shape by the first RC date, rovarga thinks we should not have that RC if it is expected to be broken
18:50:26 <skitt> #startvote Shall the TSC slip the code freeze and RC0 by one week? -1, 0, +1
18:50:26 <odl_meetbot> Begin voting on: Shall the TSC slip the code freeze and RC0 by one week? Valid vote options are -1, 0, +1.
18:50:26 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:50:27 <dfarrell07> #info dfarrell07 hopes we will not have to slip release date
18:50:39 <dfarrell07> #info jamoluhrsen doesn't want us to steal test time at the end of all of this
18:50:40 <abhijitkumbhare> #vote +1
18:52:56 <skitt> #endvote
18:52:56 <odl_meetbot> Voted on "Shall the TSC slip the code freeze and RC0 by one week?" Results are
18:52:56 <odl_meetbot> +1 (1): abhijitkumbhare
18:53:05 <skitt> #info Option 1: stick to the current release plan
18:53:14 <skitt> #info Option 2: slip code freeze and RC0 by one week
18:53:25 <skitt> #info Option 3: slip the rest of the release plan by one week
18:53:30 <skitt> #info Option 0: abstain
18:53:32 <Quan> +1 I fill it waste much time to merge odlparent bump
18:53:41 <Quan> feel ,sorry
18:54:10 <jamoluhrsen> agreed Quan
18:54:40 <skitt> #startvote Shall the TSC amend the planned dates on the release plan? 0, 1, 2, 3
18:54:40 <odl_meetbot> Begin voting on: Shall the TSC amend the planned dates on the release plan? Valid vote options are 0, 1, 2, 3.
18:54:40 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:54:41 <jamoluhrsen> #vote 3
18:54:42 <rovarga> the actual merge has not taken a full week as of right now
18:54:45 <gzhao> #vote 0
18:54:47 <skitt> #vote 3
18:54:48 <anipbu> #vote 3
18:54:50 <bjohnson> #vote 3
18:54:52 <rovarga> #vote 3
18:54:53 <jamoluhrsen> rovarga, nearly a whole week though.
18:54:57 <abhijitkumbhare> #vote 3
18:55:01 <lori> #vote 2
18:55:09 <LuisGomez> #vote 3
18:55:11 <zxiiro> #vote 3
18:55:13 <dfarrell07> and it's not done, we still have to have 2.0.1
18:55:20 <shague> #vote 2
18:55:20 <rovarga> jamoluhrsen: yes, which included a weekend and Martin Luther King Day ;-)
18:55:33 <jamoluhrsen> rovarga, true. I did not work monday :)
18:55:40 <CaseyODL> Quan: Did you want to vote?
18:55:43 <dfarrell07> we had off monday?!
18:55:53 <bjohnson> Really, I thought it was just the post office closed on MLK??
18:55:59 <Quan> vote 3
18:56:05 <rovarga> dfarrell07: jamoluhrsen: fair point, but in my experience ~5 work days to integrate ~20 projects on this scale is a pretty good statistic :)
18:56:14 <CaseyODL> Format is #vote OPTION
18:56:25 <abhijitkumbhare> Quan - just add # before “vote”
18:56:33 <skitt> rovarga, the controller failure is weird: https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/controller-maven-javadoc-verify-oxygen/227/console.log.gz
18:56:34 <Quan> #vote 3
18:56:36 <dfarrell07> rovarga: I just want to get this release refactoring done so we only have to care about a few active projects
18:56:39 <skitt> #endvote
18:56:39 <odl_meetbot> Voted on "Shall the TSC amend the planned dates on the release plan?" Results are
18:56:39 <odl_meetbot> 0 (1): gzhao
18:56:39 <odl_meetbot> 3 (9): rovarga, bjohnson, skitt, zxiiro, LuisGomez, Quan, jamoluhrsen, anipbu, abhijitkumbhare
18:56:39 <odl_meetbot> 2 (2): shague, lori
18:56:41 <Quan> sorry casey
18:56:54 <CaseyODL> No problem.  :)
18:56:59 <skitt> #agreed the TSC slips the rest of the release plan by one week
18:57:07 <skitt> I’ll have to drop in four minutes
18:57:10 <skitt> three
18:57:15 <skitt> #topic Carbon
18:57:21 <skitt> #chair dfarrell07
18:57:21 <odl_meetbot> Current chairs: CaseyODL abhijitkumbhare dfarrell07 skitt
18:57:39 <rovarga> skitt: hmm... looks nexus-y
18:57:51 <dfarrell07> #info klou has an RC out for Carbon SR3
18:57:52 <skitt> rovarga, yes
18:58:13 <dfarrell07> #info jamoluhrsen has run CSIT against that Carbon SR3, results are in and klou is updating spreadsheet
18:58:13 <rovarga> skitt: recheck should take care of that :)
18:58:29 <skitt> rovarga, done
18:58:37 <dfarrell07> #info jamoluhrsen wants us to vote now to release this RC as carbon SR3 if it passes netvirt tests, others seem sane
18:58:51 <rovarga> +1
18:59:00 <skitt> #startvote Shall the TSC approve the latest Carbon release candidate as SR3 if it passes netvirt tests? -1, 0, +1
18:59:00 <odl_meetbot> Begin voting on: Shall the TSC approve the latest Carbon release candidate as SR3 if it passes netvirt tests? Valid vote options are -1, 0, +1.
18:59:00 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:59:02 <skitt> #vote +1
18:59:06 <zxiiro> #vote +1
18:59:06 <rovarga> #vote +1
18:59:08 <abhijitkumbhare> #vote +1
18:59:09 <jamoluhrsen> #vote +1
18:59:11 <lori> #vote +1
18:59:15 <shague> #vote 1
18:59:15 <odl_meetbot> shague: 1 is not a valid option. Valid options are -1, 0, +1.
18:59:15 <bjohnson> #vote +1
18:59:18 <anipbu> #vote +1
18:59:20 <shague> #vote 1
18:59:20 <odl_meetbot> shague: 1 is not a valid option. Valid options are -1, 0, +1.
18:59:20 <dfarrell07> skitt: is a faster typer than me;)
18:59:24 <Quan> #vote +1
18:59:29 <shague> #vote +1
18:59:34 <LuisGomez> #vote +1
18:59:39 <skitt> #endvote
18:59:39 <odl_meetbot> Voted on "Shall the TSC approve the latest Carbon release candidate as SR3 if it passes netvirt tests?" Results are
18:59:39 <odl_meetbot> +1 (11): rovarga, bjohnson, skitt, anipbu, LuisGomez, shague, Quan, lori, abhijitkumbhare, zxiiro, jamoluhrsen
18:59:51 <rovarga> dfarrell07: not meaning to be offensive, but given that we have downstreams wathing our release -- isn't our slipping for Carbon SR3 problematic?
18:59:53 <jamoluhrsen> thanks skitt
19:00:07 <skitt> you’re welcome jamoluhrsen ;-)
19:00:11 <abhijitkumbhare> #topic ONS Developer Event
19:00:30 <dfarrell07> rovarga: yeah but not for overall sync with other projects like OPNFV and OpenStack
19:00:32 <abhijitkumbhare> #info LFN wiki to be live soon
19:00:38 <dfarrell07> rovarga: those are sync'd on major releases
19:00:49 <abhijitkumbhare> #info ODL DDF has to be on Sunday
19:01:12 <shague> is the lfn wiki, like our ddf wiki where we just post topics and someone makes  a schedule?
19:01:15 <rovarga> dfarrell07: but I would assume they do need our fixes, don't they?
19:01:33 <dfarrell07> rovarga: yeah but they get them via CD pipelines mostly now
19:01:54 <dfarrell07> rovarga: they needed fixes way faster than SRs way long ago
19:02:01 <jamoluhrsen> bjohnson, just use the bar for your breakouts
19:02:02 <dfarrell07> rovarga: hence the XCI work we've been doing
19:02:16 <bjohnson> breakin out at the bar
19:02:16 <abhijitkumbhare> agree jamoluhrsen :)
19:02:23 <dfarrell07> rovarga: so I don't worry so much about SR timing, but do more about major release timing
19:02:39 <rovarga> dfarrell07: so wouldn't it actually make sense to brind those CD pipelines into ODL proper to manage inter-project things?
19:02:43 <abhijitkumbhare> bjohnson: you jamoluhrsen and i can hang out at the bar :)
19:02:58 <Quan> Abhijit, I can not attend the meeting in USA. Can I Join in you online?
19:02:59 <dfarrell07> rovarga: they are, odl-proper, that's Int/Pack
19:03:30 <dfarrell07> rovarga: https://nexus.opendaylight.org/content/repositories/opendaylight-oxygen-epel-7-x86_64-devel/org/opendaylight/integration-packaging/opendaylight/
19:03:33 <abhijitkumbhare> #agreed ODL DDF has to be on Sunday
19:03:38 <dfarrell07> rovarga: they are even on Nexus:)
19:03:41 <rovarga> dfarrell07: I mean... propagating fixes between, say, netconf and of-config, the same way we are pushing them from ODL to OPNFV
19:03:41 <abhijitkumbhare> #undo
19:03:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2942150>
19:04:10 <abhijitkumbhare> #agreed ODL DDF will be on Sunday March 25, 2018
19:04:17 <dfarrell07> rovarga: yeah, that's something for you kernel folks to figure out, very different challenges I think
19:04:40 <rovarga> dfarrell07: how different?
19:04:54 <dfarrell07> rovarga: I think they are mostly maven issues preventing that, right?
19:05:00 <dfarrell07> rovarga: I don't really know to be honest
19:05:13 <abhijitkumbhare> #topic Groups.io
19:05:32 <abhijitkumbhare> #action CaseyODL to send an email about Groups.io update
19:06:02 <abhijitkumbhare> #info Any feedback to be provided over the email thread
19:06:18 <rovarga> dfarrell07: at the end of the day it boils down to a CD pipeline, which involves automatic git commits and nexus staging repos -- aside from that, I don't think there is anything special
19:06:24 <abhijitkumbhare> #topic Cookies or Beer
19:06:45 <dfarrell07> rovarga: we should have a DDF topic
19:06:51 <abhijitkumbhare> #info As usual
19:06:56 <abhijitkumbhare> #endmeeting