18:02:20 <dfarrell07> #startmeeting tsc
18:02:20 <odl_meetbot> Meeting started Thu Jan 25 18:02:20 2018 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:02:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:20 <odl_meetbot> The meeting name has been set to 'tsc'
18:02:33 <dfarrell07> #chair abhijitkumbhare jamoluhrsen skitt bjohnson klou_
18:02:33 <odl_meetbot> Current chairs: abhijitkumbhare bjohnson dfarrell07 jamoluhrsen klou_ skitt
18:02:46 <dfarrell07> #topic rollcall
18:02:52 <dfarrell07> #info dfarrell07 for shague
18:03:03 <LuisGomez> #info LuisGomez
18:03:03 <skitt> #info skitt
18:03:10 <lori> #info lori
18:03:10 <anipbu> #info anipbu
18:03:17 <zxiiro> #info Thanh Ha
18:03:27 <abhijitkumbhare> #info abhijitkumbhare
18:03:44 <dfarrell07> #chair anipbu lori zxiiro
18:03:44 <odl_meetbot> Current chairs: abhijitkumbhare anipbu bjohnson dfarrell07 jamoluhrsen klou_ lori skitt zxiiro
18:03:54 <abhijitkumbhare> #info https://wiki.opendaylight.org/view/TSC:Main#Agenda
18:04:11 <jamoluhrsen> #info jamoluhrsen
18:04:15 <bjohnson> #info Brady Johnson
18:04:19 <dfarrell07> 9
18:05:28 <dfarrell07> #topic oxygen
18:05:52 <dfarrell07> ping klou_
18:06:13 <klou_> I'm here
18:06:25 <dfarrell07> #info meeting is in https://zoom.us/j/441948593
18:06:48 <gzhao> #info gzhao
18:07:25 <klou_> #link https://wiki.opendaylight.org/view/Release_Dashboard
18:07:28 <dfarrell07> #info m2 and m3 status missing for some projects, klou_ is tracking on link above
18:08:01 <dfarrell07> #info m2 dlux and dluxapps, m3 dlux, dluxapps intdist, jsonrpc, mdsal, nic, snmp, unimanager
18:08:07 <bjohnson> #info Im still waiting to hear back from the DLUX PTL
18:08:28 <dfarrell07> #info we had a deadline last week that we are now past
18:08:53 <dfarrell07> #info oxygen release bockers are tagged as such on Jira, there are 5 currently
18:09:27 <vorburger> could someone provide a link to the 5 blocker JIRAs being talked about?
18:09:33 <klou_> #link https://jira.opendaylight.org/issues/?filter=10206 <- Current Oxygen Blockers
18:10:18 <dfarrell07> #info netconf 502 is related to bump, same thing aaa was hitting, rgoulding has a fix being tested nw
18:10:22 <dfarrell07> #undo
18:10:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b67c10>
18:10:24 <dfarrell07> #info netconf 502 is related to bump, same thing aaa was hitting, rgoulding has a fix being tested now
18:12:12 <vorburger> skitt: wasn''t https://jira.opendaylight.org/browse/GENIUS-109 "just" a test failure, not a runtime problem? Maybe more of a major or critical instead of a Blocker? ;-)
18:12:31 <abhijitkumbhare> #info Not all bugs related to the version bump. e.g. MDSAL-228
18:12:31 <skitt> vorburger, yeah I’m editing the bug
18:12:39 <vorburger> and how on earth can https://jira.opendaylight.org/browse/MDSAL-228 be a blocker for Oxygen?!
18:13:35 <dfarrell07> vorburger: you can use meetbot;)
18:13:58 <dfarrell07> #info there are some bugs that seem to be related to tests, that are very important because we can't get good test coverage, but may not be problems with oxygen
18:14:19 <dfarrell07> #info there are others listed as blockers on that filter that maybe should not be, like mdsal228 according to vorburger et al
18:15:10 <dfarrell07> #info vorburger says genius109 is a test failure, not a runtime problem, so critical but likely not a blocker
18:15:24 <dfarrell07> #info all bug owners should update bugs and maybe remove blocker label
18:16:03 <dfarrell07> #info netvirt 1058 is a bloker but is not related to the bump
18:16:17 <dfarrell07> #undo
18:16:17 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b67210>
18:16:18 <bjohnson> #info the only version bump blockers are netconf 502 and netconf 504
18:16:22 <dfarrell07> #info netvirt 1058 is a blocker but is not related to the bump
18:17:31 <dfarrell07> #info so summary is that netconf 502, 504 and netvirt 1058 are actually blockers
18:19:44 <bjohnson> #info looks like we're in good shape for the version bump
18:20:05 <dfarrell07> #info netvirt and other projects have a large stack of patches they have been holding while csit broken, they are now starting to merge those as csit is good
18:20:26 <dfarrell07> #info will continue holding code freeze and branch cutting until that mountain goes through
18:21:47 <abhijitkumbhare> #info Code freeze stands 1/28 - but we will monitor
18:22:03 <dfarrell07> #info code freeze is still 1/28, but we will be open if patch queues that were held up can't make it
18:22:07 <dfarrell07> #topic ddf
18:22:10 <bjohnson> #info the code freeze for 1/28 is for offset 2 projects
18:22:15 <bjohnson> #undo
18:22:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2bb1590>
18:23:46 <dfarrell07> #info phrobb gives some background on ddf, lots of projects want to have DDF-like events, which LF hadn't planned for
18:24:11 * bjohnson having a very hard time understanding Phil
18:24:31 <dfarrell07> #info main issues are that we don't have enough time for DDF and cost is very high
18:24:50 <dfarrell07> #info phrobb mentions a discount for contributors but I didn't understand how much
18:24:58 <jamoluhrsen> hard to understand
18:25:02 <skitt> 15% I think?
18:25:07 <vishnoianil> #info Anil Vishnoi
18:25:23 <skitt> #info 50% discount
18:25:57 <bjohnson> Can we still get in on the early bird price?
18:26:39 <dfarrell07> #info many groups were asking for time on sunday, which would be a major cost for LF, not in budget
18:26:51 <dfarrell07> #info ODL has been clear about wanting a DDF at ONS for very long time
18:27:04 <vishnoianil> dfarrell07 +1
18:27:16 <bjohnson> #info Early bird registration price of $1195 is available until February 11
18:27:16 <abhijitkumbhare> +1 dfarrell07
18:28:33 <dfarrell07> #info contributors (broad definition) get a 50% discount on early bird price, covers all of ONS, cost required for attending DDF/cross-project part before ONS-proper
18:28:38 <vishnoianil> If there will be price on DDF i might not be able to join (until and unless one of my paper get selected to the event)
18:29:15 <jamoluhrsen> vishnoianil: demo opportunity as well.
18:29:15 <dfarrell07> #info LF is trying to break even
18:30:02 <dfarrell07> #info we have a room on Sunday for 30 folks for ODL DDF, in addition to parts of Mon/Tues we want to use for DDF
18:31:00 <bjohnson> How much of a discount do ONS speakers get? I thought it was only 50%
18:31:17 <vishnoianil> first one was free and second gets 50% i beleive
18:31:18 <dfarrell07> #info still not sure if speakers to mon/tues get speaker pass for all of ONS
18:31:21 <gzhao> 100%
18:32:10 <dfarrell07> #info xci event will still happen on sunday, room for 15 people
18:33:19 <bjohnson> Will there be a fee for those that only attend the DDF on Sunday?
18:33:24 <dfarrell07> #info we will have DDF all day Sunday, and will extend to mon/tues
18:33:38 <dfarrell07> #info if there are folks that still can't pay $600 reach out to phrobb
18:33:55 <gzhao> bjohnson: I think 100% if only one primary speaker, if there are co-speaker then 50%?
18:34:14 <dfarrell07> #info phil encourages folks who attend DDF on Sunday to also attend everything else, for health of project and cost breaking even
18:34:59 <dfarrell07> #info dfarrell07 strongly suspect we will have dev things we want to do on mon/tues, so just attending sun doesn't make sense
18:35:28 <dfarrell07> #info xci talks will likely extend to mon/tues
18:36:07 <dfarrell07> #info phil thinks it's important to have this cross project part on mon/tues, that we should all stick around and take part
18:37:18 <dfarrell07> #info phil will be disappointed in you if you only come for Sunday *father figure shame* ;)
18:38:00 <dfarrell07> #info phil has a link with docs about how to get this %50 discount prices
18:38:11 <dfarrell07> #info phil will also follow up with LFN wiki where can post topics
18:39:36 <dfarrell07> #info if you don't want to come for Mon/Tues, tell Phil because he wants to work with you to make it happen
18:39:50 <dfarrell07> bjohnson^^
18:40:08 <bjohnson> dfarrell07: thanks, but I'll be there
18:40:18 <dfarrell07> bjohnson: good, me too:)
18:40:50 <dfarrell07> #info vishnoianil asks about when CFP results for main OSN will come out, it is before the early bird expires
18:41:45 <dfarrell07> #info if you register for early bird and then get accepted as speaker, you will get refunded
18:41:46 <bjohnson> abhijitkumbhare: people need to be able to plan their trip before, so the refund may not be an option for everybody
18:44:13 <dfarrell07> #info if you want to do an ODL demo, don't worry about the deadline, reach out to lisa and phil and they will make it happen
18:45:15 <dfarrell07> #info CaseyODL to broadcast the option for doing an ODL demo to ODL lists
18:45:19 <dfarrell07> #undo
18:45:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c24810>
18:45:27 <dfarrell07> #action CaseyODL to broadcast the option for doing an ODL demo to ODL lists
18:46:40 <dfarrell07> #info community seems happy with result of DDF discussion, thanks phrobb for clarifying and finding a good solution for us
18:50:23 <abhijitkumbhare> agree bjohnson - about refund option may not be an option for everyone
18:50:38 <abhijitkumbhare> #topic Carbon
18:50:56 <klou_> #link https://jira.opendaylight.org/issues/?filter=10207 <- Carbon SR3 Bugs
18:51:39 <jamoluhrsen> dfarrell07: we lost you
18:51:47 <skitt> jamoluhrsen, that’s because you cancelled him
18:52:04 <skitt> :-P
18:52:07 <abhijitkumbhare> #info https://jira.opendaylight.org/browse/NETCONF-503 & https://jira.opendaylight.org/browse/NETVIRT-896 are blocking OPNFV
18:54:17 <abhijitkumbhare> #action jamoluhrsen to ask OPNFV why https://jira.opendaylight.org/browse/NETVIRT-896 is a blocker on the JIRA
18:54:51 <abhijitkumbhare> #info jamoluhrsen notes that NetVirt still has other blocking issues for Carbon
18:55:13 <dfarrell07> #info it's unclear if netconf 503 and netvirt 896 are actually blockers, they seem to have been over-aggressively bumped to blockers
18:55:28 <dfarrell07> #info dfarrell07 is pushing to get more details on netconf503 and jamoluhrsen is doing same for netcirt896
18:55:34 <abhijitkumbhare> Thanks dfarrell07
18:56:07 <dfarrell07> #info netvirt 1022 does track actual blockers, jamoluhrsen, sam are looking
18:56:08 <abhijitkumbhare> #topic Nitrogen
18:56:22 <abhijitkumbhare> #info Next SR targeted for 2/7
18:56:22 <dfarrell07> #info Nitrogen autorelease hasn't passed in two weeks
18:56:42 <dfarrell07> #info need to start locking nitrogen autorelease down if we are going to hit SR2 release in two weeks
18:58:10 <dfarrell07> #info zxiiro asks if there is a pattern to nitrogen fails, klou_ says no, it's all over the place
18:58:14 <zxiiro> #link autorelease build failure trend https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=818416294
19:01:03 <dfarrell07> #info latest fail is in lisp, but never happens to lori locally, only sporadically in jenkins, maybe related to slower HDD or maybe not, adding sleeps to let env settle, adding debugging
19:01:38 <dfarrell07> #info lori points out that it may just be integration tests generally, not so many projects have then, maybe bgp and others hitting similar post-infra-move
19:01:57 <vorburger> lori: Jenkins is slower, we may just have to increase the timeout? Do you have an example of a such an IT test failure?
19:03:33 <bjohnson> I have another meeting, so I have to disconnect
19:04:14 <abhijitkumbhare> sure bjohnson - we are over time
19:04:58 <dfarrell07> #info looks like strangeness in mdsal to lori, LuisGomez suggests trying a ramdisk
19:06:41 <abhijitkumbhare> #action zxiiro to use ramdisk for wherever controller is running
19:07:11 <abhijitkumbhare> #action LuisGomez to narrow where all to use ramdisk
19:07:12 <dfarrell07> #action LuisGomez and zxiiro to work with lori to try ramdisk solution, will not be build itself as too big
19:07:31 <abhijitkumbhare> #undo
19:07:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2bd9e10>
19:07:34 <abhijitkumbhare> #undo
19:07:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2bd9290>
19:07:37 <abhijitkumbhare> #undo
19:07:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2adf950>
19:07:48 <abhijitkumbhare> #action LuisGomez and zxiiro to work with lori to try ramdisk solution, will not be build itself as too big
19:08:57 <lori> vorburger: here's an example log, not sure if this has the MD-SAL weirdness or somethign else: https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/lispflowmapping-maven-verify-nitrogen-mvn33-openjdk8/46/integrationtest/target/surefire-reports/org.opendaylight.lispflowmapping.integrationtest.MappingServiceIntegrationTest-output.txt.gz
19:09:19 <abhijitkumbhare> #topic LFN Demo at the ONS
19:09:46 <dfarrell07> #info the netconf 503 bug I was pushing is done, it wasn't a problem with ODL, bug marked as resolved
19:09:48 <abhijitkumbhare> #info CaseyODL says there are 4-5 slots - and we can put together a proposal for ODL
19:11:07 <abhijitkumbhare> #endmeeting