18:02:37 <CaseyODL> #startmeeting tsc
18:02:37 <odl_meetbot> Meeting started Thu Mar  1 18:02:37 2018 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:02:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:37 <odl_meetbot> The meeting name has been set to 'tsc'
18:03:08 <dfarrell07> #topic rollcall
18:03:19 <CaseyODL> #chair rovarga dfarrell07 bjohnson_
18:03:19 <odl_meetbot> Current chairs: CaseyODL bjohnson_ dfarrell07 rovarga
18:03:21 <dfarrell07> #info Daniel Farrell for Stephen Kitt
18:03:25 <anipbu> #info anipbu
18:03:28 <zxiiro> #info Thanh Ha
18:03:32 <dfarrell07> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda Agenda
18:03:36 <jamoluhrsen> my calendar is wrong. can someone give me the zoom link?
18:03:39 <jamoluhrsen> #info jamoluhrsen
18:03:41 <lori> #info lori
18:03:45 <bjohnson_> #info Brady Johnson
18:03:45 <zxiiro> jamoluhrsen: https://zoom.us/j/219174946
18:03:52 <jamoluhrsen> zxiiro: thanks
18:04:10 <dfarrell07> 6
18:04:21 <gzhao> #info gzhao
18:04:25 <LuisGomez> #info LuisGomez
18:04:29 <dfarrell07> 8
18:04:42 <rovarga> #info rovarga
18:05:23 <shague> #info shague
18:05:35 <dfarrell07> #topic oxygen
18:05:57 <klou> #link https://jira.opendaylight.org/issues/?filter=10206 <- oxygen release blockers
18:06:02 <jamoluhrsen> LOL
18:07:49 <dfarrell07> #info SFC-213 may not be a blocker because it's a new feature for Oxygen
18:09:31 <dfarrell07> #info NETVIRT-1123 is actually a blocker, not new code, actively being worked on, upstream devstack causing problems, today or tomorrow ETA
18:10:29 <dfarrell07> #info NETVIRT-1122 jamo will ping fassella to update Jira, shague will make sure he reviews if needed
18:11:13 <dfarrell07> #info NETVIRT-1106 and NETVIRT-1062 are related, have patches, haven't been able to verify fixes because of devstack
18:12:03 <dfarrell07> #info NETVIRT-1101 may not be a regression/blocker, actually being worked on, shague will confirm if blocker
18:12:43 <dfarrell07> #info NETVIRT-1045 is a regression, there is a patch, just need devstack verify again
18:14:17 <dfarrell07> #info NETCONF-516 is waiting on verify job to finish, will be good to merge after
18:17:07 <dfarrell07> #info INFRAUTILS-29 is a pretty new regression skitt and others are still tracking down, the logging problem has been fixed on master, needs to go back to oxygen, Gerrit 68937, has verify about about to get +2 from tomp
18:18:12 <dfarrell07> #info for INFRAUTILS-29 there is a second patch on master and not oxygen that may not be critical
18:18:41 <jamoluhrsen> shague: netvirt-1122 (coe blocker bug) is waiting on you or other netvirt committer to +2
18:20:36 <dfarrell07> #info GENIUS-115 is being worked on, not sure of ETA
18:21:02 <dfarrell07> #info CONTROLLER-1816 is fixed, need to be put in resolved state
18:21:13 <rovarga> #link https://jira.opendaylight.org/browse/BGPCEP-763 is a new incoming blocker, regression from Nitrogen
18:22:12 <dfarrell07> #info BGPCEP-763 just came up, has a patch
18:23:36 <bjohnson_> #link https://git.opendaylight.org/gerrit/#/c/68843/ This is the binary jar to be removed from the repo
18:24:41 <dfarrell07> #action zxiiro to raise a jira to add way to block large binary files from being merged
18:25:29 <dfarrell07> #agreed 68843 is allowed in oxygen
18:26:55 <zxiiro> bjohnson_: if someone on SFC +2's it I can merge that patch.
18:27:00 <dfarrell07> #action shague to raise jira to track GPL violation in netvirt, do same fix odlparent recently merged
18:27:03 <bjohnson_> ok, thanks
18:28:06 <dfarrell07> #info klou asks when we want to do RC1
18:28:45 <klou> actually the question is on RC2 (RC1 was 2/27)
18:29:11 <klou> #link https://wiki.opendaylight.org/view/Release_Dashboard <- Release Dashboard
18:29:11 <dfarrell07> #info once we have devstack working again we will be able to verify lots of netvirt patches and fix lots of blockers, so maybe RC after that
18:29:21 <dfarrell07> #info when the queens branch was cut, that broke our devstack stuff
18:29:42 <dfarrell07> #info shague thinks we're in good shape, just being cautious about getting these well tested
18:30:55 <dfarrell07> #info we need to have a longer discussion about dates to make sure we are in good sync pattern with other projects, for example not to get this devstack breakage when they cut openstack branches
18:32:17 <dfarrell07> #info this is more about lots of patches going into openstack, across all branches, which broke us across the board (no so much about supporting queens or not)
18:33:23 <dfarrell07> #info there is work in progress to get away from devstack, use pre-built/validated images from OPNFV Apex
18:34:11 <dfarrell07> #info targeting early next week for RC2 (sorry, not RC1 above)
18:34:18 <dfarrell07> #topic nitrogen
18:34:20 <dfarrell07> #info nothing
18:34:24 <dfarrell07> #topic carbon
18:34:43 <dfarrell07> #info when do we want to do SR4? since last SR was major delayed
18:35:08 <dfarrell07> #info rovarga says at least 4 weeks pushed, jamoluhrsen says 6 weeks to get past ONS
18:36:53 <dfarrell07> #agreed carbon SR4 is pushed out 6 weeks from 3/15, which is 4/26
18:37:40 <dfarrell07> #topic infra
18:37:43 <dfarrell07> #info nothing
18:40:11 <dfarrell07> #info Managed Release
18:40:26 <CaseyODL> #undo
18:40:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ac5410>
18:40:30 <bjohnson_> #topic Managed Release
18:40:31 <CaseyODL> #topic Managed Release
18:40:31 <dfarrell07> #info we need to get a date-based release plan
18:40:40 <jamoluhrsen> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/docs-rtd-verify-fluorine/14/html/release-process/managed-release.html  <-- release model
18:48:08 <jamoluhrsen> dfarrell07: you said trying to "integrate" the non-sr projects :)
18:48:45 <jamoluhrsen> #info we want to require managed projects to take the non-sr project releases
18:48:57 <dfarrell07> #info need vocab section, my bad;)
18:49:36 <bjohnson_> zxiiro: This license-fix patch now has a +2, so you can merge it: https://git.opendaylight.org/gerrit/#/c/68843/
18:49:58 <anipbu> what about "outmanaged"
18:50:34 <zxiiro> bjohnson_: cool will merge once verified comes through
18:51:07 <jamoluhrsen> #info example jira's created which will be used for milestone reports (see TSC project in JIRA)
18:51:22 <bjohnson_> zxiiro: ok, thanks!!
18:53:35 <dfarrell07> #action dfarrell07 will change SR Managed Release to Snapshot Integrated and Non-SR Managed Release to Release Integrated
18:53:47 <dfarrell07> #info discussion about when the release starts
18:54:23 <dfarrell07> #info rovarga thinks branch cutting should happen at code freeze, need cal to see how dates start-date should be
18:55:40 <dfarrell07> #info there is a different discussion about taking project out of SR or not, that may impact how we want to do releases in the future
18:57:47 <dfarrell07> #startvote The TSC wants to something along the lines of the Managed Release plan in Gerrit 68382, more changes will happen but the community should take note -1,+1
18:57:47 <odl_meetbot> Unable to parse vote topic and options.
18:58:07 <dfarrell07> #startvote The TSC wants to something along the lines of the Managed Release plan in Gerrit 68382, more changes will happen but the community should take note? -1,+1
18:58:07 <odl_meetbot> Begin voting on: The TSC wants to something along the lines of the Managed Release plan in Gerrit 68382, more changes will happen but the community should take note? Valid vote options are -1, +1.
18:58:07 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:58:10 <rovarga> #vote +1
18:58:11 <jamoluhrsen> #vote +1
18:58:12 <zxiiro> #vote +1
18:58:13 <dfarrell07> #vote +1
18:58:13 <shague> #vote +1
18:58:16 <LuisGomez> #vote +1
18:58:17 <anipbu> #vote +1
18:58:18 <lori> #vote +1
18:58:18 <bjohnson_> #vote +1
18:58:31 <dfarrell07> #endvote
18:58:31 <odl_meetbot> Voted on "The TSC wants to something along the lines of the Managed Release plan in Gerrit 68382, more changes will happen but the community should take note?" Results are
18:58:31 <odl_meetbot> +1 (9): rovarga, anipbu, LuisGomez, dfarrell07, shague, lori, jamoluhrsen, zxiiro, bjohnson_
18:58:47 <dfarrell07> #topic tws
18:59:41 <dfarrell07> #info CaseyODL says Lisa (Marketing LFN Dir) will ask us about what we plan to do for next release, we may not have good answers, can follow up later
19:00:24 <dfarrell07> #info This marketing request is about Oxygen
19:00:49 <dfarrell07> #action CaseyODL will make sure lots of projects hear about this marketing request, will follow up with email
19:01:07 <dfarrell07> #info rovarga points out the website is verrrry behind, talks about Carbon, no mention of Nitrogen
19:01:46 <bjohnson_> I have to disconnect, thanks for running the meeting dfarrell07
19:02:07 <dfarrell07> #action CaseyODL will fix this website homepage carbon bug
19:02:17 <jamoluhrsen> thanks dfarrell07
19:02:23 <dfarrell07> thanks all:)
19:02:31 <dfarrell07> #topic cookies
19:02:35 <dfarrell07> #endmeeting