16:59:19 <abhijitkumbhare> #startmeeting tsc
16:59:19 <odl_meetbot> Meeting started Thu Mar 22 16:59:19 2018 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:19 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:19 <odl_meetbot> The meeting name has been set to 'tsc'
16:59:48 <abhijitkumbhare> #info Agenda Bashing, Roll Call, Action Items
17:00:14 <abhijitkumbhare> #info abhijitkumbhare
17:00:27 <abhijitkumbhare> TSC members please info in
17:01:27 <jamoluhrsen> #info jamoluhrsen
17:01:33 <vishnoianil> #info Anil Vishnoi
17:01:34 <zxiiro> #info Thanh Ha
17:01:39 <skitt> #info skitt
17:01:44 <bjohnson_> #info Brady Johnson
17:02:12 <LuisGomez> #info LuisGomez
17:02:57 <anipbu> #info anipbu
17:03:02 <abhijitkumbhare> #link TSC page split up into https://wiki.opendaylight.org/view/TSC:Meeting & https://wiki.opendaylight.org/view/TSC:Procedures_and_Processes
17:03:11 <abhijitkumbhare> #undo
17:03:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2c24250>
17:03:26 <abhijitkumbhare> #info TSC page split up into https://wiki.opendaylight.org/view/TSC:Meeting & https://wiki.opendaylight.org/view/TSC:Procedures_and_Processes
17:03:50 <abhijitkumbhare> #chairs skitt dfarrell07 jamoluhrsen LuisGomez bjohnson_
17:04:15 <abhijitkumbhare> #topic Oxygen
17:04:49 <skitt> #info RC4 include a fix for a blocker in bgpcep, and is being released as Oxygen
17:04:49 <rovarga> #info rovarga
17:04:52 <gzhao> #info gzhao( (irc only)
17:04:53 <abhijitkumbhare> #info Quite a bit of activity since last TSC meeting - a few blockers fixed, signoff, etc.
17:05:30 <skitt> #info version bumping going on now
17:05:44 <skitt> #info branches unlocked hopefully by the end of the day (Pacific time)
17:06:11 <zxiiro> #link Release notes URL http://docs.opendaylight.org/en/latest/release-notes/index.html
17:09:05 <abhijitkumbhare> #info Congrats everyone for getting Oxygen out the door
17:09:18 <zxiiro> +1, very grateful for Kit's continued involvement in Oxygen.
17:10:06 <bjohnson_> +1, thanks to Kit!!
17:10:12 <abhijitkumbhare> #topic Fluorine
17:10:19 <bjohnson_> And a big Thanks to dfarrell07 for stepping up too
17:11:39 <LuisGomez> all of you guys did awesome work
17:11:42 <abhijitkumbhare> Thanks kit, dfarrell07, jamoluhrsen, rovarga, LuisGomez, skitt ,  etc.
17:11:57 <abhijitkumbhare> Have missed many others
17:11:57 <jamoluhrsen> we need to have a managed projects review in the next TSC
17:12:32 <jamoluhrsen> https://jira.opendaylight.org/browse/TSC-56?jql=project%20%3D%20tsc%20AND%20%22ODL%20Release%22%20%3D%20Fluorine%20AND%20%22ODL%20New%20Participation%22%20%3D%20%22SNAPSHOT_Integrated%20(Managed)%22
17:12:47 <jamoluhrsen> #link https://jira.opendaylight.org/browse/TSC-56?jql=project%20%3D%20tsc%20AND%20%22ODL%20Release%22%20%3D%20Fluorine%20AND%20%22ODL%20New%20Participation%22%20%3D%20%22SNAPSHOT_Integrated%20(Managed)%22  <-- projects requesting to be managed
17:12:48 <abhijitkumbhare> #info Several projects have signed up for being managed
17:14:48 <abhijitkumbhare> #info Feedback on Managed Release Process from the projects so far has been positive
17:15:32 <abhijitkumbhare> #info Folks plan to sit down at the DDF for more details
17:17:00 <abhijitkumbhare> #info Releases for yangtools & odlparent need to be done soon after the DDF (official deadline is April 15?)
17:17:42 <jamoluhrsen> #info deadline is 4/7 for MRI projects to have their releases done:   https://wiki.opendaylight.org/view/Release_Dashboard#Fluorine
17:17:48 <skitt> #info odlparent 3.1.0 is the target for Fluorine and Oxygen SR1
17:17:55 <skitt> #info yangtools 2.0.3 is the target for both
17:18:04 <skitt> #info odlparent 3.0.3 and 3.1.0 are being released now
17:18:14 <skitt> #info yangtools 2.0.3 will follow shortly thereafter
17:18:28 <rovarga> #info yangtools-2.0.2 is already in Fluorine, Oxygen-SR1 will go from 2.0.1 to 2.0.3
17:21:10 <abhijitkumbhare> #info OVSDB, Genius, Neutron, etc. have not yet signed up for being managed
17:22:49 <abhijitkumbhare> #action Dependent project PTLs to reach out to the PTLs of these project
17:23:29 <skitt> #info Ariel Adam from Red Hat will be at ONS and could step in as release manager
17:23:29 <abhijitkumbhare> #info Someone from RedHat stepping up to be the release manager for Fluorine
17:23:37 <abhijitkumbhare> #undo
17:23:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29b2510>
17:23:42 <abhijitkumbhare> #undo
17:23:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29b2990>
17:23:49 <abhijitkumbhare> #info Ariel Adam from Red Hat will be at ONS and could step in as release manager
17:24:41 <abhijitkumbhare> #topic Nitrogen & Caarbon
17:24:59 <abhijitkumbhare> #info Nitrogen & Carbon SRs coming up really soon
17:25:26 <abhijitkumbhare> #info Need to communicate to projects to backport fixes
17:25:53 <abhijitkumbhare> #topic JIRA linking across LFN projects
17:26:29 <abhijitkumbhare> #info Most LFN projects use JIRA
17:26:53 <abhijitkumbhare> #info JIRA allows to join Jira instances in a federation and cross reference
17:28:44 <abhijitkumbhare> #startvote Shall the OpenDaylight TSC approve linking to other LFN projects (ONAP, OPNFV, FD.io)? -1,0,+1
17:28:44 <odl_meetbot> Begin voting on: Shall the OpenDaylight TSC approve linking to other LFN projects (ONAP, OPNFV, FD.io)? Valid vote options are -1, 0, +1.
17:28:44 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:28:52 <rovarga> #vote +1
17:28:55 <zxiiro> #vote +1
17:28:57 <abhijitkumbhare> #vote +1
17:29:07 <bjohnson_> #vote +1
17:29:11 <anipbu> #vote +1
17:29:15 <skitt> #vote +1
17:29:17 <LuisGomez> #vote +1
17:29:41 <abhijitkumbhare> #endvote
17:29:41 <odl_meetbot> Voted on "Shall the OpenDaylight TSC approve linking to other LFN projects (ONAP, OPNFV, FD.io)?" Results are
17:29:41 <odl_meetbot> +1 (7): rovarga, skitt, zxiiro, LuisGomez, abhijitkumbhare, anipbu, bjohnson_
17:30:14 <abhijitkumbhare> #agreed ODL TSC approves linking ODL JIRA to OPNFV, ONAP & FD.io
17:31:22 <abhijitkumbhare> #action dfarrell07 to reach out to the other TSCs at the TAC
17:31:29 <abhijitkumbhare> #undo
17:31:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2ac5210>
17:31:43 <abhijitkumbhare> #action dfarrell07 to reach out to the other TSCs at the TAC about JIRA linking
17:32:05 <abhijitkumbhare> #topic Kicking off ODL Internship Program
17:32:39 <abhijitkumbhare> #info Several interns usually reach out to ODL around this time
17:32:45 <CaseyLF> #link https://wiki.lfnetworking.org/display/LN/LF+Networking+Internships Link to Internships page for LFN.
17:33:45 <abhijitkumbhare> #info dfarrell07 thinks we should assume budget is available & kick off the internship program
17:34:40 <bjohnson_> +1 to interns being able to start more often, and having their internship last longer
17:34:50 <abhijitkumbhare> #info OPNFV and others also have a possibility to have longer internships
17:36:14 <bjohnson_> #info for the 3 month option, interns would be asked to work 40 hours/week, whereas for the 6 month option, they would be asked to work 20 hours/week
17:36:16 <abhijitkumbhare> #info CaseyLF says that 6 month interns need to work only 20 hours a week as opposed to the current 3 month internships of 40 hrs/week
17:36:52 <bjohnson_> #info For a 3 month internship, new interns would barely have time to get up to speed on ODL
17:38:04 <abhijitkumbhare> #action abhijitkumbhare send out a broadcast email to solicit intern projects
17:38:13 <abhijitkumbhare> #undo
17:38:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2bd9ad0>
17:38:24 <abhijitkumbhare> #action abhijitkumbhare send out a broadcast email to solicit intern project proposals
17:39:11 <CaseyLF> #action CaseyLF to update ODL wiki page to be more clear on how to apply for internships and work with Trishan to actively solicit for Interns.
17:40:06 <abhijitkumbhare> #topic Infrastructure
17:41:12 <abhijitkumbhare> #info CaseyLF has communicated privately to the TSC about the infra costs
17:41:48 <skitt> ooh patch 69900 slipped through the cracks and *isn't* a version-bumping patch
17:42:40 <zxiiro> skitt: it's docs which isn't tied to simrel so we'll merge that soon.
17:42:48 <abhijitkumbhare> #topic DDF
17:43:16 <skitt> zxiiro, yeah it's just that I was pushing a ton of version-bumping patches and saw that number being skipped ;-)
17:43:18 <abhijitkumbhare> #info CaseyLF has updated the venue info on the wiki
17:43:37 <zxiiro> ah
17:43:52 * skitt probably won't nab 70000 :-(
17:44:24 <bjohnson_> Will there at least be coffee??
17:45:50 <abhijitkumbhare> https://www.irccloud.com/pastebin/TnTJMm2t/
17:46:25 <jamoluhrsen> zxiiro: poke place near by.
17:48:44 * bjohnson_ that's kinda like asking: raise your hand if you're not here
17:48:53 <abhijitkumbhare> #topic Weather Item
17:49:03 <rovarga> #link https://jira.opendaylight.org/browse/TSC-45
17:49:26 <abhijitkumbhare> #info MDSAL Fluorine API breakage window 1
17:49:51 <abhijitkumbhare> #info All the projects thru dependency tree need to be remerged
17:50:52 <gzhao> bjohnson_: I cannot be there on Wednesday noon.
17:51:00 <abhijitkumbhare> #info rovarga thinks best window would be March 31st as most people will be traveling
17:52:39 <abhijitkumbhare> #info jamoluhrsen asks whether this should be done after unmanaged projects are removed, rovarga thinks it does not matter
17:54:18 <abhijitkumbhare> #info This change is for https://jira.opendaylight.org/browse/MDSAL-325
17:54:40 <rovarga> #info and for https://jira.opendaylight.org/browse/MDSAL-326
17:56:55 <abhijitkumbhare> #topic TSC call during the ONS week
17:58:22 <abhijitkumbhare> #info TSC meeting will be held - we will try to make it Wednesday lunch
17:58:58 <jamoluhrsen> #action CaseyLF to get us a room for Wed lunch TSC meeting
17:59:01 <abhijitkumbhare> #action CaseyLF will try to work out the logistics of holding the TSC meeting on Wednesday
17:59:10 <skitt> bang on time
17:59:14 <zxiiro> yay
17:59:15 <abhijitkumbhare> #topic Cookies
17:59:22 <abhijitkumbhare> #endmeeting