20:33:19 <CaseyLF> #startmeeting tsc
20:33:19 <odl_meetbot> Meeting started Wed Mar 28 20:33:19 2018 UTC.  The chair is CaseyLF. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:33:19 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:33:19 <odl_meetbot> The meeting name has been set to 'tsc'
20:33:38 <vishnoianil> #info Anil Vishnoi
20:33:38 <CaseyLF> #chair abhijitkumbhare skitt jamoluhrsen
20:33:38 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare jamoluhrsen skitt
20:33:55 <shague> what is the currnent meeting id?
20:34:02 <anipbu> #info anipbu
20:34:05 <abelur> o/
20:34:09 <CaseyLF> https://zoom.us/j/219174946
20:34:09 <shague> #info shague
20:34:13 <zxiiro> #info Thanh Ha
20:34:13 <rovarga_> #info rovarga_
20:34:22 <jamoluhrsen> #info jamoluhrsen
20:35:10 <jamoluhrsen> #topic dlux archival
20:35:20 <LuisGomez> #info LuisGomez
20:36:09 <abhijitkumbhare> #info Discussion on the future of DLux
20:36:47 <abhijitkumbhare> #info Need the apps to remove the dependency on Dlux
20:36:51 <vishnoianil> #link https://www.opendaylight.org/what-we-do/lifecycle-releases
20:37:51 <vishnoianil> Above URL has Termination Review
20:38:40 <skitt> #info skitt
20:39:51 <jamoluhrsen> #info we can just let the managed release process work like we expect and probably DLUX will just not end up in the release.
20:40:08 <jamoluhrsen> #info we can also do the more formal process of archival and removal
20:43:03 <jamoluhrsen> #info side note from rovarga_ ( we still need to remove/archive tcpmd5 )
20:43:52 <jamoluhrsen> #action dfarrell07 to make an official DLUX termination request
20:44:32 <jamoluhrsen> #info everything discussed and planned for DLUX applies to DLUX-APPS
20:45:49 <jamoluhrsen> #info rovarga_ noting that we probably should not approve a UI project going forward, if they come.
20:46:15 <abhijitkumbhare> #topic VTN archival proposal
20:46:49 <abhijitkumbhare> #info Termination review to be done in two weeks (April 12)
20:48:29 <jamoluhrsen> #action dfarrell07 to follow up with VTN to see their plans to support existing releases
20:49:14 <abhijitkumbhare> #topic Release Manager
20:49:24 <abhijitkumbhare> #info Welcome Ariel Adam
20:51:17 <abhijitkumbhare> #startvote Does the TSC approve Ariel Adam as the release manager? -1,0,+1
20:51:17 <odl_meetbot> Begin voting on: Does the TSC approve Ariel Adam as the release manager? Valid vote options are -1, 0, +1.
20:51:17 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
20:51:21 <jamoluhrsen> #vote +1
20:51:22 <abhijitkumbhare> #vote +1
20:51:24 <LuisGomez> #vote +1
20:51:28 <shague> #vote +1
20:51:28 <vishnoianil> #vote +1
20:51:29 <anipbu> #vote +1
20:51:32 <zxiiro> #vote +1
20:51:35 <skitt> #vote +1
20:51:40 <lori> #vote +1
20:51:42 <rovarga_> #vote +1
20:52:01 <jamoluhrsen> #endvote
20:52:01 <odl_meetbot> Voted on "Does the TSC approve Ariel Adam as the release manager?" Results are
20:52:01 <odl_meetbot> +1 (10): skitt, zxiiro, LuisGomez, shague, lori, jamoluhrsen, anipbu, rovarga_, vishnoianil, abhijitkumbhare
20:52:31 <abhijitkumbhare> #info Congrats Ariel
20:52:32 <LuisGomez> welcome ariel
20:53:27 <abhijitkumbhare> #topic Releases
20:54:02 <jamoluhrsen> #topic Carbon SR4 due in one month?
20:54:21 <abhijitkumbhare> #info Carbon SR due on April 26th
20:54:34 <abhijitkumbhare> #info Carbon autorelease not passing
20:54:42 <jamoluhrsen> #info regresssion in yangtools is one reason autorlease is not passing
20:54:57 <jamoluhrsen> #action jamoluhrsen to bump carbon autorelease run once a day
20:55:20 <jamoluhrsen> #agree should be a default process that we bump autorelease jobs to once a day with four weeks before planned release
20:56:51 <abhijitkumbhare> #info Whether we can make tests run in parallel
20:57:06 <abhijitkumbhare> #info Not going to happen soon
20:57:10 <jamoluhrsen> #info nitrogen SR3 coming May 7th. 6 weeks from now
20:57:27 <jamoluhrsen> #info there is no successful build of nitrogen since Feb 21st
20:57:53 <jamoluhrsen> #action jamoluhrsen to turn on nitrogen autorelease jobs once per day in two weeks
20:58:19 <jamoluhrsen> #info Oxygen SR1 is april 14th
20:58:39 <dfarrell07> #link https://wiki.opendaylight.org/view/Release_Dashboard Release Dashboard
20:59:36 <skitt> hello aadam
20:59:41 <aadam> Hi there
20:59:41 <jamoluhrsen> sup aadam
20:59:53 <CaseyLF> aadam: https://wiki.opendaylight.org/view/Release_Dashboard
21:01:03 <jamoluhrsen> #info need the new odlparent and yangtools version bumps for oxy sr1
21:04:01 <jamoluhrsen> #info new odlparent and yangtools need their new releases approved by the TSC for Fluorine  and when/if approved they can be given to oxy and nitro
21:05:39 <skitt> #info yangtools 2.0.3 is a safe, non-breaking upgrade
21:06:00 <skitt> #info there was a regression related to vbd — that has been dealt with in both projects, so yangtools is non-breaking but vbd is no longer broken either
21:06:27 <skitt> #info odlparent 3.1.0 is also intended to be a safe upgrade
21:06:47 <skitt> #info rovarga_ and skitt are running final checks
21:09:17 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/release/2018-March/014493.html <-- odlparent 3.1.0 release information
21:10:39 <anipbu> Welcome aadam !!!
21:14:48 <dfarrell07> #info dfarrell07 to clarify in MR docs what happens when MRI projects only want to do non-major version bumps in the integration window
21:15:07 <dfarrell07> abhijitkumbhare: can you chair me
21:15:13 <dfarrell07> CaseyLF: can you chair me
21:15:17 <abhijitkumbhare> #chair dfarrell07
21:15:17 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare dfarrell07 jamoluhrsen skitt
21:15:21 <dfarrell07> #undo
21:15:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b59290>
21:15:30 <dfarrell07> #action dfarrell07 to clarify in MR docs what happens when MRI projects only want to do non-major version bumps in the integration window
21:17:18 <skitt> #startvote Does the TSC approve the upgrade to odlparent 3.1.0 and yangtools 2.0.3 (and any subsequent patch versions) for Fluorine? -1,0,+1
21:17:18 <odl_meetbot> Begin voting on: Does the TSC approve the upgrade to odlparent 3.1.0 and yangtools 2.0.3 (and any subsequent patch versions) for Fluorine? Valid vote options are -1, 0, +1.
21:17:18 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
21:17:27 <jamoluhrsen> #vote +1
21:17:27 <rovarga_> #vote +1
21:17:28 <anipbu> #vote +1
21:17:28 <LuisGomez> #vote +1
21:17:28 <skitt> #vote +1
21:17:30 <abhijitkumbhare> #vote +1
21:17:38 <vishnoianil> #vote +1
21:17:51 <zxiiro> #vote +1
21:18:20 <skitt> #endvote
21:18:20 <odl_meetbot> Voted on "Does the TSC approve the upgrade to odlparent 3.1.0 and yangtools 2.0.3 (and any subsequent patch versions) for Fluorine?" Results are
21:18:20 <odl_meetbot> +1 (8): skitt, zxiiro, LuisGomez, jamoluhrsen, anipbu, rovarga_, vishnoianil, abhijitkumbhare
21:18:28 <shague> #vote +1
21:18:45 <shague> can't hear you
21:18:49 <skitt> rovarga_, https://jira.opendaylight.org/browse/ODLPARENT-146
21:18:58 <shague> I was kidding
21:19:29 <skitt> #startvote Does the TSC request that the release engineering team merge all the patches to upgrade Oxygen SR1 to odlparent 3.1.0 and yangtools 2.0.3 (and any subsequent patch versions)? -1,0,+1
21:19:29 <odl_meetbot> Begin voting on: Does the TSC request that the release engineering team merge all the patches to upgrade Oxygen SR1 to odlparent 3.1.0 and yangtools 2.0.3 (and any subsequent patch versions)? Valid vote options are -1, 0, +1.
21:19:29 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
21:19:44 <rovarga_> skitt: I have updated the controller patch
21:19:48 <jamoluhrsen> #vote +1
21:19:48 <anipbu> #vote +1
21:19:49 <lori> #vote +1
21:19:55 <zxiiro> #vote +1
21:19:58 <LuisGomez> #vote +1
21:19:58 <skitt> aadam, https://meetings.opendaylight.org/opendaylight-meeting/2018/tsc/opendaylight-meeting-tsc.2018-03-28-20.33.log.txt
21:20:00 <skitt> #vote +1
21:20:16 <rovarga_> #vote +1
21:20:18 <abhijitkumbhare> #vote -1
21:21:37 <skitt> shague, ping
21:22:33 <dfarrell07> shague: ping
21:22:51 <shague> #vote +1
21:23:29 <vishnoianil> #vote +1
21:24:01 <jamoluhrsen> #info abhijitkumbhare concerned about making a karaf upgrade in between SR releases
21:24:34 <abhijitkumbhare> #endvote
21:24:34 <odl_meetbot> Voted on "Does the TSC request that the release engineering team merge all the patches to upgrade Oxygen SR1 to odlparent 3.1.0 and yangtools 2.0.3 (and any subsequent patch versions)?" Results are
21:24:34 <odl_meetbot> +1 (9): skitt, anipbu, LuisGomez, shague, lori, jamoluhrsen, zxiiro, rovarga_, vishnoianil
21:24:34 <odl_meetbot> -1 (1): abhijitkumbhare
21:25:41 <abhijitkumbhare> #topic Fluorine
21:25:46 <skitt> #info lispflowmapping and netvirt have dependencies which haven't applied to be managed
21:26:39 <jamoluhrsen> #link https://docs.google.com/document/d/1c0rpB_7VMtWKIIgldbpVXnb77yUxUtbw1ayvOONrJvg/edit?usp=sharing <-- MRI requests
21:26:42 <shague> working on the coe dependency - pinged frederick, faseela and prem
21:27:49 <shague> dlux is not a dependency with netvirt as we don't build it. The code is there but not included in poms. skitt has a patch to remove the code also.
21:28:10 <skitt> #info lispflowmapping depends on honeycomb.vbd which hasn't yet applied but is working on it
21:28:23 <skitt> #info netvirt depends on coe which is also working on it
21:28:40 <vina_ermagan> #info Patch for removing  DLUX from lispflowmapping is pending verify and will be merged soon
21:30:22 <skitt> #info lispflowmapping is using vbd in an experimental feature only so it can easily be dropped
21:30:36 <skitt> #info but it would have to be for the full release (projects can't join MR after the deadline)
21:31:23 <dfarrell07> #action dfarrell07 to ping honeycomb/vbd about joining Managed ASAP
21:31:27 <shague> lori: might be able to use a profile. netvirt has an sfc feature, that isn't built by default that uses a profile to make it easy to include or not
21:31:53 <dfarrell07> #action dfarrell07 to follow up with fkautz about COE applying to Managed
21:32:27 <lori> shague: thanks, that sounds useful
21:36:28 <anipbu> https://docs.google.com/document/d/1c0rpB_7VMtWKIIgldbpVXnb77yUxUtbw1ayvOONrJvg/edit
21:37:43 <shague> can you guys talk a bit louder?
21:40:05 <shague> :)
21:40:25 <dfarrell07> #info ovsdb has committer vishnoianil who will normally be at TSC
21:40:59 <shague> #info shague, skitt also as committers on ovsdb and in TSC
21:41:33 <skitt> #agree osvbd is approved as an MSI project for Fluorine
21:42:07 <abhijitkumbhare> #undo
21:42:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2b88b90>
21:42:21 <abhijitkumbhare> #agree ovsdb  is approved as an MSI project for Fluorine
21:43:25 <abhijitkumbhare> #link Daexim proposal for MSI https://jira.opendaylight.org/browse/TSC-61
21:43:30 <dfarrell07> #info michael will come to TSC for DAEXIM
21:43:30 <skitt> #agree daexim is approved as an MSI project for Fluorine
21:44:12 <abhijitkumbhare> #link BGPCEP MSI proposal: https://jira.opendaylight.org/browse/TSC-56
21:44:53 <dfarrell07> #info jamoluhrsen says bgpcep is active on test front, even if few committers
21:45:18 <dfarrell07> #info bgpcep seems responsive, did have a blocker bug late in oxygen but handled it well
21:45:25 <jamoluhrsen> #info bgpcep only really has one active committer currently
21:45:45 <dfarrell07> #info rovarga_ is a bgpcep committer but he doesn't look at it much, "active backup:
21:45:49 <dfarrell07> #undo
21:45:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2a5e210>
21:45:52 <dfarrell07> #info rovarga_ is a bgpcep committer but he doesn't look at it much, "active backup"
21:46:23 <dfarrell07> #info should keep level of committers on radar for bgpcep, if he seems gone may be issue TSC needs to deal with
21:46:43 <skitt> #info rovarga_ will represent the project
21:47:01 <skitt> #agree bgpcep is approved as an MSI project for Fluorine
21:48:08 <abhijitkumbhare> #info OpenFlow Plugin: https://jira.opendaylight.org/browse/TSC-50
21:48:19 <dfarrell07> #info vishnoianil has already done a committer cleanup for openflow plugin recently
21:48:36 <dfarrell07> #info openflow plugin has about five active people, multiple companies
21:49:25 <dfarrell07> #info rovarga_ has seem small patches that were not reviewed, vishnoianil is apparently only one reviewing, has been pushing committers to do reviews
21:49:49 <dfarrell07> #info there are one or two people in the contribution pipeline for becoming committers
21:50:15 <skitt> #agree openflowplugin is approved as an MSI project for Fluorine
21:51:26 <abhijitkumbhare> #info Distribution Project: https://jira.opendaylight.org/browse/TSC-48
21:51:41 <dfarrell07> #info distribution has committers who are very active in ODL, can step up in times of need easily
21:51:44 <skitt> #agree distribution is approved as an MSI project for Fluorine
21:52:21 <dfarrell07> #info genius - jamoluhrsen reports that from a test side they are very active, very responsive
21:52:23 <abhijitkumbhare> #info Genius project: https://jira.opendaylight.org/browse/TSC-63
21:52:30 <skitt> #agree genius is approved as an MSI project for Fluorine
21:52:36 <dfarrell07> #info genius meets every week, speaks up lots when things break them
21:53:03 <abhijitkumbhare> #info Neutron Northbound: https://jira.opendaylight.org/browse/TSC-60
21:53:04 <dfarrell07> #info josh h is going to take over as PTL for Neutron MB
21:53:06 <dfarrell07> #undo
21:53:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ae61d0>
21:53:09 <dfarrell07> #info josh h is going to take over as PTL for Neutron NB
21:53:22 <skitt> #agree neutron is approved as an MSI project for Fluorine
21:53:37 <dfarrell07> #info NNB does have good integration tests, and is also very well tested by other projects
21:54:29 <dfarrell07> #info maybe should be watching number of committers for NNB, fairly healthy but more might be better
21:55:30 <abhijitkumbhare> #info LISP project: https://jira.opendaylight.org/browse/TSC-54
21:56:09 <dfarrell07> #info lisb needs to deal with honeycomb/vbd dep, who has not applied for Managed
21:56:14 <abhijitkumbhare> #info Vote deferred for LISP till next week
21:56:28 <skitt> #action lori to resolve the situation wrt honeycomb by next week's TSC call
21:56:36 <dfarrell07> #info lisp can comment out honeycomb/vbd, but they *will not be able to add them back in Fluorine even if they become Managed*
21:58:52 <dfarrell07> #info rovarga_ points out that in some future version of MR, we may want to think about how MR projects could have experimental features, say that depend on unmanaged projects
21:59:28 <dfarrell07> #info waiting on lisp to cut dep, will vote no next week
22:00:23 <dfarrell07> #info sfc depends on lisp, so also waiting on vote until lisp cuts vbd dep
22:01:38 <dfarrell07> #info sfc has very active contributors in opnfv xci, so very good test coverage, also someone is is doing ODL-side testing I see frequently
22:02:16 <dfarrell07> #info bjohnson_ is on TSC, so will be at meetings for SFC
22:02:57 <shague> sorry, sfc is a profile that is simply flipped on or off
22:03:01 <shague> thanks skitt
22:03:22 <shague> coe will use a similar profile if coe doesn't go managed
22:03:52 <jamoluhrsen> shague: ack
22:04:13 <shague> dlux has been removed completely
22:05:13 <shague> profiles are very useful for experimental features
22:06:15 <jamoluhrsen> shague: so if SFC were to disappear altogether, the health and usefulness of netvirt is not really affected, right?
22:07:03 <shague> jamoluhrsen: yes, it just isn't there. that feature is no longer there
22:07:30 <jamoluhrsen> cool beans
22:10:31 <shague> :)
22:10:58 <abhijitkumbhare> #agree NetVirt  is approved as an MSI project for Fluorine
22:13:34 <dfarrell07> #info skitt has experience with tsdr waking up once or so a release to merge patches, but not watching frequently
22:14:10 <dfarrell07> #info it may be that tsdr depends on SNMP, which is not managed
22:15:22 <dfarrell07> #info it seems possible that tsdr doesn't understand that they can still be fully "a part of opendaylight" by being unmanaged, maybe just need to reassure them of that
22:15:41 <dfarrell07> #info tsdr doesn't come to tsc, doesn't have active committers, doesn't have contribution history says jamoluhrsen
22:16:32 <shague> agreed with jamo's comment. a primary trait of a managed project is being active. tsdr does not have that trait.
22:19:03 <shague> it's not the end of the world that you are not managed. unmanaged is hardly any different than managed. nothing stops the project from being used in ODL
22:21:43 <skitt> #startvote Does the TSC approve TSDR as a managed project for Fluorine? -1,0,+1
22:21:43 <odl_meetbot> Begin voting on: Does the TSC approve TSDR as a managed project for Fluorine? Valid vote options are -1, 0, +1.
22:21:43 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
22:21:45 <rovarga_> #vote -1
22:21:46 <skitt> #vote -1
22:21:47 <zxiiro> #vote -1
22:21:51 <aadam> #vote -1
22:21:53 <jamoluhrsen> #vote -1
22:21:53 <shague> #vote -1
22:21:55 <vishnoianil> #vote -1
22:21:56 <abhijitkumbhare> #vote -1
22:22:08 <anipbu> #vote 0
22:22:23 <skitt> #endvote
22:22:23 <odl_meetbot> Voted on "Does the TSC approve TSDR as a managed project for Fluorine?" Results are
22:22:23 <odl_meetbot> 0 (1): anipbu
22:22:23 <odl_meetbot> -1 (8): skitt, vishnoianil, shague, jamoluhrsen, zxiiro, rovarga_, aadam, abhijitkumbhare
22:22:57 <LuisGomez> #vote -1
22:22:59 <LuisGomez> sorry late
22:23:05 <rovarga_> whoa!
22:23:12 <rovarga_> where were you, dude?!
22:23:13 <jamoluhrsen> vote
22:23:29 <rovarga_> :-)
22:24:29 <abhijitkumbhare> #action dfarrell07 will communicate with TSDR
22:26:17 <jamoluhrsen> #agree all other projects will be removed from distribution and autorelease (LISP and SFC will be deferred)
22:27:25 <abhijitkumbhare> #topic Coffee, cookies & beer
22:28:17 <abhijitkumbhare> #endmeeting