16:58:09 <CaseyLF> #startmeeting tsc
16:58:09 <odl_meetbot> Meeting started Thu Apr  5 16:58:09 2018 UTC.  The chair is CaseyLF. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:09 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:09 <odl_meetbot> The meeting name has been set to 'tsc'
16:58:26 <abhijitkumbhare> Also dfarrell07 gzhao
16:58:31 <CaseyLF> #chair abhijitkumbhare jamoluhrsen skitt dfarrell07
16:58:31 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare dfarrell07 jamoluhrsen skitt
16:59:01 <dfarrell07> we know ;)
16:59:13 <jamoluhrsen> #info jamoluhrsen
16:59:15 <jamoluhrsen> be here in a bit
16:59:15 <abhijitkumbhare> Yes :)
16:59:23 <abhijitkumbhare> #topic Agenda Bashing, Roll Call
16:59:32 <abhijitkumbhare> #info abhijitkumbhare
16:59:39 <bjohnson_> #info Brady Johnson
17:00:03 <skitt> #info skitt
17:01:20 <jamoluhrsen> #action jamoluhrsen to ping shague to get snapshot vm work put in to jira tasks
17:01:46 <cdgasparini> #project bgpcep
17:01:47 <anipbu> #info anipbu
17:01:52 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/TSC:Meeting#Agenda Agenda
17:01:54 <zxiiro> #info Thanh Ha
17:02:14 <cdgasparini> #info Claudio
17:02:47 <abhijitkumbhare> cdgasparini: - only the TSC members need to info in
17:02:50 <rovarga_> #info rovarga_
17:02:53 <shague> #info shague
17:02:59 <dfarrell07> reminder to start doing #project <project>
17:03:04 <jamoluhrsen> projects, please info in to record your attendance
17:03:27 <dfarrell07> abhijitkumbhare: no, we also need projects to #project in
17:03:41 <dfarrell07> welcome cdgasparini :)
17:03:44 <abhijitkumbhare> Yes - projects
17:03:48 <shague> #info #project netvirt genius ovsdb coe
17:03:59 <dfarrell07> shague: no #info part
17:04:04 <bjohnson_> #project sfc
17:04:07 <gzhao> #info gzhao
17:04:13 <dfarrell07> shague: it's not a valid command but we can parse it np
17:04:16 <abhijitkumbhare> #topic Groups.io
17:04:17 <shague> dfarrell07: without #info then it would be added to the minutes right?
17:04:30 <dfarrell07> shague: it will be in the log
17:04:52 <shague> the full log but not the minutes? doesn't hurt to have #info then does it?
17:05:02 <jamoluhrsen> yeah, just #project <name> is enough
17:05:05 <dfarrell07> why aren't we following prio ordering like we agreed?
17:05:10 <skitt> #info the LF is trying to migrate to Groups.io
17:05:14 <skitt> dfarrell07, because CaseyLF
17:05:32 <skitt> #info individuals can be moderators so groups can self-moderate without LF staff
17:05:44 <skitt> #info users have a single account across all Groups.io groups
17:05:49 <LuisGomez> #info LuisGomez
17:06:32 <abhijitkumbhare> I lost audio
17:06:35 <vishnoianil> #info Anil Vishnoi
17:06:36 <dfarrell07> shague: I guess we could make a regex that doesn't matter if #project is at the beginning
17:06:42 <abhijitkumbhare> and video - reconnecting
17:07:05 <jamoluhrsen> shague: dfarrell07 we hammered out the #project semantics in painful details in gerrit. :)
17:07:27 <skitt> #info LF will be able to delegate moderation
17:07:42 <shague> dfarrell07: yeah that's what I thought - just don't expdct it at the line beginning. my main thought it is nice if e have the project people listed in the minutes since that is what we normally looko at
17:08:33 <skitt> CaseyLF, the point isn’t about big news or going fast, the point is about the TSC agreeing to a process and you walking all over it
17:08:45 <jamoluhrsen> shague: we are just going to scrape the full logs. we'll find username #projeect and <project name> all inone line and that's all we need
17:08:58 <abhijitkumbhare> I lost my connection - reconnecting
17:09:13 <skitt> #info the LF IT has decided to migrate all Mailman instances to Groups.io
17:09:23 <skitt> #info projects which don’t want Groups.io will have to find their own provider
17:09:29 <skitt> #info the deadline is end of Q2 2018
17:09:59 <shague> jamoluhrsen: understood - still doesn't address the thought that it is nice to ahve in the minutes. all you are doing is adding a #info, so don't understand why not do it. it is no extra work
17:10:22 <jamoluhrsen> shague: I don't care. we just already talked about it in gerrit. I'm fine with #info
17:10:43 <jamoluhrsen> shague: it's actually what I sugessted to start with.
17:13:39 <skitt> #info the current Mailman services we use are hosted by the LF
17:13:52 <skitt> #info and the LF is discontinuing these services at the end of Q2
17:14:00 <dfarrell07> #info dfarrell07 rovarga_ and others are very unhappy about being forced into this from above by LF, think it's not okay for LF to dictate to projects like this
17:14:02 <jamoluhrsen> #info many TSC memebers are voicing concerns about being forced to move.
17:14:16 <dfarrell07> #info dfarrell07 asks for people making this decision to attend this call, apparently the refused
17:14:22 <skitt> #info no one present from the LF has context on the decision
17:14:28 <dfarrell07> #action dfarrell07 will bring this to TAC and GB
17:14:31 <skitt> #info the people who do were asked to join the call but refused
17:15:17 <abhijitkumbhare> #info abhijitkumbhare asks whether mailman was hosted by LF? Answer is yes
17:15:17 <skitt> #info phrobb hears loud and clear the negative impact on ODL and agrees with our taking this to the TAC
17:15:50 <skitt> #info phrobb encourages TSC members to talk to board members
17:15:51 <abhijitkumbhare> #info abhijitkumbhare further asks whether this is a LF decision or an LFN decision?
17:15:53 <shague> #info this should be discussed openly, after the ONS fiasco, many projects are getting very worrisome about the LF control
17:16:00 <skitt> #info phrobb mentions that the board wasn’t involved in the decision
17:16:26 <dfarrell07> #info dfarrell07 and many others are very concerned about this type of change in LF direction
17:16:51 <skitt> #info phrobb wasn’t aware of this before the call
17:17:02 * dfarrell07 reallllly wants to know who pushed this
17:17:20 <skitt> #info the Q2 discontinuation was communicated to tykeal and CaseyLF only yesterday
17:17:53 <dfarrell07> #info anil says LF should go to projects with ideas, talk and get buy-in, then move in a direction, not force things from above
17:18:08 * rovarga_ is concerned that LF is greatly regressing in terms of openness
17:18:17 <dfarrell07> #action dfarrell07 to bring LF open process requirement to TAC
17:18:39 <skitt> #info this is an LF decision, not an LFN decision
17:19:34 <jamoluhrsen> it feels like we were given the choice of groups.io, then when we declined, the LF tried again and we still balked, and now we are just being told what to do.
17:20:38 <rovarga_> jamoluhrsen: +1
17:21:28 <rovarga_> jamoluhrsen: +1
17:22:24 <skitt> #info phrobb suggests it might just be a misunderstanding
17:22:39 <skitt> #info that someone at LF IT thought it pointless to continue maintaining two similar services
17:23:17 <jamoluhrsen> #info we don't want this precedence set where we get dictated to like this.
17:23:22 * bjohnson_ is the horse dead yet???
17:23:27 <skitt> #topic Neon DDF
17:23:42 <vishnoianil> when initially umbrella project idea was rolled out, there were some concerns about the whole idea, and these kind of instances kind of giving it away that people might be right about their concern :)
17:23:44 <jamoluhrsen> can we start a gofundme for coffee at neon ddf?
17:23:44 <skitt> #topic Releases
17:23:51 <vishnoianil> but hopefully it's first and last.
17:24:01 <skitt> #info Fluorine first
17:24:13 <anipbu> #info https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10303   <==== Fluorine Dashboard
17:24:18 <skitt> #info dfarrell07 sent a summary out on various topics
17:24:37 <skitt> #info four more reviews still need to be done, hopefully in this call
17:25:03 <abhijitkumbhare> #info https://lists.opendaylight.org/pipermail/tsc/2018-April/009331.html Managed Apps & Initial Checkpoint Status
17:25:04 <skitt> #info coe, lisp, sfc, netvirt still need approval
17:25:08 <dfarrell07> #link https://jira.opendaylight.org/issues/?filter=10235
17:25:20 <skitt> #link dfarrell07’s email: https://lists.opendaylight.org/pipermail/tsc/2018-April/009331.html
17:25:34 <dfarrell07> #link https://jira.opendaylight.org/browse/TSC-66 COE Managed Application
17:25:37 <zxiiro> dfarrell07: it's not public
17:26:15 <skitt> #info the application was submitted on time but missed a field
17:26:20 <skitt> #info very active project
17:26:24 <skitt> #info dependency of netvirt
17:26:28 <skitt> #info small code-based
17:26:33 <skitt> #info high interest
17:26:49 <skitt> #info focused scope
17:28:28 <skitt> #agreed The TSC approves COE as a managed project for Fluorine
17:28:59 <dfarrell07> #link https://jira.opendaylight.org/browse/TSC-52 netvirt
17:29:14 <skitt> #agreed The TSC approves NetVirt as a managed project for Fluorine
17:29:24 <dfarrell07> #link https://jira.opendaylight.org/browse/TSC-47
17:29:37 <skitt> #undo
17:29:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2a5ead0>
17:29:45 <dfarrell07> #link https://jira.opendaylight.org/browse/TSC-54 lisp
17:29:46 <bjohnson_> #link https://git.opendaylight.org/gerrit/#/c/70308/ Patch to cut dlux dependency
17:30:43 <dfarrell07> #link https://jira.opendaylight.org/browse/TSC-47 sfc
17:30:58 <skitt> #agreed The TSC approves LISP as a managed project for Fluorine
17:31:22 <abhijitkumbhare> Just by mentioning SFC, tbachman decided to quit
17:31:37 <skitt> #agreed The TSC approves SFC as a managed project for Fluorine
17:32:44 <skitt> #info bjohnson_ asks who should update the JIRA for joining
17:32:55 <skitt> #info dfarrell07 says he can take care of it, or bjohnson_ can if he wishes
17:33:29 <skitt> #info dfarrell07 has filed grievances against projects missing their JIRA to join the release
17:33:46 <anipbu> #action dfarrell07 will mark all participation checkpoints and initial checkpoints to "resolved" and "closed"
17:34:09 <skitt> #info we should review the grievances in the next TSC call
17:34:44 <skitt> #info LuisGomez points out we need to file more grievances against kernel projects with too few committers
17:35:45 <skitt> #info re TSDR, dfarrell07 has had lots of email discussion with yulingchen and Scott
17:36:01 <skitt> #info to explain that unmanaged status is a good thing for projects like TSDR
17:37:16 <skitt> #info and communicate the TSC’s concerns re committers
17:37:51 <skitt> #info yulingchen explains that there are two active TSDR committers along with tompantelis who helps out with technical migrations
17:38:06 <skitt> #info yulingchen feels there’s a gap between the TSC’s perception of TSDR and the reality of the project
17:38:40 <skitt> #info most of the recent patches were tompantelis’s patches
17:38:48 <skitt> #info TSDR doesn’t break ODL
17:39:15 <skitt> #info yulingchen asks if managed projects need to have commits every day
17:39:28 <skitt> #info dfarrell07 explains that managed projects need to pay close attention to the ODL ecosystem
17:41:35 <skitt> #info yulingchen points out that “unmanaged” itself has negative connotation
17:42:35 <skitt> #info managed v. unmanaged isn’t a mark of quality, it’s a mark of how well the ODL release fits a project’s specific plan and aims
17:42:38 <anipbu> for the record, USC and NEMO is still an active and high quality project and active in OpenDaylight =)
17:43:25 <skitt> #info the management angle is only with regards to the release team
17:43:37 <skitt> #info “self-managed” might be a better term, v. “release-managed”
17:44:05 <rovarga_> RMSI and RMRI are becoming a mounthful
17:45:19 <skitt> #info TSDR fears that being unmanaged will reduce their ability to be used by other projects
17:45:20 <abhijitkumbhare> We don't have to call it RMRI and RMSI rovarga_
17:45:37 <abhijitkumbhare> They can continue to be called MSI & MRI
17:46:30 <rovarga_> abhijitkumbhare: yeah, I just mean the vocabulary may be hurt by soft-speak ;-)
17:46:46 <skitt> #info “managed” is more of a commitment to the ODL community in general, with contributions to other ODL projects, processes etc.
17:46:49 <dfarrell07> #action dfarrell07 to clarify in managed docs that we expect projects to work on all of ODL, contribute back, not take more cycles then they give
17:47:16 <dfarrell07> #action dfarrell07 to consider renaming Managed to ~TSC Managed and Unmanaged to Self-Managed
17:53:17 <skitt> #info yulingchen thanks the TSC for providing all this information
17:53:49 <skitt> #info the TSC wants to reinforce the message that TSDR isn’t doing anything bad
17:54:29 <skitt> #info TSDR wants to end up being managed but understands that it needs to do more
17:55:30 <skitt> #topic SRs coming up
17:55:40 <skitt> #info Oxygen SR1 a week on Saturday
17:55:45 <skitt> #info Carbon SR4 on April 26
17:55:54 <skitt> #info Oxygen autorelease is good, Carbon autorelease is a mess
17:55:54 <abhijitkumbhare> #info Happy birthday to dfarrell07 in advance for April 14!
17:56:34 <skitt> #info anipbu asks when we want to lock the branches
17:57:03 <skitt> #info we still need to do the version bumps for Oxygen (and Fluorine)
17:57:11 <skitt> #info we should bump before we lock
17:57:16 <abhijitkumbhare> CaseyLF: I think we need to postpone the Neon DDF discussion to next week
17:58:45 <vishnoianil> Hard stop for me, need to drop now.
17:59:21 <jamoluhrsen> can we #agree on those version bumps happening asap from the releng team.
17:59:34 <bjohnson_> Me too, I have to leave in 1 minute
17:59:37 <abhijitkumbhare> yes jamoluhrsen
17:59:39 <dfarrell07> we didn't talk about nitrogen
18:00:12 <skitt> #agreed the version bumps will happen ASAP for Oxygen, driven by the releng team
18:00:14 <jamoluhrsen> #agree that oxy and fluorine version bumps can be merged by releng team asap
18:00:18 <jamoluhrsen> #undo
18:00:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2b69c90>
18:00:27 <skitt> is it #agree or #agreed?
18:01:15 <jamoluhrsen> no clue skitt you are the expert :)
18:01:36 <gzhao> I think both should work
18:01:47 <skitt> #topic cookis
18:01:49 <skitt> #undo
18:01:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2ada690>
18:01:52 <skitt> #topic cookies
18:01:54 <skitt> #endmeeting