#opendaylight-meeting: tsc

Meeting started by CaseyLF at 16:55:56 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (skitt, 16:57:29)
    1. abhijitkumbhare (abhijitkumbhare, 16:57:55)
    2. Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (skitt, 16:58:06)
    3. Last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2018/tsc/opendaylight-meeting-tsc.2018-04-05-16.58.html (skitt, 16:58:24)
    4. TSC members please info in (skitt, 16:58:29)
    5. skitt (skitt, 16:58:32)
    6. abhijitkumbhare (abhijitkumbhare, 16:58:49)
    7. Brady Johnson (bjohnson_, 16:59:47)
    8. For future TSC meetings, abhijitkumbhare asks that people update the agenda (on the wiki or by email to him) before Thursday morning Pacific (skitt, 17:00:27)
    9. jamoluhrsen (jamoluhrsen, 17:01:03)
    10. rgoulding (rgoulding, 17:01:15)
    11. anipbu (anipbu, 17:01:45)
    12. gzhao (gzhao, 17:02:08)
    13. Thanh Ha (zxiiro, 17:02:13)
    14. Project representatives please #project in (skitt, 17:02:28)
    15. shague (shague, 17:03:05)
    16. (jhershbe, 17:03:10)
    17. jhershbe (jhershbe, 17:03:17)
    18. #project netvirt ovsdb genius (shague, 17:03:44)

  2. Federate ODL and LF JIRA (skitt, 17:04:07)
    1. #project bgpcep (cdgasparini, 17:04:14)
    2. #project neutron (jhershbe, 17:04:36)

  3. Federate ODL Jira to LF Jira (abhijitkumbhare, 17:04:58)
    1. this will allow tickets to be linked (skitt, 17:05:35)
    2. as is the case with the FD.io JIRA (skitt, 17:05:45)
    3. AGREED: the ODL and LF JIRAs will be federated (skitt, 17:06:15)

  4. TAC proxy policy (skitt, 17:06:34)
    1. we’ll revisit this next time dfarrell07_pto is present (skitt, 17:07:07)

  5. Neon DDF (skitt, 17:07:19)
    1. Anil Vishnoi (vishnoianil, 17:07:24)
    2. #project openflowplugin (vishnoianil, 17:07:40)
    3. #project ovsdb (vishnoianil, 17:07:46)
    4. we need to decide when and where to host the Neon DDF (skitt, 17:07:50)
    5. 3 options (abhijitkumbhare, 17:07:59)
    6. ONS will take place in Amsterdam in late September (skitt, 17:08:06)
    7. https://lists.opendaylight.org/pipermail/tsc/2018-April/009395.html <--- Casey's email about Neon DDF with three options (anipbu, 17:08:09)
    8. 1. We can hold the DDF at ONS. The LF can peruse an offsite location the week before or after in Amsterdam. (abhijitkumbhare, 17:08:19)
    9. 2. We can pursue a hosted location in the EU near ONS. (abhijitkumbhare, 17:08:31)
    10. 3. We can peruse a hosted location in the Bay Area like we did for Oxygen. (abhijitkumbhare, 17:08:44)
    11. ACTION: CaseyLF to create an online poll for community members to vote (skitt, 17:10:12)
    12. the September time-frame is appropriate given our release calendar (skitt, 17:10:34)
    13. Fluorine is due on September 7 (skitt, 17:10:46)
    14. rovarga_ (rovarga_, 17:14:13)
    15. we need to decide sooner rather than later, especially if we host it in Europe (skitt, 17:14:52)
    16. Quan (Quan, 17:15:55)
    17. LuisGomez (LuisGomez, 17:18:10)
    18. the ONS Europe CFP is open until June 24 (skitt, 17:19:47)

  6. Fluorine (skitt, 17:20:24)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400 <--- Fluorine Tracking Dashboard (anipbu, 17:20:31)
    2. https://jira.opendaylight.org/browse/TSC-45 <--- Weather: MDSAL Fluorine API breakage window 1 has been resolved (anipbu, 17:20:38)
    3. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-3.1.0 <--- odlparent 3.1.0 and yangtools 2.0.3 still pending. Version bump Checkpoint in two weeks! (anipbu, 17:20:47)
    4. the version bump should have happened/finished back on 4/8 (jamoluhrsen, 17:23:07)
    5. the bump window calls for merges at the start (April 8) (skitt, 17:23:13)
    6. and then two weeks to settle things down (skitt, 17:23:21)
    7. we’ll start the bumps ASAP (skitt, 17:23:26)

  7. Oxygen (skitt, 17:23:32)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10401 <--- Oxygen Tracking Dashboard (anipbu, 17:23:38)
    2. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-3.1.0-oxygen <--- Oxygen version bump for odlparent 3.10 and yangtools 2.0.3 is complete (anipbu, 17:23:45)
    3. Oxygen SR1 on 4/14, but most likely delayed because of autorelease failure (anipbu, 17:24:00)
    4. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-oxygen/ <--- Oxygen SR1 Autorelease job is still failing on jsonrpc, bgpcep, controller (anipbu, 17:24:12)
    5. https://git.opendaylight.org/gerrit/#/c/70816/ <--- Fix for jsonrpc autorelease failures at 2AM (anipbu, 17:24:28)
    6. Request that releng lock oxygen branch. (anipbu, 17:24:50)
    7. there is a blocker bug (jira pending from LuisGomez) in oxygen. REST is broken (jamoluhrsen, 17:25:46)
    8. AGREED: the branches should be locked now (skitt, 17:26:12)
    9. ACTION: zxiiro to lock oxygen branch (jamoluhrsen, 17:26:15)
    10. probably 1-2 weeks delay (skitt, 17:26:36)
    11. stable/oxygen is now locked (zxiiro, 17:27:00)
    12. Quan (Quan, 17:27:24)
    13. controller patch: https://git.opendaylight.org/gerrit/70840 (rovarga_, 17:27:30)
    14. We will likely be delayed by a week (4/21) for Oxygen SR 1 (abhijitkumbhare, 17:28:43)
    15. ACTION: zxiiro to open a jira blocker for oxy about vtn/nic issue (jamoluhrsen, 17:29:25)
    16. cdgasparini will open a JIRA for the controller patch (skitt, 17:29:27)

  8. Nitrogen (skitt, 17:29:35)
    1. Last Nitrogen SR3 in one month 5/7 (anipbu, 17:29:39)
    2. autorelease is broken in Nitrogen since February 22 (skitt, 17:30:06)
    3. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-nitrogen/ <--- (anipbu, 17:30:07)

  9. Carbon (skitt, 17:30:26)
    1. Last Carbon SR4 in two weeks on 4/26 (anipbu, 17:30:40)
    2. carbon still has the vtn/nic dependency issue (jamoluhrsen, 17:31:11)
    3. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/ <--- Last successful build on April 8 (anipbu, 17:31:32)
    4. https://wiki.opendaylight.org/view/Release_Dashboard <--- General Release Dashboard (anipbu, 17:34:22)

  10. ODL Internships (abhijitkumbhare, 17:34:44)
    1. we need project proposals for internships (skitt, 17:35:15)
    2. controller bug opened -> https://jira.opendaylight.org/browse/CONTROLLER-1825 (cdgasparini, 17:35:22)
    3. several people have reached out to the LF to volunteer as interns (skitt, 17:35:28)
    4. but we don’t have projects for them (skitt, 17:35:34)

  11. Infrastructure (skitt, 17:37:52)
    1. thread on the ML about limiting patches to 5MiB (skitt, 17:38:05)
    2. we can tune that if necessary but that should be sufficient for all sensible patches (skitt, 17:38:23)
    3. this will be applied at some point in the near future when Jenkins is quiet (skitt, 17:38:43)

  12. Models Update for the models lagging standards (abhijitkumbhare, 17:44:24)
    1. We need to balance making models up-to-date vs impact to projects (abhijitkumbhare, 17:48:35)
    2. Needs to continue discussion over the mailing list (abhijitkumbhare, 17:50:36)
    3. Would likely be a big impact change, hence need to get a buy-in from projects (abhijitkumbhare, 17:51:30)

  13. Cookies & Beer (abhijitkumbhare, 17:52:29)
    1. Thanks (abhijitkumbhare, 17:52:38)


Meeting ended at 17:52:44 UTC (full logs).

Action items

  1. CaseyLF to create an online poll for community members to vote
  2. zxiiro to lock oxygen branch
  3. zxiiro to open a jira blocker for oxy about vtn/nic issue


Action items, by person

  1. CaseyLF
    1. CaseyLF to create an online poll for community members to vote
  2. zxiiro
    1. zxiiro to lock oxygen branch
    2. zxiiro to open a jira blocker for oxy about vtn/nic issue


People present (lines said)

  1. skitt (50)
  2. abhijitkumbhare (20)
  3. anipbu (17)
  4. odl_meetbot (9)
  5. jamoluhrsen (9)
  6. zxiiro (7)
  7. jhershbe (4)
  8. bjohnson_ (4)
  9. gzhao (3)
  10. vishnoianil (3)
  11. shague (2)
  12. cdgasparini (2)
  13. rovarga_ (2)
  14. rgoulding (2)
  15. vorburger (2)
  16. Quan (2)
  17. CaseyLF (2)
  18. LuisGomez (1)


Generated by MeetBot 0.1.4.