16:58:11 <abhijitkumbhare> #startmeeting tsc
16:58:11 <odl_meetbot> Meeting started Thu May  3 16:58:11 2018 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:11 <odl_meetbot> The meeting name has been set to 'tsc'
16:58:46 <abhijitkumbhare> #chair skitt jamoluhrsen LuisGomez dfarrell07 CaseyLF
16:58:46 <odl_meetbot> Current chairs: CaseyLF LuisGomez abhijitkumbhare dfarrell07 jamoluhrsen skitt
16:59:34 <abhijitkumbhare> #topic Agenda Bashing, Roll Call, Action Items
17:01:18 <skitt> #info TSC *members* please #info in
17:01:24 <skitt> #info project representatives please #project in
17:01:29 <abhijitkumbhare> #info abhijitkumbhare
17:01:29 <skitt> #info skitt
17:01:31 <skitt> #project odlparent
17:01:34 <skitt> #project neutron
17:01:36 <bjohnson_> #info Brady Johnson
17:01:44 <bjohnson_> #project SFC
17:01:54 <vorburger> #project infrautils
17:01:57 <vorburger> #project daexim
17:01:57 <lori> #info lori
17:02:06 <lori> #project lispflowmapping
17:02:11 <zxiiro> #info Thanh Ha
17:02:14 <vorburger> #project daexim
17:02:21 <vorburger> #project genius
17:02:43 * bjohnson_ raise your hand if you're not here
17:02:47 <rovarga> #info rovarga
17:02:48 <jamoluhrsen> #info jamoluhrsen
17:02:50 <dfarrell07> 7
17:03:15 <rovarga> #project mdsal,controller,bgpcep,coretutorials
17:03:24 <rovarga> #project yangtools, of course
17:03:42 <vorburger> #project archetypes
17:03:44 <faseelak> #project genius, coe
17:04:10 <LuisGomez> #info LuisGomez
17:04:34 <vorburger> #project neutron
17:04:40 <abhijitkumbhare> #topic Fluorine
17:04:41 <shague> #info shague
17:05:05 <faseelak> #info faseelak
17:05:08 <shague> #info #project netvirt ovsdb
17:05:25 <skitt> shague, it's just "#project netvirt ovsdb"
17:05:26 <jamoluhrsen> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 <-- release dashboard
17:05:53 <shague> skitt: haha, I will always add #info to capture it in the minutes :)
17:05:54 <jamoluhrsen> shague: wants it to show up in the scraped notes from meetbot so #info will do that
17:07:09 <CaseyLF> aadam: Welcome.  :)
17:07:25 <aadam> CaseyLF: Thanks :-)
17:07:26 <CaseyLF> You should maybe look into something like IRCCloud.
17:07:27 <skitt> #info Fluorine in decent shape, autorelease is healthy
17:07:27 <zxiiro> aadam: welcome!
17:11:05 <jamoluhrsen> #info we have the mdsal breaking changes to get in, but vorburger suggests we don't put a hard deadline on it but instead wash/rinse/repeat all the project patches based on the mdsal changes in repeating multipatch jobs until it's good
17:11:47 <abhijitkumbhare> #info Michael has done multi patch job for TSC-100 - which passes. He proposes he thinks should be merged.
17:12:34 <abhijitkumbhare> #undo
17:12:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2d5ce10>
17:13:03 <abhijitkumbhare> #info Michael has done multi patch job for TSC-100 - which passes. He proposes the chain of patches for TSC-100 to be merged
17:21:45 <vorburger> oh BTW who of you here has administration privileges of the project "TSC" in JIRA? I would like two new custom fields for issues of Type: Weather Item: 1. Managed Topic: 2. Last Build:
17:24:13 <jamoluhrsen> vorburger: ask zxiiro
17:25:12 <zxiiro> vorburger: aadam and Kit are the TSC project admins right now
17:25:59 <zxiiro> vorburger: I'm not sure if that includes custom fields though, if not you will need to open a helpdesk ticket
17:27:09 <vorburger> zxiiro: I've raised https://jira.opendaylight.org/browse/RELENG-110 to track that and will open a helpdesk ticket
17:28:22 <zxiiro> vorburger: yep, that works, raise jira and then point helpdesk to the jira
17:28:53 <jamoluhrsen> #info we can come up with a "drop dead" date that we can use to start using the managed release projects to start kicking out leaf projects and assigning committers to other projects to make these breaking weather changes work
17:29:59 <vorburger> #link https://lists.opendaylight.org/pipermail/lispflowmapping-dev/2018-May/001154.html is an example of new tool can prompt projects
17:30:33 <jamoluhrsen> vorburger: did the daexim patches work?
17:30:43 <vorburger> lori: I'm sure you'll react to this?
17:30:48 <vorburger> jamoluhrsen: yes, of course ;-)
17:31:33 <jamoluhrsen> vorburger: I saw the job 26 failed.
17:31:41 <jamoluhrsen> vorburger: so I suspect it failed on the next project?
17:31:57 <lori> vorburger: sure
17:32:56 <vorburger> jamoluhrsen: ignore #26; #27 is where daexim passed for TSC-99 and lispflowmapping (the next one) failed. Once they have a patch, I'll just re-run it
17:33:39 <vorburger> jamoluhrsen: it's a PITA to keep track of which multipatch job is for which Weather Item. That's why I am proposing https://jira.opendaylight.org/browse/RELENG-110
17:36:39 <dfarrell07> 6*3/5 is ~ 3 weeks
17:41:32 <dfarrell07> so generally (time_to_fix_one_project * depth of tree)
17:41:34 <vorburger> #link https://github.com/vorburger/opendaylight-bot/blob/master/bot/src/main/resources/odl/projects.txt <-- FYI this is how I currently run the multipatch job
17:42:33 <jamoluhrsen> I agree with dfarrell07 . how did we get stuck on 3 weeks and not 8 business days, or 2 weekends, etc
17:43:08 <abhijitkumbhare> that is why I am saying we should classify a change as trivial, small, medium or large
17:43:17 <abhijitkumbhare> that was for jamoluhrsen
17:44:23 <jamoluhrsen> how are we stuck in these weeds?
17:44:44 <rovarga> jamoluhrsen: yeah, sorry about that :-(
17:44:59 <abhijitkumbhare> yes we are getting stuck in weeds
17:45:27 <dfarrell07> fine I pick 2 hours
17:45:30 <dfarrell07> or 2 months
17:45:55 <aadam> 2 weeks 1 day 5 hours and 32 minutes
17:46:28 <rovarga> aadam: +1
17:47:21 <jamoluhrsen> sorry lori , needed someone to pick on :)
17:47:26 <dfarrell07> I still think it's crazy we prefer a constant guess vs something based on the actual change
17:47:33 <lori> jamoluhrsen: no worries ;)
17:47:51 <abhijitkumbhare> #agreed We keep the deadline for May 17 for TSC-100
17:47:59 <jamoluhrsen> #topic nitrogen
17:48:03 <aadam> dfarrell07: let's start with something and adapt as we go
17:48:08 <abhijitkumbhare> #undo
17:48:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2bc7190>
17:48:17 <zxiiro> #link nitrogen tracking https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=230788404
17:48:27 <jamoluhrsen> thanks zxiiro
17:48:28 <abhijitkumbhare> #undo
17:48:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2bc7490>
17:48:32 <rovarga> aadam: +1, we will get better at this as we gain experience
17:48:40 <abhijitkumbhare> #agreed We keep the deadline for May 17 for TSC-100 , we revisit at that time
17:48:48 <abhijitkumbhare> #topic Nitrogen
17:48:58 <abhijitkumbhare> #link nitrogen tracking https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=230788404
17:49:24 <rovarga> shague: don't get me wrong -- I do not want to put you on the spot, as we used to by merging breaking changes -- but we cannot also wait forever, either
17:50:04 <vishnoianil> #info Anil Vishnoi
17:50:27 <abhijitkumbhare> Welcome to the meeting vishnoianil :)
17:51:55 <faseelak> vorburger, rovarga : Could you please let me know what are the patches I should use for verifying my genius patch for TSC-99, I see all the mdsal patches on verify -1
17:51:56 <faseelak> https://git.opendaylight.org/gerrit/#/c/71560/
17:52:15 <shague> rovarga: agreed. I appreciate the need for a date. I am fine with giving a target. But it is soft and we then discuss as needed. this is a serial issue so as an end consumer I can't say with certaintity if all dependencies are satisfied. so I can't fully plan either
17:52:38 <jamoluhrsen> #info netconf has a blocker issue in their nitrogen SR3 csit
17:52:48 <vorburger> faseelak: you just have to install the dependencies of your (genius) projrect from the list on https://git.opendaylight.org/gerrit/#/q/topic:binding-tlc-rpc
17:54:04 <vorburger> faseelak: lori just proposed a cool idea - https://jira.opendaylight.org/browse/RELENG-112
17:54:56 <faseelak> vorburger, that's cool.. i am just planning to use all mdsal and controller patches, wont take others..
17:55:10 <dfarrell07> https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/netconf-csit-3node-clustering-scale-all-nitrogen/19/odl1_karaf.log.gz
17:56:04 <jamoluhrsen> #action Jakub to file a blocker for the netconf CSIT in nitrogen sr3
17:56:44 <abhijitkumbhare> #topic Stackoverflow
17:57:06 <abhijitkumbhare> #info CaseyLF requests folks to answer questions on Stackoverflow
17:57:16 <abhijitkumbhare> #topic Interns
17:57:50 <abhijitkumbhare> #info Currently 5 proposals, ability to fund 8 interns
17:57:57 <dfarrell07> #link https://gerrit.linuxfoundation.org/infra/#/c/10103/ lfn process
17:58:18 <abhijitkumbhare> #undo
17:58:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2bb8b90>
17:58:26 <abhijitkumbhare> #topic LFN process
17:58:33 <abhijitkumbhare> #link https://gerrit.linuxfoundation.org/infra/#/c/10103/ lfn process
17:58:35 <jmorvay> here is the actual log
17:58:39 <jmorvay> 2018-05-02 05:13:27,997 | WARN  | qtp603191920-264 | BrokerFacade                     | 407 - org.opendaylight.netconf.sal-rest-connector - 1.6.3 | Error reading / from datastore CONFIGURATION ReadFailedException{message=read execution failed, errorList=[RpcError [message=read execution failed, severity=ERROR, errorType=APPLICATION, tag=operation-failed, applicationTag=null, info=null, cause=java.lang.IllegalArgumentExc
17:59:01 <jmorvay> ok sorry, I guess I will put that into the blocker bug..
17:59:28 <rovarga> jmorvay: please do and can you send out the link to the issue to release@?
17:59:46 <jmorvay> yup
17:59:59 <aadam> Guys, suggest we have a clearer agenda for next week with a limit for each topic
18:00:04 <aadam> Buy
18:00:08 <abhijitkumbhare> #topic Cookies
18:00:18 <vorburger> abhijitkumbhare: thanks for making a 1h meeting be a 1h meeting!
18:00:22 <zxiiro> aadam: we do have one https://wiki.opendaylight.org/view/TSC:Meeting
18:00:27 <abhijitkumbhare> #endmeeting