16:59:00 <abhijitkumbhare> #startmeeting tsc
16:59:00 <odl_meetbot> Meeting started Thu May 24 16:59:00 2018 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:00 <odl_meetbot> The meeting name has been set to 'tsc'
16:59:06 <jhershbe> #info jhershbe
16:59:15 <skitt> #topic Agenda-bashing and roll-call
16:59:18 <bjohnson_> #info Brady Johnson
16:59:22 <abhijitkumbhare> #chair CaseyLF skitt
16:59:22 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare skitt
16:59:23 <bjohnson_> #project SFC
16:59:27 <skitt> #topic Agenda-bashing and roll-call
16:59:36 <skitt> #info skitt
16:59:41 <skitt> #project odlparent
16:59:42 <jhershbe> #project neutron
16:59:49 <lori> #info lori
17:00:04 <lori> #project lispflowmapping
17:00:12 <jhershbe> #info project neutron
17:00:16 <abhijitkumbhare> #info abhijitkumbhare
17:00:34 <cdgasparini> #project bgpcep
17:00:46 <bjohnson_> #info project sfc
17:00:58 <rovarga> #info rovarga
17:01:04 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/TSC:Meeting#Agenda Agenda
17:01:19 <rovarga> #project yangtools, mdsal, controller, coretutorials
17:01:25 <jamoluhrsen> #info jamoluhrsen
17:01:40 <shague> #info shague
17:01:45 <gzhao> #info gzhao
17:01:54 <shague> #info #project netvirt
17:02:49 <jamoluhrsen> #action abhijitkumbhare to send TSC agenda the day prior to the TSC meeting when possible
17:03:10 <jamoluhrsen> #link https://wiki.opendaylight.org/view/TSC:Meeting#Agenda <-- agenda wiki that is updated weekly
17:03:36 <skitt> #topic General topics
17:03:42 <jamoluhrsen> shague: you want to project in for genius?
17:04:00 <LuisGomez> #info LuisGomez
17:04:08 <rgoulding> #info Ryan Goulding for AAA
17:04:30 <skitt> #info CaseyLF and phrobb went through the wiki recently and noticed lots of pages are out of date
17:04:41 <skitt> #info it would be nice if projects could check their pages and update them
17:04:44 <jamoluhrsen> #info CaseyLF noticed the wiki is out of date in many places (project proposals, project facts, release planning, etc.) Asking for people to do some cleanup
17:04:51 <shague> #info #project genius
17:05:16 <skitt> #info people can also tag info as out of date if they notice it
17:05:51 <jamoluhrsen> #info dfarrell07 points out that some, if not a lot, of our documentation has moved off of the wiki to readthedocs
17:08:24 <jamoluhrsen> #info possible conflicting information between LF and ODL wiki about the same topics
17:09:42 <skitt> #info ideally project-specific docs should go in the project
17:10:53 <skitt> #info further discussion will take place in the docs call
17:11:50 <jamoluhrsen> #info docs call is tuesdays 12pm PST, for those that want to help and give ideas about making docs better
17:12:07 <skitt> point of order: we are five minutes behind schedule
17:12:44 <scottmelton> #project TSDR
17:12:52 <skitt> #info the LF is looking into switching to EPL2 (the license)
17:13:12 <skitt> #info CaseyLF has info forthcoming
17:13:20 <vorburger> sorry I joined late
17:13:22 <skitt> #info we'll have a more formal presentation next week
17:13:43 <skitt> #info CaseyLF invites participants to reach out to their legal departments regarding this
17:13:50 <jamoluhrsen> hey vorburger. you missed the entire wiki discussion. shame on you :)
17:14:39 <skitt> #info as far as the Eclipse Foundation (originator of the EPL) is concerned, EPL1 is now deprecated
17:15:08 <skitt> #info multiple issues with EPL1 are addressed in EPL2: choice of venue, files as unit of licensing rather than modules, GPL compatibility etc.
17:15:24 <faseelak> #info faseelak
17:15:33 <faseelak> #project genius coe infrautils
17:15:50 <skitt> #info CaseyLF believes the TSC could vote to migrate and "force" all projects to migrate
17:16:16 <skitt> #info we'd also need an update to the charter, section 7bi, which specifies the license in use
17:17:07 <abhijitkumbhare> #action CaseyLF Send an email providing the details about the EPL2 change - rationale, etc. to the TSC mailing list
17:17:21 <jamoluhrsen> #action CaseyLF to schedule TWS for EPL2 change
17:17:42 <anipbu> #info anipbu
17:17:56 <bjohnson_> Is the TWS scheduled for Monday, May 28 going to be cancelled? Its Memorial day here in USA, and most people will be off.
17:18:19 <abhijitkumbhare> Yes bjohnson_ - we can have that TWS the following week
17:20:26 <skitt> #info re Mailman, the LF needs to know definitively by the end of the quarter what ODL wants to do
17:20:38 <skitt> #info the Mailman services were supposed to switch to Groups.io by then
17:21:11 <skitt> #info the LF needs permission from ODL to hand over Mailman management to Oregon State Labs which is where they're hosted
17:21:32 <skitt> #info the hosting wouldn't change, it's just that the LF wouldn't be taking care of it
17:22:40 <dfarrell07> +1 to staying on mailmain, went to some good talks this week about why it's important to use open tools, full of koolaid
17:23:27 <skitt> dfarrell07, hah you met Mako, excellent
17:23:44 <skitt> +1000
17:25:36 <abhijitkumbhare> #agreed We will stay on mailman - Oregon State Labs will be taking over the management/support for mailman on June 1
17:26:03 <jamoluhrsen> #link https://doodle.com/poll/5fi657n95dgz8xqb <-- poll for possible new TSC time
17:27:35 <rovarga> dfarrell07: CaseyLF: btw, where did we get with the question of what can LF do about usable FOSS mailing list software? :)
17:28:21 <dfarrell07> rovarga: /me doesn't know
17:28:24 <jamoluhrsen> #info we no longer need to have an official agenda item for system integration and test
17:28:38 <abhijitkumbhare> #topic Releases
17:28:38 <jamoluhrsen> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 <-- release dashboard
17:28:38 <dfarrell07> https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403#
17:29:12 <CaseyLF> rovarga: Other than mailman?
17:29:23 <skitt> #info TSC-99 went very well, much less downtime than previous migrations
17:29:28 <skitt> #info TSC-101 up next
17:30:28 <skitt> dfarrell07, you're breaking up
17:30:48 <skitt> #info Fluorine middle checkpoint coming up
17:30:56 <rovarga> CaseyLF: I guess, since the new mailman is seen as unusable
17:31:11 <skitt> #info work ongoing to improve automation to track the checkpoints (attendance, broken autorelease, CLM violations...)
17:31:17 <CaseyLF> rovarga: Mailman 3?  Yes.  Very unusable.  :)
17:31:36 <rovarga> CaseyLF: the line of reasoning being: if the GNU Project cannot produce a usable piece of software, is that something LF can tackle?
17:32:31 <skitt> rovarga, is ODL usable? ;-)
17:32:54 <vorburger> skitt: unclustered, yes AFAIK ;-)
17:33:38 <skitt> vorburger, right, which is what I was getting at, since it answers the question
17:34:11 <skitt> #info should the drop-dead date for pending weather items be the middle checkpoint?
17:34:52 <jamoluhrsen> stepping away for 3m
17:35:11 <vorburger> jamoluhrsen: hey, you'll miss the next Wiki related discussion!
17:37:07 <skitt> #info with patch queues for weather items, projects which get started early are penalised because they need to rebase a lot
17:37:32 <skitt> #info shague suggests that the answer is to get the patches ready more quickly
17:38:17 <skitt> #info instead of aiming for a drop-dead date, we should encourage projects to work on weather items ASAP
17:38:35 <skitt> #info (having a drop-dead date leads some projects to wait until then to prepare their patches)
17:38:44 <skitt> #info we could also have name-and-shame emails every day
17:38:49 <jamoluhrsen> vorburger: i'm back, what did I miss?
17:39:11 <jamoluhrsen> did you guys cover the autorelease/sft thing?
17:39:24 <skitt> jamoluhrsen, no
17:39:28 <vorburger> jamoluhrsen: yeah we had a vote and decided you are going to fix it, OK for you? ;-)
17:40:03 <abhijitkumbhare> As vorburger said we assigned everything to jamoluhrsen :)
17:40:04 * jamoluhrsen has quit
17:40:11 * jamoluhrsen has quit again
17:40:19 <vorburger> jamoluhrsen: no!! We *NEED* you.
17:40:52 * gzhao agrees we need jamoluhrsen
17:41:37 <abhijitkumbhare> vorburger: jamoluhrsen quit because of us :)
17:42:39 <bjohnson_> Where can we find a list of the grievances?
17:43:01 <vorburger> bjohnson_: I JUST figured, thanks to shague, that everyone is looking at https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 ...
17:43:56 <bjohnson_> vorburger:  Oh, I see it thanks. I was looking there, but didnt see the grievances
17:44:28 <jamoluhrsen> #topic removing SFT from autorelease
17:44:39 <jamoluhrsen> I can't set a topic?
17:44:54 <skitt> #chair jamoluhrsen
17:44:54 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare jamoluhrsen skitt
17:44:56 <abhijitkumbhare> #topic  removing SFT from autorelease
17:46:10 * bjohnson_ everytime I hear SFT, I look up since it sounds like SFC
17:46:28 <abhijitkumbhare> I also thought the same bjohnson_
17:46:54 <bjohnson_> If we have time, can we discuss this email? https://lists.opendaylight.org/pipermail/tsc/2018-May/009700.html
17:49:17 <skitt> #info rovarga suggests we modify autorelease so that it ignores SFT failures (logs them but continues)
17:49:30 <skitt> #info jamoluhrsen says there’s an issue with stuck SFTs
17:50:32 <abhijitkumbhare> we can bjohnson_ and rgoulding - if we have time. ( https://lists.opendaylight.org/pipermail/tsc/2018-May/009700.html)
17:50:46 <abhijitkumbhare> and if its quick
17:50:52 <jamoluhrsen> #link https://jira.opendaylight.org/browse/ODLPARENT-89 <-- sft hanging bug
17:51:22 <jamoluhrsen> #link https://jira.opendaylight.org/browse/ODLPARENT-88 <-- the real sft hanging bug
17:57:05 <skitt> #info now that autorelease feeds into int/dist, we should have equivalent coverage at least for managed projects
17:57:24 <rovarga> jamoluhrsen: it does not look like that bug really has an owner
17:57:29 <skitt> #link SFT patch: https://git.opendaylight.org/gerrit/72168
17:57:50 <jamoluhrsen> skitt: so are we disabling it? I mean, did we agree to that, or did we just talk about the different options?
17:58:22 <skitt> jamoluhrsen, I invite interested parties to weigh in on the patch above
17:58:35 <jamoluhrsen> ack
17:58:38 <skitt> jamoluhrsen, we didn't agree to anything :-/
18:00:57 <abhijitkumbhare> #topic Cookies & Beer
18:01:01 <skitt> #endmeeting