15:59:49 <abhijitkumbhare> #startmeeting tsc
15:59:49 <odl_meetbot> Meeting started Thu Jun  7 15:59:49 2018 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:59:49 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:49 <odl_meetbot> The meeting name has been set to 'tsc'
16:00:34 <abhijitkumbhare> #topic Agenda Bashing, Roll Call, Action Items
16:00:40 <gzhao> #info gzhao
16:00:55 <abhijitkumbhare> #info abhijitkumbhare
16:01:20 <skitt> #info skitt
16:01:21 <abhijitkumbhare> ping jamoluhrsen anipbu CaseyLF
16:01:27 <skitt> #project odlparent
16:01:32 <skitt> #project netvirt
16:01:34 <abhijitkumbhare> #chair skitt dfarrell07
16:01:34 <odl_meetbot> Current chairs: abhijitkumbhare dfarrell07 skitt
16:01:36 <jamoluhrsen> #info jamoluhrsen
16:01:39 <vthapar> #info Vishal
16:01:42 <skitt> #project ovsdb
16:01:44 <abhijitkumbhare> ping LuisGomez
16:02:00 <CaseyLF> Why is nobody on the Zoom bridge?
16:02:05 <abhijitkumbhare> ping zxiiro vishnoianil  rovarga_
16:02:10 <LuisGomez> #info LuisGomez
16:02:17 <skitt> CaseyLF, because you’re on the wrong Zoom session
16:02:17 <CaseyLF> oops, I was on the wrong one.
16:02:18 <abhijitkumbhare> CaseyLF: we are on zoom
16:02:45 <lori> #info lori
16:02:52 <lori> #project lispflowmapping
16:03:28 <aadam> #info ArielAdam
16:03:28 <skitt> #link Agenda: https://wiki.opendaylight.org/index.php?title=TSC:Main#Agenda
16:03:37 <skitt> #undo
16:03:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2d5c590>
16:03:46 <skitt> #link Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda
16:03:47 <aadam> #info project neutron
16:03:53 <CaseyLF> #link https://r.lfnetworking.org/Antitrust%20Slide.pdf anti trust policy
16:04:20 <faseelak> #info faseelak
16:04:30 <faseelak> #project genius coe
16:04:30 <skitt> #info jamoluhrsen asks to add the odltools project proposal to the agenda
16:04:38 <pantelis> #info Tom Pantelis in for Brady Johnson
16:04:42 <skitt> #topic Infrastructure
16:05:18 <zxiiro> #info Thanh Ha
16:05:41 <abhijitkumbhare> #info No updates
16:05:41 <skitt> #info no updates
16:05:46 <abhijitkumbhare> #undo
16:05:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b837d0>
16:05:56 <skitt> #topic Neon DDF
16:06:28 <zxiiro> Think I was talking on mute, no updates .
16:06:41 <skitt> #info still planning to have the DDF on the Thursday and Friday before the DDF at the end of September in Amsterdam
16:06:54 <skitt> #undo
16:06:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c2e550>
16:07:04 <skitt> #info still planning to have the DDF on the Thursday and Friday before ONS Europe at the end of September in Amsterdam
16:08:21 <abhijitkumbhare> ONS Europe: https://events.linuxfoundation.org/events/open-networking-summit-europe-2018/
16:08:33 <rgoulding> #project aaa
16:08:36 <rgoulding> #info rgoulding
16:08:52 <skitt> #link ONS Europe: https://events.linuxfoundation.org/events/open-networking-summit-europe-2018/
16:11:43 <ScottM> #project tsdr
16:12:50 <abhijitkumbhare> #action CaseyLF to initiate a doodle poll for either Sunday-Monday or Thursday-Friday before the ONS
16:13:11 <abhijitkumbhare> #topic Releases
16:13:50 <abhijitkumbhare> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 Release Dashboard
16:14:33 <jamoluhrsen> #info need projects to update tracking spreadsheet for oxy sr2
16:14:50 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=790452366 <-- tracking sheet for oxy sr2
16:15:40 <jamoluhrsen> #info TSC-101 weather item is finished.
16:16:29 <vorburger> #project infrautils
16:16:32 <vorburger> #project daexim
16:16:39 <vorburger> #project ...
16:17:30 <skitt> vorburger, parse error, unrecognised project "..." :-P
16:17:41 <aadam> #action Ariel to send Jaime a mail regarding weather item TSC-114
16:17:44 <vorburger> skitt: LOL
16:18:49 <abhijitkumbhare> #info TSC-111 underway as per pantelis
16:20:25 <aadam> #action Ariel to check if he can filter out weather items which are scheduled +1 month
16:21:43 <abhijitkumbhare> #info Fluorine middle check point is July 5
16:23:06 <abhijitkumbhare> #info Grievances will be looked at during the middle checkpoint
16:23:06 <aadam> #action to change the due dates of the release grievances to the mid checkpoint and only talk about it then
16:23:39 <aadam> #action Ariel to change the due dates of the release grievances to the mid checkpoint and only talk about it then
16:24:31 <abhijitkumbhare> #topic Autorelease failures and LispFlowMapping Tests
16:25:08 <abhijitkumbhare> #info autorelease failures have been an ongoing issue
16:25:27 <skitt> #info the lispflowmapping integration tests are much more comprehensive than the CSIT tests
16:25:43 <skitt> #info even after CSIT was created, development of the integration tests in LFM continued
16:26:04 <skitt> #info they are very useful in detecting failures in lispflowmapping and upstream projects
16:26:17 <skitt> #info there were problems in the past with infrastructure changes
16:26:27 <skitt> #info sometimes the tests fail in Jenkins, but never locally
16:27:08 <skitt> #info the switch to log4j2 means the IT logs are no longer available either
16:27:32 <skitt> #info the current workaround is to keep the IT Karaf directory
16:27:41 <skitt> #info and extract the logs from there
16:28:31 <lori> #link lispflowmapping test failure https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/autorelease-release-fluorine/108/lispflowmapping/integrationtest/target/exam/721ef9e4-0e44-4d1e-b458-3386f589d22b/data/log/karaf.log.gz
16:28:39 <skitt> #info the logs on failed jobs show problems in Karaf rather than assertion errors from the tests
16:30:05 <skitt> #info shague suggested disabling the IT tests in autorelease (but leave them in the patch jobs)
16:30:44 <skitt> #info lori has no major objection to this
16:30:58 <skitt> #info as long as we can re-enable them in autorelease once we know they’re stable
16:31:19 <abhijitkumbhare> thx skitt  (your notes are stellar)
16:31:32 * skitt blushes
16:31:59 <skitt> #info jamoluhrsen also suggests increasing the frequency of the lispflowmapping merge job
16:37:42 <skitt> #info dfarrell07 doesn’t like the idea of turning tests which may be finding a real failure
16:38:28 <shague> I am out so can't reply, but a clairifcation on the disable lisp IT - could also keep the tests in autorelease - but disable failing on them, that way the autorelease job finishes, doesn't break randomly, and the lisp project stiill has the test results to truly check if was a real failure
16:39:52 <skitt> shague, thanks, abhijitkumbhare is relaying that
16:40:46 <dfarrell07> jamoluhrsen: it's possible to do that, right? keep the tests but don't fail autorelease on them?
16:40:47 <skitt> #info shague suggests keeping the job but ignoring errors
16:41:15 <zxiiro> jamoluhrsen: I moved the deploy config from that sandbox job so that it doesn't fail to deploy at the end
16:41:23 <zxiiro> removed*
16:42:49 <jamoluhrsen> #agree lisp will ignore failures in their IT for autorelease
16:43:06 <abhijitkumbhare> #topic Project Proposal : ODL Tools
16:43:38 <abhijitkumbhare> #info jamoluhrsen says that we should keep with the ODL tools
16:44:55 <skitt> #info the project name will be "ODL Support Tools" but the repo and PIP name will be "odltools"
16:45:21 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Project_Proposals:ODLTools <-- ODL Support Tools project proposal
16:45:32 <rovarga_> the trouble with flat namespaces :)
16:46:22 <skitt> rovarga_, and names which have to mean something across multiple flat namespaces
16:46:51 <abhijitkumbhare> #startvote Does the TSC approve project "ODL Support Tools" to be approved? -1,0,+1
16:46:51 <odl_meetbot> Begin voting on: Does the TSC approve project "ODL Support Tools" to be approved? Valid vote options are -1, 0, +1.
16:46:51 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
16:46:59 <abhijitkumbhare> #vote +1
16:47:03 <jamoluhrsen> #vote +1
16:47:03 <rovarga_> #vote +1
16:47:05 <gzhao> #vote +1
16:47:10 <skitt> #vote +1
16:47:12 <zxiiro> #vote +1
16:47:40 <dfarrell07> #vote +1
16:47:44 <vthapar> vote +1
16:47:49 <vthapar> #vote +1
16:48:23 <abhijitkumbhare> #endvote
16:48:23 <odl_meetbot> Voted on "Does the TSC approve project "ODL Support Tools" to be approved?" Results are
16:48:23 <odl_meetbot> +1 (8): gzhao, vthapar, skitt, dfarrell07, abhijitkumbhare, zxiiro, rovarga_, jamoluhrsen
16:48:28 <rovarga_> skitt: yeah, Juniper has 'ODL' as in 'Output Definition Language'. fingers crossed they do not populate something to pip :-P
16:48:42 <abhijitkumbhare> #info dfarrell07 voted in proxy for shague
16:48:46 <dfarrell07> #info dfarrell07's vote was on behalf of Sam, although skitt is shague's proxy, just for mechanical reasons
16:48:58 <LuisGomez> #vote +1 (sorry late)
16:49:12 <abhijitkumbhare> #info LuisGomez also voted as +1
16:49:39 <pantelis> #vote  +1   sorry forgot I was in for Brady :)
16:49:49 <abhijitkumbhare> #agreed Project "ODL Support Tools" is approved to be an ODL project
16:51:22 <abhijitkumbhare> #topic LFN update
16:52:14 <abhijitkumbhare> #info dfarrell07 informs that the governance docs are being currently finalized - roughly to be finished in a month
16:52:20 <dfarrell07> #link https://gerrit.linuxfoundation.org/infra/#/q/project:lfn/process repo with LFN gov docs
16:53:29 <vorburger> cookies with tea instead of beer today please
16:53:51 <abhijitkumbhare> #topic Community awards
16:54:02 <CaseyLF> #link https://linuxfoundation.store LFN Webstore
16:54:11 <vorburger> CaseyLF: nice!
16:54:26 <abhijitkumbhare> #info CaseyLF informs that the community awards are planned for the Fluorine release
16:54:51 <abhijitkumbhare> #info They will be awarded at the Neon DDF
16:54:55 <abhijitkumbhare> #topic Cookies with tea
16:55:04 <skitt> #endmeeting