16:01:48 <abhijitkumbhare> #startmeeting tsc
16:01:48 <odl_meetbot> Meeting started Thu Jul  5 16:01:48 2018 UTC.  The chair is abhijitkumbhare. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:48 <odl_meetbot> The meeting name has been set to 'tsc'
16:02:06 <abhijitkumbhare> #chair skitt dfarrell07 jamoluhrsen
16:02:06 <odl_meetbot> Current chairs: abhijitkumbhare dfarrell07 jamoluhrsen skitt
16:02:13 <jamoluhrsen> #info jamoluhrsen
16:02:18 <vorburger> #info vorburger
16:02:20 <bjohnson> #info Brady Johnson
16:02:26 <bjohnson> #project SFC
16:02:30 <skitt> vorburger, #info is only for TSC members
16:02:36 <abhijitkumbhare> #topic Agenda bashing and roll call
16:02:39 <rovarga> #info rovarga
16:02:40 <shague> #info shague
16:02:44 <abhijitkumbhare> #info abhijitkumbhare
16:02:44 <skitt> #info skitt
16:02:52 <rovarga> #project bgpcep, mdsal, yangtools, coretutorials
16:03:04 <skitt> #project odlparent controller netvirt ovsdb
16:03:26 <lori> #info lori
16:03:33 <lori> #project lispflowmapping
16:03:41 <shague> #info #project netvirt
16:04:09 <shague> rovarga: and comma's blow up the regex :)
16:04:10 <anipbu> #info anipbu
16:04:28 <anipbu> #info gzhao (proxy)
16:04:37 <anipbu> #project usc
16:04:54 <vorburger> #info-for-non-TSC-member-who-has-to-attend-this-meeting-anyway-just-to-pound-in-#project vorburger
16:04:57 <abhijitkumbhare> #topic Action Item check
16:05:20 <abhijitkumbhare> #info Accessing CSIT debug environments
16:06:12 <rovarga> shague: what doesn't?
16:06:43 <rovarga> #project bgpcep mdsal yangtools coretutorials
16:07:03 <vorburger> #project odlparent infrautils controller daexim neutron genius archetypes serviceutils
16:07:19 <aadam> dashboard https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403#
16:07:19 <abhijitkumbhare> #info Come back on this topic next week
16:07:25 <abhijitkumbhare> #topic ODL Parent Update
16:07:41 <rovarga> skitt: vorburger: so who is actually representing controller?
16:08:15 <abhijitkumbhare> #info Plan to result ODL Parent 4 in August
16:08:25 <shague> rovarga: yeah the regex is just a string.split() and then compare the whole word to a list of known projects, so "," is included in compare. easy to fix to be more lenient
16:08:27 <rgoulding> #info rgoulding for AAA
16:08:49 <CaseyLF> Not sure meetbot got the topic change... ?
16:09:16 <abhijitkumbhare> #topic Releases
16:09:41 <abhijitkumbhare> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 Release Dashboard
16:09:47 <skitt> rovarga, I don’t think there has to be a bijection, projects can be multiply represented
16:10:01 <jhershbe> #info jhershbe
16:10:20 <jhershbe> #project neutron
16:10:23 <vorburger> rovarga: is #project XOR ? I thought #project was "commmiters present" - is it "PTL" ?
16:10:37 <abhijitkumbhare> jhershbe: only TSC members need to info
16:10:47 <abhijitkumbhare> #topic Clustering
16:11:56 <abhijitkumbhare> #info Lots of ongoing efforts on this
16:12:26 <rovarga> vorburger: well, dfarrell07 can probably clarify, but I thought it was about representation
16:13:12 <rovarga> vorburger: i.e. I am not usually flashing bgpcep, since Claudio is usually in. today I am, as I am standing in for him
16:13:29 <abhijitkumbhare> #info Victor Packard going thru the clustering jobs
16:13:52 <dfarrell07> I'm not sure what the question is exactly but I think it's okay to #info a project twice
16:14:14 <shague> rovarga: vorburger: I think couple weeks agao dfarrell07 clarified that the rep is a committer.
16:14:40 <dfarrell07> shague, rovarga, vorburger yes, in the Managed Release docs only a committer can rep a project
16:16:01 <jamoluhrsen> #info we now have a trimmed down controller cluster job that will run in 30m and hit sporadic failures. this might be easier to use for debugging
16:17:18 <rovarga> dfarrell07: well, my question is whether pount-project is a flash of badges, or declaration of project representation
16:17:49 <dfarrell07> rovarga: declaration of project representation
16:20:39 <abhijitkumbhare> #info We need more developers to focus on clustering issues besides rovarga and pantelis_ due to their cycles
16:22:20 <abhijitkumbhare> #info There are around 8 developers trying to get on-board on the clustering code but the ramp up time is steep
16:23:15 <abhijitkumbhare> ##info A code walk thru session would be helpful
16:24:54 <dfarrell07> rovarga: it's not 8 new devs, it's heaping our existing devs on clustering
16:25:49 <vorburger> rovarga: pantelis_: I'm looking at an (internally reported) bug which I suspect is that thing somewhere in clustering which does that System.exit.. we still have that (oxygen), right? Remind me where that was?
16:26:27 <rovarga> vorburger: restart of container, look for karaf.restart or something like that
16:26:43 <rovarga> and when that triggers, there is no recourse
16:27:05 <vorburger> rovarga: "look for karaf.restart" in code or log you mean?
16:27:11 <rovarga> in code
16:28:25 <abhijitkumbhare> Previous comment did not go thru - retyping:
16:28:29 <abhijitkumbhare> #info A code walk thru session would be helpful
16:29:17 <vorburger> rovarga: would the pattern seen on https://gist.github.com/vorburger/615d2c1f73632dd273a66ff1b627c3c5 make you think this is the "karaf.restart" thing?
16:29:50 <vorburger> rovarga: org.apache.karaf.main.Main launch only once, then org.apache.karaf.main.lock.SimpleFileLock lock, then lots of stuff happening, and then a sudden abrupt
16:30:22 <rovarga> vorburger: I don't know
16:30:30 <vorburger> rovarga: abrupt "org.apache.karaf.main.lock.SimpleFileLock lock" again, without the org.apache.karaf.main.Main launch, and full restart cycle - that's a karaf.restart?
16:30:33 <rovarga> vorburger: we are loud when restarting things
16:33:19 <vorburger> rovarga: https://github.com/opendaylight/controller/blob/master/opendaylight/md-sal/sal-distributed-datastore/src/main/java/org/opendaylight/controller/cluster/akka/osgi/impl/QuarantinedMonitorActorPropsFactory.java ?
16:33:49 <abhijitkumbhare> #info Two courses of action needed: 1) Going thru issues in detail & 2) Code walk thru session
16:35:19 <rovarga> vorburger: yes
16:36:33 <aadam> https://jira.opendaylight.org/issues/?filter=10345
16:36:36 <abhijitkumbhare> #action vpickard pantelis_ jamoluhrsen to get on a call together to go thru the issues in detail
16:36:58 <abhijitkumbhare> #topic Fluorine middlepoint check - Grievances
16:37:11 <vorburger> rovarga: FYI that 'LOG.warn("Restarting karaf container");' never makes it.. probably shuts down too fast? Would adding a stupid sleep there be a crazy idea?
16:37:11 <abhijitkumbhare> #link https://jira.opendaylight.org/issues/?filter=10345
16:37:52 <rovarga> vorburger: never makes it? are you saying the container is shutting down without flushing logs?
16:37:54 <abhijitkumbhare> #link https://jira.opendaylight.org/browse/TSC-119?filter=10345 TSDR
16:38:12 <rovarga> vorburger: and yes, unsubstianted sleeps are always crazy
16:38:35 <abhijitkumbhare> #link https://jira.opendaylight.org/browse/TSC-118?filter=10345 ALTO
16:38:53 <anipbu> https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400
16:39:03 <anipbu> fluorine dashboard: https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400
16:39:25 <abhijitkumbhare> https://jira.opendaylight.org/browse/TSC-117?filter=10345 ODL-Parent
16:39:29 <vorburger> rovarga: that's what https://gist.github.com/vorburger/615d2c1f73632dd273a66ff1b627c3c5 looks like no? I'm trying to understand why there is no "org.apache.karaf.main.Main launch" in Karaf code
16:39:47 <abhijitkumbhare> #link https://jira.opendaylight.org/browse/TSC-117?filter=10345 ODL-Parent
16:42:04 <abhijitkumbhare> #link https://jira.opendaylight.org/browse/TSC-75?filter=10345 Monitor Neutron committers
16:42:53 <dfarrell07> vorburger: if you want to keep using that issue to track places odlparent MRI caused slowness, you can retarget it at end of release
16:42:57 <abhijitkumbhare> #info vorburger and jhershbe are new committers as Isaku stepped out
16:44:13 <abhijitkumbhare> #link https://jira.opendaylight.org/browse/TSC-74?filter=10345 Monitor BGP -PCEP committers
16:45:46 <abhijitkumbhare> #info Claudio has been responsive for handling issues, but keep this open as we still have very few committers
16:46:47 <aadam> https://jira.opendaylight.org/issues/?filter=10333
16:48:18 <dfarrell07> #link https://gerrit.linuxfoundation.org/infra/#/c/11139/ review this
16:49:22 <rovarga> vorburger: I do not know. I would need to understand the deployment scenario, see all the logs and spend some time on it to formulate what it does or does not look like.
16:50:03 <dfarrell07> #link https://gerrit.linuxfoundation.org/infra/#/c/11139/30/docs/lifecycle/project_data_template.rst give feedback please
16:54:10 <abhijitkumbhare> #action aadam Make a due date mandatory for TSC JIRA tickets which are grievances
16:57:05 <rovarga> jhershbe: can I assume you read ./opendaylight/md-sal/sal-distributed-datastore/src/site/asciidoc/distributed-data-store.adoc ?
16:57:15 <aadam> #action aadam to improve the grievance fields (what should be mandatory and what should be dropped)
16:57:44 <jhershbe> rovarga, I did not because I did not know it was there ;-)
16:57:55 <rovarga> jhershbe: fgrep -rn '
16:58:04 <dfarrell07> #link https://lists.opendaylight.org/pipermail/integration-dev/2018-July/012256.html midway checkpoint stats
16:58:08 <dfarrell07> jamoluhrsen: got it
16:58:15 <abhijitkumbhare> #topic Midway Checkpoint stats
16:58:20 <jhershbe> rovarga, the issues I was looking at were in controller so that's where I started looking ;-)
16:58:24 <abhijitkumbhare> #link https://lists.opendaylight.org/pipermail/integration-dev/2018-July/012256.html midway checkpoint stats
16:58:27 <rovarga> jhershbe: fgrep -rni 'term' opendayligh/mdsal/sal-distributed-datastore ... anything you are looking for stuff
16:58:55 <rovarga> nite@nitebug : ~/odl/controller on master $ ls -l ./opendaylight/md-sal/sal-distributed-datastore/src/site/asciidoc/distributed-data-store.adoc
16:58:57 <rovarga> -rw-rw-r--. 1 nite nite 18623 Jun 21 16:03 ./opendaylight/md-sal/sal-distributed-datastore/src/site/asciidoc/distributed-data-store.adoc
16:59:00 <jhershbe> rovarga, thanks
16:59:03 <rovarga> it *is* in the controller ...
16:59:19 <jhershbe> rovarga, ah, ok.
16:59:37 <abhijitkumbhare> #info BGPCEP autorelease failures (15) stands out
17:00:37 <jhershbe> rovarga, looks very useful, thanks
17:01:11 <jhershbe> skitt, ^^^
17:01:29 <skitt> jhershbe, yeah that’s what I was thinking of too
17:01:37 <skitt> vpickard, look at the above too
17:01:39 * bjohnson I have to disconnect now
17:01:46 <vpickard> skitt: ack, thanks
17:02:16 <abhijitkumbhare> #undo
17:02:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c40b50>
17:02:16 <jhershbe> skitt, I asked a few people and no one pointed me to that till now :-( Not blaming anyone, of course.
17:02:54 <abhijitkumbhare> #info Autorelease failures for BGPCEP (15) & NetConf  (7) also stands out
17:03:00 <dfarrell07> #info rovarga says high bgpcep autorelease failure count is partly related to project being first to hit version bump issues
17:03:02 <abhijitkumbhare> #undo
17:03:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b83ed0>
17:03:07 <dfarrell07> #info rovarga says high bgpcep autorelease failure count is partly related to project being first to hit version bump issues
17:03:25 <abhijitkumbhare> #undo
17:03:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b83110>
17:03:27 <abhijitkumbhare> #info Autorelease failures for BGPCEP (15) & NetConf  (7)  stand out
17:03:41 <abhijitkumbhare> #info rovarga says high bgpcep autorelease failure count is partly related to project being first to hit version bump issues
17:04:09 <abhijitkumbhare> #topic TWS this Monday
17:04:57 <abhijitkumbhare> #info End user feedback from Sprint
17:05:21 <jamoluhrsen> CaseyLF: I would send your TWS announcement sooner rather than the day
17:05:26 <abhijitkumbhare> #info All developers & TSC members are encouraged to attend
17:05:32 <abhijitkumbhare> #undo
17:05:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x29b2610>
17:05:51 <abhijitkumbhare> #info All developers & TSC members are encouraged to attend as this is an important topic
17:08:00 <abhijitkumbhare> #info Topics for the next few TWS - Clustering code walk thru in 2 weeks; Publishing of models to github
17:08:27 <abhijitkumbhare> rovarga: any other TWS topic I missed?
17:08:42 <abhijitkumbhare> #topic Cookies
17:08:46 <rovarga> abhijitkumbhare: not that I know of
17:08:51 <abhijitkumbhare> #endmeeting