15:58:44 <CaseyLF> #startmeeting tsc
15:58:44 <odl_meetbot> Meeting started Thu Jul 19 15:58:44 2018 UTC.  The chair is CaseyLF. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:58:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:58:44 <odl_meetbot> The meeting name has been set to 'tsc'
15:59:05 <CaseyLF> #chair abhijitkumbhare rovarga skitt zxiiro
15:59:05 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare rovarga skitt zxiiro
15:59:16 <CaseyLF> #chair dfarrell07
15:59:16 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare dfarrell07 rovarga skitt zxiiro
16:00:12 <skitt> #topic Roll-call and agenda bashing
16:00:15 <abhijitkumbhare> The meeting ID is not working over the phone
16:00:18 <skitt> #link Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda
16:00:25 <abhijitkumbhare> #info abhijitkumbhare
16:00:30 <skitt> #info *TSC members* please #info in
16:00:37 <anipbu> #info anipbu
16:00:38 <skitt> #info Project representatives please #project in
16:00:41 <skitt> #info skitt
16:00:54 <skitt> #project odlparent controller
16:00:55 <lori> #info lori
16:01:03 <anipbu> #info gzhao (proxy)
16:01:11 <anipbu> #project usc
16:01:56 <bjohnson> #info Brady Johnson
16:02:05 <jhershbe> #info jhershbe
16:02:06 <bjohnson> #project SFC
16:02:10 <lori> #project lispflowmapping
16:02:11 <rovarga> #info rovarga
16:02:16 <jhershbe> #project neutron
16:02:22 <dfarrell07> CaseyLF: how's that wiki intern doing?
16:02:28 <vishnoianil> #info Anil Vishnoi
16:02:32 <rovarga> #project odlparent yangtools mdsal controller bgpcep coretutorials infrautils
16:02:36 <vishnoianil> #project openflowplugin
16:02:48 <LuisGomez> #info LuisGomez
16:02:57 <LuisGomez> #project distribution
16:02:59 <gzhao> #info gzhao
16:03:03 <CaseyLF> dfarrell07: Slow, sorry.  I'm technically OOO for military duty this month.  :(
16:03:17 <zxiiro> #info Thanh Ha
16:03:27 <gzhao> anipbu: thanks
16:03:36 <vthapar> #project ovsdb
16:03:51 <jamoluhrsen> #info jamoluhrsen
16:04:00 <CaseyLF> I'm "in the office" next Monday and Tuesday.  Hope to get that box checked then.  Also going to spend some time on that on the weekend.
16:04:06 <abhijitkumbhare> #topic Neon DDF
16:04:44 <skitt> #info the LF has inquired about moving the DDF but hasn’t received an official reply
16:04:52 <rovarga> CaseyLF: unrelated, but did we receive the Sprint slides from the TWS?
16:04:55 <skitt> #info CaseyLF thinks we’ll receive a positive response
16:05:21 <abhijitkumbhare> #info Waiting for the update about moving DDF dates - but hopeful
16:05:52 <abhijitkumbhare> #topic LFN TAC / Board updates
16:05:53 <shague> #info shague
16:06:35 <shague> #info #project netvirt odltools
16:07:13 <abhijitkumbhare> #info Abhijit/Daniel provided update to the board
16:07:22 <abhijitkumbhare> #info Slides: https://docs.google.com/presentation/d/1DHp5d4BmlPMCn8sRQWdre6s8zz5_o4JWEL9voTrm1Fc/edit?usp=sharing
16:07:33 <Claudio> #project bgpcep
16:07:44 <shague> #info #project genius
16:09:01 <skitt> #topic ODL Parent
16:09:21 <CaseyLF> rovarga: Yes.  I sent you an email about it.  They are posted on the wiki along with the recording.
16:09:21 <dfarrell07> #link https://gerrit.linuxfoundation.org/infra/#/c/11139/ new project LFN induction process/lifecycle/principles docs passed TAC vote
16:09:49 <dfarrell07> #link https://gerrit.linuxfoundation.org/infra/#/c/10545/ budget proposal passed TAC vote, but dfarrell07 thinks it's half-baked and will be rejected by the Board
16:09:54 <CaseyLF> https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings
16:10:38 <rovarga> CaseyLF: thanks
16:10:49 <CaseyLF> No problem.  :)
16:10:58 <skitt> #info ODL Parent 3.1.3 released today, minor bump with Xtend Maven plugin fix
16:11:14 <skitt> #info ODL Parent 4 in preparation for Neon, projects needing features from ODL Parent should speak up now
16:11:37 <skitt> #info the big item in 4 is Mockito and PowerMock
16:12:16 <abhijitkumbhare> #topic Action Items Checks
16:12:51 <abhijitkumbhare> #info Make a due date mandatory for TSC JIRA tickets which are grievances - next week
16:13:26 <abhijitkumbhare> #info Accessing CSIT debug environments - no progress yet
16:13:46 <ScottMelton> #project tsdr
16:13:49 <abhijitkumbhare> #info CaseyLF following up with the LF staff - but no response yet
16:14:34 <abhijitkumbhare> #topic Autorelease failures
16:15:08 <abhijitkumbhare> #info Maybe the autorelease failures related to something happening in the environment
16:16:34 <abhijitkumbhare> #info jamoluhrsen says it might be actually problems on the projects side
16:17:17 <dfarrell07> CaseyLF: what's the email of that intern? I can drive things some
16:17:20 <abhijitkumbhare> #info shague says that the tests may need to be tweaked
16:17:23 <jamoluhrsen> #info jamoluhrsen ran an autorelease job that did nothing (in the sandbox). the sysstats output did not show anything major and the build system really did seem to be totally idle
16:18:52 <jamoluhrsen> https://jenkins.opendaylight.org/releng/view/bgpcep/job/bgpcep-merge-fluorine/
16:19:33 <abhijitkumbhare> #info The failures are hard to reproduce locally
16:19:54 <jamoluhrsen> bgp merge job with failure:
16:19:54 <jamoluhrsen> https://jenkins.opendaylight.org/releng/view/bgpcep/job/bgpcep-merge-fluorine/218/org.opendaylight.bgpcep$odl-bgpcep-concepts/testReport/installFeatureCatchAndLog(org.opendaylight.odlparent.featuretest.SingleFeatureTest)[repoUrl_%20file__w_workspace_bgpcep-merge-fluorine_features_concepts_odl-bgpcep-concepts_target_feature_feature.xml,%20Feature_%20odl-bgpcep-concepts%200.10.0/SNAPSHOT]/installFeatureCatchAnd
16:19:54 <jamoluhrsen> Log/
16:20:05 <abhijitkumbhare> #info It may be related to timing
16:21:22 <shague> #link: https://git.opendaylight.org/gerrit/#/c/66714/ - bgpcep connetion handling patch
16:25:55 <rovarga> jamoluhrsen: own dogfood and all that :)
16:26:16 <jamoluhrsen> rovarga: I just want to be the idea fairy.
16:26:50 <rovarga> jamoluhrsen: good luck dude, I've been trying to achieve that for 5+ years :)
16:28:23 <aadam> dashboard https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403
16:28:45 <abhijitkumbhare> #action zxiiro will try to get a single VM on Rackspace for a limited time and try to reproduce to isolate whether problems are due to Vexhost
16:29:03 <abhijitkumbhare> #topic Release Dashboard
16:29:15 <jamoluhrsen> ClaudioGasparini: which is better to try to reproduce (oxygen or fluorine)?
16:29:16 <abhijitkumbhare> #link  https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403
16:30:24 <abhijitkumbhare> #info Weather Item TSC-128
16:30:30 <abhijitkumbhare> #link https://jira.opendaylight.org/browse/TSC-128
16:31:43 <abhijitkumbhare> #info odl-mdsal-models features is being removed
16:32:41 <abhijitkumbhare> #info This has been integrated and does speed up single feature tests
16:33:40 <abhijitkumbhare> #info Weather Item TSC-130
16:33:44 <abhijitkumbhare> #link https://jira.opendaylight.org/browse/TSC-130
16:34:02 <abhijitkumbhare> #info Generated unions will lose getValue() and char[] constructor
16:37:49 <abhijitkumbhare> #info Weather TSC-114
16:38:04 <abhijitkumbhare> #info https://jira.opendaylight.org/browse/TSC-114
16:38:35 <abhijitkumbhare> #info First list of patches merged - second list needs to be merged
16:40:53 <abhijitkumbhare> #info Grievance TSC-127
16:41:01 <abhijitkumbhare> #link https://jira.opendaylight.org/browse/TSC-127
16:41:46 <abhijitkumbhare> #info rovarga indicates that the turnaround for the patch was longer than expected
16:46:50 <abhijitkumbhare> #topic Clustering
16:47:02 <dfarrell07> does anyone else want to interview the potential wiki cleanup intern on Monday at 9:30AM ET?
16:49:14 <abhijitkumbhare> #info jamoluhrsen requests someone to work on Controller-1742
16:52:21 <abhijitkumbhare> #info MDSAL-362 maybe behind some other bugs like Controller-1848
16:55:35 <jamoluhrsen> rovarga: skitt, how hard would it be to build something with cutting edge akka?
16:55:39 <jamoluhrsen> just to test with
16:56:01 <skitt> jamoluhrsen, I can give it a shot
16:58:51 <jamoluhrsen> rovarga: now you are the idea fairy
16:59:34 <CaseyLF> dfarrell07: If the meeting is on a Monday/Tues, you can add it to my calendar.  I'm taking those days next week to catch up on work.
17:00:01 <dfarrell07> CaseyLF: cool, adding you to invite
17:01:31 <abhijitkumbhare> #info Suggestion by rovarga is to consult with some Akka expert
17:03:14 <abhijitkumbhare> #action rovarga to drive technically consultation with Akka expert
17:04:00 <abhijitkumbhare> #action dfarrell07 to drive budget aspects within LFN for consultation with Akka expert
17:04:08 <abhijitkumbhare> #endmeeting