15:56:29 <CaseyLF> #startmeeting tsc
15:56:29 <odl_meetbot> Meeting started Thu Aug  9 15:56:29 2018 UTC.  The chair is CaseyLF. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:56:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:56:29 <odl_meetbot> The meeting name has been set to 'tsc'
15:56:55 <CaseyLF> #chair abhijitkumbhare zxiiro dfarrell07
15:56:55 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare dfarrell07 zxiiro
15:59:33 <CaseyLF> #topic Agenda Bashing
16:01:49 <anipbu> #info anipbu
16:01:54 <rovarga> #info rovarga
16:01:58 <jhershbe> #info jhershbe
16:01:58 <bradyjohnson> #info Brady Johnson
16:02:00 <anipbu> #project usc
16:02:00 <shague> #info shague
16:02:01 <dfarrell07> #info Daniel Farrell for Stephen Kitt
16:02:04 <mperina> #project bgpcep
16:02:08 <bradyjohnson> #project SFC
16:02:12 <jhershbe> #project neutron
16:02:14 <rovarga> #project odlparent yangtools mdsal controller infrautils bgpcep coretutorials
16:02:22 <jamoluhrsen> #info jamoluhrsen
16:02:22 <abhijitkumbhare> Laptop issues
16:02:24 * rovarga will need an alias for this badge-flashing
16:02:31 <jamoluhrsen> rovarga: that's a lot of projects :)
16:02:39 <faseelak> #project coe genius serviceutils
16:02:55 <shague> #info #project netvirt ovsdb
16:03:02 <rovarga> #project honeycomb/vbd
16:03:14 <rovarga> jamoluhrsen: I *knew* I forgot something :)
16:03:24 <vorburger> #project infrautils daexim archetypes
16:03:47 <CaseyLF> #link https://wiki.opendaylight.org/view/Events:Neon_Dev_Forum DDF Agenda
16:03:49 <lori> #info lori
16:03:56 <abelur> #project autorelease releng/buidler
16:03:57 <lori> #project lispflowmapping
16:04:27 <zxiiro> doh just realized i don't have audio
16:04:30 <zxiiro> #info Thanh Ha
16:04:57 <anipbu> #info gzhao proxy
16:05:54 <abhijitkumbhare> #info abhijitkumbhare
16:07:24 <abhijitkumbhare> #topic Releases
16:07:42 <abhijitkumbhare> #topic Fluorine
16:07:58 <abhijitkumbhare> #topic Oxygen
16:08:40 <faseelak> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403
16:09:03 <faseelak> #info aadam updates that there are still more projects left for Sign Off
16:09:24 <dfarrell07> #info netconf and controller sign-offs missing
16:13:12 <faseelak> #pantelis updates that if all the downstream projects have signed off, controller is good too
16:13:16 <dfarrell07> #info tomp says there haven't been many changes to controller, I guess implying that risk the failure is problem is low
16:13:22 <faseelak> #info pantelis updates that if all the downstream projects have signed off, controller is good too
16:13:57 <abhijitkumbhare> #startvote Does the ODL TSC approve the Oxygen 08-06 build to be Oxygen SR3 for release? -1,0,+1
16:13:57 <odl_meetbot> Begin voting on: Does the ODL TSC approve the Oxygen 08-06 build to be Oxygen SR3 for release? Valid vote options are -1, 0, +1.
16:13:57 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
16:14:06 <shague> #vote +1
16:14:07 <abhijitkumbhare> #vote +1
16:14:08 <zxiiro> #vote +1
16:14:10 <dfarrell07> #vote +1
16:14:12 <bradyjohnson> #vote +1
16:14:14 <anipbu> #vote +1
16:14:19 <rovarga> #vote +1
16:14:23 <jamoluhrsen> #vote +1
16:14:32 <lori> #vote +1
16:15:02 * jamoluhrsen hates how we assume that if doenstream has signed off, we can safely ignore project failures in things like controller, etc.
16:15:07 <faseelak> #vote +1
16:15:15 <abhijitkumbhare> #endvote
16:15:15 <odl_meetbot> Voted on "Does the ODL TSC approve the Oxygen 08-06 build to be Oxygen SR3 for release?" Results are
16:15:15 <odl_meetbot> +1 (10): rovarga, zxiiro, dfarrell07, bradyjohnson, faseelak, shague, lori, abhijitkumbhare, anipbu, jamoluhrsen
16:15:37 <abhijitkumbhare> #info faseelak vote was a proxy for Anil Vishnoi
16:15:38 <rovarga> hmm... how is this list ^^^ sorted?
16:16:07 <rovarga> #info Oxygen SR3 has been approved for release
16:16:14 <zxiiro> seems completely random :)
16:16:15 <abhijitkumbhare> rovarga: hash?
16:16:21 * bradyjohnson that's a good question rovarga, Im not sure...
16:16:26 <faseelak> rovarga, IRC knows rovarga is the first ;)
16:17:10 <abhijitkumbhare> #topic Fluorine
16:17:36 <faseelak> #info stable/fluorine branch cut is done
16:17:53 <zxiiro> https://github.com/openstack-infra/meetbot/blob/master/ircmeeting/meeting.py#L576
16:17:54 * rovarga spent long nights devising his nick to have the correct hash
16:18:07 <zxiiro> It's a python dictionary which does not guarantee order
16:18:27 <vishnoianil> #info Anil Vishnoi
16:18:35 <vishnoianil> #project openflowplugin
16:18:47 <abelur> master (Neon) is unlocked, stable/flourine is in code freeze and still locked.
16:18:50 <vishnoianil> #info Anil Vishnoi (On behalf of Luis Gomez)
16:19:41 <faseelak> #info rovarga says for some reason in the release dashboard, we dont see odlparent upcoming releases
16:20:24 <faseelak> #info aadam says we have not added it yet, and asks for inputs on the milestones to be sent to him
16:21:20 <dfarrell07> #link https://docs.opendaylight.org/en/latest/release-process/release-schedule.html release schedule
16:21:36 <jamoluhrsen> #info "OpenDaylight releases twice per year on a 6 month cadence. These releases are scheduled for September 7th and March 7th"
16:22:48 <dfarrell07> #info need to make explicit dates for neon, following template schedule above
16:23:16 <dfarrell07> #info we also need to make it clear in the relmang docs that tsc needs to approve release plan by branch cutting
16:23:42 <zxiiro> dfarrell07: I'll branch docs now so that master becomes Neon
16:23:53 <dfarrell07> zxiiro: cool, thanks
16:24:26 <dfarrell07> #info rovarga thinks TSC should vote on each release plan, sign-off on it, even if may be fairly mechanical copy+paste from last release
16:25:16 <dfarrell07> #info abhijitkumbhare suggests defaulting to always doing the template, only voting if we want to change something
16:25:51 <dfarrell07> #info aadams thinks most important point is that we need to make branch-cutting time more clear, that it's basically the start of neon
16:27:52 <dfarrell07> #action dfarrell07 and zxiiro to branch docs, add neon exact dates to release schedule
16:28:21 <dfarrell07> #action aadam to input exact dates for neon into jira for milestones on dashboard
16:29:00 <bradyjohnson> Does anyone have the "read the docs" link at hand that Jamo mentioned??
16:29:06 <dfarrell07> #info some discussion about if we need to vote on copying schedule forward or if should be automatic
16:29:15 <dfarrell07> bradyjohnson: it's the one I linked in
16:29:31 <bradyjohnson> dfarrell07: got it, thanks
16:32:23 <jamoluhrsen> bradyjohnson: it was already given above
16:32:49 <dfarrell07> #info bug scrubbing for fluorine
16:34:13 <faseelak> #action OPENFLOWPLUG-1028 Anil to review the patch which is up for review
16:34:57 <faseelak> #topic Grievances
16:35:08 <faseelak> dfarrell07, i think i cannot set the topic
16:35:21 <dfarrell07> #chair faseelak
16:35:21 <odl_meetbot> Current chairs: CaseyLF abhijitkumbhare dfarrell07 faseelak zxiiro
16:35:29 <faseelak> #topic Grievances
16:36:08 <faseelak> #info anilvishnoi says TSC-74 was added to see if the situation betters if we have more committers on BGPCEP
16:36:32 <faseelak> #info rovarga says if the situation requires, he is ready to step up
16:36:45 <dfarrell07> #info vishnoianil is concerned that there are only 1 or 2 active people for BGPCEP, wants to make sure project is healthy since it's Managed
16:37:24 <dfarrell07> #info aadam asks if there is anyone who actually has cycles/desire to step up and contribute
16:38:45 <dfarrell07> #info rovarga points out that it really amounts to if downstream stakeholders think bgpcep is important, allocate cycles
16:40:31 * rovarga thinks there is plenty of projects whichh could use this sort of monitoring -- except, monitoring only is not going to change reality :(
16:41:35 <dfarrell07> rovarga: +1
16:42:33 <abhijitkumbhare> rovarga: I think we should have monitoring status for all such projects
16:42:52 <mperina> #info I am currently also working on BGPCEP full-time, still getting familiar with project itself but in time I can step in as commiter if situation requires it
16:43:47 <rovarga> abhijitkumbhare: right, but is that really good use of TSC call time? :)
16:44:07 <rovarga> abhijitkumbhare: because if we play even field, there'd be like 6+ these grievances
16:44:14 <jamoluhrsen> I cannot come off mute
16:44:23 <jamoluhrsen> no...
16:44:37 <jamoluhrsen> I have noises that are too loud in my room
16:44:59 <jamoluhrsen> you  guys aren't listening
16:45:06 <faseelak> jamoluhrsen, :P
16:45:09 <jamoluhrsen> there is full blown construction happening IN MY ROOM
16:45:33 <dfarrell07> mperina: good that you're working on BGPCEP, thanks :) once you get some contribution history maybe it would be good to talk with the project committers about what they want from a new committer
16:45:42 <vishnoianil> jamoluhrsen time to go to backyard ;)
16:45:55 <rovarga> dfarrell07: spoilers! :)
16:46:10 <jamoluhrsen> vishnoianil: yeah. I didn't expect this right now. they just came in and starting sawing a wall in half
16:46:19 <dfarrell07> lol
16:46:34 * bradyjohnson I want to see pictures of that jamoluhrsen
16:47:07 <abhijitkumbhare> #topic Technical announcement for release
16:48:17 <abhijitkumbhare> #info Lisa says that current press releases are & should be focused toward the users
16:48:41 <abhijitkumbhare> #info The vehicle for technical update would be a blog about the release
16:56:33 <dfarrell07> #link https://docs.opendaylight.org/en/stable-oxygen/release-process/managed-release.html#final-checkpoint final checkpoint docs, please start on marketing blurb in final checkpoint jira
16:57:38 <abhijitkumbhare> #topic ODL SW quality metrics
16:58:34 <abhijitkumbhare> #info This was presented at DDF, in the TWS over email threads
16:58:56 <abhijitkumbhare> #info Current thought is for now start with checkstyle and findbugs
16:59:21 <bradyjohnson> #link https://docs.google.com/presentation/d/134O2NKS00SyTq4RziqFfJQfXc7C_MskfcZH7R3rYHF4/edit#slide=id.g35bfb30282_0_0 SW Quality improvements preso
17:02:16 <abhijitkumbhare> We are past the top of the hour
17:04:37 <rovarga> bradyjohnson: we also need some guidance so as not to end up with s***load of @SuppressWarnings to coply
17:04:39 <rovarga> comply
17:05:16 <bradyjohnson> rovarga: good point
17:05:33 <abhijitkumbhare> #topic Cookies
17:05:37 <rovarga> and metrics, of course :)
17:05:44 <abhijitkumbhare> #endmeeting